On Sat, 9 Mar 2002, Vallo Kallaste wrote:

 -> On Sat, Mar 09, 2002 at 09:42:07PM +0100, Olivier Houchard <[EMAIL PROTECTED]> 
 -> Tried without XIM support only, then without multibyte, fontset and
 -> XIM support, no joy. Exactly same linkage happens. Perhaps I should
 -> also note that using Motif for GUI will not change anything.

I have a very similar problem with windowmaker, xv and perhaps
few other X11 applications.
I also have a window manager compiled from x11-wM/phluid port.

They all dump core attempting to dlopen():
(example from phluid)

#0  0x280530be in reloc_non_plt () /usr/libexec/ld-elf.so.1
#1  0x28050b00 in find_symdef () from /usr/libexec/ld-elf.so.1
#2  0x28051097 in dlopen () from /usr/libexec/ld-elf.so.1
#3  0x28252bbb in sys_dl_open () from /usr/local/lib/libltdl.so.1
#4  0x2825313e in tryall_dlopen () from /usr/local/lib/libltdl.so.1
#5  0x282540c0 in lt_dlopen () from /usr/local/lib/libltdl.so.1
#6  0x28254395 in lt_dlopenext () from /usr/local/lib/libltdl.so.1
#7  0x28076558 in __imlib_ProduceLoader () from /usr/X11R6/lib/libImlib2.so.1
#8  0x28076bf7 in __imlib_LoadAllLoaders () from /usr/X11R6/lib/libImlib2.so.1
#9  0x28076b69 in __imlib_RescanLoaders () from /usr/X11R6/lib/libImlib2.so.1
#10 0x28076f28 in __imlib_LoadImage () from /usr/X11R6/lib/libImlib2.so.1
#11 0x28084d64 in imlib_load_image () from /usr/X11R6/lib/libImlib2.so.1
#12 0x804b167 in imlib_context_set_color ()
#13 0x80496e6 in imlib_context_set_color ()
#14 0x804963d in imlib_context_set_color ()

This is current installed from scratch from one of the late
february snaphots, with world updated every so-often
(2-3 days max). New make buildworld with -g in progress now.
I even recompiled XFree86-4 (4.1.0 port) and it didn't help.

              << Marcin Cieślak // [EMAIL PROTECTED] >>

To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-current" in the body of the message

Reply via email to