:On Sat, Mar 23, 2002 at 11:02:26AM -0800, Matthew Dillon wrote:
:>     Anyone have any ideas?  I'm trying to build the latest -current
:>     (from cvs) on an alpha running 4.3-RELEASE, using 'make buildworld'.
:I have thought about what could be the problem several times and cannot
:come up with anything (thus my slow responce).
:Please tell more about your environment.  How did you get 4.3 on the
:Alpha.  Can you build 4.3 first to verify things are OK.  Or are you
:willing to try building RELENG_4 first?

    I have successfully built and installed a -stable world.   It took all
    day, but it worked :-)  Unfortunately, it did not clear up the problem.

    I still get this error however:

/FreeBSD/FreeBSD-current/src/sys/sys/types.h:50: global register variable follows a 
function definition
/FreeBSD/FreeBSD-current/src/sys/sys/types.h:50: warning: call-clobbered register used 
for global register variable

    It appears that this line in alpha/include/pcpu.h:

register struct pcpu *pcpup __asm__("$8");  

    Must occur before any inlines.  There are inlines #include'd long before
    pcpu.h is included.  The first I can find is in alpha/include/endian.h,
    which is included by sys/types.h.

    That's as far as I've gotten.

                                        Matthew Dillon 
                                        <[EMAIL PROTECTED]>

To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-current" in the body of the message

Reply via email to