On Tue, May 21, 2002 at 02:26:57PM +0200, Georg-W. Koltermann wrote:
> Hi,
> I am unable to link C++ apps with a recent -current. It seems I would
> need a new libstdc++ which was not included. My libstdc++.so is a
> leftover from the previous cvsup.

Yes, this is correct. THe libraries libstdc++v3 and libsupc++v3 are not
built for the system compiler. You can, however, use ports/lang/gcc31.
It contains a GCC snapshot from 6th May (in comparison, the system
compiler comes from 9th May, so no big deal, both are pre-release). This
will give you a working C++ compiler. I use it to build Mozilla, and it
works. (I even tried letting CC be the system cc and redefining CXX to
the ports version and this worked too, Moz is happily chugging along
except when X freezes on me, which is unrelated, I have a Virge GX2
card -- known problem with X.)


Szilveszter ADAM
Szombathely Hungary

To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-current" in the body of the message

Reply via email to