Morning all ...

        After getting nowhere with the Surecom EP-428X that I picked up, I
went out today and grabbed one of the Linksys EC2T, figuring it's on the
list of supported devices I found, and I think I'm soooo close ...

        First, I'm running a VAIO PCG-Z505S ... I've upgraded to
5.0-CURRENT as of May 21st, mainly due to the Surecom, but figure I'll
stay there for the Linksys ...

        If I run 'pccardd -f /etc/defaults/pccard.conf' from the command
line, it comes back that its matched the card, followed by a line that

        'driver allocation failed for Linksys(...): Inappropriate ioctl
         for device'

        According to dmesg, I have:

pcic0: <Ricoh RL5C475 PCI-Cardbus Bridge> irq 9 at device 10.0 on pci0
pcic0: PCI Memory allocated: 0x44000000
pccard0: <PC Card bus (classic)> on pcic0

        If I pull out the card, the machine itself hangs ... and searching
on Google, it talks about pccard + shared interrupts ... and on this, the
internal ethernet (fxp0) is using irq 9 and the USB controller (uhci0) is
using irq 9 ...

        I looked in the pcic man page, and found the references to
hw.pcic.irq, which mine is set to 0 ... and hw.pcic.intr_path, which mine
is set to 2 ... it talks about being able to switch to ISA interrupt by
changing intr_path to 1, which I tried, with an .irq setting of 10 ...
still hung, so that wasn't the right direction ...

        So, I'm pretty much at an impasse right now as to what to try next
... does anyone have an experiences with this combination and/or
suggestions on what to try next ... ?

Thanks ...

To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-current" in the body of the message

Reply via email to