I've installed gdb-5.2_1, but I cannot debug usual code.  I've tried
with "-g", "-gstabs+" and "-g -gstabs+" but got same result.

% cat test1.c
int main() { int *p; *p = 1; }
% cc -g test1.c -o test1
% ./test1
Bus error (core dumped)
% gdb52 test1 test1.core
GNU gdb 5.2 (FreeBSD)
Copyright 2002 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-portbld-freebsd5.0"...
Core was generated by `test1'.
Program terminated with signal 10, Bus error.
regcache.c:96: gdb-internal-error: register_buffer: Assertion `regnum >= 0 && re
gnum < (NUM_REGS + NUM_PSEUDO_REGS)' failed.
An internal GDB error was detected.  This may make further
debugging unreliable.  Quit this debugging session? (y or n)

To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-current" in the body of the message

Reply via email to