At 6:14 PM +0300 6/16/02, Maxim Sobolev wrote:
>As you have requested, I installed devel/gdb52 port on my -current
>system and gave it a try. It works most of the time, but I've noticed
>that breakpoint set to a finction in a shared library doesn't work, at
>least for libraries which have no debugging info compiled in (I have
>not tested it with ibraries with debugging info yet). This can be
>easily verified by seting up break point to some function in libc and
>then executing binary which calls this function in debugger. It worked
>just fine in old gdb.

Can you provide a few more details on this problem? It worked for me 
in the test below which was using the stock system libc (ie., no 
debugging info).


current# cat > shlibtest.c
#include <stdio.h>
main() { fclose(stderr); }
current# cc -g -o shlibtest shlibtest.c
current# gdb52 shlibtest
GNU gdb 5.2 (FreeBSD)
Copyright 2002 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-portbld-freebsd5.0"...
(gdb) b fclose
Breakpoint 1 at 0x80483d4
(gdb) run
Starting program: /tmp/shlibtest
Breakpoint 1 at 0x280e076e

Breakpoint 1, 0x280e076e in fclose () from /usr/lib/
(gdb) where
#0  0x280e076e in fclose () from /usr/lib/
#1  0x0804853e in main () at shlibtest.c:2
#2  0x0804847d in _start ()

To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-current" in the body of the message

Reply via email to