"Thyer, Matthew" wrote:
> Thanks Dirk but I cant install ports/x11/XFree86-4-clients either!
> Errors below.... a gcc 3.1 ism maybe ?

Almost certainly a compiler mixup.  Did you install a binary package?
Secondly.. you have:

rm -f glxinfo
LD_LIBRARY_PATH=../../exports/lib cc -o glxinfo  -ansi -pedantic -Dasm=__asm
-Wall -Wpointer-arith     -L../../exports/lib glxinfo.o -lGLU -lGL -lXext
-lX11 -L/usr/X11R6/lib -lc_r -lm   -Wl,-rpath,/usr/X11R6/lib

Note that "cc" will not link in libstdc++.so.  The new and delete primatives
have been moved from libgcc.a to libstdc++.so.4, so if you compile and link
a c++ executable, you MUST either use "c++" instead of "cc", or explicitly
add -lstdc++ to the command line. The example above that you pasted does

Finally.. If you are really stuck here, may I suggest "make -i all install"
on the port? ie: ignore errors.  You might end up missing out on having
/usr/X11R6/bin/glxinfo installed, but I would wager that you will not miss

"All of this is for nothing if we don't go to the stars" - JMS/B5

To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-current" in the body of the message

Reply via email to