I just thought I'd mention a little problem I ran into, because I had
not seen anyone else mention it.  It might be specific to my PC
hardware, and actually it was pretty simple to solve once I took
the time to look into it.  I don't know that anything needs to be
done about any of this, but perhaps this message will help someone
else who stumbles into the same situation as I did.

I have a Matrox G400 Dual Head 32mb AGP card running on a dual
Pentium III system, and I have been using XFree86-4 on my system for
testing -current.  This worked fine for months, and I still have a
snapshot of -current from about April 23 where it works fine.
Sometime after that (probably mid-May), I did a buildworld and I
started to consistently get the following errors when XDM starts:

Timecounter "PIIX"  frequency 3579545 Hz
Timecounter "PIIX"  frequency 3579545 Hz
Timecounter "PIIX"  frequency 3579545 Hz
Timecounter "PIIX"  frequency 3579545 Hz
Timecounter "PIIX"  frequency 3579545 Hz
Timecounter "PIIX"  frequency 3579545 Hz
Timecounter "PIIX"  frequency 3579545 Hz
drm0: <Matrox G400/G450 (AGP)> mem 
xe2000000-0xe3ffffff irq 10 at device 0.0 on pci1
error: [drm:mga_init] *ERROR* Cannot initialize the agpgart module.
device_probe_and_attach: drm0 attach returned 12

XDM generally did still seem to come up okay, although occasionally
the system would panic right at that initial XDM startup.  While I
tried a few things to fix this (including various buildworlds over
time), I didn't really worry about it too much because I could always
fall back to my April 23rd snapshot of -current.

Today I finally looked into this situation, and I ended up at:


which mentioned:
     To use agpgart, the agp.ko kernel loadable module needs to
     be loaded into the kernel with  kldload(8). This can be done
     automatically with the loader(8) at boot time. Simply add
     this line to /boot/loader.conf:

I added that line, rebooted, and now XFree86-4 has no problem
initializing agpgart when XDM starts up.  I do not know why I
started to need that line in /boot/loader.conf, when I had never
actually needed it before (and I've never had 'device agp' in my
kernel).  But, I'm happy enough to have finally tracked down what
the issue was.

That web page is geared more towards 4.x releases, as it also talks
about needing to do a MAKEDEV for the device.  I did see the man
page for the agpgart module, but it didn't mention anything about
this loader.conf option.  I don't know if it should, but I just
wanted to say "well, at least I did look around some"...

I do have X built with "WITH_MATROX_GXX_DRIVER=YES" defined, but I
didn't start doing that until *after* this problem came up.

Garance Alistair Drosehn            =   [EMAIL PROTECTED]
Senior Systems Programmer           or  [EMAIL PROTECTED]
Rensselaer Polytechnic Institute    or  [EMAIL PROTECTED]

To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-current" in the body of the message

Reply via email to