Eric Anholt wrote:
> On Sat, 2002-07-20 at 03:14, John Angelmo wrote:
>>Well here's my latest XFree86-4 build errors, I made a clean build 
>>uninstalled XFree-4, perl and so on but still I get these errors
> [...]
>>===>  Extracting for XFree86-4.2.0_1,1
>>>>No MD5 checksum file.
>>===>   XFree86-4.2.0_1,1 depends on shared library: Xft.1 - found
>>===>  Patching for XFree86-4.2.0_1,1
>>===>  Configuring for XFree86-4.2.0_1,1
>>===>  Installing for XFree86-4.2.0_1,1
>>===>   XFree86-4.2.0_1,1 depends on executable: xvinfo - found
>>===>   XFree86-4.2.0_1,1 depends on file: /usr/X11R6/lib/X11/doc/ddx.TXT - found
> You don't have XFree86-4 uninstalled, or don't have it uninstalled
> successfully.  Just removing the XFree86-4 metaport doesn't remove the
> miniports that contain the actual files.  If you are going to build
> without using portupgrade, you should start from scratch wrt XFree86
> (all XFree86-4 ports uninstalled along with imake-4).

That was the second buildattempt, usually I deinstall 
XFree86-4-documents -libraries imake-4 but still I get the same error in 
the end, if we could put XFree86-4-clients in the miniport before 
-documents I think that this problem would be solved.

>>===>   XFree86-4.2.0_1,1 depends on file: 
>/usr/X11R6/lib/X11/fonts/100dpi/UTBI__10-ISO8859-1.pcf.gz - not found
>>===>    Verifying reinstall for 
>/usr/X11R6/lib/X11/fonts/100dpi/UTBI__10-ISO8859-1.pcf.gz in 
>>===>  Extracting for XFree86-font100dpi-4.2.0
>>>>Checksum OK for xc/X420src-2.tgz.
>>===>   XFree86-font100dpi-4.2.0 depends on executable: mkfontdir - found
>>===>   XFree86-font100dpi-4.2.0 depends on executable: imake - found
>>===>   XFree86-font100dpi-4.2.0 depends on shared library: X11.6 - found
>>===>  Patching for XFree86-font100dpi-4.2.0
>>===>  Configuring for XFree86-font100dpi-4.2.0
>>(cd /usr/ports/x11-fonts/XFree86-4-font100dpi/work/xc/fonts/encodings &&  imake 
>-DUseInstalled -DProjectRoot=/usr/X11R6 -I/usr/X11R6/lib/X11/config  
>-DTOPDIR=../../.. -DCURDIR=.;  make Makefiles ;  make includes ;  make depend)
>>making Makefiles in large...
>>including in ./large...
>>depending in ./large...
>>(cd /usr/ports/x11-fonts/XFree86-4-font100dpi/work/xc/fonts/bdf/100dpi &&  imake 
>-DUseInstalled -DProjectRoot=/usr/X11R6 -I/usr/X11R6/lib/X11/config  
>-DTOPDIR=../../.. -DCURDIR=.;  make Makefiles ;  make includes ;  make depend)
>>make: don't know how to make /usr/X11R6/bin/ Stop
> I'm aware of this one.  Currently the solution is "use portupgrade -RiN
> XFree86-4".  I hope to get these dependencies fixed so it's not
> necessary to do this, but I haven't made it around to that yet.
> Also, for anyone reading this, one thing that'll help figure out build
> errors (particularly relating to dependencies like this) will be to
> include an ls -l /var/db/pkg/XFree86* /var/db/pkg/imake* with bug
> reports


To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-current" in the body of the message

Reply via email to