Hello all,

I've been having a number of problems with sound under freebsd-current.
First, when playing movies with xine or mplayer, I occasionally get hangs
that result in the mplayer (or xine) process being unkillable.  The
process remains in a runnable state according to ps, but does not respond
to SIGKILL.  I am then unable to use the pcm device until I reboot.
Second, I sometimes get panics while using mplayer, xine or xmms to play
audio, though this is less frequent than the unkillable process
condition.  I've been unable to see any details of the panic (since it
happens while I'm in X)--all I see is my system freeze, followed after a
while by a reboot.  Also, after the freeze I hear the sound card playing
the same buffer over and over again.  Could either of these problems have
to do with my having two sound cards?  Or perhaps it's because I've
enabled spdif output for pcm1.  Other than that I can't think of anything
unusual about my system that could be causing problems.

Thanks for your help,
Kyle Cronan

cat /dev/sndstat
FreeBSD Audio Driver (newpcm)
Installed devices:
pcm0: <ESS Technology Maestro-2E> at I/O port 0x9400 irq 10 (4p/0r/0v
channels duplex default)
pcm1: <CMedia CMI8738> at io 0xac00 irq 11 (1p/1r/0v channels duplex)

uname -a
FreeBSD alethea 5.0-CURRENT FreeBSD 5.0-CURRENT #8: Wed Jul 17 00:50:08
CDT 2002     root@alethea:/usr/src/sys/i386/compile/ALETHEA  i386

sysctl -a | grep pcm
hw.snd.pcm0.buffersize: 16384
hw.snd.pcm0.vchans: 0
hw.snd.pcm0.hwvol_step: 5
hw.snd.pcm0.hwvol_mixer: vol
hw.snd.pcm1.buffersize: 16384
hw.snd.pcm1.vchans: 0
hw.snd.pcm1.spdif_enabled: 1

To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-current" in the body of the message

Reply via email to