As Simon 'corecode' Schubert wrote:

> my kernel can't detect fdc anymore when loading acpi. does anybody else
> have such issues?

Hmm, not here.  However, my fdc driver is modloaded, too (from the
bootloader).  I just tried to unload it, then load acpi (which yields

module_register_init: MOD_LOAD (nexus/acpi, 0xc02109c0, 0xc3a83824) error 1

but the module appears in kldstat anyway), and then fdc, but that

Unfortunately, my scratch machine which is available for testing
doesn't speak ACPI at all.

> i know that it worked with a Aug 6 or a Aug 3 kernel, this was the last
> time i accessed my fd0.

I haven't been changing much in the fdc(4) code lately.  However, the
driver gets its resource allocations from elsewhere, and if ACPI is
present, wasn't it responsible for assigning resources?  I don't know
enough about ACPI, sorry.

> fdc0: output ready timeout
> fdc0: cmd 3 failed at out byte 1 of 3
> fdc0: output ready timeout
> fdc0: cmd 3 failed at out byte 1 of 3

All this smells a bit similar to the behaviour of the problem in
kern/21397, although it happens on those Compaqs even without ACPI.
What's mysterious there is that the boot-time probe works but any
later access fails with an FDC that's no longer responding at all to
ISA bus selections (pattern 0xff on the bus).

> fdc0: cannot reserve I/O port range (6 ports)
> fdc0 failed to probe at port 0x3f0 irq 6 drq 2 on isa0

Hmm.  This means that the resources are told to be unavailable by
whoever has to decide about this.

If i read this right, with the acpi module loaded, resource allocation
is perhaps handled by ACPI, while otherwise it's handled by the PnP

cheers, J"org               .-.-.   --... ...--   -.. .  DL8DTL                        NIC: JW11-RIPE
Never trust an operating system you don't have sources for. ;-)

To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-current" in the body of the message

Reply via email to