In my machine, FreeBSD 5.0-current, NetBSD 1.6-BETA and OpenBSD 3.1 
are installed, and they share some partitions, e.  g.  /home, and
had no problem.
Now, however, after FreeBSD mount those partitions once,
when NetBSD and OpenBSD mount those partitions at boot time, 
fsck stops with error number 8 
and *BSDs fall in single-user mode.  `fsck -y' doesn't succeed too.
If I run `fsck_ffs -b 32' on NetBSD and OpenBSD, fsck finishes completely.
But FreeBSD mounts those partition once, NetBSD and OpenBSD fall in 
single-user mode again.
Though this phenomenon doesn't happen with kernel at 21 June 2002 6:15 UTC,
that happens with one at 6:20 UTC.  
Differences between them may be UFS2 codes.
So UFS2 may prevent some *BSDs from mounting shared partitions.

This phenomenon is, however, not so critical, because NetBSD and 
OpenBSD can mount those partitions without fsck checking.
If I run `mount -a' and `exit' after NetBSD and OpenBSD fall
in single-user mode, those *BSDs start with no problem.
No file is lost.

Can you let your *BSDs share some partitions?  If anyone can't do it,
I'll write send-pr.

Below are messages of FreeBSD dmesg and mount:

Copyright (c) 1992-2002 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
        The Regents of the University of California. All rights reserved.
FreeBSD 5.0-CURRENT #38: Thu Aug 22 09:27:27 JST 2002
Preloaded elf kernel "/boot/kernel/kernel" at 0xc0464000.
Preloaded elf module "/boot/kernel/acpi.ko" at 0xc04640a8.
Timecounter "i8254"  frequency 1193182 Hz
Timecounter "TSC"  frequency 250568746 Hz
CPU: AMD-K6tm w/ multimedia extensions (250.57-MHz 586-class CPU)
  Origin = "AuthenticAMD"  Id = 0x570  Stepping = 0
  AMD Features=0x400<<b10>>
real memory  = 268419072 (262128K bytes)
avail memory = 255660032 (249668K bytes)
Using $PIR table, 8 entries at 0xc00f0d00
npx0: <math processor> on motherboard
npx0: INT 16 interface
acpi0: <ASUS   P5A     > on motherboard
acpi0: power button is handled as a fixed feature programming model.
Timecounter "ACPI-safe"  frequency 3579545 Hz
acpi_timer0: <24-bit timer at 3.579545MHz> port 0xec08-0xec0b on acpi0
acpi_cpu0: <CPU> on acpi0
acpi_pcib0: <Host-PCI bridge> port 0xcf8-0xcff on acpi0
pci0: <PCI bus> on acpi_pcib0
agp0: <Ali M1541 host to AGP bridge> mem 0xe0000000-0xe3ffffff at device 0.0 on pci0
pcib1: <PCI-PCI bridge> at device 1.0 on pci0
pci1: <PCI bus> on pcib1
pci1: <display, VGA> at device 0.0 (no driver attached)
pci0: <bridge, PCI-unknown> at device 3.0 (no driver attached)
isab0: <PCI-ISA bridge> at device 7.0 on pci0
isa0: <ISA bus> on isab0
de0: <Digital 21140A Fast Ethernet> port 0xd800-0xd87f mem 0xde000000-0xde00007f irq 9 
at device 9.0 on pci0
de0: 21140A [10-100Mb/s] pass 2.0
de0: address 00:80:c8:54:f5:eb
pcm0: <Avance Logic ALS4000> port 0xd400-0xd47f irq 10 at device 11.0 on pci0
atapci0: <AcerLabs Aladdin ATA33 controller> port 0xd000-0xd00f at device 15.0 on pci0
ata0: at 0x1f0 irq 14 on atapci0
ata1: at 0x170 irq 15 on atapci0
fdc0: <enhanced floppy controller (i82077, NE72065 or clone)> port 0x3f7,0x3f2-0x3f5 
irq 6 drq 2 on acpi0
fdc0: FIFO enabled, 8 bytes threshold
fd0: <1440-KB 3.5" drive> on fdc0 drive 0
ppc0 port 0x778-0x77b,0x378-0x37f irq 7 drq 3 on acpi0
ppc0: SMC-like chipset (ECP/EPP/PS2/NIBBLE) in COMPATIBLE mode
ppc0: FIFO with 16/16/7 bytes threshold
lpt0: <Printer> on ppbus0
lpt0: Interrupt-driven port
sio0 port 0x3f8-0x3ff irq 4 on acpi0
sio0: type 16550A
sio1 port 0x2f8-0x2ff irq 3 on acpi0
sio1: type 16550A
atkbdc0: <Keyboard controller (i8042)> port 0x64,0x60 irq 1 on acpi0
atkbd0: <AT Keyboard> flags 0x1 irq 1 on atkbdc0
kbd0 at atkbd0
psm0: <PS/2 Mouse> irq 12 on atkbdc0
psm0: model IntelliMouse, device ID 3
orm0: <Option ROM> at iomem 0xc0000-0xc7fff on isa0
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
Timecounters tick every 10.000 msec
ad0: DMA limited to UDMA33, non-ATA66 cable or device
ad0: 38166MB <ST340823A> [77545/16/63] at ata0-master UDMA33
acd0: CD-RW <4424 CDRW> at ata1-slave PIO3
Mounting root from ufs:/dev/ad0s2a
de0: enabling 10baseT port

/dev/ad0s2a on / (ufs, local)
devfs on /dev (devfs, local)
/dev/md0c on /tmp (ufs, local, nodev, nosuid, soft-updates)
/dev/ad0s1 on /dos (msdosfs, local)
/dev/ad0s2h on /home (ufs, local)
/dev/ad0s2f on /usr (ufs, local)
/dev/ad0s2g on /usr/src (ufs, asynchronous, local)
/dev/ad0s2e on /var (ufs, local)

Kazuhito HONDA

To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-current" in the body of the message

Reply via email to