On Sat, 7 Sep 2002, Craig Rodrigues wrote:

> I did a cvsup from a few hours ago, and rebuilt the world.
> make buildworld worked fine.
> make installworld failed:
> ===> usr.sbin/ppp^M
> install -s -o root -g network -m 4554   ppp /usr/sbin
> m4  /usr/src/usr.sbin/ppp/ppp.8.m4 >ppp.8
> m4: not found
> I also had similar problems in /usr/src/share/termcap, because
> the Makefile there could not find /usr/bin/cap_mkdb and
> /usr/bin/ex.
> I worked around the problem by replacing references
> to m4, cap_mkdb, and ex
> in /usr/src/usr.sbin/ppp/Makefile and /usr/src/share/termcap/Makefile
> with fully qualified path names.
> Any ideas what could cause this?

Some local problem with timestamps, together with a bug in bsd.files.mk
(it uses a hack to create dependencies, and this results in things being
rebuilt at install time if something is out of date; building things at
install times is an error and the error happens to be detected because
some utilities needed for building are not in $PATH).

> My environment has /usr/bin in its PATH.  Also, if I manually
> cd to either of those directories and do: make install, then
> it finds the programs in /usr/bin with no problem.

The error is not detected in this case because there are too many utilities
in $PATH.  Building at install time would still fail if the relevant obj
directories are not writable.


To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-current" in the body of the message

Reply via email to