> In trying to setup a ccd on a -current system I
> seem to have run into a few issues:
> /etc/ccd.conf:
> # ccd           ileave  flags   component devices
> ccd0             64      none    /dev/ad1s1a /dev/ad2s1a
> # ccdconfig -g
> ccd0            64      0       /dev/ad1s1a /dev/ad2s1a
> # ls -al /dev/ccd*
> crw-r-----  1 root  operator   74,   2 Nov 17 22:09 /dev/ccd0c
> So far, so good...
> # disklabel -rw ccd0c auto
> disklabel: auto: unknown disk type
> # disklabel -rw ccd0 auto 
> disklabel: cannot open /dev/ccd0: No such file or directory
> disklabel: auto: unknown disk type
> #disklabel -e ccd0c
> disklabel: ioctl DIOCWDINFO: no disk label on disk;
> add "-r" to install initial label
> re-edit the label? [y]: 

i've never been able to use disklabel with CCD since ages.. I've always
newfs'ed my ccd once the ccdconfig -C done.. i'm using CCD since 
FreeBSD 4.x, and a current -stable gave me the same result.. 
# ccdconfig -g
ccd0            128     0       /dev/ad0s1g /dev/ad1s1e /dev/ad2s1e /dev/ad3s1e
ftp# df -gHli
Filesystem    Size   Used  Avail Capacity iused    ifree %iused  Mounted on
/dev/ad0s1a    66M    43M    18M    70%    1529     6661   19%   /
/dev/ad0s1e   258M   119M   119M    50%    8843    22899   28%   /usr
/dev/ad0s1f   132M   985K   121M     1%     104    16150    1%   /var
procfs        4.1K   4.1K     0B   100%      38      974    4%   /proc
/dev/ccd0c    260G   138G   122G    53%   80212 31819434    0%   /mnt/space

> newfs: ioctl (WDINFO): /dev/ccd0c: can't rewrite disk label: No such process
> Should we be able to disklabel 'auto' a ccd?

AFAICS, disklabeling CCD is useless. If i need to create more than one CCD,
i create more slice per disk, then CCD them into different disks.

> Should we be able to create multiple partitions? ('a','c','d', etc)

i've tried to, for hours, few years ago when i was a poor student using a
bunch of disk (some old SCSI-1 380mb HD full height) on a FreeBSD 2.x (if
i remember correctly).. Never managed to create more partition on a CCD

> If not, the ccdconfig man page and handbook probably need
> a bit of updating. They seem to indicate that the above should work.

i think so, but since noone were reporting that, i was thinking
that i was doing something wrong while creating those CCDs..

> Comments?
> Thanks,
> John
> To Unsubscribe: send mail to [EMAIL PROTECTED]
> with "unsubscribe freebsd-current" in the body of the message

Guezou Philippe                                 [EMAIL PROTECTED]
FreeBSD, The power to serve.

Buying an operating system without source is like buying
a self-assembly Space Shuttle with no instructions.

To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-current" in the body of the message

Reply via email to