On Tue, 17 Dec 2002 [EMAIL PROTECTED] wrote:

> I have a problem getting CURRENT to find my ISA SMC Ultra ethernet
> card.  No matter what I do I can't stop the kernel finding a third
> sio device on top of the memory and interrupt that the ed card
> occupies.  The kernel correctly registers its surprise at finding
> the third sio device since no hints for it exist:
> sio0 port 0x3f8-0x3ff irq 4 on acpi0
> sio0: type 16550A
> sio1 port 0x2f8-0x2ff irq 3 on acpi0
> sio1: type 16550A
> sio2: configured irq 10 not in bitmap of probed irqs 0
> sio2: port may not be enabled
> sio2 port 0x2e8-0x2ef irq 10 on acpi0
> sio2: type 16550A
> I've tried setting hint.sio.2.disabled=1.  I've tried leaving it
> out.  I can't not have sio because this server is my router and is
> permanently connected to a modem.

I guess sio2 really exists.  In any case, you don't really want it
because iof the interrupt conflict.  Try using full hints for it.  I
would have expected just the "disabled" hint to work though.  Try
leaving out the irq hint.  This should give polled mode for sio (and
thus no conflict with other devices using the irq) and works for the
plain isa case.  I suspect that there is a problem with resources
getting merged (can the irq resource be supplied by acpi even when it is
intentionally left out of the hints?).  I avoid these problems by not
using acpi.

> The SMC Ultra card exists on 0x280 irq 10 0xd8000.  Has current
> dropped ISA support (which was hinted at in the GENERIC/80386
> thread)?



To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-current" in the body of the message

Reply via email to