Adam K Kirchhoff wrote:
> I recently moved a firewire card and DVD drive that had been in my FreeBSD
> box to another computer.  I replaced it with an IDE DVD drive.  The
> probelm is that now I can't get mplayer or vlc to play any DVDs that had
> previously worked with the firewire drive.
[ ... ]
> "Couldn't open DVD device: /dev/dvd"
[ ... ]
> Now /dev/dvd is a symlink to /dev/acd0:
> [ [EMAIL PROTECTED] - /usr/home/adamk ]: ls -l /dev/dvd
> lrwxr-xr-x  1 root  wheel  3 Aug 25 15:54 /dev/dvd -> /dev/acd0
> And /dev/acd0 looks like:
> [ [EMAIL PROTECTED] - /usr/home/adamk ]: ls -l /dev/acd0
> crw-r--r--  1 root  operator  117,   0 Aug 25 15:36 /dev/acd0
> Note:  user 'adamk' is part of the 'operator' group.  In addition, as you
> can see from the mplayer.txt file, I've tried this as root just in case
> there's some strange permission thing going on.  Still no luck.

A really common problem with DVD and audio-using programs is
they try to open device read/write, instead of read-only.

I notice that you don't have write permission.  This might be
your problem.

Also, you may want to try a hard link instead of a symbolic
link; see "man devfs" and "man rc.devfs".

Finally, try recompiling your DVD player program, whatever it
is, since it might check at compile time what it's talking to,
and be too dumb to do the right thing.

You may also want to pint it directly at the device, instead
of using a symbolic link and making things more complicated
than they need to be (one less variable to vary and cause

-- Terry
[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to