Pawel Worach wrote:
Robert Watson wrote:

On Wed, 27 Aug 2003, Pawel Worach wrote:

Ok, so let me see if I have the sequence of events straight:

Hope this is not as confusing as my previus mail :)

Here is some more information. I realized that i had tcp and udp "blackholing" enabled on the server so i disabled that, still no dice. disabled rpc.statd and rpc.lockd, still no dice.

I escaped to DDB between the "not responding" and the "ok" messages
and came up with this:
[SLP]nfscon <address>] mount_nfs
[SLP]- <address>] nfsiod 3
[SLP]- <address>] nfsiod 2
[SLP]- <address>] nfsiod 1
[SLP]- <address>] nfsiod 0

I have also played with the mount options, here is the result of that:
ro,nfsv3,tcp,rdirplus - broken
ro,nfsv3,tcp - broken
ro,tcp - broken
ro - ok (defaults to nfsv2,udp according to my research)
ro,nfsv3 - ok (defaults to udp)

So it looks like what i said before, only tcp seems to cause this.

As this is the first time i'm seriusly investigating this i also noted
that a restart of the NFS daemons (or reboot) of the server is not needed,
just doing a _clean_ reboot (init 6, shutdown -r now) of the client will
make the server "recover". (sometimes is takes two clean reboots).

- Pawel

_______________________________________________ [EMAIL PROTECTED] mailing list To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to