Oh yes, user threading doesn't support multiple CPUs... Thanks for
pointing me.

Both libkse and libthr work with that code snippet, but Viewperf
when linked against any of them locks my machine pretty deadly.
With Linuxthreads it just segfaults ;)


Dan Nelson wrote:
> In the last episode (Sep 01), RMH said:
> > Hello gentlemen,
> >
> > I seem to have threading problems with 5.1-RELEASE. Every time I run
> > a multithreaded application (linked against libc_r) on a SMP system,
> > I get only 1 CPU loaded at any moment given. I tried different
> Correct.  libc_r is a userland threading library, which means that all
> threads run as a single plain process.  Linuxthreads forks a new
> process for each thread.  Try linking with -lkse or -lthr; both of
> these threading libraries allow multiple threads to run simultaneously
> on multiple CPUs.
> --
>         Dan Nelson

Want to chat instantly with your online friends?  Get the FREE Yahoo!
Messenger http://uk.messenger.yahoo.com/
[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to