[ Some CC's stripped ] On Mon, 22 Mar 2010, M. Warner Losh wrote:
P.S. I think that there's much traction to the idea of moving from COMPAT_FREEBSDx to some other variable called, for example, COMPAT_FREEBSD_BACK_TO=x, which will give compatibility for binaries as old as FreeBSD x.0, and have all the other magic handled behind the scenes. This would render the inconsistency with COMPAT_FREEBSDx part of the debate completely moot.
Doesn't matter. We're still use to COMPAT_FREEBSDx since it's been here so long. So regardless if you rename them to COMPAT_FREEBSD_BACK_TO=x, it is still potentially confusing. COMPAT_ARCH32 and all other choices David mentions seem like much better names - even if there wasn't any existing COMPAT_FREEBSDx knobs. My $0.02. -- DE _______________________________________________ email@example.com mailing list http://lists.freebsd.org/mailman/listinfo/freebsd-current To unsubscribe, send any mail to "freebsd-current-unsubscr...@freebsd.org"