https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=212845

            Bug ID: 212845
           Summary: emulators/virtualbox-ose: 5.1.6 can't connect USB
                    devices
           Product: Ports & Packages
           Version: Latest
          Hardware: Any
                OS: Any
            Status: New
          Severity: Affects Only Me
          Priority: ---
         Component: Individual Port(s)
          Assignee: v...@freebsd.org
          Reporter: gra...@menhennitt.com.au
             Flags: maintainer-feedback?(v...@freebsd.org)
          Assignee: v...@freebsd.org

I've been using my Epson scanner in Windows XP under VirtualBox for many
years. I recently updated my source and ports to the latest and now I
can't access my scanner. In fact I can't seem to attach any USB devices.
I've tried creating a filter for it under USB Settings, and I've tried
manually connecting it from the Devices->USB menu by clicking its
checkbox. In both cases, it doesn't connect. If I try a second time, I
get a message:

Failed to attach the USB device EPSON Scanner to the virtual machine
WinXP.

USB device 'EPSON EPSON Scanner' with UUID
{aa1eba25-05eb-4aed-8e9f-803807dd3bc4} is busy with a previous request.
Please try again later.

Result Code: NS_ERROR_INVALID_ARG (0x80070057)
Component: HostUSBDeviceWrap
Interface: IHostUSBDevice {c19073dd-cc7b-431b-98b2-951fda8eab89}
Callee: IConsole {872da645-4a9b-1727-bee2-5585105b9eed}

I've waited for an hour in case it was just taking a long time to
connect - no joy.

This is on FreeBSD 11-Stable AMD64, and ports updated to (r422267). And I built
the kmod with the correct current kernel source in place. It's not a problem
with permissions on the /dev/usb entries.

Today I reverted back to the port as of last month (5.0.26) and it's all
working again.

-- 
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
freebsd-emulation@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-emulation
To unsubscribe, send any mail to "freebsd-emulation-unsubscr...@freebsd.org"

Reply via email to