https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=221294

            Bug ID: 221294
           Summary: emulators/virtualbox-ose  5.1.26 r117224 Win7 VM
                    Creation Fails
           Product: Ports & Packages
           Version: Latest
          Hardware: Any
                OS: Any
            Status: New
          Severity: Affects Many People
          Priority: ---
         Component: Individual Port(s)
          Assignee: v...@freebsd.org
          Reporter: papow...@astart.com
             Flags: maintainer-feedback?(v...@freebsd.org)
          Assignee: v...@freebsd.org

Created attachment 185107
  --> https://bugs.freebsd.org/bugzilla/attachment.cgi?id=185107&action=edit
TAR of screenshots

Summary: cannot create a Windows 7 VM with Virtualbox 5.1.26 (FreeBSD 11.[01])
A VM can be created with VirtualBox 4.3.38 (FreeBSD 10.3)

I upgraded to FreeBSD 11.1 and installed VirtualBox 5.1.26 using PKG on 2 Aug
2017. The Windows 7 VMs I had created under FreeBSD 10.3, Virtualbox 4.3.38 OSE
r106717 were imported and ran without problems.  However,  when I tried to
create a new VM on FreeBSD 11.1/11.0 using VirtualBox 5.1.26, both from the
PORTs repository AND when compiled from source,  I got the same set of
problems.

When installing Windows 7 you start by creating a virtual machine flagged as
Win 7 64amd.  You boot the virtual machine and provide it an ISO image of the
Win 7 64 bit Install CD.  The VM then boots from the CD,  goes through a
prelimiary setup phase,  and then starts to copy and unpack files from the ISO
image.  During this process it displays a progress bar showing the amount of
work done.

The unpacking operation appears to fail randomly - 10%, 12%, 20%, 26%, 54%.
If you google the failure message,  then problem (according to MS) is that you
have either a bad DVD, or memory and to take corrective actions.

The ISO image checksum matches the published MD5 checksum.  I have tried this
on two different systems with the same result.  I am attaching screenshots
showing the output of the install and the Vbox.log file.

In the Vbox.log file there appears to be a hint of the cause of the failure:

00:12:32.856035 AioMgr0-N: Request 0x000000a537bd00 failed with
rc=VERR_TRY_AGAIN, migrating endpoint /root/VirtualBox
VMs/Win7_2017-08-06/Win7_2017-08-06.vdi to failsafe manager.

00:12:34.601955 AIOMgr: I/O manager 0x000000993963a0 encountered a critical
error (rc=VERR_FILE_AIO_NO_REQUEST) during operation. Falling back to failsafe
mode. Expect reduced performance

00:12:34.602001 AIOMgr: Error happened in
/wrkdirs/usr/ports/emulators/virtualbox-ose/work/VirtualBox-5.1.26/src/VBox/VMM/VMMR3/PDMAsyncCompletionFileNormal.cpp:(1673){int
pdmacFileAioMgrNormal(RTTHREAD, void *)}

00:12:34.602006 AIOMgr: Please contact the product vendor

Thanks for any help or suggestions on this problem

-- 
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
freebsd-emulation@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-emulation
To unsubscribe, send any mail to "freebsd-emulation-unsubscr...@freebsd.org"

Reply via email to