Vladimir Krstulja <vlad-f...@acheronmedia.com> has reassigned Bugzilla
Automation <bugzi...@freebsd.org>'s request for maintainer-feedback to
Bug 221361: www/firefox: Unable to build 55.0,1 due to system SQLite not
compiled with SQLITE_ENABLE_FTS3

--- Description ---
Created attachment 185190
  --> https://bugs.freebsd.org/bugzilla/attachment.cgi?id=185190&action=edit
Firefox-55.0,1 build log

I'm unable to build Firefox-55.0,1 with Poudriere (11.1, amd64) because it
complains that:

DEBUG: configure: error: System SQLite library is not compiled with

But, I have sqlite3-3.20.0 with FTS3_TOKEN and FTS4 options enabled. Help text
for FTS4 suggests it enables FTS3/4 module.

I've also tried deleting the sqlite3 package from Poudriere's repo directory,
and rebuilt everything, which recompiled all ports that depend on sqlite3, but
Firefox is still failing with the same error.

Attached is the full Firefox build log. Firefox-55.0,1 built fine the other
day, but I guess it was with sqlite3-3.19.3,1, as 3.20.0 was bumped to
yesterday (2017-08-08). Looking at the commit, only the version was bumped, no
other changes were done.
freebsd-gecko@freebsd.org mailing list
To unsubscribe, send any mail to "freebsd-gecko-unsubscr...@freebsd.org"

Reply via email to