In message <pine.bsf.4.10.9907290051210.3955-100...@janus.syracuse.net> "Brian 
F. Feldman" writes:
:       if ((p1 = (u_char *)mmap(NULL,
: -         (size_t)length, PROT_READ, MAP_SHARED, fd1, off1)) == (u_char 
*)MAP_FAILED)
: +         (size_t)mlength, PROT_READ, MAP_SHARED, fd1, off1)) == (u_char 
*)MAP_FAILED)
:               err(ERR_EXIT, "%s", file1);

This would be a good candiate for different line breaks for clarity

        if ((p1 = (u_char *)mmap(NULL, (size_t)mlength, PROT_READ, MAP_SHARED,
            fd1, off1)) == (u_char *)MAP_FAILED)

would be more readable and not violate the 80 column rule.  Since the
call to mmap is already split and you are already changing it, I don't 
think this would be a problem.  While I do try to minimize stylistic
changes, I think this one makes good sense....

: -         (size_t)length, PROT_READ, MAP_SHARED, fd2, off2)) == (u_char 
*)MAP_FAILED)
: +         (size_t)mlength, PROT_READ, MAP_SHARED, fd2, off2)) == (u_char 
*)MAP_FAILED)
:               err(ERR_EXIT, "%s", file2);

See above :-)

Warner


To Unsubscribe: send mail to majord...@freebsd.org
with "unsubscribe freebsd-hackers" in the body of the message

Reply via email to