You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     hask...@freebsd.org
Last committer: arr...@freebsd.org
Ident:          $FreeBSD: head/devel/hs-microlens-th/Makefile 489474 2019-01-06 
12:18:06Z arrowd $
Log URL:        
http://pylon.nyi.freebsd.org/data/head-powerpc64-default/p495681_s345110/logs/hs-microlens-th-0.4.2.3_1.log
Build URL:      
http://pylon.nyi.freebsd.org/build.html?mastername=head-powerpc64-default&build=p495681_s345110
Log:

=>> Building devel/hs-microlens-th
build started at Fri Mar 15 00:16:10 UTC 2019
port directory: /usr/ports/devel/hs-microlens-th
package name: hs-microlens-th-0.4.2.3_1
building for: FreeBSD head-powerpc64-default-job-11 13.0-CURRENT FreeBSD 
13.0-CURRENT 1300014 powerpc
maintained by: hask...@freebsd.org
Makefile ident:      $FreeBSD: head/devel/hs-microlens-th/Makefile 489474 
2019-01-06 12:18:06Z arrowd $
Poudriere version: 3.2.8-3-g02cc9753
Host OSVERSION: 1300012
Jail OSVERSION: 1300014
Job Id: 11




!!! Jail is newer than host. (Jail: 1300014, Host: 1300012) !!!
!!! This is not supported. !!!
!!! Host kernel must be same or newer than jail. !!!
!!! Expect build failures. !!!



---Begin Environment---
SHELL=/bin/csh
OSVERSION=1300014
UNAME_v=FreeBSD 13.0-CURRENT 1300014
UNAME_r=13.0-CURRENT
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
HOME=/root
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
LOCALBASE=/usr/local
USER=root
LIBEXECPREFIX=/usr/local/libexec/poudriere
POUDRIERE_VERSION=3.2.8-3-g02cc9753
MASTERMNT=/usr/local/poudriere/data/.m/head-powerpc64-default/ref
POUDRIERE_BUILD_TYPE=bulk
PACKAGE_BUILDING=yes
SAVED_TERM=
PWD=/usr/local/poudriere/data/.m/head-powerpc64-default/ref/.p/pool
P_PORTS_FEATURES=FLAVORS SELECTED_OPTIONS
MASTERNAME=head-powerpc64-default
SCRIPTPREFIX=/usr/local/share/poudriere
OLDPWD=/usr/local/poudriere/data/.m/head-powerpc64-default/ref/.p
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
POUDRIEREPATH=/usr/local/bin/poudriere
---End Environment---

---Begin Poudriere Port Flags/Env---
PORT_FLAGS=
PKGENV=
FLAVOR=
DEPENDS_ARGS=
MAKE_ARGS=
---End Poudriere Port Flags/Env---

---Begin OPTIONS List---
===> The following configuration options are available for 
hs-microlens-th-0.4.2.3_1:
     DOCS=on: Build and/or install documentation
     DYNAMIC=on: Add support for dynamic linking
     HSCOLOUR=off: Colorize generated documentation by HsColour
     PROFILE=off: Add support for profiling
===> Use 'make config' to modify these settings
---End OPTIONS List---

--MAINTAINER--
hask...@freebsd.org
--End MAINTAINER--

--CONFIGURE_ARGS--
--libdir=/usr/local/lib/cabal/ghc-8.6.3 --libsubdir=microlens-th-0.4.2.3 
--with-gcc=cc --with-ld=ld --with-ar=ar --haddock-options=-w 
--with-haddock=/usr/local/bin/haddock --enable-shared 
--enable-executable-dynamic --disable-profiling --disable-library-profiling
--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
XDG_DATA_HOME=/wrkdirs/usr/ports/devel/hs-microlens-th/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/devel/hs-microlens-th/work  
HOME=/wrkdirs/usr/ports/devel/hs-microlens-th/work 
TMPDIR="/wrkdirs/usr/ports/devel/hs-microlens-th/work/tmp" 
PATH=/wrkdirs/usr/ports/devel/hs-microlens-th/work/.bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
 SHELL=/bin/sh CONFIG_SHELL=/bin/sh LANG=en_US.UTF-8 LC_ALL=en_US.UTF-8
--End CONFIGURE_ENV--

--MAKE_ENV--
DESTDIR=/wrkdirs/usr/ports/devel/hs-microlens-th/work/stage 
TMPDIR=/wrkdirs/usr/ports/devel/hs-microlens-th/work/tmp 
XDG_DATA_HOME=/wrkdirs/usr/ports/devel/hs-microlens-th/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/devel/hs-microlens-th/work  
HOME=/wrkdirs/usr/ports/devel/hs-microlens-th/work 
TMPDIR="/wrkdirs/usr/ports/devel/hs-microlens-th/work/tmp" 
PATH=/wrkdirs/usr/ports/devel/hs-microlens-th/work/.bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
 NO_PIE=yes MK_DEBUG_FILES=no MK_KERNEL_SYMBOLS=no SHELL=/bin/sh NO_LINT=YES 
LANG=en_US.UTF-8 LC_ALL=en_US.UTF-8 PREFIX=/usr/local  LOCALBASE=/usr/local  
CC="cc" CFLAGS="-O2 -pipe  -I/usr/local/include -fno-strict-aliasing "  
CPP="cpp" CPPFLAGS="-I/usr/local/include"  LDFLAGS=" -L/usr/local/lib " LIBS="" 
 CXX="c++" CXXFLAGS="-O2 -pipe -I/usr/local/include -fno-strict-aliasing  "  
MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install  -s -m 555"  
BSD_INSTALL_LIB="install  -s -m 0644"  BSD_INSTALL_SCRIPT="install  -m 55
 5"  BSD_INSTALL_DATA="install  -m 0644"  BSD_INSTALL_MAN="install  -m 444"
--End MAKE_ENV--

--PLIST_SUB--
GHC_VERSION=8.6.3  PORTNAME=microlens-th  PORTVERSION=0.4.2.3  
LIBDIR_REL=lib/cabal/ghc-8.6.3/microlens-th-0.4.2.3 PORTDOCS="" OSREL=13.0 
PREFIX=%D LOCALBASE=/usr/local  RESETPREFIX=/usr/local LIB32DIR=lib 
DOCSDIR="share/doc/cabal/ghc-8.6.3/microlens-th-0.4.2.3"  
EXAMPLESDIR="share/examples/cabal/ghc-8.6.3/microlens-th-0.4.2.3"  
DATADIR="share/cabal/ghc-8.6.3/microlens-th-0.4.2.3"  WWWDIR="www/microlens-th" 
 ETCDIR="etc/microlens-th"
--End PLIST_SUB--

--SUB_LIST--
PREFIX=/usr/local LOCALBASE=/usr/local  
DATADIR=/usr/local/share/cabal/ghc-8.6.3/microlens-th-0.4.2.3 
DOCSDIR=/usr/local/share/doc/cabal/ghc-8.6.3/microlens-th-0.4.2.3 
EXAMPLESDIR=/usr/local/share/examples/cabal/ghc-8.6.3/microlens-th-0.4.2.3  
WWWDIR=/usr/local/www/microlens-th ETCDIR=/usr/local/etc/microlens-th
--End SUB_LIST--

---Begin make.conf---
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
PACKAGE_BUILDING=yes
PACKAGE_BUILDING_FLAVORS=yes
#### /usr/local/etc/poudriere.d/make.conf ####
# XXX: We really need this but cannot use it while 'make checksum' does not
# try the next mirror on checksum failure.  It currently retries the same
# failed mirror and then fails rather then trying another.  It *does*
# try the next if the size is mismatched though.
#MASTER_SITE_FREEBSD=yes
# Build ALLOW_MAKE_JOBS_PACKAGES with 2 jobs
MAKE_JOBS_NUMBER=2

# stable/10 includes src.conf too late but make.conf is in sys.mk
.if ${.CURDIR:M/poudriere/jails/10*/usr/src/usr.bin/xlint*}
# Disable build of llib now that head no longer has lint(1)
LINT=   true
.endif
#### /usr/ports/Mk/Scripts/ports_env.sh ####
_CCVERSION_921dbbb2=cc (GCC) 4.2.1 20070831 patched [FreeBSD] Copyright (C) 
2007 Free Software Foundation, Inc. This is free software; see the source for 
copying conditions. There is NO warranty; not even for MERCHANTABILITY or 
FITNESS FOR A PARTICULAR PURPOSE.
_ALTCCVERSION_921dbbb2=none
_CXXINTERNAL_acaad9ca=Using built-in specs. Target: 
powerpc64-undermydesk-freebsd Configured with: FreeBSD/powerpc64 system 
compiler Thread model: posix gcc version 4.2.1 20070831 patched [FreeBSD] 
"/usr/bin/ld" "--eh-frame-hdr" "-Qy" "-melf64ppc_fbsd" "--enable-new-dtags" 
"-dynamic-linker" "/libexec/ld-elf.so.1" "/usr/lib/crt1.o" "/usr/lib/crti.o" 
"/usr/lib/crtbegin.o" "-L/usr/lib" "-L/usr/lib" "/dev/null" "-lstdc++" "-lm" 
"-lgcc_s" "-lgcc" "-lc" "-lgcc_s" "-lgcc" "/usr/lib/crtsavres.o" 
"/usr/lib/crtend.o" "/usr/lib/crtn.o"
CC_OUTPUT_921dbbb2_58173849=yes
CC_OUTPUT_921dbbb2_9bdba57c=yes
CC_OUTPUT_921dbbb2_6a4fe7f5=cc1: error: unrecognized command line option 
"-std=c11"
CC_OUTPUT_921dbbb2_6bcac02b=yes
CC_OUTPUT_921dbbb2_67d20829=yes
CC_OUTPUT_921dbbb2_bfa62e83=cc1: error: unrecognized command line option 
"-std=gnu11"
CC_OUTPUT_921dbbb2_f0b4d593=yes
CC_OUTPUT_921dbbb2_308abb44=cc1plus: error: unrecognized command line option 
"-std=c++0x"
CC_OUTPUT_921dbbb2_f00456e5=cc1plus: error: unrecognized command line option 
"-std=c++11"
CC_OUTPUT_921dbbb2_65ad290d=cc1plus: error: unrecognized command line option 
"-std=c++14"
CC_OUTPUT_921dbbb2_f2776b26=cc1plus: error: unrecognized command line option 
"-std=c++17"
CC_OUTPUT_921dbbb2_b2657cc3=yes
CC_OUTPUT_921dbbb2_380987f7=cc1plus: error: unrecognized command line option 
"-std=gnu++11"
CC_OUTPUT_921dbbb2_160933ec=cc1plus: error: unrecognized command line option 
"-std=gnu++14"
CC_OUTPUT_921dbbb2_fb62803b=cc1plus: error: unrecognized command line option 
"-std=gnu++17"
_OBJC_CCVERSION_921dbbb2=cc (GCC) 4.2.1 20070831 patched [FreeBSD] Copyright 
(C) 2007 Free Software Foundation, Inc. This is free software; see the source 
for copying conditions. There is NO warranty; not even for MERCHANTABILITY or 
FITNESS FOR A PARTICULAR PURPOSE.
_OBJC_ALTCCVERSION_921dbbb2=none
ARCH=powerpc64
OPSYS=FreeBSD
_OSRELEASE=13.0-CURRENT
OSREL=13.0
OSVERSION=1300014
PYTHONBASE=/usr/local
CONFIGURE_MAX_CMD_LEN=262144
HAVE_PORTS_ENV=1
#### Misc Poudriere ####
GID=0
UID=0
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
--Resource limits--
cpu time               (seconds, -t)  unlimited
file size           (512-blocks, -f)  unlimited
data seg size           (kbytes, -d)  33554432
stack size              (kbytes, -s)  524288
core file size      (512-blocks, -c)  unlimited
max memory size         (kbytes, -m)  unlimited
locked memory           (kbytes, -l)  unlimited
max user processes              (-u)  89999
open files                      (-n)  1024
virtual mem size        (kbytes, -v)  unlimited
swap limit              (kbytes, -w)  unlimited
socket buffer size       (bytes, -b)  unlimited
pseudo-terminals                (-p)  unlimited
kqueues                         (-k)  unlimited
umtx shared locks               (-o)  unlimited
--End resource limits--
=======================<phase: check-sanity   >============================
===>  License BSD3CLAUSE accepted by the user
===========================================================================
=======================<phase: pkg-depends    >============================
===>   hs-microlens-th-0.4.2.3_1 depends on file: /usr/local/sbin/pkg - not 
found
===>   Installing existing package /packages/All/pkg-1.10.5_5.txz
[head-powerpc64-default-job-11] Installing pkg-1.10.5_5...
[head-powerpc64-default-job-11] Extracting pkg-1.10.5_5: .......... done
===>   hs-microlens-th-0.4.2.3_1 depends on file: /usr/local/sbin/pkg - found
===>   Returning to build of hs-microlens-th-0.4.2.3_1
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===>  License BSD3CLAUSE accepted by the user
===> Fetching all distfiles required by hs-microlens-th-0.4.2.3_1 for building
===========================================================================
=======================<phase: checksum       >============================
===>  License BSD3CLAUSE accepted by the user
===> Fetching all distfiles required by hs-microlens-th-0.4.2.3_1 for building
=> SHA256 Checksum OK for cabal/microlens-th-0.4.2.3.tar.gz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===>  License BSD3CLAUSE accepted by the user
===> Fetching all distfiles required by hs-microlens-th-0.4.2.3_1 for building
===>  Extracting for hs-microlens-th-0.4.2.3_1
=> SHA256 Checksum OK for cabal/microlens-th-0.4.2.3.tar.gz.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for hs-microlens-th-0.4.2.3_1
===========================================================================
=======================<phase: build-depends  >============================
===>   hs-microlens-th-0.4.2.3_1 depends on executable: ghc - not found
===>   Installing existing package /packages/All/ghc-8.6.3.txz
[head-powerpc64-default-job-11] Installing ghc-8.6.3...
[head-powerpc64-default-job-11] `-- Installing gcc8-8.3.0...
[head-powerpc64-default-job-11] |   `-- Installing binutils-2.32,1...
[head-powerpc64-default-job-11] |   | `-- Installing 
gettext-runtime-0.19.8.1_2...
[head-powerpc64-default-job-11] |   |   `-- Installing indexinfo-0.3.1...
[head-powerpc64-default-job-11] |   |   `-- Extracting indexinfo-0.3.1: .... 
done
[head-powerpc64-default-job-11] |   | `-- Extracting 
gettext-runtime-0.19.8.1_2: .......... done
[head-powerpc64-default-job-11] |   `-- Extracting binutils-2.32,1: .......... 
done
[head-powerpc64-default-job-11] |   `-- Installing gcc5-5.5.0_6...
[head-powerpc64-default-job-11] |   | `-- Installing gmp-6.1.2_1...
[head-powerpc64-default-job-11] |   | `-- Extracting gmp-6.1.2_1: .......... 
done
[head-powerpc64-default-job-11] |   | `-- Installing mpc-1.1.0_2...
[head-powerpc64-default-job-11] |   |   `-- Installing mpfr-4.0.2...
[head-powerpc64-default-job-11] |   |   `-- Extracting mpfr-4.0.2: .......... 
done
[head-powerpc64-default-job-11] |   | `-- Extracting mpc-1.1.0_2: ......... done
[head-powerpc64-default-job-11] |   `-- Extracting gcc5-5.5.0_6: .......... done
[head-powerpc64-default-job-11] `-- Extracting gcc8-8.3.0: .......... done
[head-powerpc64-default-job-11] `-- Installing libffi-3.2.1_3...
[head-powerpc64-default-job-11] `-- Extracting libffi-3.2.1_3: .......... done
[head-powerpc64-default-job-11] `-- Installing libiconv-1.14_11...
[head-powerpc64-default-job-11] `-- Extracting libiconv-1.14_11: .......... done
[head-powerpc64-default-job-11] Extracting ghc-8.6.3: .......... done
Message from gcc5-5.5.0_6:

To ensure binaries built with this toolchain find appropriate versions
of the necessary run-time libraries, you may want to link using

  -Wl,-rpath=/usr/local/lib/gcc5

For ports leveraging USE_GCC, USES=compiler, or USES=fortran this happens
transparently.

===>   NOTICE:

This port is deprecated; you may wish to reconsider installing it:

Unsupported by upstream. Use GCC 7 or newer instead..
Message from gcc8-8.3.0:

To ensure binaries built with this toolchain find appropriate versions
of the necessary run-time libraries, you may want to link using

  -Wl,-rpath=/usr/local/lib/gcc8

For ports leveraging USE_GCC, USES=compiler, or USES=fortran this happens
transparently.
===>   hs-microlens-th-0.4.2.3_1 depends on executable: ghc - found
===>   Returning to build of hs-microlens-th-0.4.2.3_1
===>   hs-microlens-th-0.4.2.3_1 depends on package: ghc>=8.6.3 - found
===>   hs-microlens-th-0.4.2.3_1 depends on package: hs-microlens>=0 - not found
===>   Installing existing package /packages/All/hs-microlens-0.4.9.1_2.txz
[head-powerpc64-default-job-11] Installing hs-microlens-0.4.9.1_2...
[head-powerpc64-default-job-11] Extracting hs-microlens-0.4.9.1_2: .......... 
done
microlens-0.4.9.1: Warning: dynamic-library-dirs: 
/usr/local/lib/cabal/ghc-8.6.3/ppc64-freebsd-ghc-8.6.3 doesn't exist or isn't a 
directory
===>   hs-microlens-th-0.4.2.3_1 depends on package: hs-microlens>=0 - found
===>   Returning to build of hs-microlens-th-0.4.2.3_1
===>   hs-microlens-th-0.4.2.3_1 depends on package: hs-th-abstraction>=0 - not 
found
===>   Installing existing package 
/packages/All/hs-th-abstraction-0.2.10.0_1.txz
[head-powerpc64-default-job-11] Installing hs-th-abstraction-0.2.10.0_1...
[head-powerpc64-default-job-11] Extracting hs-th-abstraction-0.2.10.0_1: 
.......... done
th-abstraction-0.2.10.0: Warning: dynamic-library-dirs: 
/usr/local/lib/cabal/ghc-8.6.3/ppc64-freebsd-ghc-8.6.3 doesn't exist or isn't a 
directory
===>   hs-microlens-th-0.4.2.3_1 depends on package: hs-th-abstraction>=0 - 
found
===>   Returning to build of hs-microlens-th-0.4.2.3_1
===========================================================================
=======================<phase: lib-depends    >============================
===>   hs-microlens-th-0.4.2.3_1 depends on shared library: libgmp.so - found 
(/usr/local/lib/libgmp.so)
===>   hs-microlens-th-0.4.2.3_1 depends on shared library: libiconv.so - found 
(/usr/local/lib/libiconv.so)
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for hs-microlens-th-0.4.2.3_1
[1 of 1] Compiling Main             ( Setup.hs, Setup.o )
Linking ./setup ...
Configuring microlens-th-0.4.2.3...
===========================================================================
=======================<phase: build          >============================
===>  Building for hs-microlens-th-0.4.2.3_1
Preprocessing library for microlens-th-0.4.2.3..
Building library for microlens-th-0.4.2.3..
[1 of 1] Compiling Lens.Micro.TH    ( src/Lens/Micro/TH.hs, 
dist/build/Lens/Micro/TH.o )
/usr/local/bin/ld: cannot find 
-lHSth-abstraction-0.2.10.0-IupKYUmBxoGBM1HXci6nJH-ghc8.6.3
/usr/local/bin/ld: cannot find 
-lHSmicrolens-0.4.9.1-4McC9qNSa3KI8NOjjY9tjo-ghc8.6.3
collect2: error: ld returned 1 exit status
`gcc8' failed in phase `Linker'. (Exit code: 1)
*** Error code 1

Stop.
make: stopped in /usr/ports/devel/hs-microlens-th
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to