You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     b...@freebsd.org
Last committer: b...@freebsd.org
Ident:          $FreeBSD: head/graphics/ipe/Makefile 501565 2019-05-13 
13:39:00Z bofh $
Log URL:        
http://pylon.nyi.freebsd.org/data/head-powerpc64-default/p503555_s348712/logs/ipe-7.2.12.log
Build URL:      
http://pylon.nyi.freebsd.org/build.html?mastername=head-powerpc64-default&build=p503555_s348712
Log:

=>> Building graphics/ipe
build started at Sun Jun  9 21:39:09 UTC 2019
port directory: /usr/ports/graphics/ipe
package name: ipe-7.2.12
building for: FreeBSD head-powerpc64-default-job-01 13.0-CURRENT FreeBSD 
13.0-CURRENT 1300030 powerpc
maintained by: b...@freebsd.org
Makefile ident:      $FreeBSD: head/graphics/ipe/Makefile 501565 2019-05-13 
13:39:00Z bofh $
Poudriere version: 3.2.8-4-g701d8fe1
Host OSVERSION: 1300012
Jail OSVERSION: 1300030
Job Id: 01




!!! Jail is newer than host. (Jail: 1300030, Host: 1300012) !!!
!!! This is not supported. !!!
!!! Host kernel must be same or newer than jail. !!!
!!! Expect build failures. !!!



---Begin Environment---
SHELL=/bin/csh
OSVERSION=1300030
UNAME_v=FreeBSD 13.0-CURRENT 1300030
UNAME_r=13.0-CURRENT
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
HOME=/root
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
LOCALBASE=/usr/local
USER=root
LIBEXECPREFIX=/usr/local/libexec/poudriere
POUDRIERE_VERSION=3.2.8-4-g701d8fe1
MASTERMNT=/usr/local/poudriere/data/.m/head-powerpc64-default/ref
POUDRIERE_BUILD_TYPE=bulk
PACKAGE_BUILDING=yes
SAVED_TERM=
PWD=/usr/local/poudriere/data/.m/head-powerpc64-default/ref/.p/pool
P_PORTS_FEATURES=FLAVORS SELECTED_OPTIONS
MASTERNAME=head-powerpc64-default
SCRIPTPREFIX=/usr/local/share/poudriere
OLDPWD=/usr/local/poudriere/data/.m/head-powerpc64-default/ref/.p
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
POUDRIEREPATH=/usr/local/bin/poudriere
---End Environment---

---Begin Poudriere Port Flags/Env---
PORT_FLAGS=
PKGENV=
FLAVOR=
DEPENDS_ARGS=
MAKE_ARGS=
---End Poudriere Port Flags/Env---

---Begin OPTIONS List---
===> The following configuration options are available for ipe-7.2.12:
     DOCS=on: Build and/or install documentation
===> Use 'make config' to modify these settings
---End OPTIONS List---

--MAINTAINER--
b...@freebsd.org
--End MAINTAINER--

--CONFIGURE_ARGS--

--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
MAKE=gmake PKG_CONFIG=pkgconf QT_SELECT=qt5 
QMAKEMODULES="/wrkdirs/usr/ports/graphics/ipe/work/ipe-7.2.12/src/mkspecs/modules:/usr/local/lib/qt5/mkspecs/modules"
 XDG_DATA_HOME=/wrkdirs/usr/ports/graphics/ipe/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/graphics/ipe/work  
HOME=/wrkdirs/usr/ports/graphics/ipe/work TMPDIR="/tmp" 
PATH=/wrkdirs/usr/ports/graphics/ipe/work/.bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
 SHELL=/bin/sh CONFIG_SHELL=/bin/sh LANG=en_US.UTF-8 LC_ALL=en_US.UTF-8
--End CONFIGURE_ENV--

--MAKE_ENV--
DL_LIBS=""  INSTALL_DIR="/bin/mkdir -p"  INSTALL_FILES="install  -m 0644"  
INSTALL_SCRIPTS="install  -m 555"  INSTALL_PROGRAMS="install  -s -m 555"  
INSTALL_ROOT="/wrkdirs/usr/ports/graphics/ipe/work/stage"  
IPEDOCDIR="/usr/local/share/doc/ipe"  IPEMANDIR="/usr/local/man/man1"  
IPEPREFIX="/usr/local"  JPEG_CFLAGS="-I/usr/local/include"  
JPEG_LIBS="-L/usr/local/lib -ljpeg"  LUA_PACKAGE="lua-5.2"  
MOC="/usr/local/lib/qt5/bin/moc" LUA_MODLIBDIR=/usr/local/lib/lua/5.2  
LUA_MODSHAREDIR=/usr/local/share/lua/5.2  LUA_VER=5.2  
LUA_INCDIR=/usr/local/include/lua52  LUA_LIBDIR=/usr/local/lib QT_SELECT=qt5 
QMAKEMODULES="/wrkdirs/usr/ports/graphics/ipe/work/ipe-7.2.12/src/mkspecs/modules:/usr/local/lib/qt5/mkspecs/modules"
 XDG_DATA_HOME=/wrkdirs/usr/ports/graphics/ipe/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/graphics/ipe/work  
HOME=/wrkdirs/usr/ports/graphics/ipe/work TMPDIR="/tmp" 
PATH=/wrkdirs/usr/ports/graphics/ipe/work/.bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bi
 n NO_PIE=yes MK_DEBUG_FILES=no MK_KERNEL_SYMBOLS=no SHELL=/bin/sh NO_LINT=YES 
ADDR2LINE="/usr/local/bin/addr2line" AR="/usr/local/bin/ar" 
AS="/usr/local/bin/as" CPPFILT="/usr/local/bin/c++filt" 
GPROF="/usr/local/bin/gprof" LD="/usr/local/bin/ld" NM="/usr/local/bin/nm" 
OBJCOPY="/usr/local/bin/objcopy" OBJDUMP="/usr/local/bin/objdump" 
RANLIB="/usr/local/bin/ranlib" READELF="/usr/local/bin/readelf" 
SIZE="/usr/local/bin/size" STRINGS="/usr/local/bin/strings" LANG=en_US.UTF-8 
LC_ALL=en_US.UTF-8 PREFIX=/usr/local  LOCALBASE=/usr/local  CC="gcc8" 
CFLAGS="-O2 -pipe  -fstack-protector-strong -Wl,-rpath=/usr/local/lib/gcc8 
-fno-strict-aliasing "  CPP="cpp8" CPPFLAGS=""  LDFLAGS=" 
-fstack-protector-strong -Wl,-rpath=/usr/local/lib/gcc8 -L/usr/local/lib/gcc8 " 
LIBS=""  CXX="g++8" CXXFLAGS="-O2 -pipe  -fstack-protector-strong 
-Wl,-rpath=/usr/local/lib/gcc8  -Wl,-rpath=/usr/local/lib/gcc8 "  
MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install  -s -m 555"  
BSD_INSTALL_LIB="install  -s -m 0644"  BS
 D_INSTALL_SCRIPT="install  -m 555"  BSD_INST!
 ALL_DATA="install  -m 0644"  BSD_INSTALL_MAN="install  -m 444"
--End MAKE_ENV--

--PLIST_SUB--
VERSION="7.2.12" PORTDOCS="" TEXMFDIR="share/texmf" 
TEXMFDISTDIR="share/texmf-dist" TEXMFLOCALDIR="share/texmf-local" 
TEXMFVARDIR="share/texmf-var" TEXMFCONFIGDIR="share/texmf-config" 
FMTUTIL_CNF="share/texmf-config/web2c/fmtutil.cnf" GTK2_VERSION="2.10.0"  
GTK3_VERSION="3.0.0" LUA_MODLIBDIR=lib/lua/5.2  LUA_MODSHAREDIR=share/lua/5.2  
LUA_VER=5.2  LUA_INCDIR=include/lua52  LUA_LIBDIR=lib  LUA_VER_STR=52 
QT_BINDIR="lib/qt5/bin" QT_INCDIR="include/qt5" QT_LIBDIR="lib/qt5" 
QT_ARCHDIR="lib/qt5" QT_PLUGINDIR="lib/qt5/plugins" QT_LIBEXECDIR="libexec/qt5" 
QT_IMPORTDIR="lib/qt5/imports" QT_QMLDIR="lib/qt5/qml" QT_DATADIR="share/qt5" 
QT_DOCDIR="share/doc/qt5" QT_L10NDIR="share/qt5/translations" 
QT_EXAMPLEDIR="share/examples/qt5" QT_TESTDIR="share/qt5/tests" 
QT_MKSPECDIR="lib/qt5/mkspecs" QT_QTCHOOSERDIR="etc/xdg/qtchooser" OSREL=13.0 
PREFIX=%D LOCALBASE=/usr/local  RESETPREFIX=/usr/local LIB32DIR=lib 
DOCSDIR="share/doc/ipe"  EXAMPLESDIR="share/examples/ipe"  DATADIR="share/ipe"  
WWWDIR="www/i
 pe"  ETCDIR="etc/ipe"
--End PLIST_SUB--

--SUB_LIST--
PREFIX=/usr/local LOCALBASE=/usr/local  DATADIR=/usr/local/share/ipe 
DOCSDIR=/usr/local/share/doc/ipe EXAMPLESDIR=/usr/local/share/examples/ipe  
WWWDIR=/usr/local/www/ipe ETCDIR=/usr/local/etc/ipe
--End SUB_LIST--

---Begin make.conf---
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
PACKAGE_BUILDING=yes
PACKAGE_BUILDING_FLAVORS=yes
#### /usr/local/etc/poudriere.d/make.conf ####
# XXX: We really need this but cannot use it while 'make checksum' does not
# try the next mirror on checksum failure.  It currently retries the same
# failed mirror and then fails rather then trying another.  It *does*
# try the next if the size is mismatched though.
#MASTER_SITE_FREEBSD=yes
# Build ALLOW_MAKE_JOBS_PACKAGES with 2 jobs
MAKE_JOBS_NUMBER=2

# stable/10 includes src.conf too late but make.conf is in sys.mk
.if ${.CURDIR:M/poudriere/jails/10*/usr/src/usr.bin/xlint*}
# Disable build of llib now that head no longer has lint(1)
LINT=   true
.endif
#### /usr/ports/Mk/Scripts/ports_env.sh ####
_CCVERSION_921dbbb2=cc (GCC) 4.2.1 20070831 patched [FreeBSD] Copyright (C) 
2007 Free Software Foundation, Inc. This is free software; see the source for 
copying conditions. There is NO warranty; not even for MERCHANTABILITY or 
FITNESS FOR A PARTICULAR PURPOSE.
_ALTCCVERSION_921dbbb2=none
_CXXINTERNAL_acaad9ca=Using built-in specs. Target: 
powerpc64-undermydesk-freebsd Configured with: FreeBSD/powerpc64 system 
compiler Thread model: posix gcc version 4.2.1 20070831 patched [FreeBSD] 
"/usr/bin/ld" "--eh-frame-hdr" "-Qy" "-melf64ppc_fbsd" "--enable-new-dtags" 
"-dynamic-linker" "/libexec/ld-elf.so.1" "/usr/lib/crt1.o" "/usr/lib/crti.o" 
"/usr/lib/crtbegin.o" "-L/usr/lib" "-L/usr/lib" "/dev/null" "-lstdc++" "-lm" 
"-lgcc_s" "-lgcc" "-lc" "-lgcc_s" "-lgcc" "/usr/lib/crtsavres.o" 
"/usr/lib/crtend.o" "/usr/lib/crtn.o"
CC_OUTPUT_921dbbb2_58173849=yes
CC_OUTPUT_921dbbb2_9bdba57c=yes
CC_OUTPUT_921dbbb2_6a4fe7f5=cc1: error: unrecognized command line option 
"-std=c11"
CC_OUTPUT_921dbbb2_6bcac02b=yes
CC_OUTPUT_921dbbb2_67d20829=yes
CC_OUTPUT_921dbbb2_bfa62e83=cc1: error: unrecognized command line option 
"-std=gnu11"
CC_OUTPUT_921dbbb2_f0b4d593=yes
CC_OUTPUT_921dbbb2_308abb44=cc1plus: error: unrecognized command line option 
"-std=c++0x"
CC_OUTPUT_921dbbb2_f00456e5=cc1plus: error: unrecognized command line option 
"-std=c++11"
CC_OUTPUT_921dbbb2_65ad290d=cc1plus: error: unrecognized command line option 
"-std=c++14"
CC_OUTPUT_921dbbb2_f2776b26=cc1plus: error: unrecognized command line option 
"-std=c++17"
CC_OUTPUT_921dbbb2_b2657cc3=yes
CC_OUTPUT_921dbbb2_380987f7=cc1plus: error: unrecognized command line option 
"-std=gnu++11"
CC_OUTPUT_921dbbb2_160933ec=cc1plus: error: unrecognized command line option 
"-std=gnu++14"
CC_OUTPUT_921dbbb2_fb62803b=cc1plus: error: unrecognized command line option 
"-std=gnu++17"
_OBJC_CCVERSION_921dbbb2=cc (GCC) 4.2.1 20070831 patched [FreeBSD] Copyright 
(C) 2007 Free Software Foundation, Inc. This is free software; see the source 
for copying conditions. There is NO warranty; not even for MERCHANTABILITY or 
FITNESS FOR A PARTICULAR PURPOSE.
_OBJC_ALTCCVERSION_921dbbb2=none
ARCH=powerpc64
OPSYS=FreeBSD
_OSRELEASE=13.0-CURRENT
OSREL=13.0
OSVERSION=1300030
PYTHONBASE=/usr/local
CONFIGURE_MAX_CMD_LEN=262144
HAVE_PORTS_ENV=1
#### Misc Poudriere ####
GID=0
UID=0
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
--Resource limits--
cpu time               (seconds, -t)  unlimited
file size           (512-blocks, -f)  unlimited
data seg size           (kbytes, -d)  33554432
stack size              (kbytes, -s)  524288
core file size      (512-blocks, -c)  unlimited
max memory size         (kbytes, -m)  unlimited
locked memory           (kbytes, -l)  unlimited
max user processes              (-u)  89999
open files                      (-n)  1024
virtual mem size        (kbytes, -v)  unlimited
swap limit              (kbytes, -w)  unlimited
socket buffer size       (bytes, -b)  unlimited
pseudo-terminals                (-p)  unlimited
kqueues                         (-k)  unlimited
umtx shared locks               (-o)  unlimited
--End resource limits--
=======================<phase: check-sanity   >============================
===>  License GPLv3+ accepted by the user
===========================================================================
=======================<phase: pkg-depends    >============================
===>   ipe-7.2.12 depends on file: /usr/local/sbin/pkg - not found
===>   Installing existing package /packages/All/pkg-1.11.1.txz
[head-powerpc64-default-job-01] Installing pkg-1.11.1...
[head-powerpc64-default-job-01] Extracting pkg-1.11.1: .......... done
===>   ipe-7.2.12 depends on file: /usr/local/sbin/pkg - found
===>   Returning to build of ipe-7.2.12
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===>  License GPLv3+ accepted by the user
===> Fetching all distfiles required by ipe-7.2.12 for building
===========================================================================
=======================<phase: checksum       >============================
===>  License GPLv3+ accepted by the user
===> Fetching all distfiles required by ipe-7.2.12 for building
=> SHA256 Checksum OK for ipe-7.2.12-src.tar.gz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===>  License GPLv3+ accepted by the user
===> Fetching all distfiles required by ipe-7.2.12 for building
===>  Extracting for ipe-7.2.12
=> SHA256 Checksum OK for ipe-7.2.12-src.tar.gz.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for ipe-7.2.12
===>  Applying FreeBSD patches for ipe-7.2.12
===========================================================================
=======================<phase: build-depends  >============================
===>   ipe-7.2.12 depends on file: /usr/local/share/texmf-var/web2c/tex/tex.fmt 
- not found
<snip>
This package installs a script named dvipdf that depends on dvips.  If you
want to use this script you need to install print/tex-dvipsk.
Message from perl5-5.28.2:

The /usr/bin/perl symlink has been removed starting with Perl 5.20.
For shebangs, you should either use:

#!/usr/local/bin/perl

or

#!/usr/bin/env perl

The first one will only work if you have a /usr/local/bin/perl,
the second will work as long as perl is in PATH.
===>   ipe-7.2.12 depends on file: /usr/local/share/texmf-var/web2c/tex/tex.fmt 
- found
===>   Returning to build of ipe-7.2.12
===>   ipe-7.2.12 depends on executable: gmake - not found
===>   Installing existing package /packages/All/gmake-4.2.1_3.txz
[head-powerpc64-default-job-01] Installing gmake-4.2.1_3...
[head-powerpc64-default-job-01] Extracting gmake-4.2.1_3: .......... done
===>   ipe-7.2.12 depends on executable: gmake - found
===>   Returning to build of ipe-7.2.12
===>   ipe-7.2.12 depends on package: pkgconf>=1.3.0_1 - not found
===>   Installing existing package /packages/All/pkgconf-1.6.1,1.txz
[head-powerpc64-default-job-01] Installing pkgconf-1.6.1,1...
[head-powerpc64-default-job-01] Extracting pkgconf-1.6.1,1: .......... done
===>   ipe-7.2.12 depends on package: pkgconf>=1.3.0_1 - found
===>   Returning to build of ipe-7.2.12
===>   ipe-7.2.12 depends on executable: gcc8 - found
===>   ipe-7.2.12 depends on file: /usr/local/bin/as - found
===>   ipe-7.2.12 depends on file: /usr/local/lib/qt5/bin/moc - not found
===>   Installing existing package /packages/All/qt5-buildtools-5.12.2.txz
[head-powerpc64-default-job-01] Installing qt5-buildtools-5.12.2...
[head-powerpc64-default-job-01] `-- Installing qtchooser-66...
[head-powerpc64-default-job-01] `-- Extracting qtchooser-66: .......... done
[head-powerpc64-default-job-01] Extracting qt5-buildtools-5.12.2: .......... 
done
Message from qtchooser-66:

qtchooser is a wrapper that allows selecting whether Qt4 or Qt5 binaries for
qmake, moc and other tools will be run when invoking the binaries in $PATH.

By default, the Qt5 versions are run. It is possible to change the behavior by
setting the QT_SELECT environment variable to "qt4". See qtchooser(1) for more
information.
===>   ipe-7.2.12 depends on file: /usr/local/lib/qt5/bin/moc - found
===>   Returning to build of ipe-7.2.12
===>   ipe-7.2.12 depends on file: /usr/local/lib/qt5/bin/qmake - not found
===>   Installing existing package /packages/All/qt5-qmake-5.12.2_1.txz
[head-powerpc64-default-job-01] Installing qt5-qmake-5.12.2_1...
[head-powerpc64-default-job-01] Extracting qt5-qmake-5.12.2_1: .......... done
===>   ipe-7.2.12 depends on file: /usr/local/lib/qt5/bin/qmake - found
===>   Returning to build of ipe-7.2.12
===========================================================================
=======================<phase: lib-depends    >============================
===>   ipe-7.2.12 depends on shared library: libpng.so - found 
(/usr/local/lib/libpng.so)
===>   ipe-7.2.12 depends on shared library: libfreetype.so - found 
(/usr/local/lib/libfreetype.so)
===>   ipe-7.2.12 depends on shared library: libcairo.so - found 
(/usr/local/lib/libcairo.so)
===>   ipe-7.2.12 depends on shared library: libjpeg.so - found 
(/usr/local/lib/libjpeg.so)
===>   ipe-7.2.12 depends on shared library: liblua-5.2.so - not found
===>   Installing existing package /packages/All/lua52-5.2.4.txz
[head-powerpc64-default-job-01] Installing lua52-5.2.4...
[head-powerpc64-default-job-01] `-- Installing libedit-3.1.20190324,1...
[head-powerpc64-default-job-01] `-- Extracting libedit-3.1.20190324,1: 
.......... done
[head-powerpc64-default-job-01] Extracting lua52-5.2.4: ......... done
===>   ipe-7.2.12 depends on shared library: liblua-5.2.so - found 
(/usr/local/lib/liblua-5.2.so)
===>   Returning to build of ipe-7.2.12
===>   ipe-7.2.12 depends on shared library: libQt5Core.so - not found
===>   Installing existing package /packages/All/qt5-core-5.12.2_1.txz
[head-powerpc64-default-job-01] Installing qt5-core-5.12.2_1...
[head-powerpc64-default-job-01] `-- Installing etc_os-release-0.1_2...
[head-powerpc64-default-job-01] `-- Extracting etc_os-release-0.1_2: . done
[head-powerpc64-default-job-01] `-- Installing pcre2-10.32_1...
[head-powerpc64-default-job-01] `-- Extracting pcre2-10.32_1: .......... done
[head-powerpc64-default-job-01] Extracting qt5-core-5.12.2_1: .......... done
===>   ipe-7.2.12 depends on shared library: libQt5Core.so - found 
(/usr/local/lib/qt5/libQt5Core.so)
===>   Returning to build of ipe-7.2.12
===>   ipe-7.2.12 depends on shared library: libQt5Gui.so - not found
===>   Installing existing package /packages/All/qt5-gui-5.12.2.txz
[head-powerpc64-default-job-01] Installing qt5-gui-5.12.2...
[head-powerpc64-default-job-01] `-- Installing encodings-1.0.4_4,1...
[head-powerpc64-default-job-01] |   `-- Installing font-util-1.3.1...
[head-powerpc64-default-job-01] |   `-- Extracting font-util-1.3.1: .......... 
done
[head-powerpc64-default-job-01] `-- Extracting encodings-1.0.4_4,1: .......... 
done
[head-powerpc64-default-job-01] `-- Installing libXi-1.7.9_2,1...
[head-powerpc64-default-job-01] `-- Extracting libXi-1.7.9_2,1: .......... done
[head-powerpc64-default-job-01] `-- Installing libxkbcommon-0.8.0_1...
[head-powerpc64-default-job-01] |   `-- Installing xkeyboard-config-2.24_1...
[head-powerpc64-default-job-01] |   `-- Extracting xkeyboard-config-2.24_1: 
.......... done
[head-powerpc64-default-job-01] `-- Extracting libxkbcommon-0.8.0_1: .......... 
done
[head-powerpc64-default-job-01] `-- Installing qt5-dbus-5.12.2...
[head-powerpc64-default-job-01] `-- Extracting qt5-dbus-5.12.2: .......... done
[head-powerpc64-default-job-01] `-- Installing qt5-network-5.12.2_1...
[head-powerpc64-default-job-01] `-- Extracting qt5-network-5.12.2_1: .......... 
done
[head-powerpc64-default-job-01] `-- Installing xcb-util-image-0.4.0_1...
[head-powerpc64-default-job-01] |   `-- Installing xcb-util-0.4.0_2,1...
[head-powerpc64-default-job-01] |   `-- Extracting xcb-util-0.4.0_2,1: 
.......... done
[head-powerpc64-default-job-01] `-- Extracting xcb-util-image-0.4.0_1: 
.......... done
[head-powerpc64-default-job-01] `-- Installing xcb-util-keysyms-0.4.0_1...
[head-powerpc64-default-job-01] `-- Extracting xcb-util-keysyms-0.4.0_1: 
......... done
[head-powerpc64-default-job-01] `-- Installing xcb-util-renderutil-0.3.9_1...
[head-powerpc64-default-job-01] `-- Extracting xcb-util-renderutil-0.3.9_1: 
......... done
[head-powerpc64-default-job-01] `-- Installing xcb-util-wm-0.4.1_3...
[head-powerpc64-default-job-01] `-- Extracting xcb-util-wm-0.4.1_3: .......... 
done
[head-powerpc64-default-job-01] `-- Installing xdg-utils-1.1.3_1...
[head-powerpc64-default-job-01] |   `-- Installing hicolor-icon-theme-0.17...
[head-powerpc64-default-job-01] |   `-- Extracting hicolor-icon-theme-0.17: . 
done
[head-powerpc64-default-job-01] |   `-- Installing xprop-1.2.4...
[head-powerpc64-default-job-01] |   `-- Extracting xprop-1.2.4: ..... done
[head-powerpc64-default-job-01] |   `-- Installing xset-1.2.4_2...
[head-powerpc64-default-job-01] |   | `-- Installing libXfontcache-1.0.5_5...
[head-powerpc64-default-job-01] |   | `-- Extracting libXfontcache-1.0.5_5: 
.......... done
[head-powerpc64-default-job-01] |   `-- Extracting xset-1.2.4_2: .. done
[head-powerpc64-default-job-01] `-- Extracting xdg-utils-1.1.3_1: .......... 
done
[head-powerpc64-default-job-01] `-- Installing xorg-fonts-truetype-7.7_1...
[head-powerpc64-default-job-01] |   `-- Installing dejavu-2.37_1...
[head-powerpc64-default-job-01] |   | `-- Installing mkfontscale-1.2.1...
[head-powerpc64-default-job-01] |   |   `-- Installing libfontenc-1.1.4...
[head-powerpc64-default-job-01] |   |   `-- Extracting libfontenc-1.1.4: 
......... done
[head-powerpc64-default-job-01] |   | `-- Extracting mkfontscale-1.2.1: ....... 
done
[head-powerpc64-default-job-01] |   `-- Extracting dejavu-2.37_1: .......... 
done
[head-powerpc64-default-job-01] |   `-- Installing font-bh-ttf-1.0.3_4...
[head-powerpc64-default-job-01] |   `-- Extracting font-bh-ttf-1.0.3_4: 
.......... done
[head-powerpc64-default-job-01] |   `-- Installing font-misc-ethiopic-1.0.3_4...
[head-powerpc64-default-job-01] |   `-- Extracting font-misc-ethiopic-1.0.3_4: 
... done
[head-powerpc64-default-job-01] |   `-- Installing font-misc-meltho-1.0.3_4...
[head-powerpc64-default-job-01] |   `-- Extracting font-misc-meltho-1.0.3_4: 
.......... done
[head-powerpc64-default-job-01] Extracting qt5-gui-5.12.2: .......... done
Message from dejavu-2.37_1:

Make sure that the freetype module is loaded.  If it is not, add the following
line to the "Modules" section of your X Windows configuration file:

        Load "freetype"

Add the following line to the "Files" section of X Windows configuration file:

        FontPath "/usr/local/share/fonts/dejavu/"

Note: your X Windows configuration file is typically /etc/X11/XF86Config
if you are using XFree86, and /etc/X11/xorg.conf if you are using X.Org.
===>   ipe-7.2.12 depends on shared library: libQt5Gui.so - found 
(/usr/local/lib/qt5/libQt5Gui.so)
===>   Returning to build of ipe-7.2.12
===>   ipe-7.2.12 depends on shared library: libQt5Widgets.so - not found
===>   Installing existing package /packages/All/qt5-widgets-5.12.2.txz
[head-powerpc64-default-job-01] Installing qt5-widgets-5.12.2...
[head-powerpc64-default-job-01] Extracting qt5-widgets-5.12.2: .......... done
===>   ipe-7.2.12 depends on shared library: libQt5Widgets.so - found 
(/usr/local/lib/qt5/libQt5Widgets.so)
===>   Returning to build of ipe-7.2.12
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for ipe-7.2.12
===========================================================================
=======================<phase: build          >============================
===>  Building for ipe-7.2.12
gmake[1]: Entering directory 
'/wrkdirs/usr/ports/graphics/ipe/work/ipe-7.2.12/src'
gmake --directory=ipelib all
gmake[2]: Entering directory 
'/wrkdirs/usr/ports/graphics/ipe/work/ipe-7.2.12/src/ipelib'
mkdir -p ../../build/obj/ipelib; echo "" > ../../build/obj/ipelib/depend.mak; 
for f in ipebase.cpp ipeplatform.cpp ipegeo.cpp ipexml.cpp ipeattributes.cpp 
ipebitmap.cpp ipeshape.cpp ipegroup.cpp ipeimage.cpp ipetext.cpp ipepath.cpp 
ipereference.cpp ipeobject.cpp ipefactory.cpp ipestdstyles.cpp ipeiml.cpp 
ipepage.cpp ipepainter.cpp ipetoolbase.cpp ipepdfparser.cpp ipepdfwriter.cpp 
iperesources.cpp ipestyle.cpp ipesnap.cpp ipeutils.cpp ipelatex.cpp ipedoc.cpp 
ipebitmap_unix.cpp ; do g++8 -MM -MT ../../build/obj/ipelib/${f%%.cpp}.o  
-DIPEUI_QT -fPIC -std=c++14 -I../include    -I/usr/local/include 
-I/usr/local/include/libpng16  $f >> ../../build/obj/ipelib/depend.mak; done
Compiling ipebase.cpp...
g++8 -O2 -pipe  -fstack-protector-strong -Wl,-rpath=/usr/local/lib/gcc8  
-Wl,-rpath=/usr/local/lib/gcc8  -fPIC -Wall -fPIC  -DIPEUI_QT -fPIC -std=c++14 
-I../include    -I/usr/local/include -I/usr/local/include/libpng16   -c -o 
../../build/obj/ipelib/ipebase.o ipebase.cpp
Compiling ipeplatform.cpp...
g++8 -O2 -pipe  -fstack-protector-strong -Wl,-rpath=/usr/local/lib/gcc8  
-Wl,-rpath=/usr/local/lib/gcc8  -fPIC -Wall -fPIC  -DIPEUI_QT -fPIC -std=c++14 
-I../include    -I/usr/local/include -I/usr/local/include/libpng16   -c -o 
../../build/obj/ipelib/ipeplatform.o ipeplatform.cpp
ipeplatform.cpp: In static member function 'static ipe::String 
ipe::Platform::realPath(ipe::String)':
ipeplatform.cpp:420:14: error: 'PATH_MAX' was not declared in this scope
   char rpath[PATH_MAX];
              ^~~~~~~~
ipeplatform.cpp:420:14: note: suggested alternative: 'INT8_MAX'
   char rpath[PATH_MAX];
              ^~~~~~~~
              INT8_MAX
ipeplatform.cpp:421:27: error: 'rpath' was not declared in this scope
   if (realpath(fname.z(), rpath))
                           ^~~~~
ipeplatform.cpp:421:27: note: suggested alternative: 'rpmatch'
   if (realpath(fname.z(), rpath))
                           ^~~~~
                           rpmatch
ipeplatform.cpp:425:21: error: 'rpath' was not declared in this scope
   if (realpath(".", rpath) == nullptr)
                     ^~~~~
ipeplatform.cpp:425:21: note: suggested alternative: 'rpmatch'
   if (realpath(".", rpath) == nullptr)
                     ^~~~~
                     rpmatch
ipeplatform.cpp:427:17: error: 'rpath' was not declared in this scope
   return String(rpath) + "/" + fname;
                 ^~~~~
ipeplatform.cpp:427:17: note: suggested alternative: 'rpmatch'
   return String(rpath) + "/" + fname;
                 ^~~~~
                 rpmatch
gmake[2]: *** [../common.mak:252: ../../build/obj/ipelib/ipeplatform.o] Error 1
gmake[2]: Leaving directory 
'/wrkdirs/usr/ports/graphics/ipe/work/ipe-7.2.12/src/ipelib'
gmake[1]: *** [Makefile:49: ipelib] Error 2
gmake[1]: Leaving directory 
'/wrkdirs/usr/ports/graphics/ipe/work/ipe-7.2.12/src'
*** Error code 1

Stop.
make: stopped in /usr/ports/graphics/ipe
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to