You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     sunp...@freebsd.org
Last committer: sunp...@freebsd.org
Ident:          $FreeBSD: head/devel/rubygem-google-gax/Makefile 515695 
2019-10-26 14:30:29Z sunpoet $
Log URL:        
http://beefy18.nyi.freebsd.org/data/head-amd64-default/p518893_s355315/logs/rubygem-google-gax-1.8.1.log
Build URL:      
http://beefy18.nyi.freebsd.org/build.html?mastername=head-amd64-default&build=p518893_s355315
Log:

=>> Building devel/rubygem-google-gax
build started at Tue Dec  3 11:30:45 UTC 2019
port directory: /usr/ports/devel/rubygem-google-gax
package name: rubygem-google-gax-1.8.1
building for: FreeBSD head-amd64-default-job-17 13.0-CURRENT FreeBSD 
13.0-CURRENT 1300062 amd64
maintained by: sunp...@freebsd.org
Makefile ident:      $FreeBSD: head/devel/rubygem-google-gax/Makefile 515695 
2019-10-26 14:30:29Z sunpoet $
Poudriere version: 3.2.8-5-gc81843e5
Host OSVERSION: 1300047
Jail OSVERSION: 1300062
Job Id: 17




!!! Jail is newer than host. (Jail: 1300062, Host: 1300047) !!!
!!! This is not supported. !!!
!!! Host kernel must be same or newer than jail. !!!
!!! Expect build failures. !!!



---Begin Environment---
SHELL=/bin/csh
OSVERSION=1300062
UNAME_v=FreeBSD 13.0-CURRENT 1300062
UNAME_r=13.0-CURRENT
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
HOME=/root
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
LOCALBASE=/usr/local
USER=root
LIBEXECPREFIX=/usr/local/libexec/poudriere
POUDRIERE_VERSION=3.2.8-5-gc81843e5
MASTERMNT=/usr/local/poudriere/data/.m/head-amd64-default/ref
POUDRIERE_BUILD_TYPE=bulk
PACKAGE_BUILDING=yes
SAVED_TERM=
PWD=/usr/local/poudriere/data/.m/head-amd64-default/ref/.p/pool
P_PORTS_FEATURES=FLAVORS SELECTED_OPTIONS
MASTERNAME=head-amd64-default
SCRIPTPREFIX=/usr/local/share/poudriere
OLDPWD=/usr/local/poudriere/data/.m/head-amd64-default/ref/.p
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
POUDRIEREPATH=/usr/local/bin/poudriere
---End Environment---

---Begin Poudriere Port Flags/Env---
PORT_FLAGS=
PKGENV=
FLAVOR=
DEPENDS_ARGS=
MAKE_ARGS=
---End Poudriere Port Flags/Env---

---Begin OPTIONS List---
---End OPTIONS List---

--MAINTAINER--
sunp...@freebsd.org
--End MAINTAINER--

--CONFIGURE_ARGS--

--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
XDG_DATA_HOME=/wrkdirs/usr/ports/devel/rubygem-google-gax/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/devel/rubygem-google-gax/work  
HOME=/wrkdirs/usr/ports/devel/rubygem-google-gax/work TMPDIR="/tmp" 
PATH=/wrkdirs/usr/ports/devel/rubygem-google-gax/work/.bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
 SHELL=/bin/sh CONFIG_SHELL=/bin/sh LANG=en_US.UTF-8 LC_ALL=en_US.UTF-8
--End CONFIGURE_ENV--

--MAKE_ENV--
XDG_DATA_HOME=/wrkdirs/usr/ports/devel/rubygem-google-gax/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/devel/rubygem-google-gax/work  
HOME=/wrkdirs/usr/ports/devel/rubygem-google-gax/work TMPDIR="/tmp" 
PATH=/wrkdirs/usr/ports/devel/rubygem-google-gax/work/.bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
 NO_PIE=yes MK_DEBUG_FILES=no MK_KERNEL_SYMBOLS=no SHELL=/bin/sh NO_LINT=YES 
LANG=en_US.UTF-8 LC_ALL=en_US.UTF-8 PREFIX=/usr/local  LOCALBASE=/usr/local  
CC="cc" CFLAGS="-O2 -pipe  -fstack-protector-strong -fno-strict-aliasing "  
CPP="cpp" CPPFLAGS=""  LDFLAGS=" -fstack-protector-strong " LIBS=""  CXX="c++" 
CXXFLAGS="-O2 -pipe -fstack-protector-strong -fno-strict-aliasing  "  
MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install  -s -m 555"  
BSD_INSTALL_LIB="install  -s -m 0644"  BSD_INSTALL_SCRIPT="install  -m 555"  
BSD_INSTALL_DATA="install  -m 0644"  BSD_INSTALL_MAN="install  -m 444"
--End MAKE_ENV--

--PLIST_SUB--
RUBY_LIBDIR="lib/ruby/2.6" RUBY_ARCHLIBDIR="lib/ruby/2.6/amd64-freebsd13" 
RUBY_SITELIBDIR="lib/ruby/site_ruby/2.6" 
RUBY_SITEARCHLIBDIR="lib/ruby/site_ruby/2.6/amd64-freebsd13" 
RUBY_VENDORLIBDIR="lib/ruby/vendor_ruby/2.6" 
RUBY_VENDORARCHLIBDIR="lib/ruby/vendor_ruby/2.6/amd64-freebsd13" 
RUBY_MODDOCDIR="share/doc/ruby26/google-gax" 
RUBY_MODEXAMPLESDIR="share/examples/ruby26/google-gax" 
RUBY_DOCDIR="share/doc/ruby26" RUBY_EXAMPLESDIR="share/examples/ruby26" 
RUBY_RIDIR="share/ri/2.6/system" RUBY_SITERIDIR="share/ri/2.6/site"  
RUBY_VERSION="2.6.5"  RUBY_VER="2.6"  RUBY_SHLIBVER="26"  
RUBY_ARCH="amd64-freebsd13"  RUBY_SUFFIX="26"  RUBY_NAME="ruby26"  
RUBY_DEFAULT_SUFFIX="26"  RUBY24="@comment "  RUBY25="@comment "  RUBY26="" 
PORTVERSION="1.8.1"  REV=""  GEMS_BASE_DIR="lib/ruby/gems/2.6"  
GEMS_DIR="lib/ruby/gems/2.6/gems"  DOC_DIR="lib/ruby/gems/2.6/doc"  
CACHE_DIR="lib/ruby/gems/2.6/cache"  
SPEC_DIR="lib/ruby/gems/2.6/specifications"  
EXT_DIR="lib/ruby/gems/2.6/extensions"  PORT="google-gax
 -1.8.1"  GEM_NAME="google-gax-1.8.1"  
GEM_LIB_DIR="lib/ruby/gems/2.6/gems/google-gax-1.8.1"  
GEM_DOC_DIR="lib/ruby/gems/2.6/doc/google-gax-1.8.1"  
GEM_SPEC="lib/ruby/gems/2.6/specifications/google-gax-1.8.1.gemspec"  
GEM_CACHE="lib/ruby/gems/2.6/cache/google-gax-1.8.1.gem"  EXTRACT_SUFX=".gem" 
OSREL=13.0 PREFIX=%D LOCALBASE=/usr/local  RESETPREFIX=/usr/local LIB32DIR=lib 
DOCSDIR="share/doc/google-gax"  EXAMPLESDIR="share/examples/google-gax"  
DATADIR="share/google-gax"  WWWDIR="www/google-gax"  ETCDIR="etc/google-gax"
--End PLIST_SUB--

--SUB_LIST--
PREFIX=/usr/local LOCALBASE=/usr/local  DATADIR=/usr/local/share/google-gax 
DOCSDIR=/usr/local/share/doc/google-gax 
EXAMPLESDIR=/usr/local/share/examples/google-gax  
WWWDIR=/usr/local/www/google-gax ETCDIR=/usr/local/etc/google-gax
--End SUB_LIST--

---Begin make.conf---
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
PACKAGE_BUILDING=yes
PACKAGE_BUILDING_FLAVORS=yes
#### /usr/local/etc/poudriere.d/make.conf ####
# XXX: We really need this but cannot use it while 'make checksum' does not
# try the next mirror on checksum failure.  It currently retries the same
# failed mirror and then fails rather then trying another.  It *does*
# try the next if the size is mismatched though.
#MASTER_SITE_FREEBSD=yes
# Build ALLOW_MAKE_JOBS_PACKAGES with 2 jobs
MAKE_JOBS_NUMBER=2
#### /usr/ports/Mk/Scripts/ports_env.sh ####
_CCVERSION_921dbbb2=FreeBSD clang version 9.0.0 (tags/RELEASE_900/final 372316) 
(based on LLVM 9.0.0) Target: x86_64-unknown-freebsd13.0 Thread model: posix 
InstalledDir: /usr/bin
_ALTCCVERSION_921dbbb2=none
_CXXINTERNAL_acaad9ca=FreeBSD clang version 9.0.0 (tags/RELEASE_900/final 
372316) (based on LLVM 9.0.0) Target: x86_64-unknown-freebsd13.0 Thread model: 
posix InstalledDir: /usr/bin "/usr/bin/ld" "--eh-frame-hdr" "-dynamic-linker" 
"/libexec/ld-elf.so.1" "--hash-style=both" "--enable-new-dtags" "-o" "a.out" 
"/usr/lib/crt1.o" "/usr/lib/crti.o" "/usr/lib/crtbegin.o" "-L/usr/lib" 
"/dev/null" "-lc++" "-lm" "-lgcc" "--as-needed" "-lgcc_s" "--no-as-needed" 
"-lc" "-lgcc" "--as-needed" "-lgcc_s" "--no-as-needed" "/usr/lib/crtend.o" 
"/usr/lib/crtn.o"
CC_OUTPUT_921dbbb2_58173849=yes
CC_OUTPUT_921dbbb2_9bdba57c=yes
CC_OUTPUT_921dbbb2_6a4fe7f5=yes
CC_OUTPUT_921dbbb2_6bcac02b=yes
CC_OUTPUT_921dbbb2_67d20829=yes
CC_OUTPUT_921dbbb2_bfa62e83=yes
CC_OUTPUT_921dbbb2_f0b4d593=yes
CC_OUTPUT_921dbbb2_308abb44=yes
CC_OUTPUT_921dbbb2_f00456e5=yes
CC_OUTPUT_921dbbb2_65ad290d=yes
CC_OUTPUT_921dbbb2_f2776b26=yes
CC_OUTPUT_921dbbb2_b2657cc3=yes
CC_OUTPUT_921dbbb2_380987f7=yes
CC_OUTPUT_921dbbb2_160933ec=yes
CC_OUTPUT_921dbbb2_fb62803b=yes
_OBJC_CCVERSION_921dbbb2=FreeBSD clang version 9.0.0 (tags/RELEASE_900/final 
372316) (based on LLVM 9.0.0) Target: x86_64-unknown-freebsd13.0 Thread model: 
posix InstalledDir: /usr/bin
_OBJC_ALTCCVERSION_921dbbb2=none
ARCH=amd64
OPSYS=FreeBSD
_OSRELEASE=13.0-CURRENT
OSREL=13.0
OSVERSION=1300062
PYTHONBASE=/usr/local
HAVE_COMPAT_IA32_KERN=YES
CONFIGURE_MAX_CMD_LEN=262144
HAVE_PORTS_ENV=1
#### Misc Poudriere ####
GID=0
UID=0
---End make.conf---
--Resource limits--
cpu time               (seconds, -t)  unlimited
file size           (512-blocks, -f)  unlimited
data seg size           (kbytes, -d)  33554432
stack size              (kbytes, -s)  524288
core file size      (512-blocks, -c)  unlimited
max memory size         (kbytes, -m)  unlimited
locked memory           (kbytes, -l)  unlimited
max user processes              (-u)  89999
open files                      (-n)  1024
virtual mem size        (kbytes, -v)  unlimited
swap limit              (kbytes, -w)  unlimited
socket buffer size       (bytes, -b)  unlimited
pseudo-terminals                (-p)  unlimited
kqueues                         (-k)  unlimited
umtx shared locks               (-o)  unlimited
--End resource limits--
=======================<phase: check-sanity   >============================
===>  License BSD3CLAUSE accepted by the user
===========================================================================
=======================<phase: pkg-depends    >============================
===>   rubygem-google-gax-1.8.1 depends on file: /usr/local/sbin/pkg - not found
===>   Installing existing package /packages/All/pkg-1.12.0.txz
[head-amd64-default-job-17] Installing pkg-1.12.0...
[head-amd64-default-job-17] Extracting pkg-1.12.0: .......... done
===>   rubygem-google-gax-1.8.1 depends on file: /usr/local/sbin/pkg - found
===>   Returning to build of rubygem-google-gax-1.8.1
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===>  License BSD3CLAUSE accepted by the user
===> Fetching all distfiles required by rubygem-google-gax-1.8.1 for building
===========================================================================
=======================<phase: checksum       >============================
===>  License BSD3CLAUSE accepted by the user
===> Fetching all distfiles required by rubygem-google-gax-1.8.1 for building
=> SHA256 Checksum OK for rubygem/google-gax-1.8.1.gem.
===========================================================================
=======================<phase: extract-depends>============================
===>   rubygem-google-gax-1.8.1 depends on file: /usr/local/bin/ruby26 - not 
found
===>   Installing existing package /packages/All/ruby-2.6.5,1.txz
[head-amd64-default-job-17] Installing ruby-2.6.5,1...
[head-amd64-default-job-17] `-- Installing libedit-3.1.20190324,1...
[head-amd64-default-job-17] `-- Extracting libedit-3.1.20190324,1: .......... 
done
[head-amd64-default-job-17] `-- Installing libffi-3.2.1_3...
[head-amd64-default-job-17] |   `-- Installing indexinfo-0.3.1...
[head-amd64-default-job-17] |   `-- Extracting indexinfo-0.3.1: .... done
[head-amd64-default-job-17] `-- Extracting libffi-3.2.1_3: .......... done
[head-amd64-default-job-17] `-- Installing libunwind-20170615...
[head-amd64-default-job-17] `-- Extracting libunwind-20170615: .......... done
[head-amd64-default-job-17] `-- Installing libyaml-0.2.2...
[head-amd64-default-job-17] `-- Extracting libyaml-0.2.2: ......... done
[head-amd64-default-job-17] Extracting ruby-2.6.5,1: .......... done
=====
Message from ruby-2.6.5,1:

--
Some of the standard commands are provided as separate ports for ease
of upgrading:

        devel/ruby-gems:        gem - RubyGems package manager
        devel/rubygem-rake:     rake - Ruby Make

And some of the standard libraries are provided as separate ports
since they require extra dependencies:

        databases/rubygem-dbm:  DBM module
        databases/rubygem-gdbm: GDBM module

Install them as occasion demands.
===>   rubygem-google-gax-1.8.1 depends on file: /usr/local/bin/ruby26 - found
===>   Returning to build of rubygem-google-gax-1.8.1
===>   rubygem-google-gax-1.8.1 depends on file: /usr/local/bin/gem26 - not 
found
===>   Installing existing package /packages/All/ruby26-gems-3.0.6.txz
[head-amd64-default-job-17] Installing ruby26-gems-3.0.6...
[head-amd64-default-job-17] Extracting ruby26-gems-3.0.6: .......... done
===>   rubygem-google-gax-1.8.1 depends on file: /usr/local/bin/gem26 - found
===>   Returning to build of rubygem-google-gax-1.8.1
===========================================================================
=======================<phase: extract        >============================
===>  License BSD3CLAUSE accepted by the user
===> Fetching all distfiles required by rubygem-google-gax-1.8.1 for building
===>  Extracting for rubygem-google-gax-1.8.1
=> SHA256 Checksum OK for rubygem/google-gax-1.8.1.gem.
Unpacked gem: 
'/wrkdirs/usr/ports/devel/rubygem-google-gax/work/google-gax-1.8.1'
===========================================================================
=======================<phase: patch-depends  >============================
===>   rubygem-google-gax-1.8.1 depends on file: /usr/local/bin/ruby26 - found
===========================================================================
=======================<phase: patch          >============================
===>  Patching for rubygem-google-gax-1.8.1
===========================================================================
=======================<phase: build-depends  >============================
===>   rubygem-google-gax-1.8.1 depends on file: /usr/local/bin/ruby26 - found
===>   rubygem-google-gax-1.8.1 depends on file: /usr/local/bin/gem26 - found
===========================================================================
=======================<phase: lib-depends    >============================
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for rubygem-google-gax-1.8.1
===========================================================================
=======================<phase: build          >============================
===>  Building for rubygem-google-gax-1.8.1
  Successfully built RubyGem
  Name: google-gax
  Version: 1.8.1
  File: google-gax-1.8.1.gem
===========================================================================
=======================<phase: run-depends    >============================
===>   rubygem-google-gax-1.8.1 depends on package: 
rubygem-google-protobuf>=3.9<4 - not found
===>   Installing existing package 
/packages/All/rubygem-google-protobuf-3.10.1.txz
[head-amd64-default-job-17] Installing rubygem-google-protobuf-3.10.1...
[head-amd64-default-job-17] Extracting rubygem-google-protobuf-3.10.1: 
.......... done
===>   rubygem-google-gax-1.8.1 depends on package: 
rubygem-google-protobuf>=3.9<4 - found
===>   Returning to build of rubygem-google-gax-1.8.1
===>   rubygem-google-gax-1.8.1 depends on package: 
rubygem-googleapis-common-protos>=1.3.9<2.0 - not found
===>   Installing existing package 
/packages/All/rubygem-googleapis-common-protos-1.3.9.txz
[head-amd64-default-job-17] Installing rubygem-googleapis-common-protos-1.3.9...
[head-amd64-default-job-17] `-- Installing 
rubygem-googleapis-common-protos-types-1.0.4...
[head-amd64-default-job-17] `-- Extracting 
rubygem-googleapis-common-protos-types-1.0.4: .......... done
[head-amd64-default-job-17] `-- Installing rubygem-grpc-1.24.0...
[head-amd64-default-job-17] |   `-- Installing c-ares-1.15.0_1...
[head-amd64-default-job-17] |   `-- Extracting c-ares-1.15.0_1: .......... done
[head-amd64-default-job-17] |   `-- Installing ca_root_nss-3.47.1...
[head-amd64-default-job-17] |   `-- Extracting ca_root_nss-3.47.1: ........ done
[head-amd64-default-job-17] |   `-- Installing grpc-1.22.0_1,2...
[head-amd64-default-job-17] |   | `-- Installing gflags-2.2.2_2...
[head-amd64-default-job-17] |   | `-- Extracting gflags-2.2.2_2: .......... done
[head-amd64-default-job-17] |   | `-- Installing protobuf-3.9.2,1...
[head-amd64-default-job-17] |   | `-- Extracting protobuf-3.9.2,1: .......... 
done
[head-amd64-default-job-17] |   `-- Extracting grpc-1.22.0_1,2: .......... done
[head-amd64-default-job-17] `-- Extracting rubygem-grpc-1.24.0: .......... done
[head-amd64-default-job-17] Extracting rubygem-googleapis-common-protos-1.3.9: 
.......... done
=====
Message from ca_root_nss-3.47.1:

--
FreeBSD does not, and can not warrant that the certification authorities
whose certificates are included in this package have in any way been
audited for trustworthiness or RFC 3647 compliance.

Assessment and verification of trust is the complete responsibility of the
system administrator.


This package installs symlinks to support root certificates discovery by
default for software that uses OpenSSL.

This enables SSL Certificate Verification by client software without manual
intervention.

If you prefer to do this manually, replace the following symlinks with
either an empty file or your site-local certificate bundle.

  * /etc/ssl/cert.pem
  * /usr/local/etc/ssl/cert.pem
  * /usr/local/openssl/cert.pem
===>   rubygem-google-gax-1.8.1 depends on package: 
rubygem-googleapis-common-protos>=1.3.9<2.0 - found
===>   Returning to build of rubygem-google-gax-1.8.1
===>   rubygem-google-gax-1.8.1 depends on package: rubygem-googleauth>=0.9<1 - 
not found
===>   Installing existing package /packages/All/rubygem-googleauth-0.10.0.txz
[head-amd64-default-job-17] Installing rubygem-googleauth-0.10.0...
[head-amd64-default-job-17] `-- Installing rubygem-faraday-0.17.0...
[head-amd64-default-job-17] |   `-- Installing rubygem-multipart-post-2.1.1...
[head-amd64-default-job-17] |   `-- Extracting rubygem-multipart-post-2.1.1: 
.......... done
[head-amd64-default-job-17] `-- Extracting rubygem-faraday-0.17.0: .......... 
done
[head-amd64-default-job-17] `-- Installing rubygem-jwt-2.2.1...
[head-amd64-default-job-17] `-- Extracting rubygem-jwt-2.2.1: .......... done
[head-amd64-default-job-17] `-- Installing rubygem-memoist-0.16.1...
[head-amd64-default-job-17] `-- Extracting rubygem-memoist-0.16.1: .......... 
done
[head-amd64-default-job-17] `-- Installing rubygem-multi_json-1.13.1...
[head-amd64-default-job-17] |   `-- Installing rubygem-json_pure-2.1.0...
[head-amd64-default-job-17] |   `-- Extracting rubygem-json_pure-2.1.0: 
.......... done
[head-amd64-default-job-17] `-- Extracting rubygem-multi_json-1.13.1: 
.......... done
[head-amd64-default-job-17] `-- Installing rubygem-os-1.0.1...
[head-amd64-default-job-17] `-- Extracting rubygem-os-1.0.1: .......... done
[head-amd64-default-job-17] `-- Installing rubygem-signet-0.12.0...
[head-amd64-default-job-17] |   `-- Installing rubygem-addressable-2.6.0_1...
[head-amd64-default-job-17] |   | `-- Installing 
rubygem-public_suffix-4.0.1_2...
[head-amd64-default-job-17] |   | `-- Extracting rubygem-public_suffix-4.0.1_2: 
.......... done
[head-amd64-default-job-17] |   `-- Extracting rubygem-addressable-2.6.0_1: 
.......... done
[head-amd64-default-job-17] `-- Extracting rubygem-signet-0.12.0: .......... 
done
[head-amd64-default-job-17] Extracting rubygem-googleauth-0.10.0: .......... 
done
===>   rubygem-google-gax-1.8.1 depends on package: rubygem-googleauth>=0.9<1 - 
found
===>   Returning to build of rubygem-google-gax-1.8.1
===>   rubygem-google-gax-1.8.1 depends on package: rubygem-grpc124>=1.24<2 - 
not found
===>   Installing existing package /packages/All/rubygem-grpc124-1.24.0.txz
[head-amd64-default-job-17] Installing rubygem-grpc124-1.24.0...
pkg-static: rubygem-grpc124-1.24.0 conflicts with rubygem-grpc-1.24.0 (installs 
files into the same place).  Problematic file: 
/usr/local/lib/ruby/gems/2.6/specifications/grpc-1.24.0.gemspec

Failed to install the following 1 package(s): 
/packages/All/rubygem-grpc124-1.24.0.txz
*** Error code 70

Stop.
make: stopped in /usr/ports/devel/rubygem-google-gax
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to