You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     igor.ostape...@pm.me
Last committer: tcber...@freebsd.org
Ident:          $FreeBSD: head/devel/git-extras/Makefile 520620 2019-12-22 
12:51:18Z tcberner $
Log URL:        
http://beefy12.nyi.freebsd.org/data/head-armv7-default/p525513_s357674/logs/git-extras-5.1.0.log
Build URL:      
http://beefy12.nyi.freebsd.org/build.html?mastername=head-armv7-default&build=p525513_s357674
Log:

=>> Building devel/git-extras
build started at Tue Feb 11 10:47:46 UTC 2020
port directory: /usr/ports/devel/git-extras
package name: git-extras-5.1.0
building for: FreeBSD head-armv7-default-job-06 13.0-CURRENT FreeBSD 
13.0-CURRENT 1300077 arm
maintained by: igor.ostape...@pm.me
Makefile ident:      $FreeBSD: head/devel/git-extras/Makefile 520620 2019-12-22 
12:51:18Z tcberner $
Poudriere version: 3.2.8-5-gc81843e5
Host OSVERSION: 1300076
Jail OSVERSION: 1300077
Job Id: 06




!!! Jail is newer than host. (Jail: 1300077, Host: 1300076) !!!
!!! This is not supported. !!!
!!! Host kernel must be same or newer than jail. !!!
!!! Expect build failures. !!!



---Begin Environment---
SHELL=/bin/csh
UNAME_p=armv7
UNAME_m=arm
ABI_FILE=/usr/lib/crt1.o
OSVERSION=1300077
UNAME_v=FreeBSD 13.0-CURRENT 1300077
UNAME_r=13.0-CURRENT
BLOCKSIZE=K
STATUS=1
HOME=/root
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
LOCALBASE=/usr/local
QEMU_EMULATING=1
USER=root
LIBEXECPREFIX=/usr/local/libexec/poudriere
POUDRIERE_VERSION=3.2.8-5-gc81843e5
MASTERMNT=/usr/local/poudriere/data/.m/head-armv7-default/ref
POUDRIERE_BUILD_TYPE=bulk
PACKAGE_BUILDING=yes
SAVED_TERM=
PWD=/usr/local/poudriere/data/.m/head-armv7-default/ref/.p/pool
P_PORTS_FEATURES=FLAVORS SELECTED_OPTIONS
MASTERNAME=head-armv7-default
SCRIPTPREFIX=/usr/local/share/poudriere
OLDPWD=/usr/local/poudriere/data/.m/head-armv7-default/ref/.p
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
POUDRIEREPATH=/usr/local/bin/poudriere
---End Environment---

---Begin Poudriere Port Flags/Env---
PORT_FLAGS=
PKGENV=
FLAVOR=
DEPENDS_ARGS=
MAKE_ARGS=
---End Poudriere Port Flags/Env---

---Begin OPTIONS List---
---End OPTIONS List---

--MAINTAINER--
igor.ostape...@pm.me
--End MAINTAINER--

--CONFIGURE_ARGS--

--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
MAKE=gmake XDG_DATA_HOME=/wrkdirs/usr/ports/devel/git-extras/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/devel/git-extras/work  
HOME=/wrkdirs/usr/ports/devel/git-extras/work TMPDIR="/tmp" 
PATH=/wrkdirs/usr/ports/devel/git-extras/work/.bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
 SHELL=/bin/sh CONFIG_SHELL=/bin/sh
--End CONFIGURE_ENV--

--MAKE_ENV--
XDG_DATA_HOME=/wrkdirs/usr/ports/devel/git-extras/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/devel/git-extras/work  
HOME=/wrkdirs/usr/ports/devel/git-extras/work TMPDIR="/tmp" 
PATH=/wrkdirs/usr/ports/devel/git-extras/work/.bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
 NO_PIE=yes MK_DEBUG_FILES=no MK_KERNEL_SYMBOLS=no SHELL=/bin/sh NO_LINT=YES 
PREFIX=/usr/local  LOCALBASE=/usr/local  CC="/nxb-bin/usr/bin/cc" CFLAGS="-O2 
-pipe  -fstack-protector-strong -fno-strict-aliasing "  
CPP="/nxb-bin/usr/bin/cpp" CPPFLAGS=""  LDFLAGS=" -fstack-protector-strong " 
LIBS=""  CXX="/nxb-bin/usr/bin/c++" CXXFLAGS="-O2 -pipe 
-fstack-protector-strong -fno-strict-aliasing  "  MANPREFIX="/usr/local" 
BSD_INSTALL_PROGRAM="install  -s -m 555"  BSD_INSTALL_LIB="install  -s -m 0644" 
 BSD_INSTALL_SCRIPT="install  -m 555"  BSD_INSTALL_DATA="install  -m 0644"  
BSD_INSTALL_MAN="install  -m 444"
--End MAKE_ENV--

--PLIST_SUB--
OSREL=13.0 PREFIX=%D LOCALBASE=/usr/local  RESETPREFIX=/usr/local LIB32DIR=lib 
DOCSDIR="share/doc/git-extras"  EXAMPLESDIR="share/examples/git-extras"  
DATADIR="share/git-extras"  WWWDIR="www/git-extras"  ETCDIR="etc/git-extras"
--End PLIST_SUB--

--SUB_LIST--
PREFIX=/usr/local LOCALBASE=/usr/local  DATADIR=/usr/local/share/git-extras 
DOCSDIR=/usr/local/share/doc/git-extras 
EXAMPLESDIR=/usr/local/share/examples/git-extras  
WWWDIR=/usr/local/www/git-extras ETCDIR=/usr/local/etc/git-extras
--End SUB_LIST--

---Begin make.conf---
.sinclude "/etc/make.nxb.conf"
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
PACKAGE_BUILDING=yes
PACKAGE_BUILDING_FLAVORS=yes
MACHINE=arm
MACHINE_ARCH=armv7
ARCH=${MACHINE_ARCH}
#### /usr/local/etc/poudriere.d/make.conf ####
# XXX: We really need this but cannot use it while 'make checksum' does not
# try the next mirror on checksum failure.  It currently retries the same
# failed mirror and then fails rather then trying another.  It *does*
# try the next if the size is mismatched though.
#MASTER_SITE_FREEBSD=yes
# Build ALLOW_MAKE_JOBS_PACKAGES with 2 jobs
MAKE_JOBS_NUMBER=2
#### /usr/ports/Mk/Scripts/ports_env.sh ####
_CCVERSION_9d218390=FreeBSD clang version 9.0.1 
(g...@github.com:llvm/llvm-project.git 
c1a0a213378a458fbea1a5c77b315c7dce08fd05) (based on LLVM 9.0.1) Target: 
armv7-unknown-freebsd13.0-gnueabihf Thread model: posix InstalledDir: 
/nxb-bin/usr/bin
_ALTCCVERSION_9d218390=none
_CXXINTERNAL_9c45a5b1=FreeBSD clang version 9.0.1 
(g...@github.com:llvm/llvm-project.git 
c1a0a213378a458fbea1a5c77b315c7dce08fd05) (based on LLVM 9.0.1) Target: 
armv7-unknown-freebsd13.0-gnueabihf Thread model: posix InstalledDir: 
/nxb-bin/usr/bin "/nxb-bin/usr/bin/ld" "--eh-frame-hdr" "-dynamic-linker" 
"/libexec/ld-elf.so.1" "--hash-style=both" "--enable-new-dtags" "-o" "a.out" 
"/usr/lib/crt1.o" "/usr/lib/crti.o" "/usr/lib/crtbegin.o" "-L/usr/lib" 
"/dev/null" "-lc++" "-lm" "-lgcc" "--as-needed" "-lgcc_s" "--no-as-needed" 
"-lc" "-lgcc" "--as-needed" "-lgcc_s" "--no-as-needed" "/usr/lib/crtend.o" 
"/usr/lib/crtn.o"
CC_OUTPUT_9d218390_58173849=yes
CC_OUTPUT_9d218390_9bdba57c=yes
CC_OUTPUT_9d218390_6a4fe7f5=yes
CC_OUTPUT_9d218390_6bcac02b=yes
CC_OUTPUT_9d218390_67d20829=yes
CC_OUTPUT_9d218390_bfa62e83=yes
CC_OUTPUT_9d218390_f0b4d593=yes
CC_OUTPUT_9d218390_308abb44=yes
CC_OUTPUT_9d218390_f00456e5=yes
CC_OUTPUT_9d218390_65ad290d=yes
CC_OUTPUT_9d218390_f2776b26=yes
CC_OUTPUT_9d218390_b2657cc3=yes
CC_OUTPUT_9d218390_380987f7=yes
CC_OUTPUT_9d218390_160933ec=yes
CC_OUTPUT_9d218390_fb62803b=yes
_OBJC_CCVERSION_9d218390=FreeBSD clang version 9.0.1 
(g...@github.com:llvm/llvm-project.git 
c1a0a213378a458fbea1a5c77b315c7dce08fd05) (based on LLVM 9.0.1) Target: 
armv7-unknown-freebsd13.0-gnueabihf Thread model: posix InstalledDir: 
/nxb-bin/usr/bin
_OBJC_ALTCCVERSION_9d218390=none
ARCH=armv7
OPSYS=FreeBSD
_OSRELEASE=13.0-CURRENT
OSREL=13.0
OSVERSION=1300077
PYTHONBASE=/usr/local
CONFIGURE_MAX_CMD_LEN=524288
HAVE_PORTS_ENV=1
#### Misc Poudriere ####
GID=0
UID=0
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
---Begin make.nxb.conf---
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
AS=/nxb-bin/usr/bin/as
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
RANLIB=/nxb-bin/usr/bin/ranlib
YACC=/nxb-bin/usr/bin/yacc
MAKE=/nxb-bin/usr/bin/make
STRINGS=/nxb-bin/usr/bin/strings
AWK=/nxb-bin/usr/bin/awk
FLEX=/nxb-bin/usr/bin/flex
---End make.nxb.conf---
--Resource limits--
cpu time               (seconds, -t)  unlimited
file size           (512-blocks, -f)  unlimited
data seg size           (kbytes, -d)  33554432
stack size              (kbytes, -s)  524288
core file size      (512-blocks, -c)  unlimited
max memory size         (kbytes, -m)  unlimited
locked memory           (kbytes, -l)  unlimited
max user processes              (-u)  89999
open files                      (-n)  1024
virtual mem size        (kbytes, -v)  unlimited
swap limit              (kbytes, -w)  unlimited
socket buffer size       (bytes, -b)  unlimited
pseudo-terminals                (-p)  unlimited
kqueues                         (-k)  unlimited
umtx shared locks               (-o)  unlimited
--End resource limits--
=======================<phase: check-sanity   >============================
===>  License MIT accepted by the user
===========================================================================
=======================<phase: pkg-depends    >============================
===>   git-extras-5.1.0 depends on file: /usr/local/sbin/pkg - not found
===>   Installing existing package /packages/All/pkg-1.12.0_1.txz
[head-armv7-default-job-06] Installing pkg-1.12.0_1...
[head-armv7-default-job-06] Extracting pkg-1.12.0_1: .......... done
===>   git-extras-5.1.0 depends on file: /usr/local/sbin/pkg - found
===>   Returning to build of git-extras-5.1.0
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===>  License MIT accepted by the user
===> Fetching all distfiles required by git-extras-5.1.0 for building
===========================================================================
=======================<phase: checksum       >============================
===>  License MIT accepted by the user
===> Fetching all distfiles required by git-extras-5.1.0 for building
=> SHA256 Checksum OK for tj-git-extras-5.1.0_GH0.tar.gz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===>  License MIT accepted by the user
===> Fetching all distfiles required by git-extras-5.1.0 for building
===>  Extracting for git-extras-5.1.0
=> SHA256 Checksum OK for tj-git-extras-5.1.0_GH0.tar.gz.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for git-extras-5.1.0
===>  Applying FreeBSD patches for git-extras-5.1.0
===========================================================================
=======================<phase: build-depends  >============================
===>   git-extras-5.1.0 depends on executable: gmake - not found
===>   Installing existing package /packages/All/gmake-4.2.1_3.txz
[head-armv7-default-job-06] Installing gmake-4.2.1_3...
[head-armv7-default-job-06] `-- Installing gettext-runtime-0.20.1...
[head-armv7-default-job-06] |   `-- Installing indexinfo-0.3.1...
[head-armv7-default-job-06] |   `-- Extracting indexinfo-0.3.1: .... done
[head-armv7-default-job-06] `-- Extracting gettext-runtime-0.20.1: .......... 
done
[head-armv7-default-job-06] Extracting gmake-4.2.1_3: .......... done
===>   git-extras-5.1.0 depends on executable: gmake - found
===>   Returning to build of git-extras-5.1.0
===========================================================================
=======================<phase: lib-depends    >============================
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for git-extras-5.1.0
===========================================================================
=======================<phase: build          >============================
===========================================================================
=======================<phase: run-depends    >============================
===>   git-extras-5.1.0 depends on executable: git - not found
===>   Installing existing package /packages/All/git-2.25.0.txz
[head-armv7-default-job-06] Installing git-2.25.0...
[head-armv7-default-job-06] `-- Installing curl-7.68.0...
[head-armv7-default-job-06] |   `-- Installing ca_root_nss-3.49.2...
[head-armv7-default-job-06] |   `-- Extracting ca_root_nss-3.49.2: ........ done
[head-armv7-default-job-06] |   `-- Installing libnghttp2-1.40.0...
[head-armv7-default-job-06] |   `-- Extracting libnghttp2-1.40.0: .......... 
done
[head-armv7-default-job-06] `-- Extracting curl-7.68.0: .......... done
[head-armv7-default-job-06] `-- Installing cvsps-2.1_2...
[head-armv7-default-job-06] `-- Extracting cvsps-2.1_2: ...... done
[head-armv7-default-job-06] `-- Installing expat-2.2.8...
[head-armv7-default-job-06] `-- Extracting expat-2.2.8: .......... done
[head-armv7-default-job-06] `-- Installing p5-Authen-SASL-2.16_1...
[head-armv7-default-job-06] |   `-- Installing p5-Digest-HMAC-1.03_1...
[head-armv7-default-job-06] |   | `-- Installing perl5-5.30.1...
[head-armv7-default-job-06] |   | `-- Extracting perl5-5.30.1: .......... done
[head-armv7-default-job-06] |   `-- Extracting p5-Digest-HMAC-1.03_1: 
.......... done
[head-armv7-default-job-06] |   `-- Installing p5-GSSAPI-0.28_1...
[head-armv7-default-job-06] |   `-- Extracting p5-GSSAPI-0.28_1: .......... done
[head-armv7-default-job-06] `-- Extracting p5-Authen-SASL-2.16_1: .......... 
done
[head-armv7-default-job-06] `-- Installing p5-CGI-4.46...
[head-armv7-default-job-06] |   `-- Installing p5-HTML-Parser-3.72...
[head-armv7-default-job-06] |   | `-- Installing p5-HTML-Tagset-3.20_1...
[head-armv7-default-job-06] |   | `-- Extracting p5-HTML-Tagset-3.20_1: ....... 
done
[head-armv7-default-job-06] |   `-- Extracting p5-HTML-Parser-3.72: .......... 
done
[head-armv7-default-job-06] `-- Extracting p5-CGI-4.46: .......... done
[head-armv7-default-job-06] `-- Installing p5-Error-0.17029...
[head-armv7-default-job-06] `-- Extracting p5-Error-0.17029: ......... done
[head-armv7-default-job-06] `-- Installing p5-IO-Socket-SSL-2.066...
[head-armv7-default-job-06] |   `-- Installing p5-IO-Socket-INET6-2.72_1...
[head-armv7-default-job-06] |   | `-- Installing p5-Socket6-0.29...
[head-armv7-default-job-06] |   | `-- Extracting p5-Socket6-0.29: ....... done
[head-armv7-default-job-06] |   `-- Extracting p5-IO-Socket-INET6-2.72_1: 
....... done
[head-armv7-default-job-06] |   `-- Installing p5-Mozilla-CA-20180117...
[head-armv7-default-job-06] |   `-- Extracting p5-Mozilla-CA-20180117: ........ 
done
[head-armv7-default-job-06] |   `-- Installing p5-Net-SSLeay-1.88...
[head-armv7-default-job-06] |   `-- Extracting p5-Net-SSLeay-1.88: .......... 
done
[head-armv7-default-job-06] `-- Extracting p5-IO-Socket-SSL-2.066: .......... 
done
[head-armv7-default-job-06] `-- Installing p5-Term-ReadKey-2.38_1...
[head-armv7-default-job-06] `-- Extracting p5-Term-ReadKey-2.38_1: ........ done
[head-armv7-default-job-06] `-- Installing p5-subversion-1.13.0...
[head-armv7-default-job-06] |   `-- Installing apr-1.7.0.1.6.1...
[head-armv7-default-job-06] |   | `-- Installing db5-5.3.28_7...
[head-armv7-default-job-06] |   | `-- Extracting db5-5.3.28_7: .......... done
[head-armv7-default-job-06] |   | `-- Installing gdbm-1.18.1_1...
[head-armv7-default-job-06] |   |   `-- Installing readline-8.0.1...
[head-armv7-default-job-06] |   |   `-- Extracting readline-8.0.1: .......... 
done
[head-armv7-default-job-06] |   | `-- Extracting gdbm-1.18.1_1: .......... done
[head-armv7-default-job-06] |   `-- Extracting apr-1.7.0.1.6.1: .......... done
[head-armv7-default-job-06] |   `-- Installing liblz4-1.9.2_1,1...
[head-armv7-default-job-06] |   `-- Extracting liblz4-1.9.2_1,1: .......... done
[head-armv7-default-job-06] |   `-- Installing sqlite3-3.30.1,1...
[head-armv7-default-job-06] |   `-- Extracting sqlite3-3.30.1,1: .......... done
[head-armv7-default-job-06] |   `-- Installing subversion-1.13.0...
[head-armv7-default-job-06] |   | `-- Installing serf-1.3.9_4...
[head-armv7-default-job-06] |   | `-- Extracting serf-1.3.9_4: .......... done
[head-armv7-default-job-06] |   | `-- Installing utf8proc-2.4.0...
[head-armv7-default-job-06] |   | `-- Extracting utf8proc-2.4.0: .......... done
[head-armv7-default-job-06] |   `-- Extracting subversion-1.13.0: .......... 
done
[head-armv7-default-job-06] `-- Extracting p5-subversion-1.13.0: .......... done
[head-armv7-default-job-06] `-- Installing pcre-8.43_2...
[head-armv7-default-job-06] `-- Extracting pcre-8.43_2: .......... done
[head-armv7-default-job-06] `-- Installing python37-3.7.6...
[head-armv7-default-job-06] |   `-- Installing libffi-3.2.1_3...
[head-armv7-default-job-06] |   `-- Extracting libffi-3.2.1_3: .......... done
[head-armv7-default-job-06] `-- Extracting python37-3.7.6: .......... done
===> Creating groups.
Creating group 'git_daemon' with gid '964'.
===> Creating users
Creating user 'git_daemon' with uid '964'.
[head-armv7-default-job-06] Extracting git-2.25.0: .......... done
=====
Message from ca_root_nss-3.49.2:

--
FreeBSD does not, and can not warrant that the certification authorities
whose certificates are included in this package have in any way been
audited for trustworthiness or RFC 3647 compliance.

Assessment and verification of trust is the complete responsibility of the
system administrator.


This package installs symlinks to support root certificates discovery by
default for software that uses OpenSSL.

This enables SSL Certificate Verification by client software without manual
intervention.

If you prefer to do this manually, replace the following symlinks with
either an empty file or your site-local certificate bundle.

  * /etc/ssl/cert.pem
  * /usr/local/etc/ssl/cert.pem
  * /usr/local/openssl/cert.pem
=====
Message from perl5-5.30.1:

--
The /usr/bin/perl symlink has been removed starting with Perl 5.20.
For shebangs, you should either use:

#!/usr/local/bin/perl

or

#!/usr/bin/env perl

The first one will only work if you have a /usr/local/bin/perl,
the second will work as long as perl is in PATH.
=====
Message from apr-1.7.0.1.6.1:

--
The Apache Portable Runtime project removed support for FreeTDS with
version 1.6. Users requiring MS-SQL connectivity must migrate
configurations to use the added ODBC driver and FreeTDS' ODBC features.
=====
Message from python37-3.7.6:

--
Note that some standard Python modules are provided as separate ports
as they require additional dependencies. They are available as:

py37-gdbm       databases/py-gdbm@py37
py37-sqlite3    databases/py-sqlite3@py37
py37-tkinter    x11-toolkits/py-tkinter@py37
=====
Message from git-2.25.0:

--
If you installed the GITWEB option please follow these instructions:

In the directory /usr/local/share/examples/git/gitweb you can find all files to
make gitweb work as a public repository on the web.

All you have to do to make gitweb work is:
1) Please be sure you're able to execute CGI scripts in
   /usr/local/share/examples/git/gitweb.
2) Set the GITWEB_CONFIG variable in your webserver's config to
   /usr/local/etc/git/gitweb.conf. This variable is passed to gitweb.cgi.
3) Restart server.


If you installed the CONTRIB option please note that the scripts are
installed in /usr/local/share/git-core/contrib. Some of them require
other ports to be installed (perl, python, etc), which you may need to
install manually.
===>   git-extras-5.1.0 depends on executable: git - found
===>   Returning to build of git-extras-5.1.0
===>   git-extras-5.1.0 depends on executable: bash - not found
===>   Installing existing package /packages/All/bash-5.0.11.txz
[head-armv7-default-job-06] Installing bash-5.0.11...
[head-armv7-default-job-06] Extracting bash-5.0.11: .......... done
===>   git-extras-5.1.0 depends on executable: bash - found
===>   Returning to build of git-extras-5.1.0
===========================================================================
=======================<phase: stage          >============================
===>  Staging for git-extras-5.1.0
===>   Generating temporary packing list
gmake[1]: Entering directory 
'/wrkdirs/usr/ports/devel/git-extras/work/git-extras-5.1.0'
Check dependencies before installation

=>> Killing runaway build after 21600 seconds with no output
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to