You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     mar...@freebsd.org
Last committer: mar...@freebsd.org
Ident:          $FreeBSD: branches/2014Q2/devel/matreshka/Makefile 348377 
2014-03-15 20:21:49Z marino $
Log URL:        
http://beefy1.isc.freebsd.org/bulk/91i386-quarterly/2014-05-07_01h03m39s/logs/matreshka-0.6.0_2.log
Build URL:      
http://beefy1.isc.freebsd.org/bulk/91i386-quarterly/2014-05-07_01h03m39s
Log:

====>> Building devel/matreshka
build started at Wed May  7 01:27:22 UTC 2014
port directory: /usr/ports/devel/matreshka
building for: FreeBSD 91i386-quarterly-job-07 9.1-RELEASE-p11 FreeBSD 
9.1-RELEASE-p11 i386
maintained by: mar...@freebsd.org
Makefile ident:      $FreeBSD: branches/2014Q2/devel/matreshka/Makefile 348377 
2014-03-15 20:21:49Z marino $
Poudriere version: 3.1-pre
Host OSVERSION: 1100013
Jail OSVERSION: 901000

---Begin Environment---
UNAME_m=i386
UNAME_p=i386
OSVERSION=901000
UNAME_v=FreeBSD 9.1-RELEASE-p11
UNAME_r=9.1-RELEASE-p11
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
SAVED_TERM=
MASTERMNT=/usr/local/poudriere/data/build/91i386-quarterly/ref
PKG_EXT=txz
tpid=39229
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
POUDRIERE_BUILD_TYPE=bulk
PKGNG=1
PKGNAME=matreshka-0.6.0_2
PKG_DELETE=/usr/local/sbin/pkg-static delete -y -f
PKG_ADD=/usr/local/sbin/pkg-static add
OLDPWD=/usr/local/poudriere/data/build/91i386-quarterly/ref/poudriere/rdeps
PWD=/usr/local/poudriere/data/build/91i386-quarterly/ref/poudriere/pool
MASTERNAME=91i386-quarterly
USER=root
HOME=/root
POUDRIERE_VERSION=3.1-pre
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
PKG_VERSION=/poudriere/pkg-static version
PKG_BIN=/usr/local/sbin/pkg-static
---End Environment---

---Begin OPTIONS List---
===> The following configuration options are available for matreshka-0.6.0_2:
     AMF=off: Build Ada Modeling Framework
     FIREBIRD=on: Firebird (Interbase) database support
     MYSQL=on: MySQL database support
     ORACLE=off: Oracle database support
     PGSQL=on: PostgreSQL database support
     SQLITE3=on: SQLite 3 database support
===> Use 'make config' to modify these settings
---End OPTIONS List---

--CONFIGURE_ARGS--
--disable-amf --enable-firebird --enable-mysql --disable-oracle 
--enable-postgresql --enable-sqlite3 --with-firebird-libdir=/usr/local/lib
--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
TMPDIR="/tmp" TMPDIR="/tmp" 
PATH=/usr/local/gcc-aux/bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
 ADA_PROJECT_PATH=/usr/local/lib/gnat MAKE=gmake PKG_CONFIG=pkgconf 
SHELL=/bin/sh CONFIG_SHELL=/bin/sh
--End CONFIGURE_ENV--

--MAKE_ENV--
SMP_MFLAGS=-j1 TMPDIR="/tmp" TMPDIR="/tmp" 
PATH=/usr/local/gcc-aux/bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
 ADA_PROJECT_PATH=/usr/local/lib/gnat SHELL=/bin/sh NO_LINT=YES 
PREFIX=/usr/local  LOCALBASE=/usr/local  LIBDIR="/usr/lib"  CC="ada" 
CFLAGS="-O2 -pipe -fno-strict-aliasing"  CPP="cpp" 
CPPFLAGS="-I/usr/local/include"  LDFLAGS=" -L/usr/local/lib"  CXX="c++" 
CXXFLAGS="-O2 -pipe -fno-strict-aliasing"  MANPREFIX="/usr/local" 
BSD_INSTALL_PROGRAM="install  -s -o root -g wheel -m 555"  
BSD_INSTALL_LIB="install  -s -o root -g wheel -m 444"  
BSD_INSTALL_SCRIPT="install  -o root -g wheel -m 555"  
BSD_INSTALL_DATA="install  -o root -g wheel -m 444"  BSD_INSTALL_MAN="install  
-o root -g wheel -m 444"
--End MAKE_ENV--

--PLIST_SUB--
OSREL=9.1
PREFIX=%D
LOCALBASE=/usr/local
PORTDOCS=""
PORTEXAMPLES=""
PORTDATA=""
LIB32DIR=lib
DOCSDIR="share/doc/matreshka"
EXAMPLESDIR="share/examples/matreshka"
DATADIR="share/matreshka"
WWWDIR="www/matreshka"
ETCDIR="etc/matreshka"
--End PLIST_SUB--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/matreshka
DOCSDIR=/usr/local/share/doc/matreshka
EXAMPLESDIR=/usr/local/share/examples/matreshka
WWWDIR=/usr/local/www/matreshka
ETCDIR=/usr/local/etc/matreshka
--End SUB_LIST--

---Begin make.conf---
ARCH=i386
MACHINE=i386
MACHINE_ARCH=i386
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
WITH_PKGNG=yes
NO_RESTRICTED=yes
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
===>  Cleaning for matreshka-0.6.0_2
=======================<phase: check-sanity   >============================
===>  License BSD3CLAUSE accepted by the user
===========================================================================
=======================<phase: pkg-depends    >============================
===>   matreshka-0.6.0_2 depends on file: /usr/local/sbin/pkg - not found
===>    Verifying install for /usr/local/sbin/pkg in /usr/ports/ports-mgmt/pkg
===>   Installing existing package /packages/All/pkg-1.2.7.txz
Installing pkg-1.2.7... done
If you are upgrading from the old package format, first run:

  # pkg2ng
===>   Returning to build of matreshka-0.6.0_2
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===>  License BSD3CLAUSE accepted by the user
===> Fetching all distfiles required by matreshka-0.6.0_2 for building
===========================================================================
=======================<phase: checksum       >============================
===>  License BSD3CLAUSE accepted by the user
===> Fetching all distfiles required by matreshka-0.6.0_2 for building
=> SHA256 Checksum OK for matreshka-0.6.0.tar.gz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===>  License BSD3CLAUSE accepted by the user
===> Fetching all distfiles required by matreshka-0.6.0_2 for building
===>  Extracting for matreshka-0.6.0_2
=> SHA256 Checksum OK for matreshka-0.6.0.tar.gz.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for matreshka-0.6.0_2
===>  Applying FreeBSD patches for matreshka-0.6.0_2
===========================================================================
=======================<phase: build-depends  >============================
===>   matreshka-0.6.0_2 depends on package: gprbuild>=20120510 - not found
pkg-static: No package(s) matching gprbuild
===>    Verifying install for gprbuild>=20120510 in /usr/ports/devel/gprbuild
===>   Installing existing package /packages/All/gprbuild-20130416_1.txz
Installing gprbuild-20130416_1... done
===>   Returning to build of matreshka-0.6.0_2
===>   matreshka-0.6.0_2 depends on file: /usr/local/gcc-aux/bin/ada - not found
===>    Verifying install for /usr/local/gcc-aux/bin/ada in 
/usr/ports/lang/gcc-aux
===>   Installing existing package /packages/All/gcc-aux-20140330.txz
Installing gcc-aux-20140330...Installing gmp-5.1.3_1... done
Installing libiconv-1.14_3... done
Installing mpc-1.0.2...Installing mpfr-3.1.2_1... done
 done
 done
===>   Returning to build of matreshka-0.6.0_2
===>   matreshka-0.6.0_2 depends on executable: gmake - not found
===>    Verifying install for gmake in /usr/ports/devel/gmake
===>   Installing existing package /packages/All/gmake-3.82_1.txz
Installing gmake-3.82_1...Installing gettext-0.18.3.1... done
 done
===>   Returning to build of matreshka-0.6.0_2
===>   matreshka-0.6.0_2 depends on executable: pkgconf - not found
===>    Verifying install for pkgconf in /usr/ports/devel/pkgconf
===>   Installing existing package /packages/All/pkgconf-0.9.5.txz
Installing pkgconf-0.9.5... done
===>   Returning to build of matreshka-0.6.0_2
===========================================================================
=======================<phase: lib-depends    >============================
===>   matreshka-0.6.0_2 depends on shared library: libsqlite3.so - not found
===>    Verifying for libsqlite3.so in /usr/ports/databases/sqlite3
===>   Installing existing package /packages/All/sqlite3-3.8.4.1.txz
Installing sqlite3-3.8.4.1... done
===>   Returning to build of matreshka-0.6.0_2
===>   matreshka-0.6.0_2 depends on shared library: mysqlclient.18 - not found
===>    Verifying install for mysqlclient.18 in 
/usr/ports/databases/mysql55-client
===>   Installing existing package /packages/All/mysql55-client-5.5.37.txz
Installing mysql55-client-5.5.37... done
===>   Returning to build of matreshka-0.6.0_2
===>   matreshka-0.6.0_2 depends on shared library: pq.5 - not found
===>    Verifying install for pq.5 in /usr/ports/databases/postgresql90-client
===>   Installing existing package /packages/All/postgresql90-client-9.0.17.txz
Installing postgresql90-client-9.0.17...Installing libxml2-2.8.0_3... done
 done
The PostgreSQL port has a collection of "side orders":

postgresql-docs
  For all of the html documentation

p5-Pg
  A perl5 API for client access to PostgreSQL databases.

postgresql-tcltk 
  If you want tcl/tk client support.

postgresql-jdbc
  For Java JDBC support.

postgresql-odbc
  For client access from unix applications using ODBC as access
  method. Not needed to access unix PostgreSQL servers from Win32
  using ODBC. See below.

ruby-postgres, py-PyGreSQL
  For client access to PostgreSQL databases using the ruby & python
  languages.

postgresql-plperl, postgresql-pltcl & postgresql-plruby
  For using perl5, tcl & ruby as procedural languages.

postgresql-contrib
  Lots of contributed utilities, postgresql functions and
  datatypes. There you find pg_standby, pgcrypto and many other cool
  things.

etc...
===>   Returning to build of matreshka-0.6.0_2
===>   matreshka-0.6.0_2 depends on shared library: fbclient.2 - not found
===>    Verifying install for fbclient.2 in 
/usr/ports/databases/firebird25-client
===>   Installing existing package /packages/All/firebird25-client-2.5.2_2.txz
Installing firebird25-client-2.5.2_2...Installing icu-52.1... done
 done
===>   Returning to build of matreshka-0.6.0_2
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for matreshka-0.6.0_2
cd /wrkdirs/usr/ports/devel/matreshka/work/matreshka-0.6.0 && /usr/bin/env 
TMPDIR="/tmp" TMPDIR="/tmp" 
PATH=/usr/local/gcc-aux/bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
 ADA_PROJECT_PATH=/usr/local/lib/gnat MAKE=gmake PKG_CONFIG=pkgconf 
SHELL=/bin/sh CONFIG_SHELL=/bin/sh gmake config
gnatmake -p -j0  -Pgnat/tools_configure.gpr
object directory 
"/wrkdirs/usr/ports/devel/matreshka/work/matreshka-0.6.0/gnat/../.objs/configure"
 created for project tools_configure
ada -c -g -gnat05 -gnato -fstack-check -I- -gnatA 
/wrkdirs/usr/ports/devel/matreshka/work/matreshka-0.6.0/tools/configure/configure-driver.adb
ada -c -g -gnat05 -gnato -fstack-check -I- -gnatA 
/wrkdirs/usr/ports/devel/matreshka/work/matreshka-0.6.0/tools/configure/configure.adb
ada -c -g -gnat05 -gnato -fstack-check -I- -gnatA 
/wrkdirs/usr/ports/devel/matreshka/work/matreshka-0.6.0/tools/configure/configure-architecture.adb
ada -c -g -gnat05 -gnato -fstack-check -I- -gnatA 
/wrkdirs/usr/ports/devel/matreshka/work/matreshka-0.6.0/tools/configure/configure-instantiate.adb
ada -c -g -gnat05 -gnato -fstack-check -I- -gnatA 
/wrkdirs/usr/ports/devel/matreshka/work/matreshka-0.6.0/tools/configure/configure-operating_system.adb
ada -c -g -gnat05 -gnato -fstack-check -I- -gnatA 
/wrkdirs/usr/ports/devel/matreshka/work/matreshka-0.6.0/tools/configure/configure-rtl_version.adb
ada -c -g -gnat05 -gnato -fstack-check -I- -gnatA 
/wrkdirs/usr/ports/devel/matreshka/work/matreshka-0.6.0/tools/configure/configure-tests.ads
ada -c -g -gnat05 -gnato -fstack-check -I- -gnatA 
/wrkdirs/usr/ports/devel/matreshka/work/matreshka-0.6.0/tools/configure/configure-tests-firebird.adb
ada -c -g -gnat05 -gnato -fstack-check -I- -gnatA 
/wrkdirs/usr/ports/devel/matreshka/work/matreshka-0.6.0/tools/configure/configure-tests-gprbuild.adb
ada -c -g -gnat05 -gnato -fstack-check -I- -gnatA 
/wrkdirs/usr/ports/devel/matreshka/work/matreshka-0.6.0/tools/configure/configure-tests-install.adb
ada -c -g -gnat05 -gnato -fstack-check -I- -gnatA 
/wrkdirs/usr/ports/devel/matreshka/work/matreshka-0.6.0/tools/configure/configure-tests-installation_directories.adb
ada -c -g -gnat05 -gnato -fstack-check -I- -gnatA 
/wrkdirs/usr/ports/devel/matreshka/work/matreshka-0.6.0/tools/configure/configure-tests-modules.ads
ada -c -g -gnat05 -gnato -fstack-check -I- -gnatA 
/wrkdirs/usr/ports/devel/matreshka/work/matreshka-0.6.0/tools/configure/configure-tests-modules-amf.adb
ada -c -g -gnat05 -gnato -fstack-check -I- -gnatA 
/wrkdirs/usr/ports/devel/matreshka/work/matreshka-0.6.0/tools/configure/configure-tests-mysql.adb
ada -c -g -gnat05 -gnato -fstack-check -I- -gnatA 
/wrkdirs/usr/ports/devel/matreshka/work/matreshka-0.6.0/tools/configure/configure-tests-oci.adb
ada -c -g -gnat05 -gnato -fstack-check -I- -gnatA 
/wrkdirs/usr/ports/devel/matreshka/work/matreshka-0.6.0/tools/configure/configure-tests-postgresql.adb
ada -c -g -gnat05 -gnato -fstack-check -I- -gnatA 
/wrkdirs/usr/ports/devel/matreshka/work/matreshka-0.6.0/tools/configure/configure-tests-sqlite3.adb
ada -c -g -gnat05 -gnato -fstack-check -I- -gnatA 
/wrkdirs/usr/ports/devel/matreshka/work/matreshka-0.6.0/tools/configure/configure-tests-valgrind.adb
ada -c -g -gnat05 -gnato -fstack-check -I- -gnatA 
/wrkdirs/usr/ports/devel/matreshka/work/matreshka-0.6.0/tools/configure/configure-version.adb
ada -c -g -gnat05 -gnato -fstack-check -I- -gnatA 
/wrkdirs/usr/ports/devel/matreshka/work/matreshka-0.6.0/tools/configure/configure-builder.adb
ada -c -g -gnat05 -gnato -fstack-check -I- -gnatA 
/wrkdirs/usr/ports/devel/matreshka/work/matreshka-0.6.0/tools/configure/configure-abstract_tests.adb
ada -c -g -gnat05 -gnato -fstack-check -I- -gnatA 
/wrkdirs/usr/ports/devel/matreshka/work/matreshka-0.6.0/tools/configure/configure-component_switches.adb
ada -c -g -gnat05 -gnato -fstack-check -I- -gnatA 
/wrkdirs/usr/ports/devel/matreshka/work/matreshka-0.6.0/tools/configure/configure-pkg_config.adb
gnatbind -x 
/wrkdirs/usr/ports/devel/matreshka/work/matreshka-0.6.0/.objs/configure/configure-driver.ali
gnatlink 
/wrkdirs/usr/ports/devel/matreshka/work/matreshka-0.6.0/.objs/configure/configure-driver.ali
 -o /wrkdirs/usr/ports/devel/matreshka/work/matreshka-0.6.0/configure
[modules   ] checking whether to build AMF module...: no
[mysql     ] checking whether to build MySQL module...: yes (mysql_config)
[mysql     ] checking for linker switches...: "-L/usr/local/lib/mysql", 
"-lmysqlclient_r", "-pthread", "-lz"
[mysql     ] checking whether MySQL library is usable...: yes
[mysql     ] checking whether MySQL server can be used for testing...: no
[oci       ] checking whether to build Oracle module...: no (command line)
configure: (info) Oracle driver module is disabled
[postgresql] checking whether to build PostgreSQL module...: yes (pg_config)
[postgresql] checking whether PostgreSQL library is usable...: yes
[sqlite3   ] checking whether to build SQLite3 module...: yes (pkg-config)
[sqlite3   ] checking for SQLite3 version...: 
[sqlite3   ] checking for linker switches...: "-L/usr/local/lib", "-lsqlite3"
[sqlite3   ] checking whether SQLite3 library is usable...: yes
[firebird  ] checking whether to build Firebird module...: yes (command line)
[firebird  ] checking whether Firebird library is usable...: no
configure: (fatal) Firebird library is not found but support is requested
===>  Script "configure" failed unexpectedly.
Please report the problem to mar...@freebsd.org [maintainer] and attach the
"/wrkdirs/usr/ports/devel/matreshka/work/matreshka-0.6.0/config.log" including
the output of the failure of your make command. Also, it might be a good idea
to provide an overview of all packages installed on your system (e.g. a
/usr/local/sbin/pkg-static info -g -Ea).
*** [do-configure] Error code 1

Stop in /usr/ports/devel/matreshka.
===>  Cleaning for matreshka-0.6.0_2
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to