You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     ash...@freebsd.org
Last committer: ash...@freebsd.org
Ident:          $FreeBSD: branches/2014Q2/lang/rubinius/Makefile 345758 
2014-02-23 19:21:43Z ashish $
Log URL:        
http://beefy1.isc.freebsd.org/bulk/10i386-quarterly/2014-05-07_06h02m16s/logs/rubinius-2.2.5.log
Build URL:      
http://beefy1.isc.freebsd.org/bulk/10i386-quarterly/2014-05-07_06h02m16s
Log:

====>> Building lang/rubinius
build started at Wed May  7 06:39:00 UTC 2014
port directory: /usr/ports/lang/rubinius
building for: FreeBSD 10i386-quarterly-job-10 10.0-RELEASE-p1 FreeBSD 
10.0-RELEASE-p1 i386
maintained by: ash...@freebsd.org
Makefile ident:      $FreeBSD: branches/2014Q2/lang/rubinius/Makefile 345758 
2014-02-23 19:21:43Z ashish $
Poudriere version: 3.1-pre
Host OSVERSION: 1100013
Jail OSVERSION: 1000510

---Begin Environment---
UNAME_m=i386
UNAME_p=i386
OSVERSION=1000510
UNAME_v=FreeBSD 10.0-RELEASE-p1
UNAME_r=10.0-RELEASE-p1
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
SAVED_TERM=
MASTERMNT=/usr/local/poudriere/data/build/10i386-quarterly/ref
PKG_EXT=txz
tpid=3829
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
POUDRIERE_BUILD_TYPE=bulk
PKGNG=1
PKGNAME=rubinius-2.2.5
PKG_DELETE=/usr/local/sbin/pkg-static delete -y -f
PKG_ADD=/usr/local/sbin/pkg-static add
OLDPWD=/usr/local/poudriere/data/build/10i386-quarterly/ref/poudriere/rdeps
PWD=/usr/local/poudriere/data/build/10i386-quarterly/ref/poudriere/pool
MASTERNAME=10i386-quarterly
USER=root
HOME=/root
POUDRIERE_VERSION=3.1-pre
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
PKG_VERSION=/poudriere/pkg-static version
PKG_BIN=/usr/local/sbin/pkg-static
---End Environment---

---Begin OPTIONS List---
---End OPTIONS List---

--CONFIGURE_ARGS--
-P "/usr/local"  -I "/usr/local/include/rubinius"  -L 
"/usr/local/lib/ruby/rubinius"  -G "/usr/local/lib/ruby/gems/rubinius"  -B 
"/usr/local/bin"  -M "/usr/local/man"  --cc cc  --cxx c++  --no-bin-links  
--llvm-config /usr/local/bin/llvm-config34  --sitedir 
"/usr/local/lib/ruby/site_ruby/rubinius"  --vendordir 
"/usr/local/lib/ruby/vendor_ruby/rubinius"  --stagingdir 
"/wrkdirs/usr/ports/lang/rubinius/work/stage/usr/local"
--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
TMPDIR="/tmp" ac_cv_path_PERL=/usr/local/bin/perl MAKE=gmake TMPDIR="/tmp" 
SHELL=/bin/sh CONFIG_SHELL=/bin/sh
--End CONFIGURE_ENV--

--MAKE_ENV--
HOME=/wrkdirs/usr/ports/lang/rubinius/work/rubinius-2.2.5 TMPDIR="/tmp" 
TMPDIR="/tmp" SHELL=/bin/sh NO_LINT=YES PREFIX=/usr/local  LOCALBASE=/usr/local 
 LIBDIR="/usr/lib"  CC="cc" CFLAGS="-O2 -pipe -fno-strict-aliasing"  CPP="cpp" 
CPPFLAGS=""  LDFLAGS=""  CXX="c++" CXXFLAGS="-O2 -pipe -fno-strict-aliasing"  
MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install  -s -o root -g wheel -m 
555"  BSD_INSTALL_LIB="install  -s -o root -g wheel -m 444"  
BSD_INSTALL_SCRIPT="install  -o root -g wheel -m 555"  
BSD_INSTALL_DATA="install  -o root -g wheel -m 444"  BSD_INSTALL_MAN="install  
-o root -g wheel -m 444"
--End MAKE_ENV--

--PLIST_SUB--
FREEBSD_DIR=x86-freebsd-10
RUBY_LIBDIR="lib/ruby/1.9"
RUBY_ARCHLIBDIR="lib/ruby/1.9/i386-freebsd10"
RUBY_SITELIBDIR="lib/ruby/site_ruby/1.9"
RUBY_SITEARCHLIBDIR="lib/ruby/site_ruby/1.9/i386-freebsd10"
RUBY_VENDORLIBDIR="lib/ruby/vendor_ruby/1.9"
RUBY_VENDORARCHLIBDIR="lib/ruby/vendor_ruby/1.9/i386-freebsd10"
RUBY_MODDOCDIR="share/doc/ruby19/rubinius"
RUBY_MODEXAMPLESDIR="share/examples/ruby19/rubinius"
RUBY_DOCDIR="share/doc/ruby19"
RUBY_EXAMPLESDIR="share/examples/ruby19"
RUBY_RIDIR="share/ri/1.9/system"
RUBY_SITERIDIR="share/ri/1.9/site"
RUBY_ELISPDIR="lib/ruby/elisp"
RUBY_VERSION="1.9.3.484"
RUBY_VER="1.9"
RUBY_SHLIBVER="19"
RUBY_ARCH="i386-freebsd10"
RUBY_SUFFIX="19"
RUBY_NAME="ruby19"
RUBY_DEFAULT_SUFFIX="19"
RUBY19=""
RUBY20="@comment
"
RUBY21="@comment
"
RUBY_RD_HTML_FILES="@comment
"
OSREL=10.0
PREFIX=%D
LOCALBASE=/usr/local
PORTDOCS=""
PORTEXAMPLES=""
PORTDATA=""
LIB32DIR=lib
PERL_VERSION=5.16.3
PERL_VER=5.16
PERL_ARCH=mach
PERL5_MAN3=lib/perl5/5.16/man/man3
SITE_PERL=lib/perl5/site_perl/5.16
DOCSDIR="share/doc/rubinius"
EXAMPLESDIR="share/examples/rubinius"
DATADIR="share/rubinius"
WWWDIR="www/rubinius"
ETCDIR="etc/rubinius"
--End PLIST_SUB--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/rubinius
DOCSDIR=/usr/local/share/doc/rubinius
EXAMPLESDIR=/usr/local/share/examples/rubinius
WWWDIR=/usr/local/www/rubinius
ETCDIR=/usr/local/etc/rubinius
--End SUB_LIST--

---Begin make.conf---
ARCH=i386
MACHINE=i386
MACHINE_ARCH=i386
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
WITH_PKGNG=yes
NO_RESTRICTED=yes
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
===>  Cleaning for rubinius-2.2.5
=======================<phase: check-sanity   >============================
===>  License BSD3CLAUSE accepted by the user
===========================================================================
=======================<phase: pkg-depends    >============================
===>   rubinius-2.2.5 depends on file: /usr/local/sbin/pkg - not found
===>    Verifying install for /usr/local/sbin/pkg in /usr/ports/ports-mgmt/pkg
===>   Installing existing package /packages/All/pkg-1.2.7.txz
Installing pkg-1.2.7... done
If you are upgrading from the old package format, first run:

  # pkg2ng
===>   Returning to build of rubinius-2.2.5
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===>  License BSD3CLAUSE accepted by the user
===> Fetching all distfiles required by rubinius-2.2.5 for building
===========================================================================
=======================<phase: checksum       >============================
===>  License BSD3CLAUSE accepted by the user
===> Fetching all distfiles required by rubinius-2.2.5 for building
=> SHA256 Checksum OK for rubinius-2.2.5.tar.bz2.
===========================================================================
=======================<phase: extract-depends>============================
===>   rubinius-2.2.5 depends on file: /usr/local/bin/ruby19 - not found
===>    Verifying install for /usr/local/bin/ruby19 in /usr/ports/lang/ruby19
===>   Installing existing package /packages/All/ruby-1.9.3.484_2,1.txz
Installing ruby-1.9.3.484_2,1...Installing libffi-3.0.13_1... done
Installing libyaml-0.1.4_3... done
 done
====
Some of the standard commands are provided as separate ports for ease
of upgrading:

        devel/ruby-gems:        gem - RubyGems package manager
        devel/rubygem-rake:     rake - Ruby Make

And some of the standard libraries are provided as separate ports
since they require extra dependencies:

        converters/ruby-iconv:  iconv module
        databases/ruby-gdbm:    GDBM module
        x11-toolkits/ruby-tk:   Tcl/Tk modules
        japanese/ruby-tk:       Tcl/Tk modules for Japanized Tcl/Tk

Install them as occasion demands.
====
===>   Returning to build of rubinius-2.2.5
===========================================================================
=======================<phase: extract        >============================
===>  License BSD3CLAUSE accepted by the user
===> Fetching all distfiles required by rubinius-2.2.5 for building
===>  Extracting for rubinius-2.2.5
=> SHA256 Checksum OK for rubinius-2.2.5.tar.bz2.
===========================================================================
=======================<phase: patch-depends  >============================
===>   rubinius-2.2.5 depends on file: /usr/local/bin/ruby19 - found
===========================================================================
=======================<phase: patch          >============================
===>  Patching for rubinius-2.2.5
===>  Applying FreeBSD patches for rubinius-2.2.5
===========================================================================
=======================<phase: build-depends  >============================
===>   rubinius-2.2.5 depends on file: /usr/local/bin/bundle - not found
===>    Verifying install for /usr/local/bin/bundle in 
/usr/ports/sysutils/rubygem-bundler
===>   Installing existing package /packages/All/rubygem-bundler-1.5.3.txz
Installing rubygem-bundler-1.5.3...Installing ruby19-gems-1.8.29... done
 done
===>   Returning to build of rubinius-2.2.5
===>   rubinius-2.2.5 depends on file: /usr/local/bin/llvm-config34 - not found
===>    Verifying install for /usr/local/bin/llvm-config34 in 
/usr/ports/devel/llvm34
===>   Installing existing package /packages/All/llvm34-3.4.txz
Installing llvm34-3.4...Installing perl5-5.16.3_9... done
Installing python27-2.7.6_4...Installing gettext-0.18.3.1... done
 done
 done
====
Note that some of the standard modules are provided as separate
ports since they require extra dependencies:

bsddb           databases/py-bsddb
gdbm            databases/py-gdbm
sqlite3         databases/py-sqlite3
tkinter         x11-toolkits/py-tkinter

Install them as needed.
====
===>   Returning to build of rubinius-2.2.5
===>   rubinius-2.2.5 depends on file: /usr/local/bin/bison - not found
===>    Verifying install for /usr/local/bin/bison in /usr/ports/devel/bison
===>   Installing existing package /packages/All/bison-2.7.1,1.txz
Installing bison-2.7.1,1...Installing m4-1.4.17_1,1... done
 done
===>   Returning to build of rubinius-2.2.5
===>   rubinius-2.2.5 depends on file: /usr/local/bin/ruby19 - found
===>   rubinius-2.2.5 depends on file: /usr/local/bin/rake - not found
===>    Verifying install for /usr/local/bin/rake in 
/usr/ports/devel/rubygem-rake
===>   Installing existing package /packages/All/rubygem-rake-10.2.2.txz
Installing rubygem-rake-10.2.2... done
===>   Returning to build of rubinius-2.2.5
===>   rubinius-2.2.5 depends on executable: gmake - not found
===>    Verifying install for gmake in /usr/ports/devel/gmake
===>   Installing existing package /packages/All/gmake-3.82_1.txz
Installing gmake-3.82_1... done
===>   Returning to build of rubinius-2.2.5
===>   rubinius-2.2.5 depends on file: /usr/local/bin/perl5.16.3 - found
===========================================================================
=======================<phase: lib-depends    >============================
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for rubinius-2.2.5
===>   FreeBSD 10 autotools fix applied to 
/wrkdirs/usr/ports/lang/rubinius/work/rubinius-2.2.5/vendor/zlib/configure
===>   FreeBSD 10 autotools fix applied to 
/wrkdirs/usr/ports/lang/rubinius/work/rubinius-2.2.5/vendor/udis86/aclocal.m4
===>   FreeBSD 10 autotools fix applied to 
/wrkdirs/usr/ports/lang/rubinius/work/rubinius-2.2.5/vendor/udis86/configure
===>   FreeBSD 10 autotools fix applied to 
/wrkdirs/usr/ports/lang/rubinius/work/rubinius-2.2.5/vendor/winpthreads/aclocal.m4
===>   FreeBSD 10 autotools fix applied to 
/wrkdirs/usr/ports/lang/rubinius/work/rubinius-2.2.5/vendor/winpthreads/configure
===>   FreeBSD 10 autotools fix applied to 
/wrkdirs/usr/ports/lang/rubinius/work/rubinius-2.2.5/vendor/libffi/acinclude.m4
===>   FreeBSD 10 autotools fix applied to 
/wrkdirs/usr/ports/lang/rubinius/work/rubinius-2.2.5/vendor/libffi/m4/libtool.m4
===>   FreeBSD 10 autotools fix applied to 
/wrkdirs/usr/ports/lang/rubinius/work/rubinius-2.2.5/vendor/libffi/aclocal.m4
===>   FreeBSD 10 autotools fix applied to 
/wrkdirs/usr/ports/lang/rubinius/work/rubinius-2.2.5/vendor/libffi/configure
===>   FreeBSD 10 autotools fix applied to 
/wrkdirs/usr/ports/lang/rubinius/work/rubinius-2.2.5/configure
cd /wrkdirs/usr/ports/lang/rubinius/work/rubinius-2.2.5 && /bin/mkdir -p gems 
&& /usr/local/bin/bundle install --local 
--path=/wrkdirs/usr/ports/lang/rubinius/work/rubinius-2.2.5/gems
Resolving dependencies...
Installing rake (10.1.1)
Installing daedalus-core (0.0.3)
Installing gems (0.8.3)
Installing redcard (1.1.0)
Installing rubinius-ast (2.0.11)
Installing rubinius-bridge (1.0.3)
Installing rubinius-compiler (2.0.4)
Installing rubinius-toolset (0.1.1)
Installing rubinius-melbourne (2.0.1.0)
Installing rubinius-processor (2.0.1)
Using bundler (1.5.3)
Updating files in vendor/cache
Your bundle is complete!
It was installed into ./gems
------------------------- WARNING -----------------------
The specified prefix '/usr/local' already exists.
Installing Rubinius into an existing directory may
overwrite existing unrelated files or cause conflicts
between different versions of Rubinius files.
---------------------------------------------------------
Checking cc: found
Checking c++: found
Checking bison: found

Detected old configuration settings, forcing a clean build
The directory /usr/local already exists, installing to /usr/local/rubinius/2.2
Configuring LLVM...
  Checking for existing LLVM library tree: skipping due to explicit LLVM 
options.
  Checking for 'llvm-config': found! (version 3.4 - api: 304)

Checking sizeof(short): 2 bytes
Checking sizeof(int): 4 bytes
Checking sizeof(void*): 4 bytes
Checking sizeof(size_t): 4 bytes
Checking sizeof(long): 4 bytes
Checking sizeof(long long): 8 bytes
Checking sizeof(float): 4 bytes
Checking sizeof(double): 8 bytes
Checking sizeof(off_t): 8 bytes
Checking sizeof(time_t): 4 bytes
Checking for libc version: libc.so.7 found!
Checking platform endianness: little endian
Checking for tr1: not found
Checking for tr1/hash definition: not found
Checking for x86_32: yes
Checking for function 'clock_gettime': found!
Checking for function 'nl_langinfo': found!
Checking for function 'setproctitle': found!
Checking for function 'posix_fadvise': found!
Checking for function 'strnlen': found!
Checking for function 'lchmod': found!
Checking for function 'lchown': found!
Checking for struct tm has member tm_gmtoff: found!
Checking for struct tm has member tm_zone: found!
Checking for global 'timezone': found!
Checking for global 'tzname': found!
Checking for global 'daylight': not found
Checking for header 'zlib.h': found!
Checking for header 'openssl/ssl.h': found!
Checking for header 'alloca.h': not found
Checking for header 'string.h': found!
Checking for header 'sys/time.h': found!
Checking for header 'sys/times.h': found!
Checking for header 'sys/types.h': found!
Checking for header 'unistd.h': found!
Checking for header 'stdarg.h': found!
Checking for header 'sys/pstat.h': not found
Checking for header 'valgrind/valgrind.h': not found
Checking curses library: curses
Checking if function 'strerror_r' returns char*: no

Verifying gems...

Setting up bootstrap gems...
Unpacked gem: 
'/wrkdirs/usr/ports/lang/rubinius/work/stage/usr/local/rubinius/2.2/runtime/gems/rubinius-ast-2.0.11'
Unpacked gem: 
'/wrkdirs/usr/ports/lang/rubinius/work/stage/usr/local/rubinius/2.2/runtime/gems/rubinius-compiler-2.0.4'
Unpacked gem: 
'/wrkdirs/usr/ports/lang/rubinius/work/stage/usr/local/rubinius/2.2/runtime/gems/rubinius-melbourne-2.0.1.0'
Unpacked gem: 
'/wrkdirs/usr/ports/lang/rubinius/work/stage/usr/local/rubinius/2.2/runtime/gems/rubinius-processor-2.0.1'
Unpacked gem: 
'/wrkdirs/usr/ports/lang/rubinius/work/stage/usr/local/rubinius/2.2/runtime/gems/rubinius-toolset-0.1.1'
Unpacked gem: 
'/wrkdirs/usr/ports/lang/rubinius/work/rubinius-2.2.5/bootstrap/gems/ffi2-generators-0.1.1'
Unpacked gem: 
'/wrkdirs/usr/ports/lang/rubinius/work/rubinius-2.2.5/bootstrap/gems/rubysl-etc-2.0.3'
Unpacked gem: 
'/wrkdirs/usr/ports/lang/rubinius/work/rubinius-2.2.5/bootstrap/gems/rubysl-fileutils-2.0.3'
Unpacked gem: 
'/wrkdirs/usr/ports/lang/rubinius/work/rubinius-2.2.5/bootstrap/gems/rubysl-mkmf-2.0.1'
Unpacked gem: 
'/wrkdirs/usr/ports/lang/rubinius/work/rubinius-2.2.5/bootstrap/gems/rubysl-shellwords-2.0.0'
Unpacked gem: 
'/wrkdirs/usr/ports/lang/rubinius/work/rubinius-2.2.5/bootstrap/gems/rubysl-date-2.0.6'
Unpacked gem: 
'/wrkdirs/usr/ports/lang/rubinius/work/rubinius-2.2.5/bootstrap/gems/rubysl-delegate-2.0.1'
Unpacked gem: 
'/wrkdirs/usr/ports/lang/rubinius/work/rubinius-2.2.5/bootstrap/gems/rubysl-digest-2.0.3'
Unpacked gem: 
'/wrkdirs/usr/ports/lang/rubinius/work/rubinius-2.2.5/bootstrap/gems/rubysl-fcntl-2.0.4'
Unpacked gem: 
'/wrkdirs/usr/ports/lang/rubinius/work/rubinius-2.2.5/bootstrap/gems/rubysl-monitor-2.0.0'
Unpacked gem: 
'/wrkdirs/usr/ports/lang/rubinius/work/rubinius-2.2.5/bootstrap/gems/rubysl-openssl-2.1.0'
Unpacked gem: 
'/wrkdirs/usr/ports/lang/rubinius/work/rubinius-2.2.5/bootstrap/gems/rubysl-optparse-2.0.1'
Unpacked gem: 
'/wrkdirs/usr/ports/lang/rubinius/work/rubinius-2.2.5/bootstrap/gems/rubysl-stringio-2.0.0'
Unpacked gem: 
'/wrkdirs/usr/ports/lang/rubinius/work/rubinius-2.2.5/bootstrap/gems/rubysl-strscan-2.0.0'
Unpacked gem: 
'/wrkdirs/usr/ports/lang/rubinius/work/rubinius-2.2.5/bootstrap/gems/rubysl-tempfile-2.0.1'
Unpacked gem: 
'/wrkdirs/usr/ports/lang/rubinius/work/rubinius-2.2.5/bootstrap/gems/rubysl-thread-2.0.2'
Unpacked gem: 
'/wrkdirs/usr/ports/lang/rubinius/work/rubinius-2.2.5/bootstrap/gems/rubysl-tmpdir-2.0.0'
Unpacked gem: 
'/wrkdirs/usr/ports/lang/rubinius/work/rubinius-2.2.5/bootstrap/gems/rubysl-uri-2.0.0'
Unpacked gem: 
'/wrkdirs/usr/ports/lang/rubinius/work/rubinius-2.2.5/bootstrap/gems/rubysl-yaml-2.0.4'
Unpacked gem: 
'/wrkdirs/usr/ports/lang/rubinius/work/rubinius-2.2.5/bootstrap/gems/rubysl-zlib-2.0.1'

Writing configuration files...
------------------------------------------------------------------

Rubinius has been configured for the following paths:

prefix:  /usr/local
bin:     /usr/local/bin
lib:     /usr/local/lib/ruby/rubinius
runtime: /usr/local/rubinius/2.2/runtime
kernel:  /usr/local/rubinius/2.2/kernel
site:    /usr/local/lib/ruby/site_ruby/rubinius
vendor:  /usr/local/lib/ruby/vendor_ruby/rubinius
man:     /usr/local/man
gems:    /usr/local/lib/ruby/gems/rubinius
include: /usr/local/include/rubinius

Run 'rake' to build, test and install Rubinius.

After building, you may add

'/usr/local/bin'

to your PATH or run commands directly from that directory.

Available commands are:

  ruby, rake, gem, irb, rdoc, ri, erb, rbx

------------------------------------------------------------------
===========================================================================
=======================<phase: build          >============================
===>  Building for rubinius-2.2.5
rake aborted!
Gem::LoadError: You have already activated rake 10.2.2, but your Gemfile 
requires rake 10.1.1. Prepending `bundle exec` to your command may solve this.
/wrkdirs/usr/ports/lang/rubinius/work/rubinius-2.2.5/Rakefile:1:in `<top 
(required)>'
(See full trace by running task with --trace)
*** Error code 1

Stop.
make: stopped in /usr/ports/lang/rubinius
===>  Cleaning for rubinius-2.2.5
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to