You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     rodr...@freebsd.org
Last committer: zeis...@freebsd.org
Ident:          $FreeBSD: head/games/adonthell/Makefile 351411 2014-04-16 
18:28:47Z zeising $
Log URL:        
http://beefy2.isc.freebsd.org/bulk/10amd64-default/2014-05-08_03h52m07s/logs/adonthell-0.3.5_10.log
Build URL:      
http://beefy2.isc.freebsd.org/bulk/10amd64-default/2014-05-08_03h52m07s
Log:

====>> Building games/adonthell
build started at Thu May  8 10:19:46 UTC 2014
port directory: /usr/ports/games/adonthell
building for: FreeBSD 10amd64-default-job-09 10.0-RELEASE-p1 FreeBSD 
10.0-RELEASE-p1 amd64
maintained by: rodr...@freebsd.org
Makefile ident:      $FreeBSD: head/games/adonthell/Makefile 351411 2014-04-16 
18:28:47Z zeising $
Poudriere version: 3.1-pre
Host OSVERSION: 1100013
Jail OSVERSION: 1000510

---Begin Environment---
OSVERSION=1000510
UNAME_v=FreeBSD 10.0-RELEASE-p1
UNAME_r=10.0-RELEASE-p1
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
SAVED_TERM=
MASTERMNT=/usr/local/poudriere/data/build/10amd64-default/ref
PKG_EXT=txz
tpid=53581
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
POUDRIERE_BUILD_TYPE=bulk
PKGNG=1
PKGNAME=adonthell-0.3.5_10
PKG_DELETE=/usr/local/sbin/pkg-static delete -y -f
PKG_ADD=/usr/local/sbin/pkg-static add
OLDPWD=/usr/local/poudriere/data/build/10amd64-default/ref/poudriere/rdeps
PWD=/usr/local/poudriere/data/build/10amd64-default/ref/poudriere/pool
MASTERNAME=10amd64-default
USER=root
HOME=/root
POUDRIERE_VERSION=3.1-pre
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
PKG_VERSION=/poudriere/pkg-static version
PKG_BIN=/usr/local/sbin/pkg-static
---End Environment---

---Begin OPTIONS List---
---End OPTIONS List---

--CONFIGURE_ARGS--
--disable-py-debug --prefix=/usr/local ${_LATE_CONFIGURE_ARGS}
--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
PYPACKAGE="/usr/local/bin/python2.7" ac_cv_path_P_SWIG=no TMPDIR="/tmp" 
PYTHON="/usr/local/bin/python2.7" MAKE=gmake TMPDIR="/tmp" SHELL=/bin/sh 
CONFIG_SHELL=/bin/sh SDL_CONFIG=/usr/local/bin/sdl-config 
CONFIG_SITE=/usr/ports/Templates/config.site lt_cv_sys_max_cmd_len=262144
--End CONFIGURE_ENV--

--MAKE_ENV--
TMPDIR="/tmp" TMPDIR="/tmp" SHELL=/bin/sh NO_LINT=YES 
SDL_CONFIG=/usr/local/bin/sdl-config PREFIX=/usr/local  LOCALBASE=/usr/local  
LIBDIR="/usr/lib"  CC="cc" CFLAGS="-O2 -pipe -fno-strict-aliasing"  CPP="cpp" 
CPPFLAGS="-I/usr/local/include "  LDFLAGS=" -L/usr/local/lib -pthread"  
CXX="c++" CXXFLAGS="-O2 -pipe -fno-strict-aliasing"  MANPREFIX="/usr/local" 
BSD_INSTALL_PROGRAM="install  -s -o root -g wheel -m 555"  
BSD_INSTALL_LIB="install  -s -o root -g wheel -m 444"  
BSD_INSTALL_SCRIPT="install  -o root -g wheel -m 555"  
BSD_INSTALL_DATA="install  -o root -g wheel -m 444"  BSD_INSTALL_MAN="install  
-o root -g wheel -m 444"
--End MAKE_ENV--

--PLIST_SUB--
VERSION="0.3"
PYTHON_INCLUDEDIR=include/python2.7
PYTHON_LIBDIR=lib/python2.7
PYTHON_PLATFORM=freebsd10
PYTHON_SITELIBDIR=lib/python2.7/site-packages
PYTHON_VERSION=python2.7
OSREL=10.0
PREFIX=%D
LOCALBASE=/usr/local
PORTDOCS=""
PORTEXAMPLES=""
PORTDATA=""
LIB32DIR=lib
DOCSDIR="share/doc/adonthell"
EXAMPLESDIR="share/examples/adonthell"
DATADIR="share/adonthell"
WWWDIR="www/adonthell"
ETCDIR="etc/adonthell"
--End PLIST_SUB--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/adonthell
DOCSDIR=/usr/local/share/doc/adonthell
EXAMPLESDIR=/usr/local/share/examples/adonthell
WWWDIR=/usr/local/www/adonthell
ETCDIR=/usr/local/etc/adonthell
--End SUB_LIST--

---Begin make.conf---
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
WITH_PKGNG=yes
NO_RESTRICTED=yes
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
===>  Cleaning for adonthell-0.3.5_10
=======================<phase: check-sanity   >============================
===>  License GPLv2 accepted by the user
===========================================================================
=======================<phase: pkg-depends    >============================
===>   adonthell-0.3.5_10 depends on file: /usr/local/sbin/pkg - not found
===>    Verifying install for /usr/local/sbin/pkg in /usr/ports/ports-mgmt/pkg
===>   Installing existing package /packages/All/pkg-1.2.7_2.txz
Installing pkg-1.2.7_2... done
If you are upgrading from the old package format, first run:

  # pkg2ng
===>   Returning to build of adonthell-0.3.5_10
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===>  License GPLv2 accepted by the user
===> Fetching all distfiles required by adonthell-0.3.5_10 for building
===========================================================================
=======================<phase: checksum       >============================
===>  License GPLv2 accepted by the user
===> Fetching all distfiles required by adonthell-0.3.5_10 for building
=> SHA256 Checksum OK for adonthell-src-0.3.5.tar.gz.
=> SHA256 Checksum OK for wastesedge-src-0.3.5.tar.gz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===>  License GPLv2 accepted by the user
===> Fetching all distfiles required by adonthell-0.3.5_10 for building
===>  Extracting for adonthell-0.3.5_10
=> SHA256 Checksum OK for adonthell-src-0.3.5.tar.gz.
=> SHA256 Checksum OK for wastesedge-src-0.3.5.tar.gz.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for adonthell-0.3.5_10
===>  Applying FreeBSD patches for adonthell-0.3.5_10
===========================================================================
=======================<phase: build-depends  >============================
===>   adonthell-0.3.5_10 depends on file: /usr/local/bin/python2.7 - not found
===>    Verifying install for /usr/local/bin/python2.7 in 
/usr/ports/lang/python27
===>   Installing existing package /packages/All/python27-2.7.6_4.txz
Installing python27-2.7.6_4...Installing gettext-0.18.3.1... done
 done
====
Note that some of the standard modules are provided as separate
ports since they require extra dependencies:

bsddb           databases/py-bsddb
gdbm            databases/py-gdbm
sqlite3         databases/py-sqlite3
tkinter         x11-toolkits/py-tkinter

Install them as needed.
====
===>   Returning to build of adonthell-0.3.5_10
===>   adonthell-0.3.5_10 depends on executable: gmake - not found
===>    Verifying install for gmake in /usr/ports/devel/gmake
===>   Installing existing package /packages/All/gmake-3.82_1.txz
Installing gmake-3.82_1... done
===>   Returning to build of adonthell-0.3.5_10
===>   adonthell-0.3.5_10 depends on file: /usr/local/bin/sdl-config - not found
===>    Verifying install for /usr/local/bin/sdl-config in 
/usr/ports/devel/sdl12
===>   Installing existing package /packages/All/sdl-1.2.15_4,2.txz
Installing sdl-1.2.15_4,2...Installing aalib-1.4.r5_10... done
Installing libGLU-9.0.0...Installing libGL-7.6.1_4...Installing 
dri2proto-2.8... done
Installing expat-2.1.0... done
Installing libX11-1.6.2_2,1...Installing kbproto-1.0.6... done
Installing libXau-1.0.8_2...Installing xproto-7.0.25... done
 done
Installing libXdmcp-1.1.1_2... done
Installing libxcb-1.10_2...Installing libpthread-stubs-0.3_4... done
Installing libxml2-2.8.0_5... done
 done
 done
Installing libXdamage-1.1.4_2...Installing damageproto-1.2.1... done
Installing libXfixes-5.0.1_2...Installing fixesproto-5.0... done
 done
 done
Installing libXext-1.3.2_2,1...Installing xextproto-7.3.0... done
 done
Installing libXxf86vm-1.1.3_2...Installing xf86vidmodeproto-2.3.1... done
 done
Installing libdrm-2.4.17_1...Installing libpciaccess-0.13.2_2...Installing 
pciids-20140502... done
 done
 done
 done
 done
Installing libXrandr-1.4.2_2...Installing libXrender-0.9.8_2...Installing 
renderproto-0.11.1... done
 done
Installing randrproto-1.4.0... done
 done
 done
------------------------------------------------------------------------------
 Your SDL library has been built with libvgl support, which means that you
 can run almost any SDL application straight on your console (VESA 2.0
 compatible videocard is required).

 To do this you have to load the vesa kernel module or enable it in your
<snip>
gmake[3]: Entering directory 
`/wrkdirs/usr/ports/games/adonthell/work/adonthell-0.3.5/m4'
gmake[3]: Nothing to be done for `all'.
gmake[3]: Leaving directory 
`/wrkdirs/usr/ports/games/adonthell/work/adonthell-0.3.5/m4'
Making all in po
gmake[3]: Entering directory 
`/wrkdirs/usr/ports/games/adonthell/work/adonthell-0.3.5/po'
gmake adonthell.pot-update
gmake[4]: Entering directory 
`/wrkdirs/usr/ports/games/adonthell/work/adonthell-0.3.5/po'
sed -e '/^#/d' remove-potcdate.sin > t-remove-potcdate.sed
mv t-remove-potcdate.sed remove-potcdate.sed
if test -n 'adonthell-proj...@linuxgames.com' || test 
'adonthell-de...@nongnu.org' = '@'PACKAGE_BUGREPORT'@'; then \
  msgid_bugs_address='adonthell-proj...@linuxgames.com'; \
else \
  msgid_bugs_address='adonthell-de...@nongnu.org'; \
fi; \
/usr/local/bin/xgettext --default-domain=adonthell --directory=.. \
  --add-comments=TRANSLATORS: --keyword=_ --keyword=N_ \
  --files-from=./POTFILES.in \
  --copyright-holder='Kai Sterker' \
  --msgid-bugs-address="$msgid_bugs_address"
test ! -f adonthell.po || { \
  if test -f ./adonthell.pot; then \
    sed -f remove-potcdate.sed < ./adonthell.pot > adonthell.1po && \
    sed -f remove-potcdate.sed < adonthell.po > adonthell.2po && \
    if cmp adonthell.1po adonthell.2po >/dev/null 2>&1; then \
      rm -f adonthell.1po adonthell.2po adonthell.po; \
    else \
      rm -f adonthell.1po adonthell.2po ./adonthell.pot && \
      mv adonthell.po ./adonthell.pot; \
    fi; \
  else \
    mv adonthell.po ./adonthell.pot; \
  fi; \
}
gmake[4]: Leaving directory 
`/wrkdirs/usr/ports/games/adonthell/work/adonthell-0.3.5/po'
test ! -f ./adonthell.pot || \
  test -z "" || gmake 
gmake[3]: Leaving directory 
`/wrkdirs/usr/ports/games/adonthell/work/adonthell-0.3.5/po'
Making all in src
gmake[3]: Entering directory 
`/wrkdirs/usr/ports/games/adonthell/work/adonthell-0.3.5/src'
Making all in .
gmake[4]: Entering directory 
`/wrkdirs/usr/ports/games/adonthell/work/adonthell-0.3.5/src'
c++ -DHAVE_CONFIG_H -I. -I..   -DOGG_MUSIC -I/usr/local/include/SDL 
-I/usr/local/include -D_GNU_SOURCE=1 -D_REENTRANT -D_THREAD_SAFE 
-I/usr/local/include -I/usr/local/include/python2.7 
-I/usr/local/include/freetype2 -I/usr/local/include  -O2 -pipe 
-fno-strict-aliasing -Wall -fno-exceptions  
-DDATA_DIR="\"/usr/local/share/adonthell\""  -MT adonthell.o -MD -MP -MF 
.deps/adonthell.Tpo -c -o adonthell.o adonthell.cc
In file included from adonthell.cc:24:
In file included from ./win_manager.h:25:
In file included from ./str_hash.h:27:
/usr/include/c++/v1/ext/hash_map:209:2: warning: Use of the header 
<ext/hash_map> is deprecated.  Migrate to <unordered_map> [-W#warnings]
#warning Use of the header <ext/hash_map> is deprecated.  Migrate to 
<unordered_map>
 ^
In file included from adonthell.cc:24:
In file included from ./win_manager.h:25:
./str_hash.h:41:67: error: use of undeclared identifier '__stl_hash_string'
        size_t operator()(const std::string & __s) const { return 
__stl_hash_string(__s.c_str()); }
                                                                  ^
In file included from adonthell.cc:24:
In file included from ./win_manager.h:27:
In file included from ./win_ttf.h:19:
In file included from ./win_font.h:16:
In file included from /usr/include/c++/v1/iostream:38:
In file included from /usr/include/c++/v1/ios:216:
/usr/include/c++/v1/__locale:434:15: error: C++ requires a type specifier for 
all declarations
    char_type toupper(char_type __c) const
              ^~~~~~~~~~~~~~~~~~~~~~
/usr/local/include/python2.7/pyport.h:731:29: note: expanded from macro 
'toupper'
#define toupper(c) towupper(btowc(c))
                            ^~~~~
In file included from adonthell.cc:24:
In file included from ./win_manager.h:27:
In file included from ./win_ttf.h:19:
In file included from ./win_font.h:16:
In file included from /usr/include/c++/v1/iostream:38:
In file included from /usr/include/c++/v1/ios:216:
/usr/include/c++/v1/__locale:440:48: error: too many arguments provided to 
function-like macro invocation
    const char_type* toupper(char_type* __low, const char_type* __high) const
                                               ^
/usr/local/include/python2.7/pyport.h:731:9: note: macro 'toupper' defined here
#define toupper(c) towupper(btowc(c))
        ^
In file included from adonthell.cc:24:
In file included from ./win_manager.h:27:
In file included from ./win_ttf.h:19:
In file included from ./win_font.h:16:
In file included from /usr/include/c++/v1/iostream:38:
In file included from /usr/include/c++/v1/ios:216:
/usr/include/c++/v1/__locale:440:29: error: expected ';' at end of declaration 
list
    const char_type* toupper(char_type* __low, const char_type* __high) const
                            ^
/usr/include/c++/v1/__locale:452:48: error: too many arguments provided to 
function-like macro invocation
    const char_type* tolower(char_type* __low, const char_type* __high) const
                                               ^
/usr/local/include/python2.7/pyport.h:729:9: note: macro 'tolower' defined here
#define tolower(c) towlower(btowc(c))
        ^
In file included from adonthell.cc:24:
In file included from ./win_manager.h:27:
In file included from ./win_ttf.h:19:
In file included from ./win_font.h:16:
In file included from /usr/include/c++/v1/iostream:38:
In file included from /usr/include/c++/v1/ios:216:
/usr/include/c++/v1/__locale:436:27: error: use of undeclared identifier '__c'
        return do_toupper(__c);
                          ^
/usr/include/c++/v1/__locale:543:15: error: C++ requires a type specifier for 
all declarations
    char_type toupper(char_type __c) const
              ^~~~~~~~~~~~~~~~~~~~~~
/usr/local/include/python2.7/pyport.h:731:29: note: expanded from macro 
'toupper'
#define toupper(c) towupper(btowc(c))
                            ^~~~~
In file included from adonthell.cc:24:
In file included from ./win_manager.h:27:
In file included from ./win_ttf.h:19:
In file included from ./win_font.h:16:
In file included from /usr/include/c++/v1/iostream:38:
In file included from /usr/include/c++/v1/ios:216:
/usr/include/c++/v1/__locale:549:48: error: too many arguments provided to 
function-like macro invocation
    const char_type* toupper(char_type* __low, const char_type* __high) const
                                               ^
/usr/local/include/python2.7/pyport.h:731:9: note: macro 'toupper' defined here
#define toupper(c) towupper(btowc(c))
        ^
In file included from adonthell.cc:24:
In file included from ./win_manager.h:27:
In file included from ./win_ttf.h:19:
In file included from ./win_font.h:16:
In file included from /usr/include/c++/v1/iostream:38:
In file included from /usr/include/c++/v1/ios:216:
/usr/include/c++/v1/__locale:549:29: error: expected ';' at end of declaration 
list
    const char_type* toupper(char_type* __low, const char_type* __high) const
                            ^
/usr/include/c++/v1/__locale:561:48: error: too many arguments provided to 
function-like macro invocation
    const char_type* tolower(char_type* __low, const char_type* __high) const
                                               ^
/usr/local/include/python2.7/pyport.h:729:9: note: macro 'tolower' defined here
#define tolower(c) towlower(btowc(c))
        ^
In file included from adonthell.cc:24:
In file included from ./win_manager.h:27:
In file included from ./win_ttf.h:19:
In file included from ./win_font.h:16:
In file included from /usr/include/c++/v1/iostream:38:
In file included from /usr/include/c++/v1/ios:216:
/usr/include/c++/v1/__locale:545:27: error: use of undeclared identifier '__c'
        return do_toupper(__c);
                          ^
/usr/include/c++/v1/__locale:671:21: error: too many arguments provided to 
function-like macro invocation
isspace(_CharT __c, const locale& __loc)
                    ^
/usr/local/include/python2.7/pyport.h:725:9: note: macro 'isspace' defined here
#define isspace(c) iswspace(btowc(c))
        ^
In file included from adonthell.cc:24:
In file included from ./win_manager.h:27:
In file included from ./win_ttf.h:19:
In file included from ./win_font.h:16:
In file included from /usr/include/c++/v1/iostream:38:
In file included from /usr/include/c++/v1/ios:216:
/usr/include/c++/v1/__locale:669:1: error: 'inline' can only appear on functions
inline _LIBCPP_INLINE_VISIBILITY
^
/usr/include/c++/v1/__locale:671:1: error: variable 'isspace' declared as a 
template
isspace(_CharT __c, const locale& __loc)
^
/usr/include/c++/v1/__locale:671:8: error: expected ';' at end of declaration
isspace(_CharT __c, const locale& __loc)
       ^
/usr/include/c++/v1/__locale:672:1: error: expected unqualified-id
{
^
/usr/include/c++/v1/__locale:695:21: error: too many arguments provided to 
function-like macro invocation
isupper(_CharT __c, const locale& __loc)
                    ^
/usr/local/include/python2.7/pyport.h:727:9: note: macro 'isupper' defined here
#define isupper(c) iswupper(btowc(c))
        ^
In file included from adonthell.cc:24:
In file included from ./win_manager.h:27:
In file included from ./win_ttf.h:19:
In file included from ./win_font.h:16:
In file included from /usr/include/c++/v1/iostream:38:
In file included from /usr/include/c++/v1/ios:216:
/usr/include/c++/v1/__locale:693:1: error: 'inline' can only appear on functions
inline _LIBCPP_INLINE_VISIBILITY
^
/usr/include/c++/v1/__locale:695:1: error: variable 'isupper' declared as a 
template
isupper(_CharT __c, const locale& __loc)
^
fatal error: too many errors emitted, stopping now [-ferror-limit=]
1 warning and 20 errors generated.
gmake[4]: *** [adonthell.o] Error 1
gmake[4]: Leaving directory 
`/wrkdirs/usr/ports/games/adonthell/work/adonthell-0.3.5/src'
gmake[3]: *** [all-recursive] Error 1
gmake[3]: Leaving directory 
`/wrkdirs/usr/ports/games/adonthell/work/adonthell-0.3.5/src'
gmake[2]: *** [all-recursive] Error 1
gmake[2]: Leaving directory 
`/wrkdirs/usr/ports/games/adonthell/work/adonthell-0.3.5'
gmake[1]: *** [all] Error 2
gmake[1]: Leaving directory 
`/wrkdirs/usr/ports/games/adonthell/work/adonthell-0.3.5'
*** Error code 1

Stop.
make: stopped in /usr/ports/games/adonthell
===>  Cleaning for adonthell-0.3.5_10
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to