You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     kbowl...@freebsd.org
Last committer: kev...@freebsd.org
Ident:          $FreeBSD: head/emulators/qemu-powernv/Makefile 518850 
2019-12-02 14:51:09Z kevans $
Log URL:        
http://beefy8.nyi.freebsd.org/data/head-armv6-default/p529018_s359264/logs/qemu-powernv-3.0.50_2.log
Build URL:      
http://beefy8.nyi.freebsd.org/build.html?mastername=head-armv6-default&build=p529018_s359264
Log:

=>> Building emulators/qemu-powernv
build started at Wed Mar 25 12:55:41 UTC 2020
port directory: /usr/ports/emulators/qemu-powernv
package name: qemu-powernv-3.0.50_2
building for: FreeBSD head-armv6-default-job-17 13.0-CURRENT FreeBSD 
13.0-CURRENT 1300085 arm
maintained by: kbowl...@freebsd.org
Makefile ident:      $FreeBSD: head/emulators/qemu-powernv/Makefile 518850 
2019-12-02 14:51:09Z kevans $
Poudriere version: 3.2.8-5-gc81843e5
Host OSVERSION: 1300076
Jail OSVERSION: 1300085
Job Id: 17




!!! Jail is newer than host. (Jail: 1300085, Host: 1300076) !!!
!!! This is not supported. !!!
!!! Host kernel must be same or newer than jail. !!!
!!! Expect build failures. !!!



---Begin Environment---
SHELL=/bin/csh
UNAME_p=armv6
UNAME_m=arm
ABI_FILE=/usr/lib/crt1.o
OSVERSION=1300085
UNAME_v=FreeBSD 13.0-CURRENT 1300085
UNAME_r=13.0-CURRENT
BLOCKSIZE=K
STATUS=1
HOME=/root
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
LOCALBASE=/usr/local
QEMU_EMULATING=1
USER=root
LIBEXECPREFIX=/usr/local/libexec/poudriere
POUDRIERE_VERSION=3.2.8-5-gc81843e5
MASTERMNT=/usr/local/poudriere/data/.m/head-armv6-default/ref
POUDRIERE_BUILD_TYPE=bulk
PACKAGE_BUILDING=yes
SAVED_TERM=
PWD=/usr/local/poudriere/data/.m/head-armv6-default/ref/.p/pool
P_PORTS_FEATURES=FLAVORS SELECTED_OPTIONS
MASTERNAME=head-armv6-default
SCRIPTPREFIX=/usr/local/share/poudriere
OLDPWD=/usr/local/poudriere/data/.m/head-armv6-default/ref/.p
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
POUDRIEREPATH=/usr/local/bin/poudriere
---End Environment---

---Begin Poudriere Port Flags/Env---
PORT_FLAGS=
PKGENV=
FLAVOR=
DEPENDS_ARGS=
MAKE_ARGS=
---End Poudriere Port Flags/Env---

---Begin OPTIONS List---
---End OPTIONS List---

--MAINTAINER--
kbowl...@freebsd.org
--End MAINTAINER--

--CONFIGURE_ARGS--
--target-list=ppc64-softmmu  --cc=/nxb-bin/usr/bin/cc  --disable-curl  
--disable-docs  --disable-gtk  --disable-gcrypt  --disable-kvm  
--disable-libssh2  --disable-linux-aio  --disable-linux-user  --disable-vnc  
--disable-sdl  --disable-nettle  --disable-gnutls  --disable-vte  --disable-xen 
 
--extra-cflags=-I/wrkdirs/usr/ports/emulators/qemu-powernv/work/qemu-powernv-3.0.50\
 -I/usr/local/include\ -DPREFIX=\\\"\"/usr/local\\\"\"  
--extra-ldflags=-L\"/usr/local/lib\"  --localstatedir=/var  
--datadir=/usr/local/share/qemu-powernv  --python=/usr/local/bin/python3.7
--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
MAKE=gmake PKG_CONFIG=pkgconf PYTHON="/usr/local/bin/python3.7" 
XDG_DATA_HOME=/wrkdirs/usr/ports/emulators/qemu-powernv/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/emulators/qemu-powernv/work  
HOME=/wrkdirs/usr/ports/emulators/qemu-powernv/work TMPDIR="/tmp" 
PATH=/wrkdirs/usr/ports/emulators/qemu-powernv/work/.bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
 SHELL=/bin/sh CONFIG_SHELL=/bin/sh LANG=en_US.UTF-8 LC_ALL=en_US.UTF-8
--End CONFIGURE_ENV--

--MAKE_ENV--
XDG_DATA_HOME=/wrkdirs/usr/ports/emulators/qemu-powernv/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/emulators/qemu-powernv/work  
HOME=/wrkdirs/usr/ports/emulators/qemu-powernv/work TMPDIR="/tmp" 
PATH=/wrkdirs/usr/ports/emulators/qemu-powernv/work/.bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
 NO_PIE=yes MK_DEBUG_FILES=no MK_KERNEL_SYMBOLS=no SHELL=/bin/sh NO_LINT=YES 
LANG=en_US.UTF-8 LC_ALL=en_US.UTF-8 PREFIX=/usr/local  LOCALBASE=/usr/local  
CC="/nxb-bin/usr/bin/cc" CFLAGS="-O2 -pipe  -fstack-protector-strong 
-fno-strict-aliasing "  CPP="/nxb-bin/usr/bin/cpp" CPPFLAGS=""  LDFLAGS=" 
-fstack-protector-strong " LIBS=""  CXX="/nxb-bin/usr/bin/c++" CXXFLAGS="-O2 
-pipe -fstack-protector-strong -fno-strict-aliasing  "  MANPREFIX="/usr/local" 
BSD_INSTALL_PROGRAM="install  -s -m 555"  BSD_INSTALL_LIB="install  -s -m 0644" 
 BSD_INSTALL_SCRIPT="install  -m 555"  BSD_INSTALL_DATA="install  -m 0644"  
BSD_INSTALL_MAN="install  -m 444"
--End MAKE_ENV--

--PLIST_SUB--
GTK2_VERSION="2.10.0"  GTK3_VERSION="3.0.0" 
PYTHON_INCLUDEDIR=include/python3.7m  PYTHON_LIBDIR=lib/python3.7  
PYTHON_PLATFORM=freebsd13  PYTHON_SITELIBDIR=lib/python3.7/site-packages  
PYTHON_SUFFIX=37  PYTHON_VER=3.7  PYTHON_VERSION=python3.7 PYTHON2="@comment " 
PYTHON3="" OSREL=13.0 PREFIX=%D LOCALBASE=/usr/local  RESETPREFIX=/usr/local 
LIB32DIR=lib DOCSDIR="share/doc/qemu-powernv"  
EXAMPLESDIR="share/examples/qemu-powernv"  DATADIR="share/qemu-powernv"  
WWWDIR="www/qemu-powernv"  ETCDIR="etc/qemu-powernv"
--End PLIST_SUB--

--SUB_LIST--
PREFIX=/usr/local LOCALBASE=/usr/local  DATADIR=/usr/local/share/qemu-powernv 
DOCSDIR=/usr/local/share/doc/qemu-powernv 
EXAMPLESDIR=/usr/local/share/examples/qemu-powernv  
WWWDIR=/usr/local/www/qemu-powernv ETCDIR=/usr/local/etc/qemu-powernv
--End SUB_LIST--

---Begin make.conf---
.sinclude "/etc/make.nxb.conf"
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
PACKAGE_BUILDING=yes
PACKAGE_BUILDING_FLAVORS=yes
MACHINE=arm
MACHINE_ARCH=armv6
ARCH=${MACHINE_ARCH}
#### /usr/local/etc/poudriere.d/make.conf ####
# XXX: We really need this but cannot use it while 'make checksum' does not
# try the next mirror on checksum failure.  It currently retries the same
# failed mirror and then fails rather then trying another.  It *does*
# try the next if the size is mismatched though.
#MASTER_SITE_FREEBSD=yes
# Build ALLOW_MAKE_JOBS_PACKAGES with 2 jobs
MAKE_JOBS_NUMBER=2
#### /usr/ports/Mk/Scripts/ports_env.sh ####
_CCVERSION_9d218390=FreeBSD clang version 10.0.0 
(g...@github.com:llvm/llvm-project.git llvmorg-10.0.0-rc4-5-g52c365aa9ca) 
Target: armv6-unknown-freebsd13.0-gnueabihf Thread model: posix InstalledDir: 
/nxb-bin/usr/bin
_ALTCCVERSION_9d218390=none
_CXXINTERNAL_9c45a5b1=FreeBSD clang version 10.0.0 
(g...@github.com:llvm/llvm-project.git llvmorg-10.0.0-rc4-5-g52c365aa9ca) 
Target: armv6-unknown-freebsd13.0-gnueabihf Thread model: posix InstalledDir: 
/nxb-bin/usr/bin "/nxb-bin/usr/bin/ld" "--eh-frame-hdr" "-dynamic-linker" 
"/libexec/ld-elf.so.1" "--hash-style=both" "--enable-new-dtags" "-o" "a.out" 
"/usr/lib/crt1.o" "/usr/lib/crti.o" "/usr/lib/crtbegin.o" "-L/usr/lib" 
"/dev/null" "-lc++" "-lm" "-lgcc" "--as-needed" "-lgcc_s" "--no-as-needed" 
"-lc" "-lgcc" "--as-needed" "-lgcc_s" "--no-as-needed" "/usr/lib/crtend.o" 
"/usr/lib/crtn.o"
CC_OUTPUT_9d218390_58173849=yes
CC_OUTPUT_9d218390_9bdba57c=yes
CC_OUTPUT_9d218390_6a4fe7f5=yes
CC_OUTPUT_9d218390_6bcac02b=yes
CC_OUTPUT_9d218390_67d20829=yes
CC_OUTPUT_9d218390_bfa62e83=yes
CC_OUTPUT_9d218390_f0b4d593=yes
CC_OUTPUT_9d218390_308abb44=yes
CC_OUTPUT_9d218390_f00456e5=yes
CC_OUTPUT_9d218390_65ad290d=yes
CC_OUTPUT_9d218390_f2776b26=yes
CC_OUTPUT_9d218390_b2657cc3=yes
CC_OUTPUT_9d218390_380987f7=yes
CC_OUTPUT_9d218390_160933ec=yes
CC_OUTPUT_9d218390_fb62803b=yes
_OBJC_CCVERSION_9d218390=FreeBSD clang version 10.0.0 
(g...@github.com:llvm/llvm-project.git llvmorg-10.0.0-rc4-5-g52c365aa9ca) 
Target: armv6-unknown-freebsd13.0-gnueabihf Thread model: posix InstalledDir: 
/nxb-bin/usr/bin
_OBJC_ALTCCVERSION_9d218390=none
ARCH=armv6
OPSYS=FreeBSD
_OSRELEASE=13.0-CURRENT
OSREL=13.0
OSVERSION=1300085
PYTHONBASE=/usr/local
CONFIGURE_MAX_CMD_LEN=524288
HAVE_PORTS_ENV=1
#### Misc Poudriere ####
GID=0
UID=0
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
---Begin make.nxb.conf---
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
AS=/nxb-bin/usr/bin/as
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
RANLIB=/nxb-bin/usr/bin/ranlib
YACC=/nxb-bin/usr/bin/yacc
MAKE=/nxb-bin/usr/bin/make
STRINGS=/nxb-bin/usr/bin/strings
AWK=/nxb-bin/usr/bin/awk
FLEX=/nxb-bin/usr/bin/flex
---End make.nxb.conf---
--Resource limits--
cpu time               (seconds, -t)  unlimited
file size           (512-blocks, -f)  unlimited
data seg size           (kbytes, -d)  33554432
stack size              (kbytes, -s)  524288
core file size      (512-blocks, -c)  unlimited
max memory size         (kbytes, -m)  unlimited
locked memory           (kbytes, -l)  unlimited
max user processes              (-u)  89999
open files                      (-n)  1024
virtual mem size        (kbytes, -v)  unlimited
swap limit              (kbytes, -w)  unlimited
socket buffer size       (bytes, -b)  unlimited
pseudo-terminals                (-p)  unlimited
kqueues                         (-k)  unlimited
umtx shared locks               (-o)  unlimited
--End resource limits--
=======================<phase: check-sanity   >============================
===>  License GPLv2 accepted by the user
===========================================================================
=======================<phase: pkg-depends    >============================
===>   qemu-powernv-3.0.50_2 depends on file: /usr/local/sbin/pkg - not found
===>   Installing existing package /packages/All/pkg-1.13.2.txz
[head-armv6-default-job-17] Installing pkg-1.13.2...
[head-armv6-default-job-17] Extracting pkg-1.13.2: .......... done
===>   qemu-powernv-3.0.50_2 depends on file: /usr/local/sbin/pkg - found
===>   Returning to build of qemu-powernv-3.0.50_2
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===>  License GPLv2 accepted by the user
===> Fetching all distfiles required by qemu-powernv-3.0.50_2 for building
===========================================================================
=======================<phase: checksum       >============================
===>  License GPLv2 accepted by the user
===> Fetching all distfiles required by qemu-powernv-3.0.50_2 for building
=> SHA256 Checksum OK for qemu-powernv-3.0.50.tar.bz2.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===>  License GPLv2 accepted by the user
===> Fetching all distfiles required by qemu-powernv-3.0.50_2 for building
===>  Extracting for qemu-powernv-3.0.50_2
=> SHA256 Checksum OK for qemu-powernv-3.0.50.tar.bz2.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for qemu-powernv-3.0.50_2
===========================================================================
=======================<phase: build-depends  >============================
===>   qemu-powernv-3.0.50_2 depends on file: /usr/local/lib/libfdt.so - not 
found
===>   Installing existing package /packages/All/dtc-1.4.7.txz
[head-armv6-default-job-17] Installing dtc-1.4.7...
[head-armv6-default-job-17] Extracting dtc-1.4.7: .......... done
===>   qemu-powernv-3.0.50_2 depends on file: /usr/local/lib/libfdt.so - found
===>   Returning to build of qemu-powernv-3.0.50_2
===>   qemu-powernv-3.0.50_2 depends on executable: bison - not found
===>   Installing existing package /packages/All/bison-3.5.2,1.txz
[head-armv6-default-job-17] Installing bison-3.5.2,1...
[head-armv6-default-job-17] `-- Installing gettext-runtime-0.20.1...
[head-armv6-default-job-17] |   `-- Installing indexinfo-0.3.1...
[head-armv6-default-job-17] |   `-- Extracting indexinfo-0.3.1: .... done
[head-armv6-default-job-17] `-- Extracting gettext-runtime-0.20.1: .......... 
done
[head-armv6-default-job-17] `-- Installing libtextstyle-0.20.1...
[head-armv6-default-job-17] `-- Extracting libtextstyle-0.20.1: .......... done
[head-armv6-default-job-17] `-- Installing m4-1.4.18_1,1...
[head-armv6-default-job-17] `-- Extracting m4-1.4.18_1,1: .......... done
[head-armv6-default-job-17] Extracting bison-3.5.2,1: .......... done
===>   qemu-powernv-3.0.50_2 depends on executable: bison - found
===>   Returning to build of qemu-powernv-3.0.50_2
===>   qemu-powernv-3.0.50_2 depends on executable: gmake - not found
===>   Installing existing package /packages/All/gmake-4.2.1_3.txz
[head-armv6-default-job-17] Installing gmake-4.2.1_3...
[head-armv6-default-job-17] Extracting gmake-4.2.1_3: .......... done
===>   qemu-powernv-3.0.50_2 depends on executable: gmake - found
===>   Returning to build of qemu-powernv-3.0.50_2
===>   qemu-powernv-3.0.50_2 depends on file: /usr/local/bin/makeinfo - not 
found
===>   Installing existing package /packages/All/texinfo-6.7_1,1.txz
[head-armv6-default-job-17] Installing texinfo-6.7_1,1...
[head-armv6-default-job-17] `-- Installing p5-Locale-libintl-1.31...
[head-armv6-default-job-17] |   `-- Installing libiconv-1.14_11...
[head-armv6-default-job-17] |   `-- Extracting libiconv-1.14_11: .......... done
[head-armv6-default-job-17] |   `-- Installing perl5-5.30.2...
[head-armv6-default-job-17] |   `-- Extracting perl5-5.30.2: .......... done
[head-armv6-default-job-17] `-- Extracting p5-Locale-libintl-1.31: .......... 
done
[head-armv6-default-job-17] `-- Installing p5-Text-Unidecode-1.30...
[head-armv6-default-job-17] `-- Extracting p5-Text-Unidecode-1.30: .......... 
done
[head-armv6-default-job-17] `-- Installing p5-Unicode-EastAsianWidth-12.0...
[head-armv6-default-job-17] `-- Extracting p5-Unicode-EastAsianWidth-12.0: 
...... done
[head-armv6-default-job-17] Extracting texinfo-6.7_1,1: .......... done
=====
Message from perl5-5.30.2:

--
The /usr/bin/perl symlink has been removed starting with Perl 5.20.
For shebangs, you should either use:

#!/usr/local/bin/perl

or

#!/usr/bin/env perl

The first one will only work if you have a /usr/local/bin/perl,
the second will work as long as perl is in PATH.
===>   qemu-powernv-3.0.50_2 depends on file: /usr/local/bin/makeinfo - found
===>   Returning to build of qemu-powernv-3.0.50_2
===>   qemu-powernv-3.0.50_2 depends on package: pkgconf>=1.3.0_1 - not found
===>   Installing existing package /packages/All/pkgconf-1.6.3,1.txz
[head-armv6-default-job-17] Installing pkgconf-1.6.3,1...
[head-armv6-default-job-17] Extracting pkgconf-1.6.3,1: .......... done
===>   qemu-powernv-3.0.50_2 depends on package: pkgconf>=1.3.0_1 - found
===>   Returning to build of qemu-powernv-3.0.50_2
===>   qemu-powernv-3.0.50_2 depends on file: /usr/local/bin/python3.7 - not 
found
===>   Installing existing package /packages/All/python37-3.7.7.txz
[head-armv6-default-job-17] Installing python37-3.7.7...
[head-armv6-default-job-17] `-- Installing libffi-3.2.1_3...
[head-armv6-default-job-17] `-- Extracting libffi-3.2.1_3: .......... done
[head-armv6-default-job-17] `-- Installing readline-8.0.4...
[head-armv6-default-job-17] `-- Extracting readline-8.0.4: .......... done
[head-armv6-default-job-17] Extracting python37-3.7.7: .......... done
=====
Message from python37-3.7.7:

--
Note that some standard Python modules are provided as separate ports
as they require additional dependencies. They are available as:

py37-gdbm       databases/py-gdbm@py37
py37-sqlite3    databases/py-sqlite3@py37
py37-tkinter    x11-toolkits/py-tkinter@py37
===>   qemu-powernv-3.0.50_2 depends on file: /usr/local/bin/python3.7 - found
===>   Returning to build of qemu-powernv-3.0.50_2
===>   qemu-powernv-3.0.50_2 depends on file: 
/usr/local/libdata/pkgconfig/pixman-1.pc - not found
===>   Installing existing package /packages/All/pixman-0.38.4.txz
[head-armv6-default-job-17] Installing pixman-0.38.4...
[head-armv6-default-job-17] Extracting pixman-0.38.4: .......... done
===>   qemu-powernv-3.0.50_2 depends on file: 
/usr/local/libdata/pkgconfig/pixman-1.pc - found
===>   Returning to build of qemu-powernv-3.0.50_2
===========================================================================
=======================<phase: lib-depends    >============================
===>   qemu-powernv-3.0.50_2 depends on shared library: libglib-2.0.so - not 
found
===>   Installing existing package /packages/All/glib-2.56.3_7,1.txz
[head-armv6-default-job-17] Installing glib-2.56.3_7,1...
[head-armv6-default-job-17] `-- Installing libxml2-2.9.10...
[head-armv6-default-job-17] `-- Extracting libxml2-2.9.10: .......... done
[head-armv6-default-job-17] `-- Installing pcre-8.43_2...
[head-armv6-default-job-17] `-- Extracting pcre-8.43_2: .......... done
[head-armv6-default-job-17] Extracting glib-2.56.3_7,1: .......... done
No schema files found: doing nothing.
===>   qemu-powernv-3.0.50_2 depends on shared library: libglib-2.0.so - found 
(/usr/local/lib/libglib-2.0.so)
===>   Returning to build of qemu-powernv-3.0.50_2
===>   qemu-powernv-3.0.50_2 depends on shared library: libintl.so - found 
(/usr/local/lib/libintl.so)
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for qemu-powernv-3.0.50_2

ERROR: We need to link the QEMU user mode binaries at a
       specific text address. Unfortunately your linker
       doesn't support either the -Ttext-segment option or
       printing the default linker script with --verbose.
       If you don't want the user mode binaries, pass the
       --disable-user option to configure.

===>  Script "configure" failed unexpectedly.
Please report the problem to kbowl...@freebsd.org [maintainer] and attach the
"/wrkdirs/usr/ports/emulators/qemu-powernv/work/qemu-powernv-3.0.50/config.log"
including the output of the failure of your make command. Also, it might be
a good idea to provide an overview of all packages installed on your system
(e.g. a /usr/local/sbin/pkg-static info -g -Ea).
*** Error code 1

Stop.
make: stopped in /usr/ports/emulators/qemu-powernv
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to