You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     rodr...@freebsd.org
Last committer: da...@freebsd.org
Ident:          $FreeBSD: head/graphics/ufraw/Makefile 524151 2020-01-26 
04:57:44Z danfe $
Log URL:        
http://beefy17.nyi.freebsd.org/data/head-i386-default/p529018_s359264/logs/ufraw-0.22_15.log
Build URL:      
http://beefy17.nyi.freebsd.org/build.html?mastername=head-i386-default&build=p529018_s359264
Log:

=>> Building graphics/ufraw
build started at Wed Mar 25 18:42:56 UTC 2020
port directory: /usr/ports/graphics/ufraw
package name: ufraw-0.22_15
building for: FreeBSD head-i386-default-job-07 13.0-CURRENT FreeBSD 
13.0-CURRENT 1300085 i386
maintained by: rodr...@freebsd.org
Makefile ident:      $FreeBSD: head/graphics/ufraw/Makefile 524151 2020-01-26 
04:57:44Z danfe $
Poudriere version: 3.2.8-5-gc81843e5
Host OSVERSION: 1300076
Jail OSVERSION: 1300085
Job Id: 07




!!! Jail is newer than host. (Jail: 1300085, Host: 1300076) !!!
!!! This is not supported. !!!
!!! Host kernel must be same or newer than jail. !!!
!!! Expect build failures. !!!



---Begin Environment---
SHELL=/bin/csh
UNAME_p=i386
UNAME_m=i386
OSVERSION=1300085
UNAME_v=FreeBSD 13.0-CURRENT 1300085
UNAME_r=13.0-CURRENT
BLOCKSIZE=K
STATUS=1
HOME=/root
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
LOCALBASE=/usr/local
USER=root
LIBEXECPREFIX=/usr/local/libexec/poudriere
POUDRIERE_VERSION=3.2.8-5-gc81843e5
MASTERMNT=/usr/local/poudriere/data/.m/head-i386-default/ref
POUDRIERE_BUILD_TYPE=bulk
PACKAGE_BUILDING=yes
SAVED_TERM=
PWD=/usr/local/poudriere/data/.m/head-i386-default/ref/.p/pool
P_PORTS_FEATURES=FLAVORS SELECTED_OPTIONS
MASTERNAME=head-i386-default
SCRIPTPREFIX=/usr/local/share/poudriere
OLDPWD=/usr/local/poudriere/data/.m/head-i386-default/ref/.p
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
POUDRIEREPATH=/usr/local/bin/poudriere
---End Environment---

---Begin Poudriere Port Flags/Env---
PORT_FLAGS=
PKGENV=
FLAVOR=
DEPENDS_ARGS=
MAKE_ARGS=
---End Poudriere Port Flags/Env---

---Begin OPTIONS List---
===> The following configuration options are available for ufraw-0.22_15:
     CONTRAST=on: Enable contrast setting option
     DST=off: Use local time for timestamps
     EXIV2=on: EXIF and IPTC metadata support via exiv2
     FITS=off: FITS output support
     GIMP=off: Install GIMP plugin
     GNOME=off: GNOME desktop environment support
     GTK2=on: GTK+ 2 GUI toolkit support
     LENSFUN=on: Camera lens database support via LensFun
===> Use 'make config' to modify these settings
---End OPTIONS List---

--MAINTAINER--
rodr...@freebsd.org
--End MAINTAINER--

--CONFIGURE_ARGS--
--enable-extras --enable-contrast --disable-dst-correction --without-gimp 
--disable-mime --with-gtk --prefix=/usr/local ${_LATE_CONFIGURE_ARGS}
--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
MAKE=gmake PKG_CONFIG=pkgconf 
XDG_DATA_HOME=/wrkdirs/usr/ports/graphics/ufraw/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/graphics/ufraw/work  
HOME=/wrkdirs/usr/ports/graphics/ufraw/work TMPDIR="/tmp" 
PATH=/wrkdirs/usr/ports/graphics/ufraw/work/.bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
 SHELL=/bin/sh CONFIG_SHELL=/bin/sh LANG=en_US.UTF-8 LC_ALL=en_US.UTF-8 
CONFIG_SITE=/usr/ports/Templates/config.site lt_cv_sys_max_cmd_len=524288
--End CONFIGURE_ENV--

--MAKE_ENV--
XDG_DATA_HOME=/wrkdirs/usr/ports/graphics/ufraw/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/graphics/ufraw/work  
HOME=/wrkdirs/usr/ports/graphics/ufraw/work TMPDIR="/tmp" 
PATH=/wrkdirs/usr/ports/graphics/ufraw/work/.bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
 NO_PIE=yes MK_DEBUG_FILES=no MK_KERNEL_SYMBOLS=no SHELL=/bin/sh NO_LINT=YES 
LANG=en_US.UTF-8 LC_ALL=en_US.UTF-8 PREFIX=/usr/local  LOCALBASE=/usr/local  
CC="cc" CFLAGS="-O2 -pipe  -fstack-protector-strong -fno-strict-aliasing "  
CPP="cpp" CPPFLAGS="-I/usr/local/include"  LDFLAGS=" -lpthread -L/usr/local/lib 
-fstack-protector-strong " LIBS=""  CXX="c++" CXXFLAGS="-O2 -pipe 
-fstack-protector-strong -fno-strict-aliasing  "  MANPREFIX="/usr/local" 
BSD_INSTALL_PROGRAM="install  -s -m 555"  BSD_INSTALL_LIB="install  -s -m 0644" 
 BSD_INSTALL_SCRIPT="install  -m 555"  BSD_INSTALL_DATA="install  -m 0644"  
BSD_INSTALL_MAN="install  -m 444"
--End MAKE_ENV--

--PLIST_SUB--
CONTRAST="" NO_CONTRAST="@comment " DST="@comment " NO_DST="" EXIV2="" 
NO_EXIV2="@comment " FITS="@comment " NO_FITS="" GIMP="@comment " NO_GIMP="" 
GNOME="@comment " NO_GNOME="" GTK2="" NO_GTK2="@comment " LENSFUN="" 
NO_LENSFUN="@comment " GTK2_VERSION="2.10.0"  GTK3_VERSION="3.0.0" OSREL=13.0 
PREFIX=%D LOCALBASE=/usr/local  RESETPREFIX=/usr/local LIB32DIR=lib 
DOCSDIR="share/doc/ufraw"  EXAMPLESDIR="share/examples/ufraw"  
DATADIR="share/ufraw"  WWWDIR="www/ufraw"  ETCDIR="etc/ufraw"
--End PLIST_SUB--

--SUB_LIST--
CONTRAST="" NO_CONTRAST="@comment " DST="@comment " NO_DST="" EXIV2="" 
NO_EXIV2="@comment " FITS="@comment " NO_FITS="" GIMP="@comment " NO_GIMP="" 
GNOME="@comment " NO_GNOME="" GTK2="" NO_GTK2="@comment " LENSFUN="" 
NO_LENSFUN="@comment " PREFIX=/usr/local LOCALBASE=/usr/local  
DATADIR=/usr/local/share/ufraw DOCSDIR=/usr/local/share/doc/ufraw 
EXAMPLESDIR=/usr/local/share/examples/ufraw  WWWDIR=/usr/local/www/ufraw 
ETCDIR=/usr/local/etc/ufraw
--End SUB_LIST--

---Begin make.conf---
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
PACKAGE_BUILDING=yes
PACKAGE_BUILDING_FLAVORS=yes
MACHINE=i386
MACHINE_ARCH=i386
ARCH=${MACHINE_ARCH}
#### /usr/local/etc/poudriere.d/make.conf ####
# XXX: We really need this but cannot use it while 'make checksum' does not
# try the next mirror on checksum failure.  It currently retries the same
# failed mirror and then fails rather then trying another.  It *does*
# try the next if the size is mismatched though.
#MASTER_SITE_FREEBSD=yes
# Build ALLOW_MAKE_JOBS_PACKAGES with 2 jobs
MAKE_JOBS_NUMBER=2
#### /usr/ports/Mk/Scripts/ports_env.sh ####
_CCVERSION_921dbbb2=FreeBSD clang version 10.0.0 
(g...@github.com:llvm/llvm-project.git llvmorg-10.0.0-rc4-5-g52c365aa9ca) 
Target: i386-unknown-freebsd13.0 Thread model: posix InstalledDir: /usr/bin
_ALTCCVERSION_921dbbb2=none
_CXXINTERNAL_acaad9ca=FreeBSD clang version 10.0.0 
(g...@github.com:llvm/llvm-project.git llvmorg-10.0.0-rc4-5-g52c365aa9ca) 
Target: i386-unknown-freebsd13.0 Thread model: posix InstalledDir: /usr/bin 
"/usr/bin/ld" "--eh-frame-hdr" "-dynamic-linker" "/libexec/ld-elf.so.1" 
"--hash-style=both" "--enable-new-dtags" "-m" "elf_i386_fbsd" "-o" "a.out" 
"/usr/lib/crt1.o" "/usr/lib/crti.o" "/usr/lib/crtbegin.o" "-L/usr/lib" 
"/dev/null" "-lc++" "-lm" "-lgcc" "--as-needed" "-lgcc_s" "--no-as-needed" 
"-lc" "-lgcc" "--as-needed" "-lgcc_s" "--no-as-needed" "/usr/lib/crtend.o" 
"/usr/lib/crtn.o"
CC_OUTPUT_921dbbb2_58173849=yes
CC_OUTPUT_921dbbb2_9bdba57c=yes
CC_OUTPUT_921dbbb2_6a4fe7f5=yes
CC_OUTPUT_921dbbb2_6bcac02b=yes
CC_OUTPUT_921dbbb2_67d20829=yes
CC_OUTPUT_921dbbb2_bfa62e83=yes
CC_OUTPUT_921dbbb2_f0b4d593=yes
CC_OUTPUT_921dbbb2_308abb44=yes
CC_OUTPUT_921dbbb2_f00456e5=yes
CC_OUTPUT_921dbbb2_65ad290d=yes
CC_OUTPUT_921dbbb2_f2776b26=yes
CC_OUTPUT_921dbbb2_b2657cc3=yes
CC_OUTPUT_921dbbb2_380987f7=yes
CC_OUTPUT_921dbbb2_160933ec=yes
CC_OUTPUT_921dbbb2_fb62803b=yes
_OBJC_CCVERSION_921dbbb2=FreeBSD clang version 10.0.0 
(g...@github.com:llvm/llvm-project.git llvmorg-10.0.0-rc4-5-g52c365aa9ca) 
Target: i386-unknown-freebsd13.0 Thread model: posix InstalledDir: /usr/bin
_OBJC_ALTCCVERSION_921dbbb2=none
ARCH=i386
OPSYS=FreeBSD
_OSRELEASE=13.0-CURRENT
OSREL=13.0
OSVERSION=1300085
PYTHONBASE=/usr/local
CONFIGURE_MAX_CMD_LEN=524288
HAVE_PORTS_ENV=1
#### Misc Poudriere ####
GID=0
UID=0
---End make.conf---
--Resource limits--
cpu time               (seconds, -t)  unlimited
file size           (512-blocks, -f)  unlimited
data seg size           (kbytes, -d)  524288
stack size              (kbytes, -s)  65536
core file size      (512-blocks, -c)  unlimited
max memory size         (kbytes, -m)  unlimited
locked memory           (kbytes, -l)  unlimited
max user processes              (-u)  89999
open files                      (-n)  1024
virtual mem size        (kbytes, -v)  unlimited
swap limit              (kbytes, -w)  unlimited
socket buffer size       (bytes, -b)  unlimited
pseudo-terminals                (-p)  unlimited
kqueues                         (-k)  unlimited
umtx shared locks               (-o)  unlimited
--End resource limits--
=======================<phase: check-sanity   >============================
===>  License GPLv2 accepted by the user
===========================================================================
=======================<phase: pkg-depends    >============================
===>   ufraw-0.22_15 depends on file: /usr/local/sbin/pkg - not found
===>   Installing existing package /packages/All/pkg-1.13.2.txz
[head-i386-default-job-07] Installing pkg-1.13.2...
[head-i386-default-job-07] Extracting pkg-1.13.2: .......... done
ldconfig: aout support is deprecated
===>   ufraw-0.22_15 depends on file: /usr/local/sbin/pkg - found
===>   Returning to build of ufraw-0.22_15
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===>  License GPLv2 accepted by the user
===> Fetching all distfiles required by ufraw-0.22_15 for building
===========================================================================
=======================<phase: checksum       >============================
===>  License GPLv2 accepted by the user
===> Fetching all distfiles required by ufraw-0.22_15 for building
=> SHA256 Checksum OK for sergiomb2-ufraw-0.22-6d3259a_GH0.tar.gz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===>  License GPLv2 accepted by the user
===> Fetching all distfiles required by ufraw-0.22_15 for building
===>  Extracting for ufraw-0.22_15
=> SHA256 Checksum OK for sergiomb2-ufraw-0.22-6d3259a_GH0.tar.gz.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
<snip>
    ^
/usr/local/include/lensfun/lensfun.h:103:43: note: expanded from macro 
'DEPRECATED'
#        define DEPRECATED __attribute__((deprecated))
                                          ^
ufraw_lensfun.cc:487:36: warning: 'InterpolateVignetting' is deprecated 
[-Wdeprecated-declarations]
        if (!Lensfun.Interpolation.InterpolateVignetting(
                                   ^
/usr/local/include/lensfun/lensfun.h:1427:5: note: 'InterpolateVignetting' has 
been explicitly marked deprecated here
    DEPRECATED bool InterpolateVignetting (
    ^
/usr/local/include/lensfun/lensfun.h:103:43: note: expanded from macro 
'DEPRECATED'
#        define DEPRECATED __attribute__((deprecated))
                                          ^
ufraw_lensfun.cc:550:18: warning: 'CalibDistortion' is deprecated 
[-Wdeprecated-declarations]
        if (lens.CalibDistortion != NULL)
                 ^
/usr/local/include/lensfun/lensfun.h:1081:5: note: 'CalibDistortion' has been 
explicitly marked deprecated here
    DEPRECATED lfLensCalibDistortion **CalibDistortion;
    ^
/usr/local/include/lensfun/lensfun.h:103:43: note: expanded from macro 
'DEPRECATED'
#        define DEPRECATED __attribute__((deprecated))
                                          ^
ufraw_lensfun.cc:551:25: warning: 'CalibDistortion' is deprecated 
[-Wdeprecated-declarations]
            while (lens.CalibDistortion[0] != NULL)
                        ^
/usr/local/include/lensfun/lensfun.h:1081:5: note: 'CalibDistortion' has been 
explicitly marked deprecated here
    DEPRECATED lfLensCalibDistortion **CalibDistortion;
    ^
/usr/local/include/lensfun/lensfun.h:103:43: note: expanded from macro 
'DEPRECATED'
#        define DEPRECATED __attribute__((deprecated))
                                          ^
ufraw_lensfun.cc:552:22: warning: 'RemoveCalibDistortion' is deprecated 
[-Wdeprecated-declarations]
                lens.RemoveCalibDistortion(0);
                     ^
/usr/local/include/lensfun/lensfun.h:1165:5: note: 'RemoveCalibDistortion' has 
been explicitly marked deprecated here
    DEPRECATED bool RemoveCalibDistortion (int idx);
    ^
/usr/local/include/lensfun/lensfun.h:103:43: note: expanded from macro 
'DEPRECATED'
#        define DEPRECATED __attribute__((deprecated))
                                          ^
ufraw_lensfun.cc:574:36: warning: 'InterpolateDistortion' is deprecated 
[-Wdeprecated-declarations]
        if (!Lensfun.Interpolation.InterpolateDistortion(
                                   ^
/usr/local/include/lensfun/lensfun.h:1368:5: note: 'InterpolateDistortion' has 
been explicitly marked deprecated here
    DEPRECATED bool InterpolateDistortion (float focal, lfLensCalibDistortion 
&res) const;
    ^
/usr/local/include/lensfun/lensfun.h:103:43: note: expanded from macro 
'DEPRECATED'
#        define DEPRECATED __attribute__((deprecated))
                                          ^
ufraw_lensfun.cc:682:18: warning: 'CropFactor' is deprecated 
[-Wdeprecated-declarations]
        cropLens.CropFactor = crop_factor;
                 ^
/usr/local/include/lensfun/lensfun.h:1077:5: note: 'CropFactor' has been 
explicitly marked deprecated here
    DEPRECATED float CropFactor;
    ^
/usr/local/include/lensfun/lensfun.h:103:43: note: expanded from macro 
'DEPRECATED'
#        define DEPRECATED __attribute__((deprecated))
                                          ^
ufraw_lensfun.cc:700:20: warning: 'CropFactor' is deprecated 
[-Wdeprecated-declarations]
    Transformation.CropFactor = Interpolation.CropFactor;
                   ^
/usr/local/include/lensfun/lensfun.h:1077:5: note: 'CropFactor' has been 
explicitly marked deprecated here
    DEPRECATED float CropFactor;
    ^
/usr/local/include/lensfun/lensfun.h:103:43: note: expanded from macro 
'DEPRECATED'
#        define DEPRECATED __attribute__((deprecated))
                                          ^
ufraw_lensfun.cc:700:47: warning: 'CropFactor' is deprecated 
[-Wdeprecated-declarations]
    Transformation.CropFactor = Interpolation.CropFactor;
                                              ^
/usr/local/include/lensfun/lensfun.h:1077:5: note: 'CropFactor' has been 
explicitly marked deprecated here
    DEPRECATED float CropFactor;
    ^
/usr/local/include/lensfun/lensfun.h:103:43: note: expanded from macro 
'DEPRECATED'
#        define DEPRECATED __attribute__((deprecated))
                                          ^
ufraw_lensfun.cc:828:27: warning: 'Destroy' is deprecated 
[-Wdeprecated-declarations]
            uf->modifier->Destroy();
                          ^
/usr/local/include/lensfun/lensfun.h:2459:5: note: 'Destroy' has been 
explicitly marked deprecated here
    DEPRECATED void Destroy ();
    ^
/usr/local/include/lensfun/lensfun.h:103:43: note: expanded from macro 
'DEPRECATED'
#        define DEPRECATED __attribute__((deprecated))
                                          ^
ufraw_lensfun.cc:829:36: warning: 'Create' is deprecated 
[-Wdeprecated-declarations]
        uf->modifier = lfModifier::Create(&Lensfun.Transformation,
                                   ^
/usr/local/include/lensfun/lensfun.h:2402:5: note: 'Create' has been explicitly 
marked deprecated here
    DEPRECATED static lfModifier *Create (const lfLens *lens, float crop, int 
width, int height);
    ^
/usr/local/include/lensfun/lensfun.h:103:43: note: expanded from macro 
'DEPRECATED'
#        define DEPRECATED __attribute__((deprecated))
                                          ^
ufraw_lensfun.cc:835:38: warning: 'Initialize' is deprecated 
[-Wdeprecated-declarations]
        uf->modFlags = uf->modifier->Initialize(&Lensfun.Transformation,
                                     ^
/usr/local/include/lensfun/lensfun.h:2449:5: note: 'Initialize' has been 
explicitly marked deprecated here
    DEPRECATED int Initialize (
    ^
/usr/local/include/lensfun/lensfun.h:103:43: note: expanded from macro 
'DEPRECATED'
#        define DEPRECATED __attribute__((deprecated))
                                          ^
ufraw_lensfun.cc:841:27: warning: 'Destroy' is deprecated 
[-Wdeprecated-declarations]
            uf->modifier->Destroy();
                          ^
/usr/local/include/lensfun/lensfun.h:2459:5: note: 'Destroy' has been 
explicitly marked deprecated here
    DEPRECATED void Destroy ();
    ^
/usr/local/include/lensfun/lensfun.h:103:43: note: expanded from macro 
'DEPRECATED'
#        define DEPRECATED __attribute__((deprecated))
                                          ^
ufraw_lensfun.cc:853:30: warning: 'Destroy' is deprecated 
[-Wdeprecated-declarations]
            uf->TCAmodifier->Destroy();
                             ^
/usr/local/include/lensfun/lensfun.h:2459:5: note: 'Destroy' has been 
explicitly marked deprecated here
    DEPRECATED void Destroy ();
    ^
/usr/local/include/lensfun/lensfun.h:103:43: note: expanded from macro 
'DEPRECATED'
#        define DEPRECATED __attribute__((deprecated))
                                          ^
ufraw_lensfun.cc:854:39: warning: 'Create' is deprecated 
[-Wdeprecated-declarations]
        uf->TCAmodifier = lfModifier::Create(&Lensfun.Transformation,
                                      ^
/usr/local/include/lensfun/lensfun.h:2402:5: note: 'Create' has been explicitly 
marked deprecated here
    DEPRECATED static lfModifier *Create (const lfLens *lens, float crop, int 
width, int height);
    ^
/usr/local/include/lensfun/lensfun.h:103:43: note: expanded from macro 
'DEPRECATED'
#        define DEPRECATED __attribute__((deprecated))
                                          ^
ufraw_lensfun.cc:860:41: warning: 'Initialize' is deprecated 
[-Wdeprecated-declarations]
        int modFlags = uf->TCAmodifier->Initialize(&Lensfun.Transformation,
                                        ^
/usr/local/include/lensfun/lensfun.h:2449:5: note: 'Initialize' has been 
explicitly marked deprecated here
    DEPRECATED int Initialize (
    ^
/usr/local/include/lensfun/lensfun.h:103:43: note: expanded from macro 
'DEPRECATED'
#        define DEPRECATED __attribute__((deprecated))
                                          ^
ufraw_lensfun.cc:866:30: warning: 'Destroy' is deprecated 
[-Wdeprecated-declarations]
            uf->TCAmodifier->Destroy();
                             ^
/usr/local/include/lensfun/lensfun.h:2459:5: note: 'Destroy' has been 
explicitly marked deprecated here
    DEPRECATED void Destroy ();
    ^
/usr/local/include/lensfun/lensfun.h:103:43: note: expanded from macro 
'DEPRECATED'
#        define DEPRECATED __attribute__((deprecated))
                                          ^
25 warnings generated.
mv -f .deps/ufraw_lensfun.Tpo .deps/ufraw_lensfun.Po
cc -DHAVE_CONFIG_H -I.  -I/usr/local/include  -I/usr/local/include 
-I/usr/local/include/gtk-2.0 -I/usr/local/include/pango-1.0 
-I/usr/local/include/glib-2.0 -I/usr/local/lib/glib-2.0/include 
-I/usr/local/include/fribidi -I/usr/local/include/cairo 
-I/usr/local/include/pixman-1 -I/usr/local/include/freetype2 
-I/usr/local/include/uuid -I/usr/local/include/libdrm 
-I/usr/local/include/libpng16 -I/usr/local/include/harfbuzz 
-I/usr/local/include/gdk-pixbuf-2.0 -I/usr/local/include/atk-1.0 -D_THREAD_SAFE 
-pthread  -I/usr/local/include/glib-2.0 -I/usr/local/lib/glib-2.0/include 
-I/usr/local/include -pthread  -I/usr/local/include  -I/usr/local/include 
-I/usr/local/include/lensfun -I/usr/local/include/glib-2.0 
-I/usr/local/lib/glib-2.0/include  -I/usr/local/include  
-I/usr/local/include/libpng16   -DDCRAW_NOMAIN 
-DUFRAW_LOCALEDIR=\"/usr/local/share/locale\" -I/usr/local/include  -O2 -pipe  
-fstack-protector-strong -fno-strict-aliasing  -fopenmp -MT wb_presets.o -MD 
-MP -MF .deps/wb_presets.Tpo 
 -c -o wb_presets.o wb_presets.c
mv -f .deps/wb_presets.Tpo .deps/wb_presets.Po
c++ -DHAVE_CONFIG_H -I.  -I/usr/local/include  -I/usr/local/include 
-I/usr/local/include/gtk-2.0 -I/usr/local/include/pango-1.0 
-I/usr/local/include/glib-2.0 -I/usr/local/lib/glib-2.0/include 
-I/usr/local/include/fribidi -I/usr/local/include/cairo 
-I/usr/local/include/pixman-1 -I/usr/local/include/freetype2 
-I/usr/local/include/uuid -I/usr/local/include/libdrm 
-I/usr/local/include/libpng16 -I/usr/local/include/harfbuzz 
-I/usr/local/include/gdk-pixbuf-2.0 -I/usr/local/include/atk-1.0 -D_THREAD_SAFE 
-pthread  -I/usr/local/include/glib-2.0 -I/usr/local/lib/glib-2.0/include 
-I/usr/local/include -pthread  -I/usr/local/include  -I/usr/local/include 
-I/usr/local/include/lensfun -I/usr/local/include/glib-2.0 
-I/usr/local/lib/glib-2.0/include  -I/usr/local/include  
-I/usr/local/include/libpng16   -DDCRAW_NOMAIN 
-DUFRAW_LOCALEDIR=\"/usr/local/share/locale\" -I/usr/local/include  -O2 -pipe 
-fstack-protector-strong -fno-strict-aliasing   -fopenmp -MT dcraw_api.o -MD 
-MP -MF .deps/dcraw_api.Tpo -
 c -o dcraw_api.o dcraw_api.cc
dcraw_api.cc:909:77: error: variable 'black' must have explicitly specified 
data sharing attributes
                    gint32 p = (gint64)(get_pixel(h, dark, i, cc, pixels) - 
black) *
                                                                            
^~~~~
dcraw_api.cc:903:63: note: explicit data sharing attribute requested here
            #pragma omp parallel for schedule(static) default(none) \
                                                              ^
dcraw_api.cc:906:33: error: variable 'pixels' must have explicitly specified 
data sharing attributes
            for (int i = 0; i < pixels; i++) {
                                ^~~~~~
dcraw_api.cc:903:63: note: explicit data sharing attribute requested here
            #pragma omp parallel for schedule(static) default(none) \
                                                              ^
dcraw_api.cc:923:82: error: variable 'black' must have explicitly specified 
data sharing attributes
                                                  ((gint64)h->raw.image[i][cc] 
- black) *
                                                                                
 ^~~~~
/usr/local/include/glib-2.0/glib/gmacros.h:297:23: note: expanded from macro 
'MAX'
#define MAX(a, b)  (((a) > (b)) ? (a) : (b))
                      ^
/usr/local/include/glib-2.0/glib/gmacros.h:300:23: note: expanded from macro 
'MIN'
#define MIN(a, b)  (((a) < (b)) ? (a) : (b))
                      ^
dcraw_api.cc:916:63: note: explicit data sharing attribute requested here
            #pragma omp parallel for schedule(static) default(none) \
                                                              ^
dcraw_api.cc:919:33: error: variable 'pixels' must have explicitly specified 
data sharing attributes
            for (int i = 0; i < pixels; i++) {
                                ^~~~~~
dcraw_api.cc:916:63: note: explicit data sharing attribute requested here
            #pragma omp parallel for schedule(static) default(none) \
                                                              ^
4 errors generated.
gmake[3]: *** [Makefile:920: dcraw_api.o] Error 1
gmake[3]: *** Waiting for unfinished jobs....
11 warnings generated.
mv -f .deps/dcraw.Tpo .deps/dcraw.Po
gmake[3]: Leaving directory 
'/wrkdirs/usr/ports/graphics/ufraw/work/ufraw-6d3259a'
gmake[2]: *** [Makefile:1060: all-recursive] Error 1
gmake[2]: Leaving directory 
'/wrkdirs/usr/ports/graphics/ufraw/work/ufraw-6d3259a'
gmake[1]: *** [Makefile:610: all] Error 2
gmake[1]: Leaving directory 
'/wrkdirs/usr/ports/graphics/ufraw/work/ufraw-6d3259a'
===> Compilation failed unexpectedly.
Try to set MAKE_JOBS_UNSAFE=yes and rebuild before reporting the failure to
the maintainer.
*** Error code 1

Stop.
make: stopped in /usr/ports/graphics/ufraw
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to