You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     h...@freebsd.org
Last committer: h...@freebsd.org
Ident:          $FreeBSD: head/cad/klayout/Makefile 348233 2014-03-14 13:54:48Z 
hrs $
Log URL:        
http://beefy2.isc.freebsd.org/bulk/head-amd64-default/2014-05-08_17h29m07s/logs/klayout-0.23.3.log
Build URL:      
http://beefy2.isc.freebsd.org/bulk/head-amd64-default/2014-05-08_17h29m07s
Log:

====>> Building cad/klayout
build started at Fri May  9 07:55:15 UTC 2014
port directory: /usr/ports/cad/klayout
building for: FreeBSD head-amd64-default-job-14 11.0-CURRENT FreeBSD 
11.0-CURRENT r264257 amd64
maintained by: h...@freebsd.org
Makefile ident:      $FreeBSD: head/cad/klayout/Makefile 348233 2014-03-14 
13:54:48Z hrs $
Poudriere version: 3.1-pre
Host OSVERSION: 1100013
Jail OSVERSION: 1100018




!!! Jail is newer than host. (Jail: 1100018, Host: 1100013) !!!
!!! This is not supported. !!!
!!! Host kernel must be same or newer than jail. !!!
!!! Expect build failures. !!!



---Begin Environment---
OSVERSION=1100018
UNAME_v=FreeBSD 11.0-CURRENT r264257
UNAME_r=11.0-CURRENT
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
SAVED_TERM=
MASTERMNT=/usr/local/poudriere/data/build/head-amd64-default/ref
PKG_EXT=txz
tpid=22298
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
POUDRIERE_BUILD_TYPE=bulk
PKGNG=1
PKGNAME=klayout-0.23.3
PKG_DELETE=/usr/local/sbin/pkg-static delete -y -f
PKG_ADD=/usr/local/sbin/pkg-static add
OLDPWD=/usr/local/poudriere/data/build/head-amd64-default/ref/poudriere/rdeps
PWD=/usr/local/poudriere/data/build/head-amd64-default/ref/poudriere/pool
MASTERNAME=head-amd64-default
USER=root
HOME=/root
POUDRIERE_VERSION=3.1-pre
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
PKG_VERSION=/poudriere/pkg-static version
PKG_BIN=/usr/local/sbin/pkg-static
---End Environment---

---Begin OPTIONS List---
---End OPTIONS List---

--CONFIGURE_ARGS--
--with-qt-includes=/usr/local/include/qt4  
--with-qt-libraries=/usr/local/lib/qt4  
--with-extra-includes=/usr/local/include  --with-extra-libs=/usr/local/lib
--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
TMPDIR="/tmp" QTDIR="/usr/local" QMAKE="/usr/local/bin/qmake-qt4"  
MOC="/usr/local/bin/moc-qt4" RCC="/usr/local/bin/rcc" 
UIC="/usr/local/bin/uic-qt4"  
QMAKESPEC="/usr/local/share/qt4/mkspecs/freebsd-$(ccver="$(c++ --version)"; 
case "$ccver" in *clang*) echo clang ;; *) echo g++ ;; esac)" MAKE=gmake 
TMPDIR="/tmp" SHELL=/bin/sh CONFIG_SHELL=/bin/sh
--End CONFIGURE_ENV--

--MAKE_ENV--
TMPDIR="/tmp" TMPDIR="/tmp" SHELL=/bin/sh NO_LINT=YES PREFIX=/usr/local  
LOCALBASE=/usr/local  LIBDIR="/usr/lib"  CC="cc" CFLAGS="-O2 -pipe  
-fno-strict-aliasing"  CPP="cpp" CPPFLAGS=""  LDFLAGS=""  CXX="c++" 
CXXFLAGS="-O2 -pipe -fno-strict-aliasing"  MANPREFIX="/usr/local" 
BSD_INSTALL_PROGRAM="install  -s -o root -g wheel -m 555"  
BSD_INSTALL_LIB="install  -s -o root -g wheel -m 444"  
BSD_INSTALL_SCRIPT="install  -o root -g wheel -m 555"  
BSD_INSTALL_DATA="install  -o root -g wheel -m 444"  BSD_INSTALL_MAN="install  
-o root -g wheel -m 444"
--End MAKE_ENV--

--PLIST_SUB--
RUBY_LIBDIR="lib/ruby/1.9"
RUBY_ARCHLIBDIR="lib/ruby/1.9/amd64-freebsd11"
RUBY_SITELIBDIR="lib/ruby/site_ruby/1.9"
RUBY_SITEARCHLIBDIR="lib/ruby/site_ruby/1.9/amd64-freebsd11"
RUBY_VENDORLIBDIR="lib/ruby/vendor_ruby/1.9"
RUBY_VENDORARCHLIBDIR="lib/ruby/vendor_ruby/1.9/amd64-freebsd11"
RUBY_MODDOCDIR="share/doc/ruby19/klayout"
RUBY_MODEXAMPLESDIR="share/examples/ruby19/klayout"
RUBY_DOCDIR="share/doc/ruby19"
RUBY_EXAMPLESDIR="share/examples/ruby19"
RUBY_RIDIR="share/ri/1.9/system"
RUBY_SITERIDIR="share/ri/1.9/site"
RUBY_ELISPDIR="lib/ruby/elisp"
RUBY_VERSION="1.9.3.484"
RUBY_VER="1.9"
RUBY_SHLIBVER="19"
RUBY_ARCH="amd64-freebsd11"
RUBY_SUFFIX="19"
RUBY_NAME="ruby19"
RUBY_DEFAULT_SUFFIX="19"
RUBY19=""
RUBY20="@comment
"
RUBY21="@comment
"
RUBY_RD_HTML_FILES="@comment
"
QT_PREFIX="/usr/local"
QT_BINDIR="bin"
QT_INCDIR="include/qt4"
QT_LIBDIR="lib/qt4"
QT_ARCHDIR="lib/qt4/qt4"
QT_PLUGINDIR="lib/qt4/plugins"
QT_LIBEXECDIR="libexec/qt4"
QT_IMPORTDIR="lib/qt4/imports"
QT_QMLDIR="lib/qt4/qt4/qml"
QT_DATADIR="share/qt4"
QT_DOCDIR="share/doc/qt4"
QT_L10NDIR="share/qt4/translations"
QT_ETCDIR="etc/xdg"
QT_EXAMPLEDIR="share/examples/qt4"
QT_TESTDIR="share/qt4/tests"
QT_MKSPECDIR="share/qt4/mkspecs"
OSREL=11.0
PREFIX=%D
LOCALBASE=/usr/local
PORTDOCS=""
PORTEXAMPLES=""
PORTDATA=""
LIB32DIR=lib
DOCSDIR="share/doc/klayout"
EXAMPLESDIR="share/examples/klayout"
DATADIR="share/klayout"
WWWDIR="www/klayout"
ETCDIR="etc/klayout"
--End PLIST_SUB--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/klayout
DOCSDIR=/usr/local/share/doc/klayout
EXAMPLESDIR=/usr/local/share/examples/klayout
WWWDIR=/usr/local/www/klayout
ETCDIR=/usr/local/etc/klayout
--End SUB_LIST--

---Begin make.conf---
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
WITH_PKGNG=yes
NO_RESTRICTED=yes
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
===>  Cleaning for klayout-0.23.3
=======================<phase: check-sanity   >============================
===>  License GPLv2 accepted by the user
===========================================================================
=======================<phase: pkg-depends    >============================
===>   klayout-0.23.3 depends on file: /usr/local/sbin/pkg - not found
===>    Verifying install for /usr/local/sbin/pkg in /usr/ports/ports-mgmt/pkg
===>   Installing existing package /packages/All/pkg-1.2.7_2.txz
Installing pkg-1.2.7_2... done
If you are upgrading from the old package format, first run:

  # pkg2ng
===>   Returning to build of klayout-0.23.3
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===>  License GPLv2 accepted by the user
===> Fetching all distfiles required by klayout-0.23.3 for building
===========================================================================
=======================<phase: checksum       >============================
===>  License GPLv2 accepted by the user
===> Fetching all distfiles required by klayout-0.23.3 for building
=> SHA256 Checksum OK for klayout-0.23.3.tar.gz.
===========================================================================
=======================<phase: extract-depends>============================
===>   klayout-0.23.3 depends on file: /usr/local/bin/ruby19 - not found
===>    Verifying install for /usr/local/bin/ruby19 in /usr/ports/lang/ruby19
===>   Installing existing package /packages/All/ruby-1.9.3.484_2,1.txz
Installing ruby-1.9.3.484_2,1...Installing libffi-3.0.13_1... done
Installing libyaml-0.1.6... done
 done
====
Some of the standard commands are provided as separate ports for ease
of upgrading:

        devel/ruby-gems:        gem - RubyGems package manager
        devel/rubygem-rake:     rake - Ruby Make

And some of the standard libraries are provided as separate ports
since they require extra dependencies:

        converters/ruby-iconv:  iconv module
        databases/ruby-gdbm:    GDBM module
        x11-toolkits/ruby-tk:   Tcl/Tk modules
        japanese/ruby-tk:       Tcl/Tk modules for Japanized Tcl/Tk

Install them as occasion demands.
====
===>   Returning to build of klayout-0.23.3
===========================================================================
=======================<phase: extract        >============================
===>  License GPLv2 accepted by the user
===> Fetching all distfiles required by klayout-0.23.3 for building
===>  Extracting for klayout-0.23.3
<snip>
 - Common UNIX Printing System (CUPS) (enabled by default)
 - Network Audio System (NAS)
 - Qt style that renders using GTK (QGTKSTYLE)

In order to enable them, you have to add
        QT4_OPTIONS=    CUPS NAS QGTKSTYLE
to your /etc/make.conf and compile devel/qt4-corelib and
x11-toolkits/qt4-gui ports.

Attention! Whenever you change the QT4_OPTIONS both
devel/qt4-corelib and x11-toolkits/qt4-gui ports must be rebuilt!

======================================================================
===>   Returning to build of klayout-0.23.3
===>   klayout-0.23.3 depends on file: /usr/local/bin/designer-qt4 - not found
===>    Verifying install for /usr/local/bin/designer-qt4 in 
/usr/ports/devel/qt4-designer
===>   Installing existing package /packages/All/qt4-designer-4.8.6.txz
Installing qt4-designer-4.8.6...Installing qt4-assistant-4.8.6...Installing 
qt4-doc-4.8.6... done
Installing qt4-gui-4.8.6...Installing encodings-1.0.4_1,1...Installing 
font-util-1.3.0_1... done
 done
Installing fontconfig-2.11.0_2,1...Installing expat-2.1.0... done
Installing freetype2-2.5.3_2... done
Running fc-cache to build fontconfig cache...
/usr/local/share/fonts: skipping, no such directory
/usr/local/lib/X11/fonts: caching, new cache contents: 0 fonts, 3 dirs
/usr/local/lib/X11/fonts/encodings: caching, new cache contents: 0 fonts, 1 dirs
/usr/local/lib/X11/fonts/encodings/large: caching, new cache contents: 0 fonts, 
0 dirs
/usr/local/lib/X11/fonts/local: caching, new cache contents: 0 fonts, 0 dirs
/usr/local/lib/X11/fonts/util: caching, new cache contents: 0 fonts, 0 dirs
/root/.local/share/fonts: skipping, no such directory
/root/.fonts: skipping, no such directory
/usr/local/share/fonts: skipping, no such directory
/usr/local/lib/X11/fonts: caching, new cache contents: 0 fonts, 3 dirs
/root/.local/share/fonts: skipping, no such directory
/root/.fonts: skipping, no such directory
/var/db/fontconfig: cleaning cache directory
/root/.cache/fontconfig: not cleaning non-existent cache directory
/root/.fontconfig: not cleaning non-existent cache directory
fc-cache: succeeded
 done
Installing libICE-1.0.8_2,1...Installing xproto-7.0.25... done
 done
Installing libSM-1.2.2_2,1... done
Installing libX11-1.6.2_2,1...Installing kbproto-1.0.6... done
Installing libXau-1.0.8_2... done
Installing libXdmcp-1.1.1_2... done
Installing libxcb-1.10_2...Installing libpthread-stubs-0.3_4... done
Installing libxml2-2.8.0_5... done
 done
 done
Installing libXcursor-1.1.14_2...Installing libXfixes-5.0.1_2...Installing 
fixesproto-5.0... done
 done
Installing libXrender-0.9.8_2...Installing renderproto-0.11.1... done
 done
 done
Installing libXext-1.3.2_2,1...Installing xextproto-7.3.0... done
 done
Installing libXi-1.7.2_2,1...Installing inputproto-2.3... done
 done
Installing libXinerama-1.1.3_2,1...Installing xineramaproto-1.2.1... done
 done
Installing libXrandr-1.4.2_2...Installing randrproto-1.4.0... done
 done
Installing libXt-1.1.4_2,1... done
Installing png-1.5.18... done
Installing xdg-utils-1.0.2.20130919_1...Installing hicolor-icon-theme-0.12... 
done
Installing xprop-1.2.2...Installing libXmu-1.1.2_2,1... done
 done
Installing xset-1.2.3_1...Installing libXfontcache-1.0.5_2...Installing 
fontcacheproto-0.1.3... done
 done
 done
 done
Installing xorg-fonts-truetype-7.7_1...Installing dejavu-2.34_3... done
Installing font-bh-ttf-1.0.3_1...Installing mkfontdir-1.0.7...Installing 
mkfontscale-1.1.1_1...Installing libfontenc-1.1.2_2... done
 done
 done
 done
Installing font-misc-ethiopic-1.0.3_1... done
Installing font-misc-meltho-1.0.3_1... done
 done
 done
Installing qt4-help-4.8.6...Installing qt4-clucene-4.8.6... done
Installing qt4-network-4.8.6...Installing ca_root_nss-3.16... done
 done
Installing qt4-sql-4.8.6... done
Installing qt4-sqlite-plugin-4.8.6...Installing sqlite3-3.8.4.2... done
 done
Installing qt4-xml-4.8.6... done
 done
Installing qt4-webkit-4.8.6...Installing 
gstreamer-plugins-0.10.36_4,3...Installing gstreamer-0.10.36_2...Installing 
gobject-introspection-1.36.0_2...Installing gnomehier-3.0... done
Installing python2-2_2... done
 done
 done
Installing libXv-1.0.10_2,1...Installing videoproto-2.3.2... done
 done
Installing orc-0.4.19_2... done
 done
Installing qt4-declarative-4.8.6...Installing qt4-opengl-4.8.6...Installing 
libGL-9.1.7...Installing dri2proto-2.8... done
Installing libXdamage-1.1.4_2...Installing damageproto-1.2.1... done
 done
Installing libXxf86vm-1.1.3_2...Installing xf86vidmodeproto-2.3.1... done
 done
Installing libdrm-2.4.52...Installing libpciaccess-0.13.2_2...Installing 
pciids-20140502... done
 done
 done
 done
 done
Installing qt4-script-4.8.6... done
Installing qt4-svg-4.8.6... done
Installing qt4-xmlpatterns-4.8.6... done
 done
 done
 done
Installing qt4-qt3support-4.8.6... done
 done
Make sure that the freetype module is loaded.  If it is not, add the following
line to the "Modules" section of your X Windows configuration file:

        Load "freetype"

Add the following line to the "Files" section of X Windows configuration file:

        FontPath "/usr/local/lib/X11/fonts/dejavu/"

Note: your X Windows configuration file is typically /etc/X11/XF86Config
if you are using XFree86, and /etc/X11/xorg.conf if you are using X.Org.
======================================================================

Qt paint engine makes common use of shared memory. To avoid MIT-SHM
errors (i.e., blank windows), you probably need to raise shared memory
limits in loader.conf(5). The following should be safe values for the
KDE Plasma Desktop:

kern.ipc.shmall=32768
kern.ipc.shmmni=1024
kern.ipc.shmseg=1024

======================================================================
======================================================================

To enable Qt database support, install the database plugin ports. The
following plugin ports are available:
 - databases/qt4-ibase-plugin           InterBase/Firebird
 - databases/qt4-mysql-plugin           MySQL
 - databases/qt4-odbc-plugin            Open Database Connectivity
 - databases/qt4-pgsql-plugin           PostgreSQL
 - databases/qt4-sqlite-plugin          SQLite 2
 - databases/qt4-sqlite3-plugin         SQLite 3

======================================================================
===>   Returning to build of klayout-0.23.3
===>   klayout-0.23.3 depends on file: /usr/local/lib/qt4/libQtGui.so - found
===>   klayout-0.23.3 depends on file: /usr/local/bin/moc-qt4 - not found
===>    Verifying install for /usr/local/bin/moc-qt4 in /usr/ports/devel/qt4-moc
===>   Installing existing package /packages/All/qt4-moc-4.8.6.txz
Installing qt4-moc-4.8.6... done
===>   Returning to build of klayout-0.23.3
===>   klayout-0.23.3 depends on file: /usr/local/lib/qt4/libQtNetwork.so - 
found
===>   klayout-0.23.3 depends on file: /usr/local/lib/qt4/libQt3Support.so - 
found
===>   klayout-0.23.3 depends on file: /usr/local/bin/rcc - not found
===>    Verifying install for /usr/local/bin/rcc in /usr/ports/devel/qt4-rcc
===>   Installing existing package /packages/All/qt4-rcc-4.8.6.txz
Installing qt4-rcc-4.8.6... done
===>   Returning to build of klayout-0.23.3
===>   klayout-0.23.3 depends on file: /usr/local/lib/qt4/libQtSql.so - found
===>   klayout-0.23.3 depends on file: /usr/local/bin/uic-qt4 - not found
===>    Verifying install for /usr/local/bin/uic-qt4 in /usr/ports/devel/qt4-uic
===>   Installing existing package /packages/All/qt4-uic-4.8.6.txz
Installing qt4-uic-4.8.6... done
===>   Returning to build of klayout-0.23.3
===>   klayout-0.23.3 depends on file: /usr/local/lib/qt4/libQtXml.so - found
===========================================================================
=======================<phase: lib-depends    >============================
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for klayout-0.23.3
===========================================================================
=======================<phase: build          >============================
===>  Building for klayout-0.23.3
cd /wrkdirs/usr/ports/cad/klayout/work/klayout-0.23.3 &&  /bin/sh build.sh 
-platform freebsd-32-gcc-release  -qtbin /usr/local/bin  -qtinc 
/usr/local/include/qt4  -qtlib /usr/local/lib/qt4
Scanning installation ..

Using ruby interpreter: ruby
    Ruby version code is 10901
    Ruby library found: /usr/local/lib/libruby19.so.19
    Ruby headers found: /usr/local/include/ruby-1.9/ and 
/usr/local/include/ruby-1.9//amd64-freebsd11
    Ruby installation is in:
    - /usr/local/lib/libruby19.so.19 (lib)
    - /usr/local/include/ruby-1.9/ (includes)
    - /usr/local/include/ruby-1.9//amd64-freebsd11 (config for 1.9.x)

Qt installation directory is /usr/local/lib/qt4 (lib), /usr/local/bin (tools) 
and /usr/local/include/qt4 (includes)

Platform is freebsd-32-gcc-release
*** ERROR: unable to locate gcc in path
*** Error code 1

Stop.
make: stopped in /usr/ports/cad/klayout
===>  Cleaning for klayout-0.23.3
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to