You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     po...@freebsd.org
Last committer: zeis...@freebsd.org
Ident:          $FreeBSD: head/games/evq3/Makefile 351411 2014-04-16 18:28:47Z 
zeising $
Log URL:        
http://beefy1.isc.freebsd.org/bulk/head-i386-default/2014-05-08_19h11m27s/logs/evq3-1.3.20080810_9.log
Build URL:      
http://beefy1.isc.freebsd.org/bulk/head-i386-default/2014-05-08_19h11m27s
Log:

====>> Building games/evq3
build started at Fri May  9 08:38:23 UTC 2014
port directory: /usr/ports/games/evq3
building for: FreeBSD head-i386-default-job-13 11.0-CURRENT FreeBSD 
11.0-CURRENT r264257 i386
maintained by: po...@freebsd.org
Makefile ident:      $FreeBSD: head/games/evq3/Makefile 351411 2014-04-16 
18:28:47Z zeising $
Poudriere version: 3.1-pre
Host OSVERSION: 1100013
Jail OSVERSION: 1100018




!!! Jail is newer than host. (Jail: 1100018, Host: 1100013) !!!
!!! This is not supported. !!!
!!! Host kernel must be same or newer than jail. !!!
!!! Expect build failures. !!!



---Begin Environment---
UNAME_m=i386
UNAME_p=i386
OSVERSION=1100018
UNAME_v=FreeBSD 11.0-CURRENT r264257
UNAME_r=11.0-CURRENT
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
SAVED_TERM=
MASTERMNT=/usr/local/poudriere/data/build/head-i386-default/ref
PKG_EXT=txz
tpid=86660
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
POUDRIERE_BUILD_TYPE=bulk
PKGNG=1
PKGNAME=evq3-1.3.20080810_9
PKG_DELETE=/usr/local/sbin/pkg-static delete -y -f
PKG_ADD=/usr/local/sbin/pkg-static add
OLDPWD=/usr/local/poudriere/data/build/head-i386-default/ref/poudriere/rdeps
PWD=/usr/local/poudriere/data/build/head-i386-default/ref/poudriere/pool
MASTERNAME=head-i386-default
USER=root
HOME=/root
POUDRIERE_VERSION=3.1-pre
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
PKG_VERSION=/poudriere/pkg-static version
PKG_BIN=/usr/local/sbin/pkg-static
---End Environment---

---Begin OPTIONS List---
===> The following configuration options are available for evq3-1.3.20080810_9:
     CURL=on: Data transfer support via cURL
     CURL_DLOPEN=on: Enable dynamic loading of curl
     GAMELIBS=off: Build game libraries (when not mandatory)
     OPENAL=off: Enable OpenAL (3D sound) support
     OPENAL_DLOPEN=off: Enable dynamic loading of OpenAL
     OPTIMIZED_CFLAGS=on: Use extra compiler optimizations
     VOIP=off: Enable Voice Over IP
     VORBIS=on: Ogg Vorbis audio codec support
====> Options available for the multi TYPE: you have to choose at least one of 
them
     CLIENT=on: Build client
     DEDICATED=on: Build dedicated server
     SMP=on: Build SMP (threaded) client
===> Use 'make config' to modify these settings
---End OPTIONS List---

--CONFIGURE_ARGS--

--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
TMPDIR="/tmp" MAKE=gmake TMPDIR="/tmp" SHELL=/bin/sh CONFIG_SHELL=/bin/sh 
SDL_CONFIG=/usr/local/bin/sdl-config
--End CONFIGURE_ENV--

--MAKE_ENV--
DEFAULT_BASEDIR="/usr/local/share/quake3" LIBDIR="/usr/local/lib/evq3"  
PTHREAD_LIBS="-pthread" Q3DIR="/usr/local/share/quake3" TMPDIR="/tmp" 
HAVE_VM_COMPILED=true USE_CURL=1 USE_CURL_DLOPEN=1 USE_CODEC_VORBIS=1 
BUILD_CLIENT=1 BUILD_SERVER=1 USE_OPTIMIZED_CFLAGS=1 BUILD_CLIENT_SMP=1 
TMPDIR="/tmp" SHELL=/bin/sh NO_LINT=YES SDL_CONFIG=/usr/local/bin/sdl-config 
PREFIX=/usr/local  LOCALBASE=/usr/local  LIBDIR="/usr/local/lib/evq3"  CC="cc" 
CFLAGS="-O2 -pipe  -DMAP_ANONYMOUS=MAP_ANON -fno-strict-aliasing"  CPP="cpp" 
CPPFLAGS=""  LDFLAGS=""  CXX="c++" CXXFLAGS="-O2 -pipe -DMAP_ANONYMOUS=MAP_ANON 
-fno-strict-aliasing"  MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install  -s 
-o root -g wheel -m 555"  BSD_INSTALL_LIB="install  -s -o root -g wheel -m 444" 
 BSD_INSTALL_SCRIPT="install  -o root -g wheel -m 555"  
BSD_INSTALL_DATA="install  -o root -g wheel -m 444"  BSD_INSTALL_MAN="install  
-o root -g wheel -m 444"
--End MAKE_ENV--

--PLIST_SUB--
LIBDIR="lib/evq3"
Q3DIR="share/quake3"
CLIENT=""
DEDICATED=""
GAMELIBS="@comment
"
SMP=""
OSREL=11.0
PREFIX=%D
LOCALBASE=/usr/local
PORTDOCS=""
PORTEXAMPLES=""
PORTDATA=""
LIB32DIR=lib
DOCSDIR="share/doc/evq3"
EXAMPLESDIR="share/examples/evq3"
DATADIR="share/evq3"
WWWDIR="www/evq3"
ETCDIR="etc/evq3"
--End PLIST_SUB--

--SUB_LIST--
Q3DIR="/usr/local/share/quake3"
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/evq3
DOCSDIR=/usr/local/share/doc/evq3
EXAMPLESDIR=/usr/local/share/examples/evq3
WWWDIR=/usr/local/www/evq3
ETCDIR=/usr/local/etc/evq3
--End SUB_LIST--

---Begin make.conf---
ARCH=i386
MACHINE=i386
MACHINE_ARCH=i386
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
WITH_PKGNG=yes
NO_RESTRICTED=yes
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
===>  Cleaning for evq3-1.3.20080810_9
=======================<phase: check-sanity   >============================
===========================================================================
=======================<phase: pkg-depends    >============================
===>   evq3-1.3.20080810_9 depends on file: /usr/local/sbin/pkg - not found
===>    Verifying install for /usr/local/sbin/pkg in /usr/ports/ports-mgmt/pkg
===>   Installing existing package /packages/All/pkg-1.2.7_2.txz
Installing pkg-1.2.7_2... done
If you are upgrading from the old package format, first run:

  # pkg2ng
===>   Returning to build of evq3-1.3.20080810_9
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===> Fetching all distfiles required by evq3-1.3.20080810_9 for building
===========================================================================
=======================<phase: checksum       >============================
===> Fetching all distfiles required by evq3-1.3.20080810_9 for building
=> SHA256 Checksum OK for evq3-1.3.20080810.tar.bz2.
=> SHA256 Checksum OK for pak-evq3.pk3.
=> SHA256 Checksum OK for pak-5evq3.pk3.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===> Fetching all distfiles required by evq3-1.3.20080810_9 for building
===>  Extracting for evq3-1.3.20080810_9
=> SHA256 Checksum OK for evq3-1.3.20080810.tar.bz2.
=> SHA256 Checksum OK for pak-evq3.pk3.
=> SHA256 Checksum OK for pak-5evq3.pk3.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for evq3-1.3.20080810_9
===>   Converting DOS text files to UNIX text files
===>  Applying FreeBSD patches for evq3-1.3.20080810_9
===========================================================================
=======================<phase: build-depends  >============================
===>   evq3-1.3.20080810_9 depends on executable: gmake - not found
===>    Verifying install for gmake in /usr/ports/devel/gmake
===>   Installing existing package /packages/All/gmake-3.82_1.txz
Installing gmake-3.82_1...Installing gettext-0.18.3.1... done
 done
===>   Returning to build of evq3-1.3.20080810_9
===>   evq3-1.3.20080810_9 depends on file: /usr/local/bin/sdl-config - not 
found
===>    Verifying install for /usr/local/bin/sdl-config in 
/usr/ports/devel/sdl12
===>   Installing existing package /packages/All/sdl-1.2.15_4,2.txz
Installing sdl-1.2.15_4,2...Installing aalib-1.4.r5_10... done
Installing libGLU-9.0.0...Installing libGL-9.1.7...Installing dri2proto-2.8... 
done
Installing expat-2.1.0... done
Installing libX11-1.6.2_2,1...Installing kbproto-1.0.6... done
Installing libXau-1.0.8_2...Installing xproto-7.0.25... done
 done
Installing libXdmcp-1.1.1_2... done
Installing libxcb-1.10_2...Installing libpthread-stubs-0.3_4... done
Installing libxml2-2.8.0_5... done
 done
 done
Installing libXdamage-1.1.4_2...Installing damageproto-1.2.1... done
Installing libXfixes-5.0.1_2...Installing fixesproto-5.0... done
 done
 done
Installing libXext-1.3.2_2,1...Installing xextproto-7.3.0... done
 done
Installing libXxf86vm-1.1.3_2...Installing xf86vidmodeproto-2.3.1... done
 done
Installing libdrm-2.4.52...Installing libpciaccess-0.13.2_2...Installing 
pciids-20140502... done
 done
 done
 done
 done
Installing libXrandr-1.4.2_2...Installing libXrender-0.9.8_2...Installing 
renderproto-0.11.1... done
 done
Installing randrproto-1.4.0... done
 done
 done
------------------------------------------------------------------------------
 Your SDL library has been built with libvgl support, which means that you
 can run almost any SDL application straight on your console (VESA 2.0
 compatible videocard is required).

 To do this you have to load the vesa kernel module or enable it in your
 kernel, and set environment variable "SDL_VIDEODRIVER=vgl".
------------------------------------------------------------------------------
===>   Returning to build of evq3-1.3.20080810_9
===========================================================================
=======================<phase: lib-depends    >============================
===>   evq3-1.3.20080810_9 depends on shared library: libfreetype.so - not found
===>    Verifying for libfreetype.so in /usr/ports/print/freetype2
===>   Installing existing package /packages/All/freetype2-2.5.3_2.txz
Installing freetype2-2.5.3_2... done
===>   Returning to build of evq3-1.3.20080810_9
===>   evq3-1.3.20080810_9 depends on shared library: libcurl.so - not found
===>    Verifying for libcurl.so in /usr/ports/ftp/curl
===>   Installing existing package /packages/All/curl-7.36.0.txz
Installing curl-7.36.0...Installing ca_root_nss-3.16... done
 done
===>   Returning to build of evq3-1.3.20080810_9
===>   evq3-1.3.20080810_9 depends on shared library: libvorbis.so - not found
===>    Verifying for libvorbis.so in /usr/ports/audio/libvorbis
===>   Installing existing package /packages/All/libvorbis-1.3.4,3.txz
Installing libvorbis-1.3.4,3...Installing libogg-1.3.1,4... done
 done
===>   Returning to build of evq3-1.3.20080810_9
===>   evq3-1.3.20080810_9 depends on shared library: libSDL.so - found
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for evq3-1.3.20080810_9
===========================================================================
=======================<phase: build          >============================
===>  Building for evq3-1.3.20080810_9
gmake[1]: Entering directory `/wrkdirs/usr/ports/games/evq3/work/evq3'
gmake[2]: Entering directory `/wrkdirs/usr/ports/games/evq3/work/evq3'

Building evq3 in build/release:
  PLATFORM: freebsd
  ARCH: i386
  VERSION: 1.35
  COMPILE_PLATFORM: freebsd
  COMPILE_ARCH: i386
  CC: cc

  CFLAGS:
    -O2
    -pipe
    -DMAP_ANONYMOUS=MAP_ANON
    -fno-strict-aliasing
    -MMD
    -DARCH="i386"
    -I/usr/local/include
    -Wall
    -fno-strict-aliasing
    -Wimplicit
    -Wstrict-prototypes
    -DLIBDIR="/usr/local/lib/evq3"
    -DUSE_ICON
    -I/usr/local/include/SDL
    -I/usr/local/include
    -D_GNU_SOURCE=1
    -D_REENTRANT
    -D_THREAD_SAFE
    -DUSE_CODEC_VORBIS
    -DUSE_CURL=1
    -DUSE_CURL_DLOPEN=1
    -DDEFAULT_BASEDIR="/usr/local/share/quake3"
    -DPRODUCT_VERSION="1.35"
    -DNDEBUG
    -pipe
    -O3
    -ffast-math
    -funroll-loops
    -fomit-frame-pointer
    -fexpensive-optimizations
    -falign-loops=2
    -falign-jumps=2
    -falign-functions=2
    -fstrength-reduce

  LDFLAGS:
    -lm

  Output:
    build/release/evq3ded
    build/release/evq3
    build/release/evq3-smp

gmake[3]: Entering directory `/wrkdirs/usr/ports/games/evq3/work/evq3'
DED_CC code/server/sv_bot.c
cc: error: unknown argument: '-falign-loops=2'
cc: error: unknown argument: '-falign-jumps=2'
gmake[3]: *** [build/release/ded/sv_bot.o] Error 1
gmake[3]: Leaving directory `/wrkdirs/usr/ports/games/evq3/work/evq3'
gmake[2]: *** [targets] Error 2
gmake[2]: Leaving directory `/wrkdirs/usr/ports/games/evq3/work/evq3'
gmake[1]: *** [release] Error 2
gmake[1]: Leaving directory `/wrkdirs/usr/ports/games/evq3/work/evq3'
*** Error code 1

Stop.
make: stopped in /usr/ports/games/evq3
===>  Cleaning for evq3-1.3.20080810_9
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to