You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     po...@freebsd.org
Last committer: ger...@freebsd.org
Ident:          $FreeBSD: branches/2014Q2/graphics/gdal-grass/Makefile 347809 
2014-03-10 20:55:20Z gerald $
Log URL:        
http://beefy1.isc.freebsd.org/bulk/10i386-quarterly/2014-05-14_03h53m10s/logs/gdal-grass-1.4.3_13.log
Build URL:      
http://beefy1.isc.freebsd.org/bulk/10i386-quarterly/2014-05-14_03h53m10s
Log:

====>> Building graphics/gdal-grass
build started at Wed May 14 04:14:44 UTC 2014
port directory: /usr/ports/graphics/gdal-grass
building for: FreeBSD 10i386-quarterly-job-14 10.0-RELEASE-p1 FreeBSD 
10.0-RELEASE-p1 i386
maintained by: po...@freebsd.org
Makefile ident:      $FreeBSD: branches/2014Q2/graphics/gdal-grass/Makefile 
347809 2014-03-10 20:55:20Z gerald $
Poudriere version: 3.1-pre
Host OSVERSION: 1100013
Jail OSVERSION: 1000510

---Begin Environment---
UNAME_m=i386
UNAME_p=i386
OSVERSION=1000510
UNAME_v=FreeBSD 10.0-RELEASE-p1
UNAME_r=10.0-RELEASE-p1
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
SAVED_TERM=
MASTERMNT=/usr/local/poudriere/data/build/10i386-quarterly/ref
PKG_EXT=txz
tpid=17374
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
POUDRIERE_BUILD_TYPE=bulk
PKGNG=1
PKGNAME=gdal-grass-1.4.3_13
PKG_DELETE=/usr/local/sbin/pkg-static delete -y -f
PKG_ADD=/usr/local/sbin/pkg-static add
OLDPWD=/usr/local/poudriere/data/build/10i386-quarterly/ref/poudriere/rdeps
PWD=/usr/local/poudriere/data/build/10i386-quarterly/ref/poudriere/pool
MASTERNAME=10i386-quarterly
USER=root
HOME=/root
POUDRIERE_VERSION=3.1-pre
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
PKG_VERSION=/poudriere/pkg-static version
PKG_BIN=/usr/local/sbin/pkg-static
---End Environment---

---Begin OPTIONS List---
---End OPTIONS List---

--CONFIGURE_ARGS--
--with-gdal=/usr/local/bin/gdal-config  --with-grass=/usr/local/grass-6.4.2  
--with-autoload=/usr/local/lib/gdalplugins --prefix=/usr/local 
${_LATE_CONFIGURE_ARGS}
--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
TMPDIR="/tmp" MAKE=gmake TMPDIR="/tmp" SHELL=/bin/sh CONFIG_SHELL=/bin/sh 
CONFIG_SITE=/usr/ports/Templates/config.site lt_cv_sys_max_cmd_len=262144
--End CONFIGURE_ENV--

--MAKE_ENV--
TMPDIR="/tmp" TMPDIR="/tmp" SHELL=/bin/sh NO_LINT=YES PREFIX=/usr/local  
LOCALBASE=/usr/local  LIBDIR="/usr/lib"  CC="cc" CFLAGS="-O2 -pipe 
-fno-strict-aliasing"  CPP="cpp" CPPFLAGS=""  LDFLAGS=""  CXX="c++" 
CXXFLAGS="-O2 -pipe -fno-strict-aliasing"  MANPREFIX="/usr/local" 
BSD_INSTALL_PROGRAM="install  -s -o root -g wheel -m 555"  
BSD_INSTALL_LIB="install  -s -o root -g wheel -m 444"  
BSD_INSTALL_SCRIPT="install  -o root -g wheel -m 555"  
BSD_INSTALL_DATA="install  -o root -g wheel -m 444"  BSD_INSTALL_MAN="install  
-o root -g wheel -m 444"
--End MAKE_ENV--

--PLIST_SUB--
OSREL=10.0
PREFIX=%D
LOCALBASE=/usr/local
PORTDOCS=""
PORTEXAMPLES=""
PORTDATA=""
LIB32DIR=lib
DOCSDIR="share/doc/gdal-grass"
EXAMPLESDIR="share/examples/gdal-grass"
DATADIR="share/gdal-grass"
WWWDIR="www/gdal-grass"
ETCDIR="etc/gdal-grass"
--End PLIST_SUB--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/gdal-grass
DOCSDIR=/usr/local/share/doc/gdal-grass
EXAMPLESDIR=/usr/local/share/examples/gdal-grass
WWWDIR=/usr/local/www/gdal-grass
ETCDIR=/usr/local/etc/gdal-grass
--End SUB_LIST--

---Begin make.conf---
ARCH=i386
MACHINE=i386
MACHINE_ARCH=i386
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
WITH_PKGNG=yes
NO_RESTRICTED=yes
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
===>  Cleaning for gdal-grass-1.4.3_13
=======================<phase: check-sanity   >============================
===========================================================================
=======================<phase: pkg-depends    >============================
===>   gdal-grass-1.4.3_13 depends on file: /usr/local/sbin/pkg - not found
===>    Verifying install for /usr/local/sbin/pkg in /usr/ports/ports-mgmt/pkg
===>   Installing existing package /packages/All/pkg-1.2.7.txz
Installing pkg-1.2.7... done
If you are upgrading from the old package format, first run:

  # pkg2ng
===>   Returning to build of gdal-grass-1.4.3_13
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===> Fetching all distfiles required by gdal-grass-1.4.3_13 for building
===========================================================================
=======================<phase: checksum       >============================
===> Fetching all distfiles required by gdal-grass-1.4.3_13 for building
=> SHA256 Checksum OK for gdal-grass-1.4.3.tar.gz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===> Fetching all distfiles required by gdal-grass-1.4.3_13 for building
===>  Extracting for gdal-grass-1.4.3_13
=> SHA256 Checksum OK for gdal-grass-1.4.3.tar.gz.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for gdal-grass-1.4.3_13
===========================================================================
=======================<phase: build-depends  >============================
===>   gdal-grass-1.4.3_13 depends on package: grass>6 - not found
pkg-static: No package(s) matching grass
===>    Verifying install for grass>6 in /usr/ports/databases/grass
===>   Installing existing package /packages/All/grass-6.4.3_1,2.txz
Installing grass-6.4.3_1,2...Installing bash-4.3.0_1...Installing 
gettext-0.18.3.1... done
Updating /etc/shells
 done
Installing blas-3.4.2_2...Installing gcc-4.7.3...Installing binutils-2.24... 
done
Installing gcc-ecj-4.5... done
Installing gmp-5.1.3_1... done
Installing mpc-1.0.2...Installing mpfr-3.1.2_1... done
 done
 done
 done
Installing cairo-1.10.2_7,2...Installing xcb-util-renderutil-0.3.8...Installing 
libxcb-1.9.3...Installing libXau-1.0.8...Installing xproto-7.0.25... done
 done
Installing libXdmcp-1.1.1... done
Installing libpthread-stubs-0.3_4... done
Installing libxml2-2.8.0_3... done
 done
Installing xcb-util-0.3.9_1,1... done
 done
Installing pixman-0.32.4... done
Installing libXrender-0.9.8...Installing libX11-1.6.2,1...Installing 
kbproto-1.0.6... done
 done
Installing renderproto-0.11.1... done
 done
Installing fontconfig-2.11.0_1,1...Installing expat-2.1.0... done
Installing freetype2-2.5.3... done
Running fc-cache to build fontconfig cache...
/usr/local/share/fonts: skipping, no such directory
/usr/local/lib/X11/fonts: caching, new cache contents: 0 fonts, 1 dirs
/usr/local/lib/X11/fonts/local: caching, new cache contents: 0 fonts, 0 dirs
/root/.local/share/fonts: skipping, no such directory
/root/.fonts: skipping, no such directory
/usr/local/share/fonts: skipping, no such directory
/usr/local/lib/X11/fonts: caching, new cache contents: 0 fonts, 1 dirs
/root/.local/share/fonts: skipping, no such directory
/root/.fonts: skipping, no such directory
/var/db/fontconfig: cleaning cache directory
/root/.cache/fontconfig: not cleaning non-existent cache directory
/root/.fontconfig: not cleaning non-existent cache directory
fc-cache: succeeded
 done
Installing png-1.5.18... done
Installing pcre-8.34... done
Installing libffi-3.0.13_1... done
Installing glib-2.36.3_2...Installing libiconv-1.14_3... done
Installing perl5-5.16.3_9... done
Installing python27-2.7.6_4... done
No schema files found: doing nothing.
 done
 done
Installing fftw3-3.3.3_1... done
Installing gdal-1.10.1_4...Installing giflib-nox11-4.2.3_1... done
Installing jasper-1.900.1_12...Installing jpeg-8_4... done
 done
Installing libgeotiff-1.4.0_1...Installing jbigkit-1.6... done
Installing proj-4.8.0_2... done
Installing tiff-4.0.3...Installing freeglut-2.8.1...Installing 
libGLU-9.0.0...Installing libGL-7.6.1_4...Installing dri2proto-2.8... done
Installing libXdamage-1.1.4...Installing damageproto-1.2.1... done
Installing libXfixes-5.0.1...Installing fixesproto-5.0... done
 done
 done
Installing libXext-1.3.2,1...Installing xextproto-7.2.1... done
 done
Installing libXxf86vm-1.1.3...Installing xf86vidmodeproto-2.3.1... done
 done
Installing libdrm-2.4.17_1...Installing libpciaccess-0.13.2...Installing 
pciids-20140312... done
 done
 done
 done
 done
Installing libICE-1.0.8,1... done
Installing libXi-1.7.2,1...Installing inputproto-2.3... done
 done
Installing libXrandr-1.4.2...Installing randrproto-1.4.0... done
 done
 done
Installing libSM-1.2.2,1... done
Installing libXmu-1.1.2,1...Installing libXt-1.1.4,1... done
 done
 done
 done
 done
Installing lapack-3.4.2_2... done
Installing postgresql90-client-9.0.17... done
Installing py27-wxPython28-2.8.12.1_3...Installing 
wx28-gtk2-contrib-2.8.12_2...Installing ORBit2-2.14.19...Installing 
libIDL-0.8.14_1... done
 done
Installing atk-2.8.0...Installing gnomehier-3.0... done
 done
Installing gconf2-2.32.0_3...Installing dbus-glib-0.100.2...Installing 
dbus-1.6.18...Installing gnome_subr-1.0... done
===> Creating users and/or groups.
Creating group 'messagebus' with gid '556'.
Creating user 'messagebus' with uid '556'.
 done
 done
Installing dconf-0.14.1_1... done
Installing gtk2-2.24.22_1...Installing cups-client-1.7.1_1...===> Creating 
users and/or groups.
Creating group 'cups' with gid '193'.
Creating user 'cups' with uid '193'.
 done
Installing gdk-pixbuf2-2.28.2... done
Installing gtk-update-icon-cache-2.24.22...Installing 
hicolor-icon-theme-0.12... done
Installing libXcomposite-0.4.4,1...Installing compositeproto-0.4.2... done
 done
Installing libXcursor-1.1.14... done
Installing libXinerama-1.1.3,1...Installing xineramaproto-1.2.1... done
 done
Installing pango-1.34.1_2...Installing encodings-1.0.4_1,1...Installing 
font-util-1.3.0_1... done
 done
Installing harfbuzz-0.9.25_1...Installing graphite2-1.2.4... done
Installing icu-52.1... done
 done
Installing libXft-2.3.1... done
Installing xorg-fonts-truetype-7.7_1...Installing dejavu-2.34_3... done
Installing font-bh-ttf-1.0.3_1...Installing mkfontdir-1.0.7...Installing 
mkfontscale-1.1.1...Installing libfontenc-1.1.2... done
 done
 done
 done
Installing font-misc-ethiopic-1.0.3_1... done
Installing font-misc-meltho-1.0.3_1... done
 done
 done
Installing shared-mime-info-1.1... done
 done
Installing python-2.7_1,2...Installing python2-2_2... done
 done
 done
Installing polkit-0.105_2...Installing gobject-introspection-1.36.0_2... done
 done
 done
Installing gstreamer-plugins-0.10.36_3,3...Installing gstreamer-0.10.36... done
Installing libXv-1.0.10,1...Installing videoproto-2.3.2... done
 done
Installing orc-0.4.18... done
 done
Installing libmspack-0.4... done
Installing pangox-compat-0.0.2... done
Installing wx28-gtk2-contrib-common-2.8.12_2...Installing 
wx28-gtk2-common-2.8.12_2... done
 done
Installing wx28-gtk2-2.8.12_2... done
 done
Installing py27-wxPython28-common-2.8.12.1_3...Installing 
py27-opengl-3.0.1_4...Installing py27-imaging-1.1.7_2...Installing 
lcms-1.19_1,1... done
Installing py27-setuptools27-2.0.1... done
Installing py27-tkinter-2.7.6_4...Installing tk86-8.6.1...Installing 
libXScrnSaver-1.2.2...Installing scrnsaverproto-1.2.2... done
 done
Installing tcl86-8.6.1... done
 done
 done
 done
Installing py27-numpy-1.8.0_1,1...Installing py27-nose-1.3.0_1... done
Installing suitesparse-4.0.2_3... done
 done
 done
 done
 done
 done
====
Note that some of the standard modules are provided as separate
ports since they require extra dependencies:

bsddb           databases/py-bsddb
gdbm            databases/py-gdbm
sqlite3         databases/py-sqlite3
tkinter         x11-toolkits/py-tkinter

Install them as needed.
====
Since FreeBSD has new USB stack, freeglut normally doesn't build on FreeBSD 8
(yet). To workaround this a small patch adds one include file and comments out
content of one function (only leaves return NULL).

This might cause side effects.  Joysticks do not work, and there might be ports
that do not compile or applications that crash because of this.

Do not hesitate to contact x...@freebsd.org if there are any issues and side
effects because of this.
The PostgreSQL port has a collection of "side orders":

postgresql-docs
  For all of the html documentation

p5-Pg
  A perl5 API for client access to PostgreSQL databases.

postgresql-tcltk 
  If you want tcl/tk client support.

postgresql-jdbc
  For Java JDBC support.

postgresql-odbc
  For client access from unix applications using ODBC as access
  method. Not needed to access unix PostgreSQL servers from Win32
  using ODBC. See below.

ruby-postgres, py-PyGreSQL
  For client access to PostgreSQL databases using the ruby & python
  languages.

postgresql-plperl, postgresql-pltcl & postgresql-plruby
  For using perl5, tcl & ruby as procedural languages.

postgresql-contrib
  Lots of contributed utilities, postgresql functions and
  datatypes. There you find pg_standby, pgcrypto and many other cool
  things.

etc...
Make sure that the freetype module is loaded.  If it is not, add the following
line to the "Modules" section of your X Windows configuration file:

        Load "freetype"

Add the following line to the "Files" section of X Windows configuration file:

        FontPath "/usr/local/lib/X11/fonts/dejavu/"

Note: your X Windows configuration file is typically /etc/X11/XF86Config
if you are using XFree86, and /etc/X11/xorg.conf if you are using X.Org.
===>   Returning to build of gdal-grass-1.4.3_13
===>   gdal-grass-1.4.3_13 depends on executable: gmake - not found
===>    Verifying install for gmake in /usr/ports/devel/gmake
===>   Installing existing package /packages/All/gmake-3.82_1.txz
Installing gmake-3.82_1... done
===>   Returning to build of gdal-grass-1.4.3_13
===========================================================================
=======================<phase: lib-depends    >============================
===>   gdal-grass-1.4.3_13 depends on shared library: libgdal.so - found
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for gdal-grass-1.4.3_13
===>   FreeBSD 10 autotools fix applied to 
/wrkdirs/usr/ports/graphics/gdal-grass/work/gdal-grass-1.4.3/aclocal.m4
===>   FreeBSD 10 autotools fix applied to 
/wrkdirs/usr/ports/graphics/gdal-grass/work/gdal-grass-1.4.3/configure
configure: loading site script /usr/ports/Templates/config.site
checking for gcc... cc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables... 
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether cc accepts -g... yes
checking for cc option to accept ANSI C... none needed
checking whether we are using the GNU C++ compiler... yes
checking whether c++ accepts -g... yes
checking for ranlib... ranlib
./configure: gcc: not found
checking for c++ -shared ... yes
user supplied gdal-config (/usr/local/bin/gdal-config)
using /usr/local/lib/gdalplugins as GDAL shared library autoload directory
checking for G_asprintf in -lgrass_gis... no
configure: error: --with-grass=/usr/local/grass-6.4.2 requested, but libraries 
not found!  Perhaps you need to set LD_LIBRARY_PATH to include 
/usr/local/grass-6.4.2/lib?
===>  Script "configure" failed unexpectedly.
Please report the problem to po...@freebsd.org [maintainer] and attach the
"/wrkdirs/usr/ports/graphics/gdal-grass/work/gdal-grass-1.4.3/config.log"
including the output of the failure of your make command. Also, it might be
a good idea to provide an overview of all packages installed on your system
(e.g. a /usr/local/sbin/pkg-static info -g -Ea).
*** Error code 1

Stop.
make: stopped in /usr/ports/graphics/gdal-grass
===>  Cleaning for gdal-grass-1.4.3_13
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to