You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     thie...@freebsd.org
Last committer: thie...@freebsd.org
Ident:          $FreeBSD: head/graphics/cimg/Makefile 352142 2014-04-25 
17:49:34Z thierry $
Log URL:        
http://beefy1.isc.freebsd.org/bulk/84i386-default/2014-05-14_06h48m14s/logs/cimg-1.5.8_1,3.log
Build URL:      
http://beefy1.isc.freebsd.org/bulk/84i386-default/2014-05-14_06h48m14s
Log:

====>> Building graphics/cimg
build started at Wed May 14 17:22:39 UTC 2014
port directory: /usr/ports/graphics/cimg
building for: FreeBSD 84i386-default-job-19 8.4-RELEASE FreeBSD 8.4-RELEASE i386
maintained by: thie...@freebsd.org
Makefile ident:      $FreeBSD: head/graphics/cimg/Makefile 352142 2014-04-25 
17:49:34Z thierry $
Poudriere version: 3.1-pre
Host OSVERSION: 1100013
Jail OSVERSION: 804000

---Begin Environment---
UNAME_m=i386
UNAME_p=i386
OSVERSION=804000
UNAME_v=FreeBSD 8.4-RELEASE
UNAME_r=8.4-RELEASE
FTP_PASSIVE_MODE=YES
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
SAVED_TERM=
MASTERMNT=/usr/local/poudriere/data/build/84i386-default/ref
PKG_EXT=txz
tpid=59098
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
POUDRIERE_BUILD_TYPE=bulk
PKGNG=1
PKGNAME=cimg-1.5.8_1,3
PKG_DELETE=/usr/local/sbin/pkg-static delete -y -f
PKG_ADD=/usr/local/sbin/pkg-static add
OLDPWD=/usr/local/poudriere/data/build/84i386-default/ref/poudriere/rdeps
PWD=/usr/local/poudriere/data/build/84i386-default/ref/poudriere/pool
MASTERNAME=84i386-default
USER=root
HOME=/root
POUDRIERE_VERSION=3.1-pre
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
PKG_VERSION=/poudriere/pkg-static version
PKG_BIN=/usr/local/sbin/pkg-static
---End Environment---

---Begin OPTIONS List---
---End OPTIONS List---

--CONFIGURE_ARGS--

--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
TMPDIR="/tmp" MAKE=gmake TMPDIR="/tmp" SHELL=/bin/sh CONFIG_SHELL=/bin/sh
--End CONFIGURE_ENV--

--MAKE_ENV--
X11PATH=/usr/local LOCALBASE=/usr/local TMPDIR="/tmp" TMPDIR="/tmp" 
SHELL=/bin/sh NO_LINT=YES PREFIX=/usr/local  LOCALBASE=/usr/local  
LIBDIR="/usr/lib"  CC="cc" CFLAGS="-O2 -pipe -fno-strict-aliasing"  CPP="cpp" 
CPPFLAGS="-O2 -pipe -fno-strict-aliasing "  LDFLAGS=" -pthread"  CXX="c++" 
CXXFLAGS="-O2 -pipe -fno-strict-aliasing"  MANPREFIX="/usr/local" 
BSD_INSTALL_PROGRAM="install  -s -o root -g wheel -m 555"  
BSD_INSTALL_LIB="install  -s -o root -g wheel -m 444"  
BSD_INSTALL_SCRIPT="install  -o root -g wheel -m 555"  
BSD_INSTALL_DATA="install  -o root -g wheel -m 444"  BSD_INSTALL_MAN="install  
-o root -g wheel -m 444"
--End MAKE_ENV--

--PLIST_SUB--
OSREL=8.4
PREFIX=%D
LOCALBASE=/usr/local
PORTDOCS=""
PORTEXAMPLES=""
PORTDATA=""
LIB32DIR=lib
DOCSDIR="share/doc/cimg"
EXAMPLESDIR="share/examples/cimg"
DATADIR="share/cimg"
WWWDIR="www/cimg"
ETCDIR="etc/cimg"
--End PLIST_SUB--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/cimg
DOCSDIR=/usr/local/share/doc/cimg
EXAMPLESDIR=/usr/local/share/examples/cimg
WWWDIR=/usr/local/www/cimg
ETCDIR=/usr/local/etc/cimg
--End SUB_LIST--

---Begin make.conf---
ARCH=i386
MACHINE=i386
MACHINE_ARCH=i386
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
WITH_PKGNG=yes
NO_RESTRICTED=yes
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
===>  Cleaning for cimg-1.5.8_1,3
=======================<phase: check-sanity   >============================
===>  License CeCILL_C CeCILL accepted by the user
===========================================================================
=======================<phase: pkg-depends    >============================
===>   cimg-1.5.8_1,3 depends on file: /usr/local/sbin/pkg - not found
===>    Verifying install for /usr/local/sbin/pkg in /usr/ports/ports-mgmt/pkg
===>   Installing existing package /packages/All/pkg-1.2.7_2.txz
Installing pkg-1.2.7_2... done
If you are upgrading from the old package format, first run:

  # pkg2ng
===>   Returning to build of cimg-1.5.8_1,3
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===>  License CeCILL_C CeCILL accepted by the user
===> Fetching all distfiles required by cimg-1.5.8_1,3 for building
===========================================================================
=======================<phase: checksum       >============================
===>  License CeCILL_C CeCILL accepted by the user
===> Fetching all distfiles required by cimg-1.5.8_1,3 for building
=> SHA256 Checksum OK for cimg-1.5.8_1/CImg-1.5.8.zip.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===>  License CeCILL_C CeCILL accepted by the user
===> Fetching all distfiles required by cimg-1.5.8_1,3 for building
===>  Extracting for cimg-1.5.8_1,3
=> SHA256 Checksum OK for cimg-1.5.8_1/CImg-1.5.8.zip.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for cimg-1.5.8_1,3
===>  Applying FreeBSD patches for cimg-1.5.8_1,3
===========================================================================
=======================<phase: build-depends  >============================
===>   cimg-1.5.8_1,3 depends on executable: gmake - not found
===>    Verifying install for gmake in /usr/ports/devel/gmake
===>   Installing existing package /packages/All/gmake-3.82_1.txz
Installing gmake-3.82_1...Installing gettext-0.18.3.1_1...Installing 
libiconv-1.14_3... done
 done
 done
===>   Returning to build of cimg-1.5.8_1,3
===========================================================================
=======================<phase: lib-depends    >============================
===>   cimg-1.5.8_1,3 depends on shared library: libboard.so - not found
===>    Verifying for libboard.so in /usr/ports/graphics/libboard
===>   Installing existing package /packages/All/libboard-0.9.0_1.txz
Installing libboard-0.9.0_1... done
===>   Returning to build of cimg-1.5.8_1,3
===>   cimg-1.5.8_1,3 depends on shared library: libpng15.so - not found
===>    Verifying for libpng15.so in /usr/ports/graphics/png
===>   Installing existing package /packages/All/png-1.5.18.txz
Installing png-1.5.18... done
===>   Returning to build of cimg-1.5.8_1,3
===>   cimg-1.5.8_1,3 depends on shared library: libjpeg.so - not found
===>    Verifying for libjpeg.so in /usr/ports/graphics/jpeg
===>   Installing existing package /packages/All/jpeg-8_5.txz
Installing jpeg-8_5... done
===>   Returning to build of cimg-1.5.8_1,3
===>   cimg-1.5.8_1,3 depends on shared library: libtiff.so - not found
===>    Verifying for libtiff.so in /usr/ports/graphics/tiff
===>   Installing existing package /packages/All/tiff-4.0.3_2.txz
Installing tiff-4.0.3_2...Installing freeglut-2.8.1_2...Installing 
libGLU-9.0.0...Installing libGL-7.6.1_4...Installing dri2proto-2.8... done
Installing expat-2.1.0... done
Installing libX11-1.6.2_2,1...Installing kbproto-1.0.6... done
Installing libXau-1.0.8_2...Installing xproto-7.0.25... done
 done
Installing libXdmcp-1.1.1_2... done
Installing libxcb-1.10_2...Installing libpthread-stubs-0.3_4... done
Installing libxml2-2.9.1... done
 done
 done
Installing libXdamage-1.1.4_2...Installing damageproto-1.2.1... done
Installing libXfixes-5.0.1_2...Installing fixesproto-5.0... done
 done
 done
Installing libXext-1.3.2_2,1...Installing xextproto-7.3.0... done
 done
Installing libXxf86vm-1.1.3_2...Installing xf86vidmodeproto-2.3.1... done
 done
Installing libdrm-2.4.17_1...Installing libpciaccess-0.13.2_2...Installing 
pciids-20140502... done
 done
 done
 done
 done
Installing libICE-1.0.8_2,1... done
Installing libXi-1.7.2_2,1...Installing inputproto-2.3... done
 done
Installing libXrandr-1.4.2_2...Installing libXrender-0.9.8_2...Installing 
renderproto-0.11.1... done
 done
Installing randrproto-1.4.0... done
 done
 done
Installing jbigkit-1.6... done
Installing libSM-1.2.2_2,1... done
Installing libXmu-1.1.2_2,1...Installing libXt-1.1.4_2,1... done
 done
<snip>
 done
Installing iso-codes-3.51... done
Installing lcms2-2.6_1... done
Installing libart_lgpl-2.3.21,1... done
Installing libmng-1.0.10_2...Installing lcms-1.19_3,1... done
 done
Installing libwmf-0.2.8.4_11... done
Installing poppler-glib-0.24.5_1...Installing poppler-data-0.4.6... done
Installing poppler-0.24.5_3...Installing openjpeg-1.5.0_2... done
 done
 done
Installing webkit-gtk2-1.8.3_3...Installing curl-7.36.0... done
Installing enchant-1.6.0_3...Installing hunspell-1.3.2_4... done
 done
Installing gstreamer-plugins-0.10.36_4,3...Installing gstreamer-0.10.36_2... 
done
Installing libXv-1.0.10_2,1...Installing videoproto-2.3.2... done
 done
Installing orc-0.4.19_2... done
 done
 done
 done
====
Note that some of the standard modules are provided as separate
ports since they require extra dependencies:

bsddb           databases/py-bsddb
gdbm            databases/py-gdbm
sqlite3         databases/py-sqlite3
tkinter         x11-toolkits/py-tkinter

Install them as needed.
====
Make sure that the freetype module is loaded.  If it is not, add the following
line to the "Modules" section of your X Windows configuration file:

        Load "freetype"

Add the following line to the "Files" section of X Windows configuration file:

        FontPath "/usr/local/lib/X11/fonts/dejavu/"

Note: your X Windows configuration file is typically /etc/X11/XF86Config
if you are using XFree86, and /etc/X11/xorg.conf if you are using X.Org.
You have built the Boost library with thread support.

Don't forget to add -pthread to your linker options when
linking your code.
------------------------------------------------------------------------------
 Your SDL library has been built with libvgl support, which means that you
 can run almost any SDL application straight on your console (VESA 2.0
 compatible videocard is required).

 To do this you have to load the vesa kernel module or enable it in your
 kernel, and set environment variable "SDL_VIDEODRIVER=vgl".
------------------------------------------------------------------------------
======================================================================

bash requires fdescfs(5) mounted on /dev/fd

If you have not done it yet, please do the following:

        mount -t fdescfs fdesc /dev/fd

To make it permanent, you need the following lines in /etc/fstab:

        fdesc   /dev/fd         fdescfs         rw      0       0

======================================================================
The following catalogs are installed:

 1) /usr/local/share/sgml/catalog

   The top level catalog for SGML stuff.  It is not changed
   by any ports/packages except textproc/xmlcatmgr.

 2) /usr/local/share/sgml/catalog.ports

   This catalog is for handling SGML stuff installed under
   /usr/local/share/sgml.  It is changed by ports/packages.

 3) /usr/local/share/xml/catalog

   The top level catalog for XML stuff.  It is not changed
   by any ports/packages except textproc/xmlcatmgr.

 4) /usr/local/share/xml/catalog.ports

   This catalog is for handling XML stuff installed under
   /usr/local/share/xml.  It is changed by ports/packages.
===>   Returning to build of cimg-1.5.8_1,3
===>   cimg-1.5.8_1,3 depends on shared library: libfftw3.so - not found
===>    Verifying for libfftw3.so in /usr/ports/math/fftw3
===>   Installing existing package /packages/All/fftw3-3.3.3_1.txz
Installing fftw3-3.3.3_1... done
===>   Returning to build of cimg-1.5.8_1,3
===>   cimg-1.5.8_1,3 depends on shared library: libopencv_legacy.so - not found
===>    Verifying for libopencv_legacy.so in /usr/ports/graphics/opencv
===>   Installing existing package /packages/All/opencv-2.4.7_1.txz
Installing opencv-2.4.7_1...Installing libv4l-0.8.8_1... done
Installing opencv-core-2.4.7_1... done
 done
===>   Returning to build of cimg-1.5.8_1,3
===>   cimg-1.5.8_1,3 depends on shared library: libopencv_core.so - found
===>   cimg-1.5.8_1,3 depends on shared library: libGraphicsMagick.so.14 - not 
found
===>    Verifying for libGraphicsMagick.so.14 in 
/usr/ports/graphics/GraphicsMagick13
===>   Installing existing package /packages/All/GraphicsMagick13-1.3.19_6.txz
Installing GraphicsMagick13-1.3.19_6...Installing dgs-0.5.9.1_12...Installing 
ghostscript9-9.06_6...Installing cups-image-1.7.2...===> Creating users and/or 
groups.
Using existing group 'cups'.
Using existing user 'cups'.
 done
Installing gsfonts-8.11_6... done
Installing jbig2dec-0.11_1... done
Installing libidn-1.28_1... done
Installing libpaper-1.1.24_1... done
Installing svgalib-1.4.3_7... done
 done
Installing glib12-1.2.10_13... done
 done
Installing webp-0.4.0...Installing giflib-nox11-4.2.3_2... done
 done
 done
Note: in order to use the script "dvipdf", dvips must be installed.
This program may be provided by either print/dvips or print/dvipsk-tetex
(print/dvipsk-tetex may be preferable since it doesn't conflict with
tetex things).

FAPIfontmap and FAPIcidfmap in /usr/local/share/ghostscript/9.06/Resource/Init
have to be configured if you want to use FAPI feature.
===>   Returning to build of cimg-1.5.8_1,3
===>   cimg-1.5.8_1,3 depends on shared library: libavformat.so - not found
===>    Verifying for libavformat.so in /usr/ports/multimedia/ffmpeg
===>   Installing existing package /packages/All/ffmpeg-2.1.1_3,1.txz
Installing ffmpeg-2.1.1_3,1...Installing libtheora-1.1.1_5...Installing 
libvorbis-1.3.4,3...Installing libogg-1.3.1,4... done
 done
 done
Installing libvpx-1.3.0... done
Installing schroedinger-1.0.11_1... done
Installing x264-0.136.2358_3...Installing gpac-libgpac-0.5.0,1... done
 done
Installing xvid-1.3.2,1... done
 done
===>   Returning to build of cimg-1.5.8_1,3
===>   cimg-1.5.8_1,3 depends on shared library: libblas.so - not found
===>    Verifying for libblas.so in /usr/ports/math/blas
===>   Installing existing package /packages/All/blas-3.4.2_2.txz
Installing blas-3.4.2_2...Installing gcc-4.7.3_1...Installing binutils-2.24... 
done
Installing gcc-ecj-4.5... done
Installing mpc-1.0.2...Installing mpfr-3.1.2_2... done
 done
 done
 done
To ensure binaries built with this toolchain find appropriate versions
of the necessary run-time libraries, you may want to link using

  -Wl,-rpath=/usr/local/lib/gcc47

For ports leveraging USE_GCC, USES=compiler, or USES=fortran this happens
transparently.
===>   Returning to build of cimg-1.5.8_1,3
===>   cimg-1.5.8_1,3 depends on shared library: liblapack.so - not found
===>    Verifying for liblapack.so in /usr/ports/math/lapack
===>   Installing existing package /packages/All/lapack-3.4.2_2.txz
Installing lapack-3.4.2_2... done
===>   Returning to build of cimg-1.5.8_1,3
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for cimg-1.5.8_1,3
/usr/bin/sed -i "" -e 's|make|gmake|' 
/wrkdirs/usr/ports/graphics/cimg/work/CImg-1.5.8/examples/Makefile
/usr/bin/sed -i "" -e 's|#CIMG_FFMPEG_CFLAGS|CIMG_FFMPEG_CFLAGS|'        -e 
's|#CIMG_FFMPEG_LDFLAGS|CIMG_FFMPEG_LDFLAGS|'        
/wrkdirs/usr/ports/graphics/cimg/work/CImg-1.5.8/examples/Makefile
/usr/bin/sed -i "" -e 's|#CIMG_LAPACK_CFLAGS|CIMG_LAPACK_CFLAGS|'        -e 
's|#CIMG_LAPACK_LDFLAGS|CIMG_LAPACK_LDFLAGS|'        -e 's|-lblas 
-llapack|-L/usr/local/lib -llapack -lblas|'                        
/wrkdirs/usr/ports/graphics/cimg/work/CImg-1.5.8/examples/Makefile
/usr/bin/sed -i "" -e 's|-pedantic|-O2 -pipe -fno-strict-aliasing|'             
         -e 's|-lpthread|-pthread|' 
/wrkdirs/usr/ports/graphics/cimg/work/CImg-1.5.8/examples/Makefile
===========================================================================
=======================<phase: build          >============================
===>  Building for cimg-1.5.8_1,3
gmake[1]: Entering directory 
`/wrkdirs/usr/ports/graphics/cimg/work/CImg-1.5.8/examples'

** Compiling 'CImg_demo (1.5.8)' with 'c++'

c++ -o CImg_demo CImg_demo.cpp -I.. -Wall -W -O2 -pipe -fno-strict-aliasing  
-Dcimg_use_vt100 -I/usr/local/include  -Dcimg_use_xrandr -Dcimg_use_tiff 
-Dcimg_use_openexr -I//usr/local/include/OpenEXR -Dcimg_use_png -Dcimg_use_jpeg 
-Dcimg_use_zlib -Dcimg_use_opencv -I/usr/local/include/opencv -Dcimg_use_magick 
-I/usr/local/include/GraphicsMagick -O2 -pipe -fno-strict-aliasing 
-D_THREAD_SAFE -Dcimg_use_lapack -Dcimg_use_fftw3  -pthread -lm -lm 
-L/usr/local/lib -lX11   -lXrandr -ltiff -ltiffxx -ltiffxx -lIlmImf -lHalf 
-lpng -lz -ljpeg -lz -L/usr/local/lib -llapack -lblas -lopencv_core 
-lopencv_highgui -L/usr/local/lib -L/usr/local/lib -L/usr/local/lib 
-L/usr/local/lib -lGraphicsMagick++ -lGraphicsMagick -ljbig -lwebp -llcms2 
-ltiff -lfreetype -ljasper -ljpeg -lpng15 -lwmflite -ldpstk -ldps -lXt -lXext 
-lSM -lICE -lX11 -llzma -lbz2 -lxml2 -lz -lm -lgomp -pthread -lfftw3 
-lfftw3_threads
/usr/local/lib/gcc47/libgfortran.so.3: undefined reference to 
`__subtf3@GCC_4.6.0'
/usr/local/lib/gcc47/libgfortran.so.3: undefined reference to 
`__letf2@GCC_4.6.0'
/usr/local/lib/gcc47/libgfortran.so.3: undefined reference to 
`__lttf2@GCC_4.6.0'
/usr/local/lib/gcc47/libgfortran.so.3: undefined reference to 
`__netf2@GCC_4.6.0'
/usr/local/lib/gcc47/libgfortran.so.3: undefined reference to 
`__unordtf2@GCC_4.6.0'
/usr/local/lib/gcc47/libgfortran.so.3: undefined reference to 
`__trunctfdf2@GCC_4.6.0'
/usr/local/lib/gcc47/libgfortran.so.3: undefined reference to 
`__gttf2@GCC_4.6.0'
/usr/local/lib/gcc47/libgfortran.so.3: undefined reference to 
`__floatsitf@GCC_4.6.0'
/usr/local/lib/gcc47/libgfortran.so.3: undefined reference to 
`__eqtf2@GCC_4.6.0'
/usr/local/lib/gcc47/libgfortran.so.3: undefined reference to 
`__divtf3@GCC_4.6.0'
/usr/local/lib/gcc47/libgfortran.so.3: undefined reference to 
`__floatunditf@GCC_4.6.0'
/usr/local/lib/gcc47/libgfortran.so.3: undefined reference to 
`__multf3@GCC_4.6.0'
/usr/local/lib/gcc47/libgfortran.so.3: undefined reference to 
`__addtf3@GCC_4.6.0'
/usr/local/lib/gcc47/libgfortran.so.3: undefined reference to 
`__getf2@GCC_4.6.0'
gmake[1]: *** [CImg_demo] Error 1
gmake[1]: Leaving directory 
`/wrkdirs/usr/ports/graphics/cimg/work/CImg-1.5.8/examples'
gmake: *** [Mlinux] Error 2
*** Error code 1

Stop in /usr/ports/graphics/cimg.
===>  Cleaning for cimg-1.5.8_1,3
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to