You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     ecli...@freebsd.org
Last committer: bdrew...@freebsd.org
Ident:          $FreeBSD: head/java/eclipse/Makefile 317757 2013-05-10 
01:46:52Z bdrewery $
Log URL:        
http://beefy1.isc.freebsd.org/bulk/91i386-default/2013-09-18_11h01m08s/logs/eclipse-3.7.1_4.log
Build URL:      
http://beefy1.isc.freebsd.org/bulk/91i386-default/2013-09-18_11h01m08s
Log:

====>> Building java/eclipse
build started at Wed Sep 18 14:28:39 UTC 2013
port directory: /usr/ports/java/eclipse
building for: FreeBSD 91i386-default-job-15 9.1-RELEASE FreeBSD 9.1-RELEASE i386
maintained by: ecli...@freebsd.org
Makefile ident:      $FreeBSD: head/java/eclipse/Makefile 317757 2013-05-10 
01:46:52Z bdrewery $
Poudriere version: 3.1-pre

---Begin Environment---
UNAME_m=i386
UNAME_p=i386
OSVERSION=901000
UNAME_v=FreeBSD 9.1-RELEASE
UNAME_r=9.1-RELEASE
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
MASTERMNT=/usr/local/poudriere/data/build/91i386-default/ref
PKG_EXT=txz
tpid=81679
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
POUDRIERE_BUILD_TYPE=bulk
NBPARALLEL=24
PKGNG=1
PKGNAME=eclipse-3.7.1_4
PKG_DELETE=/usr/local/sbin/pkg delete -y -f
PKG_ADD=/usr/local/sbin/pkg add
PWD=/root
MASTERNAME=91i386-default
USER=root
HOME=/root
POUDRIERE_VERSION=3.1-pre
SKIPSANITY=0
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
---End Environment---

---Begin OPTIONS List---
===> The following configuration options are available for eclipse-3.7.1_4:
     TESTS=off: Build SDK test suite
===> Use 'make config' to modify these settings
---End OPTIONS List---

--CONFIGURE_ARGS--

--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
TMPDIR="/tmp" TMPDIR="/tmp" PKG_CONFIG=pkgconf MAKE=gmake SHELL=/bin/sh 
CONFIG_SHELL=/bin/sh ESD_CONFIG="/usr/local/bin/esd-config"
--End CONFIGURE_ENV--

--MAKE_ENV--
GRE_HOME=/usr/local/lib/ _JAVA_OPTIONS="-Xmx1024m" JAVA_VENDOR=openjdk 
TMPDIR="/tmp" TMPDIR="/tmp" JAVA_HOME=/usr/local/openjdk6 SHELL=/bin/sh 
NO_LINT=YES ESD_CONFIG="/usr/local/bin/esd-config" PREFIX=/usr/local  
LOCALBASE=/usr/local  LIBDIR="/usr/lib"  CC="cc" CFLAGS="-O2 -pipe 
-fno-strict-aliasing"  CPP="cpp" CPPFLAGS=""  LDFLAGS=""  CXX="c++" 
CXXFLAGS="-O2 -pipe -fno-strict-aliasing"  MANPREFIX="/usr/local" 
BSD_INSTALL_PROGRAM="install  -s -o root -g wheel -m 555"  
BSD_INSTALL_LIB="install  -s -o root -g wheel -m 444"  
BSD_INSTALL_SCRIPT="install  -o root -g wheel -m 555"  
BSD_INSTALL_DATA="install  -o root -g wheel -m 444"  BSD_INSTALL_MAN="install  
-o root -g wheel -m 444"
--End MAKE_ENV--

--SUB_LIST--
JAVASHAREDIR="/usr/local/share/java"
JAVAJARDIR="/usr/local/share/java/classes"
JAVALIBDIR="/usr/local/share/java/classes"
JAVA_VERSION="1.6"
JAVA_VENDOR="openjdk"
JAVA_OS="native"
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/eclipse
DOCSDIR=/usr/local/share/doc/eclipse
EXAMPLESDIR=/usr/local/share/examples/eclipse
WWWDIR=/usr/local/www/eclipse
ETCDIR=/usr/local/etc/eclipse
--End SUB_LIST--

---Begin make.conf---
ARCH=i386
MACHINE=i386
MACHINE_ARCH=i386
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
WITH_PKGNG=yes
NO_RESTRICTED=yes
DISABLE_MAKE_JOBS=yes
---End make.conf---
===>  Cleaning for eclipse-3.7.1_4
=======================<phase: check-config   >============================
===========================================================================
=======================<phase: pkg-depends    >============================
===>   eclipse-3.7.1_4 depends on file: /usr/local/sbin/pkg - not found
===>    Verifying install for /usr/local/sbin/pkg in /usr/ports/ports-mgmt/pkg
===>   Installing existing package /packages/All/pkg-1.1.4_2.txz
Installing pkg-1.1.4_2... done
If you are upgrading from the old package format, first run:

  # pkg2ng
===>   Returning to build of eclipse-3.7.1_4
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===> Fetching all distfiles required by eclipse-3.7.1_4 for building
===========================================================================
=======================<phase: checksum       >============================
===> Fetching all distfiles required by eclipse-3.7.1_4 for building
=> SHA256 Checksum OK for 
eclipse/eclipse-build-914dc6de2bfc5ee5819a229cf4877f7043040a92.tar.xz.
=> SHA256 Checksum OK for eclipse/eclipse-3.7.1-src.tar.bz2.
=> SHA256 Checksum OK for eclipse/apache-ant-1.8.2-bin.tar.bz2.
=> SHA256 Checksum OK for eclipse/junit3.8.2.zip.
=> SHA256 Checksum OK for eclipse/junit-4.8.2.jar.
=> SHA256 Checksum OK for eclipse/apache-tomcat-7.0.25.tar.gz.
=> SHA256 Checksum OK for eclipse/tomcat-juli.jar.
=> SHA256 Checksum OK for eclipse/com.ibm.icu_4.4.2.v20110208.jar.
=> SHA256 Checksum OK for eclipse/com.jcraft.jsch_0.1.41.v201101211617.jar.
=> SHA256 Checksum OK for 
eclipse/org.apache.commons.codec_1.3.0.v201101211617.jar.
=> SHA256 Checksum OK for eclipse/org.apache.commons.el_1.0.0.v201101211617.jar.
=> SHA256 Checksum OK for 
eclipse/org.apache.commons.httpclient_3.1.0.v201012070820.jar.
=> SHA256 Checksum OK for 
eclipse/org.apache.commons.logging_1.0.4.v201101211617.jar.
=> SHA256 Checksum OK for 
eclipse/org.apache.lucene.core_2.9.1.v201101211721.jar.
=> SHA256 Checksum OK for 
eclipse/org.apache.lucene.analysis_2.9.1.v201101211721.jar.
=> SHA256 Checksum OK for eclipse/org.hamcrest.core_1.1.0.v20090501071000.jar.
=> SHA256 Checksum OK for 
eclipse/org.mortbay.jetty.util_6.1.23.v201012071420.jar.
=> SHA256 Checksum OK for 
eclipse/org.mortbay.jetty.server_6.1.23.v201012071420.jar.
=> SHA256 Checksum OK for eclipse/org.objectweb.asm_3.3.1.v201105211655.jar.
=> SHA256 Checksum OK for eclipse/org.sat4j.core_2.3.0.v20110329.jar.
=> SHA256 Checksum OK for eclipse/org.sat4j.pb_2.3.0.v20110329.jar.
===========================================================================
=======================<phase: extract-depends>============================
===>   eclipse-3.7.1_4 depends on file: /usr/local/bin/unzip - not found
===>    Verifying install for /usr/local/bin/unzip in /usr/ports/archivers/unzip
===>   Installing existing package /packages/All/unzip-6.0_1.txz
Installing unzip-6.0_1... done
===>   Returning to build of eclipse-3.7.1_4
===========================================================================
=======================<phase: extract        >============================
===> Fetching all distfiles required by eclipse-3.7.1_4 for building
===>  Extracting for eclipse-3.7.1_4
=> SHA256 Checksum OK for 
eclipse/eclipse-build-914dc6de2bfc5ee5819a229cf4877f7043040a92.tar.xz.
=> SHA256 Checksum OK for eclipse/eclipse-3.7.1-src.tar.bz2.
=> SHA256 Checksum OK for eclipse/apache-ant-1.8.2-bin.tar.bz2.
=> SHA256 Checksum OK for eclipse/junit3.8.2.zip.
=> SHA256 Checksum OK for eclipse/junit-4.8.2.jar.
=> SHA256 Checksum OK for eclipse/apache-tomcat-7.0.25.tar.gz.
=> SHA256 Checksum OK for eclipse/tomcat-juli.jar.
=> SHA256 Checksum OK for eclipse/com.ibm.icu_4.4.2.v20110208.jar.
=> SHA256 Checksum OK for eclipse/com.jcraft.jsch_0.1.41.v201101211617.jar.
=> SHA256 Checksum OK for 
eclipse/org.apache.commons.codec_1.3.0.v201101211617.jar.
=> SHA256 Checksum OK for eclipse/org.apache.commons.el_1.0.0.v201101211617.jar.
=> SHA256 Checksum OK for 
eclipse/org.apache.commons.httpclient_3.1.0.v201012070820.jar.
=> SHA256 Checksum OK for 
eclipse/org.apache.commons.logging_1.0.4.v201101211617.jar.
=> SHA256 Checksum OK for 
eclipse/org.apache.lucene.core_2.9.1.v201101211721.jar.
=> SHA256 Checksum OK for 
eclipse/org.apache.lucene.analysis_2.9.1.v201101211721.jar.
=> SHA256 Checksum OK for eclipse/org.hamcrest.core_1.1.0.v20090501071000.jar.
=> SHA256 Checksum OK for 
eclipse/org.mortbay.jetty.util_6.1.23.v201012071420.jar.
=> SHA256 Checksum OK for 
eclipse/org.mortbay.jetty.server_6.1.23.v201012071420.jar.
=> SHA256 Checksum OK for eclipse/org.objectweb.asm_3.3.1.v201105211655.jar.
=> SHA256 Checksum OK for eclipse/org.sat4j.core_2.3.0.v20110329.jar.
=> SHA256 Checksum OK for eclipse/org.sat4j.pb_2.3.0.v20110329.jar.
===========================================================================
=======================<phase: patch-depends  >============================
===>   eclipse-3.7.1_4 depends on executable: ant - not found
===>    Verifying install for ant in /usr/ports/devel/apache-ant
===>   Installing existing package /packages/All/apache-ant-1.8.4.txz
Installing apache-ant-1.8.4...Installing xproto-7.0.24... done
Installing xextproto-7.2.1... done
Installing xbitmaps-1.1.1... done
Installing renderproto-0.11.1... done
Installing recordproto-1.14.2... done
Installing printproto-1.0.5... done
Installing libxcb-1.9.1...Installing libXdmcp-1.1.1... done
Installing libXau-1.0.8... done
Installing libxml2-2.8.0_2...Installing pkgconf-0.9.3... done
Installing libiconv-1.14_1... done
 done
Installing libpthread-stubs-0.3_3... done
 done
Installing libXtst-1.2.2...Installing libXi-1.7.2,1...Installing 
libXfixes-5.0.1...Installing libX11-1.6.1,1...Installing kbproto-1.0.6... done
 done
Installing fixesproto-5.0... done
 done
Installing libXext-1.3.2,1... done
Installing inputproto-2.3... done
 done
 done
Installing libXrender-0.9.8... done
Installing libXpm-3.5.10...Installing libSM-1.2.1,1...Installing 
libICE-1.0.8,1... done
 done
Installing libXt-1.1.4,1... done
 done
Installing libXp-1.0.2,1... done
Installing open-motif-2.3.4...Installing libXmu-1.1.1,1... done
Installing libXaw-1.0.11,2... done
Installing libXft-2.3.1...Installing fontconfig-2.10.93,1...Installing 
expat-2.1.0... done
Installing freetype2-2.4.12_1... done
Running fc-cache to build fontconfig cache...
/usr/local/share/fonts: skipping, no such directory
/usr/local/lib/X11/fonts: caching, new cache contents: 0 fonts, 1 dirs
/usr/local/lib/X11/fonts/local: caching, new cache contents: 0 fonts, 0 dirs
/root/.local/share/fonts: skipping, no such directory
<snip>
Installing hal-0.5.14_20...Installing dmidecode-2.12... done
Installing consolekit-0.4.3... done
Installing libvolume_id-0.81.1... done
===> Creating users and/or groups.
Creating group 'haldaemon' with gid '560'.
Creating user 'haldaemon' with uid '560'.
 done
Installing samba36-libsmbclient-3.6.18...Installing tevent-0.9.18...Installing 
talloc-2.0.8... done
 done
Installing libexecinfo-1.1_3... done
Installing tdb-1.2.12,1... done
 done
Installing avahi-app-0.6.31...Installing libdaemon-0.14... done
Installing gdbm-1.10... done
===> Creating users and/or groups.
Creating group 'avahi' with gid '558'.
Creating user 'avahi' with uid '558'.
 done
Installing gamin-0.1.10_6... done
 done
===============================================================================

Gamin will only provide realtime notification of changes for at most n files,
where n is the minimum value between (kern.maxfiles * 0.7) and
(kern.maxfilesperproc - 200). Beyond that limit, files will be polled.

If you often open several large folders with Nautilus, you might want to
increase the kern.maxfiles tunable (you do not need to set
kern.maxfilesperproc, since it is computed at boot time from kern.maxfiles).

For a typical desktop, add the following line to /boot/loader.conf, then
reboot the system:

    kern.maxfiles="25000"

The behavior of gamin can be controlled via the various gaminrc files.
See http://www.gnome.org/~veillard/gamin/config.html on how to create
these files.  In particular, if you find gam_server is taking up too much
CPU time polling for changes, something like the following may help
in one of the gaminrc files:

# reduce polling frequency to once per 10 seconds
# for UFS file systems in order to lower CPU load
fsset ufs poll 10

===============================================================================
===>   Returning to build of eclipse-3.7.1_4
===>   eclipse-3.7.1_4 depends on shared library: gtk-x11-2.0.0 - found
===>   eclipse-3.7.1_4 depends on shared library: art_lgpl_2.5 - not found
===>    Verifying install for art_lgpl_2.5 in /usr/ports/graphics/libart_lgpl
===>   Installing existing package /packages/All/libart_lgpl-2.3.21,1.txz
Installing libart_lgpl-2.3.21,1... done
===>   Returning to build of eclipse-3.7.1_4
===>   eclipse-3.7.1_4 depends on shared library: bonobo-2.0 - not found
===>    Verifying install for bonobo-2.0 in /usr/ports/devel/libbonobo
===>   Installing existing package /packages/All/libbonobo-2.32.0.txz
Installing libbonobo-2.32.0...Installing popt-1.16... done
 done
===>   Returning to build of eclipse-3.7.1_4
===>   eclipse-3.7.1_4 depends on shared library: bonoboui-2.0 - not found
===>    Verifying install for bonoboui-2.0 in 
/usr/ports/x11-toolkits/libbonoboui
===>   Installing existing package /packages/All/libbonoboui-2.24.4_1.txz
Installing libbonoboui-2.24.4_1...Installing libgnome-2.32.0_1...Installing 
xmlcharent-0.3_2...Installing xmlcatmgr-2.2... + Creating 
/usr/local/share/sgml/catalog
 + Registering CATALOG catalog.ports (SGML)
 + Creating /usr/local/share/sgml/catalog.ports
 + Creating /usr/local/share/xml/catalog
 + Registering nextCatalog catalog.ports (XML)
 + Creating /usr/local/share/xml/catalog.ports
 done
 done
Installing rarian-0.8.1...Installing iso8879-1986_3... done
Installing docbook-xsl-1.76.1_1...Installing docbook-xml-4.5... done
Installing docbook-xml-4.4_1... done
Installing docbook-xml-4.3... done
Installing docbook-xml-4.2_1... done
Installing docbook-sk-4.1.2_4... done
Installing docbook-5.0_1... done
Installing docbook-4.5_2... done
Installing docbook-4.4_2... done
Installing docbook-4.3... done
Installing docbook-4.2... done
Installing docbook-4.1_4... done
Installing docbook-1.4_1... done
 done
Installing bash-4.2.45... done
Installing getopt-1.1.5... done
 done
Installing libltdl-2.4.2_1... done
Installing libvorbis-1.3.3_1,3...Installing libogg-1.3.1,4... done
 done
Installing libcanberra-0.28_3... done
 done
Installing libgnomecanvas-2.30.3_1...Installing libglade2-2.6.4_5... done
 done
 done
The following catalogs are installed:

 1) /usr/local/share/sgml/catalog

   The top level catalog for SGML stuff.  It is not changed
   by any ports/packages except textproc/xmlcatmgr.

 2) /usr/local/share/sgml/catalog.ports

   This catalog is for handling SGML stuff installed under
   /usr/local/share/sgml.  It is changed by ports/packages.

 3) /usr/local/share/xml/catalog

   The top level catalog for XML stuff.  It is not changed
   by any ports/packages except textproc/xmlcatmgr.

 4) /usr/local/share/xml/catalog.ports

   This catalog is for handling XML stuff installed under
   /usr/local/share/xml.  It is changed by ports/packages.
===>   Returning to build of eclipse-3.7.1_4
===>   eclipse-3.7.1_4 depends on shared library: glade-2.0.0 - found
===>   eclipse-3.7.1_4 depends on shared library: gnome-2.0 - found
===>   eclipse-3.7.1_4 depends on shared library: gnomecanvas-2.0 - found
===>   eclipse-3.7.1_4 depends on shared library: gnomeui-2.0 - not found
===>    Verifying install for gnomeui-2.0 in /usr/ports/x11-toolkits/libgnomeui
===>   Installing existing package /packages/All/libgnomeui-2.24.4_2.txz
Installing libgnomeui-2.24.4_2...Installing startup-notification-0.12_1... done
Installing py27-libxml2-2.8.0... done
Installing gnome-doc-utils-0.20.10... done
Installing policykit-gnome-0.9.2_6... done
Installing libcdio-0.83_2...Installing libcddb-1.3.2_1... done
Installing cdparanoia-3.9.8_9... done
 done
Installing gnome-mount-0.8_11...Installing libgnome-keyring-2.32.0_5... done
Installing libnotify-0.7.5... done
 done
Installing gnome-keyring-2.32.1_3... done
Installing gnome-icon-theme-3.6.2... done
Installing libgphoto2-2.4.14_3...Installing libexif-0.6.21... done
 done
Installing libsoup-gnome-2.40.3_3... done
Installing gvfs-1.12.3_1... done
 done
===>   Returning to build of eclipse-3.7.1_4
===>   eclipse-3.7.1_4 depends on shared library: IDL-2.0 - found
===>   eclipse-3.7.1_4 depends on shared library: xml2.5 - found
===>   eclipse-3.7.1_4 depends on shared library: ORBit-2.0 - found
===>   eclipse-3.7.1_4 depends on shared library: pango-1.0 - found
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for eclipse-3.7.1_4
===========================================================================
=======================<phase: build          >============================
===>  Building for eclipse-3.7.1_4
Picked up _JAVA_OPTIONS: -Xmx1024m
Buildfile: 
/wrkdirs/usr/ports/java/eclipse/work/eclipse-build-914dc6de2bfc5ee5819a229cf4877f7043040a92/build.xml
     [echo] Build log is available in build_20130918143051.log
     [echo] uname -m: i386. Build eclipse on x86 for x86.

fetch:

setLib64Dir:

setLibDir:

symlinkBuildFeature:

symlinkBuildConfig:

unpack:

insertBuildId:

applyPatches:

buildHelperTask:
    [mkdir] Created dir: 
/wrkdirs/usr/ports/java/eclipse/work/eclipse-build-914dc6de2bfc5ee5819a229cf4877f7043040a92/task-bin
    [javac] 
/wrkdirs/usr/ports/java/eclipse/work/eclipse-build-914dc6de2bfc5ee5819a229cf4877f7043040a92/build.xml:379:
 warning: 'includeantruntime' was not set, defaulting to 
build.sysclasspath=last; set to false for repeatable builds
    [javac] Compiling 4 source files to 
/wrkdirs/usr/ports/java/eclipse/work/eclipse-build-914dc6de2bfc5ee5819a229cf4877f7043040a92/task-bin

defineTasks:

symlinkDeps:
#
# A fatal error has been detected by the Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0x76dcd4a8, pid=28813, tid=676315136
#
# JRE version: 6.0_32-b27
# Java VM: OpenJDK Server VM (20.0-b12 mixed mode bsd-x86 )
# Problematic frame:
# C  0x76dcd4a8
#
# An error report file with more information is saved as:
# 
/wrkdirs/usr/ports/java/eclipse/work/eclipse-build-914dc6de2bfc5ee5819a229cf4877f7043040a92/hs_err_pid28813.log
#
# If you would like to submit a bug report, please visit:
#   http://java.sun.com/webapps/bugreport/crash.jsp
#
*** [do-build] Signal 6

Stop in /usr/ports/java/eclipse.
===>  Cleaning for eclipse-3.7.1_4
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to