You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     p...@freebsd.org
Last committer: vani...@freebsd.org
Ident:          $FreeBSD: head/devel/p5-Module-Install-Template/Makefile 332120 
2013-10-30 14:44:54Z vanilla $
Log URL:        
http://beefy1.isc.freebsd.org/bulk/head-i386-default/2014-05-16_10h45m04s/logs/p5-Module-Install-Template-0.08.log
Build URL:      
http://beefy1.isc.freebsd.org/bulk/head-i386-default/2014-05-16_10h45m04s
Log:

====>> Building devel/p5-Module-Install-Template
build started at Fri May 16 22:24:17 UTC 2014
port directory: /usr/ports/devel/p5-Module-Install-Template
building for: FreeBSD head-i386-default-job-24 11.0-CURRENT FreeBSD 
11.0-CURRENT r264257 i386
maintained by: p...@freebsd.org
Makefile ident:      $FreeBSD: head/devel/p5-Module-Install-Template/Makefile 
332120 2013-10-30 14:44:54Z vanilla $
Poudriere version: 3.1-pre
Host OSVERSION: 1100013
Jail OSVERSION: 1100018




!!! Jail is newer than host. (Jail: 1100018, Host: 1100013) !!!
!!! This is not supported. !!!
!!! Host kernel must be same or newer than jail. !!!
!!! Expect build failures. !!!



---Begin Environment---
UNAME_m=i386
UNAME_p=i386
OSVERSION=1100018
UNAME_v=FreeBSD 11.0-CURRENT r264257
UNAME_r=11.0-CURRENT
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
SAVED_TERM=
MASTERMNT=/usr/local/poudriere/data/build/head-i386-default/ref
PKG_EXT=txz
tpid=17240
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
POUDRIERE_BUILD_TYPE=bulk
PKGNG=1
PKGNAME=p5-Module-Install-Template-0.08
PKG_DELETE=/usr/local/sbin/pkg-static delete -y -f
PKG_ADD=/usr/local/sbin/pkg-static add
OLDPWD=/usr/local/poudriere/data/build/head-i386-default/ref/poudriere/rdeps
PWD=/usr/local/poudriere/data/build/head-i386-default/ref/poudriere/pool
MASTERNAME=head-i386-default
USER=root
HOME=/root
POUDRIERE_VERSION=3.1-pre
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
PKG_VERSION=/poudriere/pkg-static version
PKG_BIN=/usr/local/sbin/pkg-static
---End Environment---

---Begin OPTIONS List---
---End OPTIONS List---

--CONFIGURE_ARGS--
INSTALLDIRS="site" CC="cc" CCFLAGS="-O2 -pipe  -fno-strict-aliasing" 
PREFIX="/usr/local"  INSTALLPRIVLIB="/usr/local/lib" 
INSTALLARCHLIB="/usr/local/lib"
--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
TMPDIR="/tmp" ac_cv_path_PERL=/usr/local/bin/perl 
ac_cv_path_PERL_PATH=/usr/local/bin/perl SHELL=/bin/sh CONFIG_SHELL=/bin/sh 
PERL_EXTUTILS_AUTOINSTALL="--skipdeps" PERL_MM_USE_DEFAULT="YES"
--End CONFIGURE_ENV--

--MAKE_ENV--
TMPDIR="/tmp" SHELL=/bin/sh NO_LINT=YES PREFIX=/usr/local  LOCALBASE=/usr/local 
 LIBDIR="/usr/lib"  CC="cc" CFLAGS="-O2 -pipe  -fno-strict-aliasing"  CPP="cpp" 
CPPFLAGS=""  LDFLAGS=""  CXX="c++" CXXFLAGS="-O2 -pipe -fno-strict-aliasing"  
MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install  -s -o root -g wheel -m 
555"  BSD_INSTALL_LIB="install  -s -o root -g wheel -m 444"  
BSD_INSTALL_SCRIPT="install  -o root -g wheel -m 555"  
BSD_INSTALL_DATA="install  -o root -g wheel -m 444"  BSD_INSTALL_MAN="install  
-o root -g wheel -m 444"
--End MAKE_ENV--

--PLIST_SUB--
OSREL=11.0
PREFIX=%D
LOCALBASE=/usr/local
PORTDOCS=""
PORTEXAMPLES=""
PORTDATA=""
LIB32DIR=lib
PERL_VERSION=5.16.3
PERL_VER=5.16
PERL_ARCH=mach
PERL5_MAN3=lib/perl5/5.16/man/man3
SITE_PERL=lib/perl5/site_perl/5.16
DOCSDIR="share/doc/Module-Install-Template"
EXAMPLESDIR="share/examples/Module-Install-Template"
DATADIR="share/Module-Install-Template"
WWWDIR="www/Module-Install-Template"
ETCDIR="etc/Module-Install-Template"
--End PLIST_SUB--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/Module-Install-Template
DOCSDIR=/usr/local/share/doc/Module-Install-Template
EXAMPLESDIR=/usr/local/share/examples/Module-Install-Template
WWWDIR=/usr/local/www/Module-Install-Template
ETCDIR=/usr/local/etc/Module-Install-Template
--End SUB_LIST--

---Begin make.conf---
ARCH=i386
MACHINE=i386
MACHINE_ARCH=i386
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
WITH_PKGNG=yes
NO_RESTRICTED=yes
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
===>  Cleaning for p5-Module-Install-Template-0.08
=======================<phase: check-sanity   >============================
===========================================================================
=======================<phase: pkg-depends    >============================
===>   p5-Module-Install-Template-0.08 depends on file: /usr/local/sbin/pkg - 
not found
===>    Verifying install for /usr/local/sbin/pkg in /usr/ports/ports-mgmt/pkg
===>   Installing existing package /packages/All/pkg-1.2.7_2.txz
Installing pkg-1.2.7_2... done
If you are upgrading from the old package format, first run:

  # pkg2ng
===>   Returning to build of p5-Module-Install-Template-0.08
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===> Fetching all distfiles required by p5-Module-Install-Template-0.08 for 
building
===========================================================================
=======================<phase: checksum       >============================
===> Fetching all distfiles required by p5-Module-Install-Template-0.08 for 
building
=> SHA256 Checksum OK for Module-Install-Template-0.08.tar.gz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===> Fetching all distfiles required by p5-Module-Install-Template-0.08 for 
building
===>  Extracting for p5-Module-Install-Template-0.08
=> SHA256 Checksum OK for Module-Install-Template-0.08.tar.gz.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for p5-Module-Install-Template-0.08
===========================================================================
=======================<phase: build-depends  >============================
===>   p5-Module-Install-Template-0.08 depends on package: 
p5-Template-Toolkit>=0 - not found
pkg-static: No package(s) matching p5-Template-Toolkit
===>    Verifying install for p5-Template-Toolkit>=0 in 
/usr/ports/www/p5-Template-Toolkit
===>   Installing existing package /packages/All/p5-Template-Toolkit-2.25.txz
Installing p5-Template-Toolkit-2.25...Installing p5-AppConfig-1.66...Installing 
perl5-5.16.3_9... done
 done
 done
===>   Returning to build of p5-Module-Install-Template-0.08
===>   p5-Module-Install-Template-0.08 depends on package: p5-Module-Install>=0 
- not found
pkg-static: No package(s) matching p5-Module-Install
===>    Verifying install for p5-Module-Install>=0 in 
/usr/ports/devel/p5-Module-Install
===>   Installing existing package /packages/All/p5-Module-Install-1.08.txz
Installing p5-Module-Install-1.08...Installing p5-File-Remove-1.52... done
Installing p5-JSON-2.90... done
Installing p5-Module-ScanDeps-1.10... done
Installing p5-PAR-Dist-0.49... done
Installing p5-YAML-Tiny-1.61... done
 done
===>   Returning to build of p5-Module-Install-Template-0.08
===>   p5-Module-Install-Template-0.08 depends on file: 
/usr/local/bin/perl5.16.3 - found
===========================================================================
=======================<phase: lib-depends    >============================
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for p5-Module-Install-Template-0.08
Can't locate URI/Escape.pm in @INC (@INC contains: inc 
/usr/local/lib/perl5/5.16/BSDPAN /usr/local/lib/perl5/site_perl/5.16/mach 
/usr/local/lib/perl5/site_perl/5.16 /usr/local/lib/perl5/5.16/mach 
/usr/local/lib/perl5/5.16 .) at inc/Module/Install/Homepage.pm line 5.
BEGIN failed--compilation aborted at inc/Module/Install/Homepage.pm line 5.
Compilation failed in require at inc/Module/Install.pm line 283.
Can't locate URI/Escape.pm in @INC (@INC contains: inc 
/usr/local/lib/perl5/5.16/BSDPAN /usr/local/lib/perl5/site_perl/5.16/mach 
/usr/local/lib/perl5/site_perl/5.16 /usr/local/lib/perl5/5.16/mach 
/usr/local/lib/perl5/5.16 .) at inc/Module/Install/Bugtracker.pm line 5.
BEGIN failed--compilation aborted at inc/Module/Install/Bugtracker.pm line 5.
Compilation failed in require at inc/Module/Install.pm line 283.
Bareword "auto_set_homepage" not allowed while "strict subs" in use at 
./Makefile.PL line 7.
Bareword "auto_set_bugtracker" not allowed while "strict subs" in use at 
./Makefile.PL line 8.
Execution of ./Makefile.PL aborted due to compilation errors.
*** Error code 255

Stop.
make: stopped in /usr/ports/devel/p5-Module-Install-Template
===>  Cleaning for p5-Module-Install-Template-0.08
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to