You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     oli...@freebsd.org
Last committer: oli...@freebsd.org
Ident:          $FreeBSD: head/net/cyphesis/Makefile 348846 2014-03-23 
09:45:39Z oliver $
Log URL:        
http://beefy1.isc.freebsd.org/bulk/head-i386-default/2014-05-16_10h45m04s/logs/cyphesis-0.6.2_2.log
Build URL:      
http://beefy1.isc.freebsd.org/bulk/head-i386-default/2014-05-16_10h45m04s
Log:

====>> Building net/cyphesis
build started at Sat May 17 00:02:27 UTC 2014
port directory: /usr/ports/net/cyphesis
building for: FreeBSD head-i386-default-job-08 11.0-CURRENT FreeBSD 
11.0-CURRENT r264257 i386
maintained by: oli...@freebsd.org
Makefile ident:      $FreeBSD: head/net/cyphesis/Makefile 348846 2014-03-23 
09:45:39Z oliver $
Poudriere version: 3.1-pre
Host OSVERSION: 1100013
Jail OSVERSION: 1100018




!!! Jail is newer than host. (Jail: 1100018, Host: 1100013) !!!
!!! This is not supported. !!!
!!! Host kernel must be same or newer than jail. !!!
!!! Expect build failures. !!!



---Begin Environment---
UNAME_m=i386
UNAME_p=i386
OSVERSION=1100018
UNAME_v=FreeBSD 11.0-CURRENT r264257
UNAME_r=11.0-CURRENT
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
SAVED_TERM=
MASTERMNT=/usr/local/poudriere/data/build/head-i386-default/ref
PKG_EXT=txz
tpid=3279
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
POUDRIERE_BUILD_TYPE=bulk
PKGNG=1
PKGNAME=cyphesis-0.6.2_2
PKG_DELETE=/usr/local/sbin/pkg-static delete -y -f
PKG_ADD=/usr/local/sbin/pkg-static add
OLDPWD=/usr/local/poudriere/data/build/head-i386-default/ref/poudriere/rdeps
PWD=/usr/local/poudriere/data/build/head-i386-default/ref/poudriere/pool
MASTERNAME=head-i386-default
USER=root
HOME=/root
POUDRIERE_VERSION=3.1-pre
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
PKG_VERSION=/poudriere/pkg-static version
PKG_BIN=/usr/local/sbin/pkg-static
---End Environment---

---Begin OPTIONS List---
===> The following configuration options are available for cyphesis-0.6.2_2:
     DOCS=on: Build and/or install documentation
===> Use 'make config' to modify these settings
---End OPTIONS List---

--CONFIGURE_ARGS--
--with-python=/usr/local --prefix=/usr/local ${_LATE_CONFIGURE_ARGS}
--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
TMPDIR="/tmp" TMPDIR="/tmp" PYTHON="/usr/local/bin/python2.7" MAKE=gmake 
PKG_CONFIG=pkgconf SHELL=/bin/sh CONFIG_SHELL=/bin/sh 
CONFIG_SITE=/usr/ports/Templates/config.site lt_cv_sys_max_cmd_len=262144
--End CONFIGURE_ENV--

--MAKE_ENV--
TMPDIR="/tmp" TMPDIR="/tmp" SHELL=/bin/sh NO_LINT=YES PREFIX=/usr/local  
LOCALBASE=/usr/local  LIBDIR="/usr/lib"  CC="cc" CFLAGS="-O2 -pipe  
-I/usr/local/include -fno-strict-aliasing"  CPP="cpp" 
CPPFLAGS="-I/usr/local/include"  LDFLAGS=" -L/usr/local/lib"  CXX="c++" 
CXXFLAGS="-O2 -pipe -I/usr/local/include -fno-strict-aliasing"  
MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install  -s -o root -g wheel -m 
555"  BSD_INSTALL_LIB="install  -s -o root -g wheel -m 444"  
BSD_INSTALL_SCRIPT="install  -o root -g wheel -m 555"  
BSD_INSTALL_DATA="install  -o root -g wheel -m 444"  BSD_INSTALL_MAN="install  
-o root -g wheel -m 444"
--End MAKE_ENV--

--PLIST_SUB--
PYTHON_INCLUDEDIR=include/python2.7
PYTHON_LIBDIR=lib/python2.7
PYTHON_PLATFORM=freebsd11
PYTHON_SITELIBDIR=lib/python2.7/site-packages
PYTHON_VERSION=python2.7
OSREL=11.0
PREFIX=%D
LOCALBASE=/usr/local
PORTDOCS=""
PORTEXAMPLES=""
PORTDATA=""
LIB32DIR=lib
DOCSDIR="share/doc/cyphesis"
EXAMPLESDIR="share/examples/cyphesis"
DATADIR="share/cyphesis"
WWWDIR="www/cyphesis"
ETCDIR="etc/cyphesis"
--End PLIST_SUB--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/cyphesis
DOCSDIR=/usr/local/share/doc/cyphesis
EXAMPLESDIR=/usr/local/share/examples/cyphesis
WWWDIR=/usr/local/www/cyphesis
ETCDIR=/usr/local/etc/cyphesis
--End SUB_LIST--

---Begin make.conf---
ARCH=i386
MACHINE=i386
MACHINE_ARCH=i386
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
WITH_PKGNG=yes
NO_RESTRICTED=yes
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
===>  Cleaning for cyphesis-0.6.2_2
=======================<phase: check-sanity   >============================
===========================================================================
=======================<phase: pkg-depends    >============================
===>   cyphesis-0.6.2_2 depends on file: /usr/local/sbin/pkg - not found
===>    Verifying install for /usr/local/sbin/pkg in /usr/ports/ports-mgmt/pkg
===>   Installing existing package /packages/All/pkg-1.2.7_2.txz
Installing pkg-1.2.7_2... done
If you are upgrading from the old package format, first run:

  # pkg2ng
===>   Returning to build of cyphesis-0.6.2_2
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===> Fetching all distfiles required by cyphesis-0.6.2_2 for building
===========================================================================
=======================<phase: checksum       >============================
===> Fetching all distfiles required by cyphesis-0.6.2_2 for building
=> SHA256 Checksum OK for cyphesis-0.6.2.tar.bz2.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===> Fetching all distfiles required by cyphesis-0.6.2_2 for building
===>  Extracting for cyphesis-0.6.2_2
=> SHA256 Checksum OK for cyphesis-0.6.2.tar.bz2.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for cyphesis-0.6.2_2
===>  Applying FreeBSD patches for cyphesis-0.6.2_2
===========================================================================
=======================<phase: build-depends  >============================
===>   cyphesis-0.6.2_2 depends on file: /usr/local/bin/python2.7 - not found
===>    Verifying install for /usr/local/bin/python2.7 in 
/usr/ports/lang/python27
===>   Installing existing package /packages/All/python27-2.7.6_4.txz
Installing python27-2.7.6_4...Installing gettext-0.18.3.1_1... done
 done
====
Note that some of the standard modules are provided as separate
ports since they require extra dependencies:

bsddb           databases/py-bsddb
gdbm            databases/py-gdbm
sqlite3         databases/py-sqlite3
tkinter         x11-toolkits/py-tkinter

Install them as needed.
====
===>   Returning to build of cyphesis-0.6.2_2
===>   cyphesis-0.6.2_2 depends on executable: python2 - not found
===>    Verifying install for python2 in /usr/ports/lang/python2
===>   Installing existing package /packages/All/python2-2_2.txz
Installing python2-2_2... done
===>   Returning to build of cyphesis-0.6.2_2
===>   cyphesis-0.6.2_2 depends on executable: gmake - not found
===>    Verifying install for gmake in /usr/ports/devel/gmake
===>   Installing existing package /packages/All/gmake-3.82_1.txz
Installing gmake-3.82_1... done
===>   Returning to build of cyphesis-0.6.2_2
===>   cyphesis-0.6.2_2 depends on executable: pkgconf - not found
===>    Verifying install for pkgconf in /usr/ports/devel/pkgconf
===>   Installing existing package /packages/All/pkgconf-0.9.5.txz
Installing pkgconf-0.9.5... done
===>   Returning to build of cyphesis-0.6.2_2
===========================================================================
=======================<phase: lib-depends    >============================
===>   cyphesis-0.6.2_2 depends on shared library: libAtlas-0.6.so - not found
===>    Verifying for libAtlas-0.6.so in /usr/ports/devel/atlas-devel
===>   Installing existing package /packages/All/Atlas-devel-0.6.3_2.txz
Installing Atlas-devel-0.6.3_2... done
===>   Returning to build of cyphesis-0.6.2_2
===>   cyphesis-0.6.2_2 depends on shared library: libvarconf-1.0.so - not found
===>    Verifying for libvarconf-1.0.so in /usr/ports/devel/varconf
===>   Installing existing package /packages/All/varconf-1.0.1_3.txz
Installing varconf-1.0.1_3...Installing libsigc++-2.3.1... done
 done
===>   Returning to build of cyphesis-0.6.2_2
===>   cyphesis-0.6.2_2 depends on shared library: libwfmath-1.0.so - not found
===>    Verifying for libwfmath-1.0.so in /usr/ports/math/wfmath
===>   Installing existing package /packages/All/wfmath-1.0.2_3.txz
Installing wfmath-1.0.2_3... done
<snip>
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for cyphesis-0.6.2_2
===>   FreeBSD 10 autotools fix applied to 
/wrkdirs/usr/ports/net/cyphesis/work/cyphesis-0.6.2/acinclude.m4
===>   FreeBSD 10 autotools fix applied to 
/wrkdirs/usr/ports/net/cyphesis/work/cyphesis-0.6.2/aclocal.m4
===>   FreeBSD 10 autotools fix applied to 
/wrkdirs/usr/ports/net/cyphesis/work/cyphesis-0.6.2/configure
configure: loading site script /usr/ports/Templates/config.site
checking build system type... i386-portbld-freebsd11.0
checking host system type... i386-portbld-freebsd11.0
checking for a BSD-compatible install... /usr/bin/install -c -o root -g wheel
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... (cached) /bin/mkdir -p
checking for gawk... (cached) /usr/bin/awk
checking whether gmake sets $(MAKE)... yes
checking whether gmake supports nested variables... yes
checking whether gmake supports nested variables... (cached) yes
checking for /proc/self/maps... no
checking whether everything is installed to the same prefix... yes
checking whether binary relocation support should be enabled... no
checking whether the C++ compiler works... yes
checking for C++ compiler default output file name... a.out
checking for suffix of executables... 
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C++ compiler... yes
checking whether c++ accepts -g... yes
checking for style of include used by gmake... GNU
checking dependency style of c++... gcc3
checking for gcc... cc
checking whether we are using the GNU C compiler... yes
checking whether cc accepts -g... yes
checking for cc option to accept ISO C89... none needed
checking dependency style of cc... gcc3
checking how to run the C preprocessor... cpp
checking for ranlib... ranlib
checking for xmllint... /usr/local/bin/xmllint
checking whether c++ supports C++11 features by default... no
checking whether c++ supports C++11 features with -std=gnu++11... yes
checking for sigset... yes
checking for sigaction... (cached) yes
checking for epoll_create... no
checking for poll... (cached) yes
checking for localtime_r... yes
checking for syslog... yes
checking for uname... (cached) yes
checking for getuid... (cached) yes
checking for nice... yes
checking for fork... (cached) yes
checking for setsid... (cached) yes
checking for wait4... yes
checking for getppid... yes
checking for kill... yes
checking for inet_ntop... (cached) yes
checking for unlink... yes
checking for usleep... (cached) yes
checking for Sleep... no
checking for gettimeofday... (cached) yes
checking for getnameinfo... (cached) yes
checking for library containing cos... none required
checking whether we have res_init() available... no
checking for boostlib >= 1.40... yes
checking whether we should link to MacOS-X frameworks... no
checking how to run the C++ preprocessor... c++ -E
checking for grep that handles long lines and -e... (cached) /usr/bin/grep
checking for egrep... (cached) /usr/bin/egrep
checking for ANSI C header files... (cached) yes
checking for sys/types.h... (cached) yes
checking for sys/stat.h... (cached) yes
checking for stdlib.h... (cached) yes
checking for string.h... (cached) yes
checking for memory.h... (cached) yes
checking for strings.h... (cached) yes
checking for inttypes.h... (cached) yes
checking for stdint.h... (cached) yes
checking for unistd.h... (cached) yes
checking termios.h usability... yes
checking termios.h presence... yes
checking for termios.h... yes
checking for signal.h... (cached) yes
checking syslog.h usability... yes
checking syslog.h presence... yes
checking for syslog.h... yes
checking sys/utsname.h usability... yes
checking sys/utsname.h presence... yes
checking for sys/utsname.h... yes
checking for sys/wait.h... (cached) yes
checking winsock.h usability... no
checking winsock.h presence... no
checking for winsock.h... no
checking for arpa/inet.h... (cached) yes
checking for sys/un.h... (cached) yes
checking for dirent.h... (cached) yes
checking io.h usability... no
checking io.h presence... no
checking for io.h... no
checking sys/ucred.h usability... yes
checking sys/ucred.h presence... yes
checking for sys/ucred.h... yes
checking windows.h usability... no
checking windows.h presence... no
checking for windows.h... no
checking for getopt.h... (cached) yes
checking python2.7/Python.h usability... yes
checking python2.7/Python.h presence... yes
checking for python2.7/Python.h... yes
checking for dlopen in -ldl... no
checking for openpty in -lutil... yes
checking for pthread_mutex_trylock... yes
checking for Py_Initialize in -pthread -lpython2.7... yes
checking for libgcrypt-config... /usr/local/bin/libgcrypt-config
checking for LIBGCRYPT - version >= 1.2.0... yes (1.5.3)
checking pkg-config is at least version 0.9.0... yes
checking for DEPS... yes
checking for WFMATH... yes
checking for MERCATOR... yes
checking for BULLET... no
no
configure: WARNING:
Cannot find valid versions of required physics library, bullet:
Package bullet was not found in the pkg-config search path.
Perhaps you should add the directory containing `bullet.pc'
to the PKG_CONFIG_PATH environment variable
Package 'bullet', required by 'world', not found
Perhaps you should add the directory containing the missing libraries to the
PKG_CONFIG_PATH environment variable.
Please see http://worldforge.org/dev/eng/servers/cyphesis for details of the
libraries required and where to obtain them.
checking for SKSTREAM... yes
checking for AVAHI... no
no
configure: Ommiting DNS-SD functionality.
checking for pg_config... /usr/local/bin/pg_config
checking for psql - version >= 7.1.0... 9.0.17
checking for PQconnectdb in -lpq... yes
checking for tgetent in -ltermcap... yes
checking for readline in -lreadline... yes
checking whether tar allows permissions to be overriden... no
configure: creating ./config.status
config.status: creating cyphesis.spec
config.status: creating cyphesis.iss
config.status: creating Makefile
config.status: creating libraries/Makefile
config.status: creating physics/Makefile
config.status: creating common/Makefile
config.status: creating modules/Makefile
config.status: creating rulesets/Makefile
config.status: creating server/Makefile
config.status: creating client/Makefile
config.status: creating tools/Makefile
config.status: creating data/Makefile
config.status: creating data/minimal/Makefile
config.status: creating data/mars/Makefile
config.status: creating tests/Makefile
config.status: creating man/Makefile
config.status: creating dox/Makefile
config.status: creating autopackage/default.apspec
config.status: creating Doxyfile
config.status: creating Doxyfile-python
config.status: creating config.h
config.status: executing depfiles commands
===========================================================================
=======================<phase: build          >============================
===>  Building for cyphesis-0.6.2_2
gmake[1]: Entering directory 
`/wrkdirs/usr/ports/net/cyphesis/work/cyphesis-0.6.2'
gmake  all-recursive
gmake[2]: Entering directory 
`/wrkdirs/usr/ports/net/cyphesis/work/cyphesis-0.6.2'
Making all in libraries
gmake[3]: Entering directory 
`/wrkdirs/usr/ports/net/cyphesis/work/cyphesis-0.6.2/libraries'
gmake[3]: Nothing to be done for `all'.
gmake[3]: Leaving directory 
`/wrkdirs/usr/ports/net/cyphesis/work/cyphesis-0.6.2/libraries'
Making all in physics
gmake[3]: Entering directory 
`/wrkdirs/usr/ports/net/cyphesis/work/cyphesis-0.6.2/physics'
  CXX    Vector3D.o
  CXX    BBox.o
BBox.cpp:49:17: error: no member named 'max' in namespace 'std'; did you mean 
'fmax'?
    return std::max(sqrMag(box.lowCorner()), sqrMag(box.highCorner()));
           ~~~~~^~~
                fmax
/usr/include/math.h:313:8: note: 'fmax' declared here
double  fmax(double, double) __pure2;
        ^
BBox.cpp:54:17: error: no member named 'max' in namespace 'std'; did you mean 
'fmax'?
    return std::max(sqrMag(WFMath::Point<2>(box.lowCorner().x(), 
box.lowCorner().y())),
           ~~~~~^~~
                fmax
/usr/include/math.h:313:8: note: 'fmax' declared here
double  fmax(double, double) __pure2;
        ^
2 errors generated.
gmake[3]: *** [BBox.o] Error 1
gmake[3]: Leaving directory 
`/wrkdirs/usr/ports/net/cyphesis/work/cyphesis-0.6.2/physics'
gmake[2]: *** [all-recursive] Error 1
gmake[2]: Leaving directory 
`/wrkdirs/usr/ports/net/cyphesis/work/cyphesis-0.6.2'
gmake[1]: *** [all] Error 2
gmake[1]: Leaving directory 
`/wrkdirs/usr/ports/net/cyphesis/work/cyphesis-0.6.2'
*** Error code 1

Stop.
make: stopped in /usr/ports/net/cyphesis
===>  Cleaning for cyphesis-0.6.2_2
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to