You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     m...@freebsd.org
Last committer: m...@freebsd.org
Ident:          $FreeBSD: head/security/openpgpsdk/Makefile 340722 2014-01-22 
17:00:46Z mat $
Log URL:        
http://beefy2.isc.freebsd.org/bulk/head-amd64-default/2014-05-23_09h21m35s/logs/openpgpsdk-0.9.log
Build URL:      
http://beefy2.isc.freebsd.org/bulk/head-amd64-default/2014-05-23_09h21m35s
Log:

====>> Building security/openpgpsdk
build started at Fri May 23 19:44:20 UTC 2014
port directory: /usr/ports/security/openpgpsdk
building for: FreeBSD head-amd64-default-job-06 11.0-CURRENT FreeBSD 
11.0-CURRENT r264257 amd64
maintained by: m...@freebsd.org
Makefile ident:      $FreeBSD: head/security/openpgpsdk/Makefile 340722 
2014-01-22 17:00:46Z mat $
Poudriere version: 3.1-pre
Host OSVERSION: 1100013
Jail OSVERSION: 1100018




!!! Jail is newer than host. (Jail: 1100018, Host: 1100013) !!!
!!! This is not supported. !!!
!!! Host kernel must be same or newer than jail. !!!
!!! Expect build failures. !!!



---Begin Environment---
OSVERSION=1100018
UNAME_v=FreeBSD 11.0-CURRENT r264257
UNAME_r=11.0-CURRENT
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
SAVED_TERM=
MASTERMNT=/usr/local/poudriere/data/build/head-amd64-default/ref
PKG_EXT=txz
tpid=14666
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
POUDRIERE_BUILD_TYPE=bulk
PKGNG=1
PKGNAME=openpgpsdk-0.9
PKG_DELETE=/usr/local/sbin/pkg-static delete -y -f
PKG_ADD=/usr/local/sbin/pkg-static add
OLDPWD=/usr/local/poudriere/data/build/head-amd64-default/ref/poudriere/rdeps
PWD=/usr/local/poudriere/data/build/head-amd64-default/ref/poudriere/pool
MASTERNAME=head-amd64-default
USER=root
HOME=/root
POUDRIERE_VERSION=3.1-pre
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
PKG_VERSION=/poudriere/pkg-static version
PKG_BIN=/usr/local/sbin/pkg-static
---End Environment---

---Begin OPTIONS List---
---End OPTIONS List---

--CONFIGURE_ARGS--
--without-idea --with-cunit=/usr/local
--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
TMPDIR="/tmp" ac_cv_path_PERL=/usr/local/bin/perl 
ac_cv_path_PERL_PATH=/usr/local/bin/perl SHELL=/bin/sh CONFIG_SHELL=/bin/sh
--End CONFIGURE_ENV--

--MAKE_ENV--
TMPDIR="/tmp" SHELL=/bin/sh NO_LINT=YES PREFIX=/usr/local  LOCALBASE=/usr/local 
 LIBDIR="/usr/lib"  CC="cc" CFLAGS="-O2 -pipe  -fno-strict-aliasing"  CPP="cpp" 
CPPFLAGS=""  LDFLAGS=""  CXX="c++" CXXFLAGS="-O2 -pipe -fno-strict-aliasing"  
MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install  -s -o root -g wheel -m 
555"  BSD_INSTALL_LIB="install  -s -o root -g wheel -m 444"  
BSD_INSTALL_SCRIPT="install  -o root -g wheel -m 555"  
BSD_INSTALL_DATA="install  -o root -g wheel -m 444"  BSD_INSTALL_MAN="install  
-o root -g wheel -m 444"
--End MAKE_ENV--

--PLIST_SUB--
OSREL=11.0
PREFIX=%D
LOCALBASE=/usr/local
PORTDOCS=""
PORTEXAMPLES=""
PORTDATA=""
LIB32DIR=lib
PERL_VERSION=5.16.3
PERL_VER=5.16
PERL_ARCH=mach
PERL5_MAN3=lib/perl5/5.16/man/man3
SITE_PERL=lib/perl5/site_perl/5.16
DOCSDIR="share/doc/openpgpsdk"
EXAMPLESDIR="share/examples/openpgpsdk"
DATADIR="share/openpgpsdk"
WWWDIR="www/openpgpsdk"
ETCDIR="etc/openpgpsdk"
--End PLIST_SUB--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/openpgpsdk
DOCSDIR=/usr/local/share/doc/openpgpsdk
EXAMPLESDIR=/usr/local/share/examples/openpgpsdk
WWWDIR=/usr/local/www/openpgpsdk
ETCDIR=/usr/local/etc/openpgpsdk
--End SUB_LIST--

---Begin make.conf---
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
WITH_PKGNG=yes
NO_RESTRICTED=yes
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
===>  Cleaning for openpgpsdk-0.9
=======================<phase: check-sanity   >============================
===========================================================================
=======================<phase: pkg-depends    >============================
===>   openpgpsdk-0.9 depends on file: /usr/local/sbin/pkg - not found
===>    Verifying install for /usr/local/sbin/pkg in /usr/ports/ports-mgmt/pkg
===>   Installing existing package /packages/All/pkg-1.2.7_2.txz
Installing pkg-1.2.7_2... done
If you are upgrading from the old package format, first run:

  # pkg2ng
===>   Returning to build of openpgpsdk-0.9
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===> Fetching all distfiles required by openpgpsdk-0.9 for building
===========================================================================
=======================<phase: checksum       >============================
===> Fetching all distfiles required by openpgpsdk-0.9 for building
=> SHA256 Checksum OK for openpgpsdk-0.9.tgz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===> Fetching all distfiles required by openpgpsdk-0.9 for building
===>  Extracting for openpgpsdk-0.9
=> SHA256 Checksum OK for openpgpsdk-0.9.tgz.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for openpgpsdk-0.9
===========================================================================
=======================<phase: build-depends  >============================
===>   openpgpsdk-0.9 depends on executable: gpg2 - not found
===>    Verifying install for gpg2 in /usr/ports/security/gnupg
===>   Installing existing package /packages/All/gnupg-2.0.22.txz
Installing gnupg-2.0.22...Installing curl-7.36.0...Installing 
ca_root_nss-3.16... done
 done
Installing gettext-0.18.3.1_1... done
Installing libassuan-2.1.1...Installing libgpg-error-1.13... done
 done
Installing libgcrypt-1.5.3_2... done
Installing libksba-1.3.0... done
Installing pth-2.0.7... done
 done
###############################################################################
                                A T T E N T I O N

In order to use gpg-agent, you need to install a pinentry dialog.

The following ports of pinentry dialogs are available:

security/pinentry-curses        (ncurses based dialog)
security/pinentry-gtk           (GTK 1.2 based dialog)
security/pinentry-gtk2          (GTK 2.x based dialog)
security/pinentry-qt            (QT3 based dialog)
security/pinentry-q4            (QT4 based dialog)

###############################################################################
===>   Returning to build of openpgpsdk-0.9
===>   openpgpsdk-0.9 depends on file: /usr/local/bin/perl5.16.3 - not found
===>    Verifying install for /usr/local/bin/perl5.16.3 in 
/usr/ports/lang/perl5.16
===>   Installing existing package /packages/All/perl5-5.16.3_9.txz
Installing perl5-5.16.3_9... done
===>   Returning to build of openpgpsdk-0.9
===========================================================================
=======================<phase: lib-depends    >============================
===>   openpgpsdk-0.9 depends on shared library: cunit.1 - not found
===>    Verifying install for cunit.1 in /usr/ports/devel/cunit
===>   Installing existing package /packages/All/cunit-2.1.3_1.txz
Installing cunit-2.1.3_1... done
===>   Returning to build of openpgpsdk-0.9
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for openpgpsdk-0.9
===>   FreeBSD 10 autotools fix applied to 
/wrkdirs/usr/ports/security/openpgpsdk/work/openpgpsdk-0.9/configure
Finding cc
  Finding path
  Found path: /sbin /bin /usr/sbin /usr/bin /usr/games /usr/local/sbin 
/usr/local/bin /root/bin
Found cc: cc
Finding base_cflags
  Finding is_gcc
  Found is_gcc: 1
Found base_cflags: -Wall -Werror -W -g
Check required header openssl/bn.h
Check required header zlib.h
Check required header bzlib.h
Check required header CUnit/Basic.h
Looking for header alloca.h (HAVE_ALLOCA_H)
Finding time_t
Getting info about time_t.
  time_t printf format is %ld
Found time_t: fmt -> %ld
Checking libraries for socket()
  trying no libraries ... OK
Checking for OpenSSL version
Checking for existence of gpg
gpg (GnuPG) 2.0.22
libgcrypt 1.5.3
Copyright (C) 2013 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.

Home: ~/.gnupg
Supported algorithms:
Pubkey: RSA, ELG, DSA, ?, ?
Cipher: IDEA, 3DES, CAST5, BLOWFISH, AES, AES192, AES256, TWOFISH,
        CAMELLIA128, CAMELLIA192, CAMELLIA256
Hash: MD5, SHA1, RIPEMD160, SHA256, SHA384, SHA512, SHA224
Compression: Uncompressed, ZIP, ZLIB, BZIP2
Creating src/lib/.depend
Creating src/app/.depend
Creating tests/.depend
make packet-show-cast.h
./../util/caster.pl packet-show.cast packet-show-cast.h
make clean
+++ make clean in src
+++ make clean in lib
rm -f packet-dump verify *.o *.i
rm -f TAGS
--- lib
+++ make clean in app
rm -f openpgp *.o *.i
rm -f  TAGS
--- app
find . -name '*.core' | xargs rm -f
rm -rf oink-links
--- src
+++ make clean in tests
rm -f  *.o *.i
rm -rf testdir.*
rm -f TAGS
--- tests
find . -name '*.core' | xargs rm -f
rm -rf oink-links
rm -f lib/*
make force_depend
+++ make force_depend in src
+++ make force_depend in lib
cd ../../include/openpgpsdk && make headers
cc  -I../../include  -I /usr/local/include  -DOPENSSL_NO_IDEA -Wall -Werror -W 
-g -fPIC -E -M *.c > .depend
--- lib
+++ make force_depend in app
cc -Wall -Werror -g  -I../../include  -I /usr/local/include  -DOPENSSL_NO_IDEA 
-Wall -Werror -W -g -fPIC -E -M *.c > .depend
--- app
--- src
+++ make force_depend in tests
cc -Wall -Werror -g  -I../include  -I /usr/local/include  -DOPENSSL_NO_IDEA 
-Wall -Werror -W -g -E -M *.c > .depend
In file included from test_cmdline.c:22:
./tests.h:22:9: error: '__TESTS__' is used as a header guard here, followed by 
#define of a different macro [-Werror,-Wheader-guard]
#ifndef __TESTS__
        ^~~~~~~~~
./tests.h:23:9: note: '__TESTS_' is defined here; did you mean '__TESTS__'?
#define __TESTS_
        ^~~~~~~~
        __TESTS__
1 error generated.
In file included from test_common.c:38:
./tests.h:22:9: error: '__TESTS__' is used as a header guard here, followed by 
#define of a different macro [-Werror,-Wheader-guard]
#ifndef __TESTS__
        ^~~~~~~~~
./tests.h:23:9: note: '__TESTS_' is defined here; did you mean '__TESTS__'?
#define __TESTS_
        ^~~~~~~~
        __TESTS__
1 error generated.
In file included from test_crypt_mpi.c:26:
./tests.h:22:9: error: '__TESTS__' is used as a header guard here, followed by 
#define of a different macro [-Werror,-Wheader-guard]
#ifndef __TESTS__
        ^~~~~~~~~
./tests.h:23:9: note: '__TESTS_' is defined here; did you mean '__TESTS__'?
#define __TESTS_
        ^~~~~~~~
        __TESTS__
1 error generated.
In file included from test_crypto.c:28:
./tests.h:22:9: error: '__TESTS__' is used as a header guard here, followed by 
#define of a different macro [-Werror,-Wheader-guard]
#ifndef __TESTS__
        ^~~~~~~~~
./tests.h:23:9: note: '__TESTS_' is defined here; did you mean '__TESTS__'?
#define __TESTS_
        ^~~~~~~~
        __TESTS__
1 error generated.
In file included from test_dsa_signature.c:40:
./tests.h:22:9: error: '__TESTS__' is used as a header guard here, followed by 
#define of a different macro [-Werror,-Wheader-guard]
#ifndef __TESTS__
        ^~~~~~~~~
./tests.h:23:9: note: '__TESTS_' is defined here; did you mean '__TESTS__'?
#define __TESTS_
        ^~~~~~~~
        __TESTS__
1 error generated.
In file included from test_dsa_verify.c:38:
./tests.h:22:9: error: '__TESTS__' is used as a header guard here, followed by 
#define of a different macro [-Werror,-Wheader-guard]
#ifndef __TESTS__
        ^~~~~~~~~
./tests.h:23:9: note: '__TESTS_' is defined here; did you mean '__TESTS__'?
#define __TESTS_
        ^~~~~~~~
        __TESTS__
1 error generated.
In file included from test_packet_types.c:41:
./tests.h:22:9: error: '__TESTS__' is used as a header guard here, followed by 
#define of a different macro [-Werror,-Wheader-guard]
#ifndef __TESTS__
        ^~~~~~~~~
./tests.h:23:9: note: '__TESTS_' is defined here; did you mean '__TESTS__'?
#define __TESTS_
        ^~~~~~~~
        __TESTS__
1 error generated.
In file included from test_rsa_decrypt.c:22:
./tests.h:22:9: error: '__TESTS__' is used as a header guard here, followed by 
#define of a different macro [-Werror,-Wheader-guard]
#ifndef __TESTS__
        ^~~~~~~~~
./tests.h:23:9: note: '__TESTS_' is defined here; did you mean '__TESTS__'?
#define __TESTS_
        ^~~~~~~~
        __TESTS__
1 error generated.
In file included from test_rsa_encrypt.c:35:
./tests.h:22:9: error: '__TESTS__' is used as a header guard here, followed by 
#define of a different macro [-Werror,-Wheader-guard]
#ifndef __TESTS__
        ^~~~~~~~~
./tests.h:23:9: note: '__TESTS_' is defined here; did you mean '__TESTS__'?
#define __TESTS_
        ^~~~~~~~
        __TESTS__
1 error generated.
In file included from test_rsa_keys.c:32:
./tests.h:22:9: error: '__TESTS__' is used as a header guard here, followed by 
#define of a different macro [-Werror,-Wheader-guard]
#ifndef __TESTS__
        ^~~~~~~~~
./tests.h:23:9: note: '__TESTS_' is defined here; did you mean '__TESTS__'?
#define __TESTS_
        ^~~~~~~~
        __TESTS__
1 error generated.
In file included from test_rsa_signature.c:40:
./tests.h:22:9: error: '__TESTS__' is used as a header guard here, followed by 
#define of a different macro [-Werror,-Wheader-guard]
#ifndef __TESTS__
        ^~~~~~~~~
./tests.h:23:9: note: '__TESTS_' is defined here; did you mean '__TESTS__'?
#define __TESTS_
        ^~~~~~~~
        __TESTS__
1 error generated.
In file included from test_rsa_verify.c:38:
./tests.h:22:9: error: '__TESTS__' is used as a header guard here, followed by 
#define of a different macro [-Werror,-Wheader-guard]
#ifndef __TESTS__
        ^~~~~~~~~
./tests.h:23:9: note: '__TESTS_' is defined here; did you mean '__TESTS__'?
#define __TESTS_
        ^~~~~~~~
        __TESTS__
1 error generated.
In file included from tests.c:34:
./tests.h:22:9: error: '__TESTS__' is used as a header guard here, followed by 
#define of a different macro [-Werror,-Wheader-guard]
#ifndef __TESTS__
        ^~~~~~~~~
./tests.h:23:9: note: '__TESTS_' is defined here; did you mean '__TESTS__'?
#define __TESTS_
        ^~~~~~~~
        __TESTS__
1 error generated.
*** Error code 1

Stop.
make[2]: stopped in 
/wrkdirs/usr/ports/security/openpgpsdk/work/openpgpsdk-0.9/tests
*** Error code 1

Stop.
make[1]: stopped in /wrkdirs/usr/ports/security/openpgpsdk/work/openpgpsdk-0.9
Configuration failed
===>  Script "configure" failed unexpectedly.
Please report the problem to m...@freebsd.org [maintainer] and attach the
"/wrkdirs/usr/ports/security/openpgpsdk/work/openpgpsdk-0.9/config.log"
including the output of the failure of your make command. Also, it might be
a good idea to provide an overview of all packages installed on your system
(e.g. a /usr/local/sbin/pkg-static info -g -Ea).
*** Error code 1

Stop.
make: stopped in /usr/ports/security/openpgpsdk
===>  Cleaning for openpgpsdk-0.9
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to