You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     d...@freebsd.org
Last committer: d...@freebsd.org
Ident:          $FreeBSD: branches/2014Q2/comms/gnuradio/Makefile 349385 
2014-03-28 00:30:55Z db $
Log URL:        
http://beefy2.isc.freebsd.org/bulk/10amd64-quarterly/2014-05-28_23h09m05s/logs/gnuradio-3.7.2.1.log
Build URL:      
http://beefy2.isc.freebsd.org/bulk/10amd64-quarterly/2014-05-28_23h09m05s
Log:

====>> Building comms/gnuradio
build started at Thu May 29 03:03:44 UTC 2014
port directory: /usr/ports/comms/gnuradio
building for: FreeBSD 10amd64-quarterly-job-18 10.0-RELEASE-p3 FreeBSD 
10.0-RELEASE-p3 amd64
maintained by: d...@freebsd.org
Makefile ident:      $FreeBSD: branches/2014Q2/comms/gnuradio/Makefile 349385 
2014-03-28 00:30:55Z db $
Poudriere version: 3.1-pre
Host OSVERSION: 1100013
Jail OSVERSION: 1000510

---Begin Environment---
OSVERSION=1000510
UNAME_v=FreeBSD 10.0-RELEASE-p3
UNAME_r=10.0-RELEASE-p3
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
SAVED_TERM=
MASTERMNT=/usr/local/poudriere/data/build/10amd64-quarterly/ref
PKG_EXT=txz
tpid=35529
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
POUDRIERE_BUILD_TYPE=bulk
PKGNG=1
PKGNAME=gnuradio-3.7.2.1
PKG_DELETE=/usr/local/sbin/pkg-static delete -y -f
PKG_ADD=/usr/local/sbin/pkg-static add
OLDPWD=/usr/local/poudriere/data/build/10amd64-quarterly/ref/poudriere/rdeps
PWD=/usr/local/poudriere/data/build/10amd64-quarterly/ref/poudriere/pool
MASTERNAME=10amd64-quarterly
USER=root
HOME=/root
POUDRIERE_VERSION=3.1-pre
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
PKG_VERSION=/poudriere/pkg-static version
PKG_BIN=/usr/local/sbin/pkg-static
---End Environment---

---Begin OPTIONS List---
===> The following configuration options are available for gnuradio-3.7.2.1:
     TESTING=off: Include testing support
     USRP=off: Include USRP support (UHD) from Ettus
===> Use 'make config' to modify these settings
---End OPTIONS List---

--CONFIGURE_ARGS--
--with-qt-includes=/usr/local/include/qt4  
--with-qt-libraries=/usr/local/lib/qt4  
--with-extra-includes=/usr/local/include  --with-extra-libs=/usr/local/lib
--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
TMPDIR="/tmp" PYTHON="/usr/local/bin/python2.7" QTDIR="/usr/local" 
QMAKE="/usr/local/bin/qmake-qt4"  MOC="/usr/local/bin/moc-qt4" 
RCC="/usr/local/bin/rcc" UIC="/usr/local/bin/uic-qt4"  
QMAKESPEC="/usr/local/share/qt4/mkspecs/freebsd-$(ccver="$(clang++34 
--version)"; case "$ccver" in *clang*) echo clang ;; *) echo g++ ;; esac)" 
ac_cv_path_PERL=/usr/local/bin/perl TMPDIR="/tmp" SHELL=/bin/sh 
CONFIG_SHELL=/bin/sh WX_CONFIG=/usr/local/bin/wxgtk2u-2.8-config
--End CONFIGURE_ENV--

--MAKE_ENV--
TMPDIR="/tmp" TMPDIR="/tmp" SHELL=/bin/sh NO_LINT=YES 
WX_CONFIG=/usr/local/bin/wxgtk2u-2.8-config PREFIX=/usr/local  
LOCALBASE=/usr/local  LIBDIR="/usr/lib"  CC="clang34" CFLAGS="-O2 -pipe 
-fno-strict-aliasing"  CPP="cpp" CPPFLAGS=""  LDFLAGS=""  CXX="clang++34" 
CXXFLAGS="-O2 -pipe -fno-strict-aliasing"  MANPREFIX="/usr/local" 
BSD_INSTALL_PROGRAM="install  -s -o root -g wheel -m 555"  
BSD_INSTALL_LIB="install  -s -o root -g wheel -m 444"  
BSD_INSTALL_SCRIPT="install  -o root -g wheel -m 555"  
BSD_INSTALL_DATA="install  -o root -g wheel -m 444"  BSD_INSTALL_MAN="install  
-o root -g wheel -m 444"
--End MAKE_ENV--

--PLIST_SUB--
MAJOR_VERSION="3"
PORTVERSION=3.7.2.1
PYTHON_INCLUDEDIR=include/python2.7
PYTHON_LIBDIR=lib/python2.7
PYTHON_PLATFORM=freebsd10
PYTHON_SITELIBDIR=lib/python2.7/site-packages
PYTHON_VERSION=python2.7
QT_PREFIX="/usr/local"
QT_BINDIR="bin"
QT_INCDIR="include/qt4"
QT_LIBDIR="lib/qt4"
QT_ARCHDIR="lib/qt4/qt4"
QT_PLUGINDIR="lib/qt4/plugins"
QT_LIBEXECDIR="libexec/qt4"
QT_IMPORTDIR="lib/qt4/imports"
QT_QMLDIR="lib/qt4/qt4/qml"
QT_DATADIR="share/qt4"
QT_DOCDIR="share/doc/qt4"
QT_L10NDIR="share/qt4/translations"
QT_ETCDIR="etc/xdg"
QT_EXAMPLEDIR="share/examples/qt4"
QT_TESTDIR="share/qt4/tests"
QT_MKSPECDIR="share/qt4/mkspecs"
CMAKE_BUILD_TYPE="release"
UHD="@comment
"
OSREL=10.0
PREFIX=%D
LOCALBASE=/usr/local
PORTDOCS="@comment
"
PORTEXAMPLES=""
PORTDATA=""
LIB32DIR=lib
PERL_VERSION=5.16.3
PERL_VER=5.16
PERL_ARCH=mach
PERL5_MAN3=lib/perl5/5.16/man/man3
SITE_PERL=lib/perl5/site_perl/5.16
DOCSDIR="share/doc/gnuradio-3.7.2.1"
EXAMPLESDIR="share/examples/gnuradio"
DATADIR="share/gnuradio"
WWWDIR="www/gnuradio"
ETCDIR="etc/gnuradio"
--End PLIST_SUB--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/gnuradio
DOCSDIR=share/doc/gnuradio-3.7.2.1
EXAMPLESDIR=/usr/local/share/examples/gnuradio
WWWDIR=/usr/local/www/gnuradio
ETCDIR=/usr/local/etc/gnuradio
--End SUB_LIST--

---Begin make.conf---
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
WITH_PKGNG=yes
# clean-restricted ran via poudriere.conf NO_RESTRICTED
#NO_RESTRICTED=yes
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
===>  Cleaning for gnuradio-3.7.2.1
=======================<phase: check-sanity   >============================
===========================================================================
=======================<phase: pkg-depends    >============================
===>   gnuradio-3.7.2.1 depends on file: /usr/local/sbin/pkg - not found
===>    Verifying install for /usr/local/sbin/pkg in /usr/ports/ports-mgmt/pkg
===>   Installing existing package /packages/All/pkg-1.2.7.txz
Installing pkg-1.2.7... done
If you are upgrading from the old package format, first run:

  # pkg2ng
===>   Returning to build of gnuradio-3.7.2.1
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===> Fetching all distfiles required by gnuradio-3.7.2.1 for building
===========================================================================
=======================<phase: checksum       >============================
===> Fetching all distfiles required by gnuradio-3.7.2.1 for building
=> SHA256 Checksum OK for gnuradio-3.7.2.1.tar.gz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===> Fetching all distfiles required by gnuradio-3.7.2.1 for building
===>  Extracting for gnuradio-3.7.2.1
=> SHA256 Checksum OK for gnuradio-3.7.2.1.tar.gz.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for gnuradio-3.7.2.1
===>  Applying FreeBSD patches for gnuradio-3.7.2.1
===========================================================================
=======================<phase: build-depends  >============================
===>   gnuradio-3.7.2.1 depends on executable: clang34 - not found
===>    Verifying install for clang34 in /usr/ports/lang/clang34
===>   Installing existing package /packages/All/clang34-3.4_2.txz
Installing clang34-3.4_2...Installing llvm34-3.4...Installing perl5-5.16.3_9... 
done
Installing python27-2.7.6_4...Installing gettext-0.18.3.1... done
 done
 done
 done
====
Note that some of the standard modules are provided as separate
ports since they require extra dependencies:

bsddb           databases/py-bsddb
gdbm            databases/py-gdbm
sqlite3         databases/py-sqlite3
tkinter         x11-toolkits/py-tkinter

Install them as needed.
====
===>   Returning to build of gnuradio-3.7.2.1
===>   gnuradio-3.7.2.1 depends on file: /usr/local/lib/qt4/libQtGui.so - not 
found
===>    Verifying install for /usr/local/lib/qt4/libQtGui.so in 
/usr/ports/x11-toolkits/qt4-gui
===>   Installing existing package /packages/All/qt4-gui-4.8.5.txz
Installing qt4-gui-4.8.5...Installing encodings-1.0.4_1,1...Installing 
font-util-1.3.0_1... done
 done
Installing fontconfig-2.11.0_1,1...Installing expat-2.1.0... done
Installing freetype2-2.5.3... done
Running fc-cache to build fontconfig cache...
/usr/local/share/fonts: skipping, no such directory
/usr/local/lib/X11/fonts: caching, new cache contents: 0 fonts, 3 dirs
/usr/local/lib/X11/fonts/encodings: caching, new cache contents: 0 fonts, 1 dirs
/usr/local/lib/X11/fonts/encodings/large: caching, new cache contents: 0 fonts, 
0 dirs
/usr/local/lib/X11/fonts/local: caching, new cache contents: 0 fonts, 0 dirs
/usr/local/lib/X11/fonts/util: caching, new cache contents: 0 fonts, 0 dirs
/root/.local/share/fonts: skipping, no such directory
<snip>
===>   Installing existing package /packages/All/qt4-rcc-4.8.5.txz
Installing qt4-rcc-4.8.5... done
===>   Returning to build of gnuradio-3.7.2.1
===>   gnuradio-3.7.2.1 depends on file: /usr/local/bin/uic-qt4 - not found
===>    Verifying install for /usr/local/bin/uic-qt4 in /usr/ports/devel/qt4-uic
===>   Installing existing package /packages/All/qt4-uic-4.8.5.txz
Installing qt4-uic-4.8.5... done
===>   Returning to build of gnuradio-3.7.2.1
===>   gnuradio-3.7.2.1 depends on file: /usr/local/lib/qt4/libQtXml.so - not 
found
===>    Verifying install for /usr/local/lib/qt4/libQtXml.so in 
/usr/ports/textproc/qt4-xml
===>   Installing existing package /packages/All/qt4-xml-4.8.5.txz
Installing qt4-xml-4.8.5... done
===>   Returning to build of gnuradio-3.7.2.1
===>   gnuradio-3.7.2.1 depends on file: /usr/local/lib/libwx_baseu-2.8.so.0 - 
not found
===>    Verifying install for /usr/local/lib/libwx_baseu-2.8.so.0 in 
/usr/ports/x11-toolkits/wxgtk28-unicode
===>   Installing existing package /packages/All/wx28-gtk2-unicode-2.8.12_2.txz
Installing wx28-gtk2-unicode-2.8.12_2...Installing ORBit2-2.14.19...Installing 
libIDL-0.8.14_1... done
 done
Installing atk-2.8.0...Installing gnomehier-3.0... done
 done
Installing gconf2-2.32.0_3...Installing dbus-glib-0.100.2...Installing 
dbus-1.6.18...Installing gnome_subr-1.0... done
===> Creating users and/or groups.
Creating group 'messagebus' with gid '556'.
Creating user 'messagebus' with uid '556'.
 done
 done
Installing dconf-0.14.1_1... done
Installing gtk2-2.24.22_1...Installing cups-client-1.7.1_1...===> Creating 
users and/or groups.
Creating group 'cups' with gid '193'.
Creating user 'cups' with uid '193'.
 done
Installing gdk-pixbuf2-2.28.2...Installing jasper-1.900.1_12...Installing 
jpeg-8_4... done
 done
Installing tiff-4.0.3...Installing freeglut-2.8.1...Installing 
libGLU-9.0.0...Installing libGL-7.6.1_4...Installing dri2proto-2.8... done
Installing libXdamage-1.1.4...Installing damageproto-1.2.1... done
 done
Installing libXxf86vm-1.1.3...Installing xf86vidmodeproto-2.3.1... done
 done
Installing libdrm-2.4.17_1...Installing libpciaccess-0.13.2...Installing 
pciids-20140312... done
 done
 done
 done
 done
 done
Installing jbigkit-1.6... done
 done
 done
Installing gtk-update-icon-cache-2.24.22...Installing 
libXcomposite-0.4.4,1...Installing compositeproto-0.4.2... done
 done
Installing pango-1.34.1_2...Installing cairo-1.10.2_7,2...Installing 
xcb-util-renderutil-0.3.8...Installing xcb-util-0.3.9_1,1... done
 done
Installing pixman-0.32.4... done
 done
Installing harfbuzz-0.9.25_1...Installing graphite2-1.2.4... done
 done
Installing libXft-2.3.1... done
 done
Installing shared-mime-info-1.1... done
 done
Installing python-2.7_1,2...Installing python2-2_2... done
 done
 done
Installing polkit-0.105_2...Installing gobject-introspection-1.36.0_2... done
 done
 done
Installing gstreamer-plugins-0.10.36_3,3...Installing gstreamer-0.10.36... done
Installing libXv-1.0.10,1...Installing videoproto-2.3.2... done
 done
Installing orc-0.4.18... done
 done
Installing libmspack-0.4... done
Installing pangox-compat-0.0.2... done
Installing wx28-gtk2-common-2.8.12_2... done
 done
Since FreeBSD has new USB stack, freeglut normally doesn't build on FreeBSD 8
(yet). To workaround this a small patch adds one include file and comments out
content of one function (only leaves return NULL).

This might cause side effects.  Joysticks do not work, and there might be ports
that do not compile or applications that crash because of this.

Do not hesitate to contact x...@freebsd.org if there are any issues and side
effects because of this.
===>   Returning to build of gnuradio-3.7.2.1
===>   gnuradio-3.7.2.1 depends on file: 
/usr/local/lib/python2.7/site-packages/wx-2.8-gtk2-unicode/wx/__init__.py - not 
found
===>    Verifying install for 
/usr/local/lib/python2.7/site-packages/wx-2.8-gtk2-unicode/wx/__init__.py in 
/usr/ports/x11-toolkits/py-wxPython28-unicode
===>   Installing existing package 
/packages/All/py27-wxPython28-unicode-2.8.12.1_3.txz
Installing py27-wxPython28-unicode-2.8.12.1_3...Installing 
wx28-gtk2-unicode-contrib-2.8.12_2...Installing 
wx28-gtk2-contrib-common-2.8.12_2... done
 done
Installing py27-wxPython28-common-2.8.12.1_3...Installing 
wx28-gtk2-contrib-2.8.12_2...Installing wx28-gtk2-2.8.12_2... done
 done
Installing py27-opengl-3.0.1_4...Installing py27-imaging-1.1.7_2...Installing 
lcms-1.19_1,1... done
Installing py27-setuptools27-2.0.1... done
Installing py27-tkinter-2.7.6_4...Installing tk86-8.6.1...Installing 
libXScrnSaver-1.2.2...Installing scrnsaverproto-1.2.2... done
 done
Installing tcl86-8.6.1... done
 done
 done
 done
Installing py27-numpy-1.8.0_1,1...Installing blas-3.4.2_2...Installing 
gcc-4.7.3...Installing binutils-2.24... done
Installing gcc-ecj-4.5... done
Installing gmp-5.1.3_1... done
Installing mpc-1.0.2...Installing mpfr-3.1.2_1... done
 done
 done
 done
Installing lapack-3.4.2_2... done
Installing py27-nose-1.3.0_1... done
Installing suitesparse-4.0.2_3... done
 done
 done
 done
 done
===>   Returning to build of gnuradio-3.7.2.1
===>   gnuradio-3.7.2.1 depends on file: /usr/local/bin/perl5.16.3 - found
===========================================================================
=======================<phase: lib-depends    >============================
===>   gnuradio-3.7.2.1 depends on shared library: libcppunit.so - not found
===>    Verifying for libcppunit.so in /usr/ports/devel/cppunit
===>   Installing existing package /packages/All/cppunit-1.12.1_1.txz
Installing cppunit-1.12.1_1... done
===>   Returning to build of gnuradio-3.7.2.1
===>   gnuradio-3.7.2.1 depends on shared library: libfftw3.so - not found
===>    Verifying for libfftw3.so in /usr/ports/math/fftw3
===>   Installing existing package /packages/All/fftw3-3.3.3_1.txz
Installing fftw3-3.3.3_1... done
===>   Returning to build of gnuradio-3.7.2.1
===>   gnuradio-3.7.2.1 depends on shared library: libfftw3f.so - not found
===>    Verifying for libfftw3f.so in /usr/ports/math/fftw3-float
===>   Installing existing package /packages/All/fftw3-float-3.3.3_1.txz
Installing fftw3-float-3.3.3_1... done
===>   Returning to build of gnuradio-3.7.2.1
===>   gnuradio-3.7.2.1 depends on shared library: libqwt.so - not found
===>    Verifying for libqwt.so in /usr/ports/x11-toolkits/qwt5
===>   Installing existing package /packages/All/qwt5-5.2.3.txz
Installing qwt5-5.2.3...Installing qt4-svg-4.8.5... done
 done
===>   Returning to build of gnuradio-3.7.2.1
===>   gnuradio-3.7.2.1 depends on shared library: libboost_python.so - not 
found
===>    Verifying for libboost_python.so in /usr/ports/devel/boost-python-libs
===>   Installing existing package /packages/All/boost-python-libs-1.55.0.txz
Installing boost-python-libs-1.55.0...Installing boost-libs-1.55.0... done
 done
You have built the Boost library with thread support.

Don't forget to add -pthread to your linker options when
linking your code.
You have built the Boost library with thread support.

Don't forget to add -pthread to your linker options when
linking your code.

You have built the Boost.Python library. You have to add the following
options when building your own code:

Compiler options:
   -I/usr/local/include/python2.7 -I/usr/local/include

Linker options:
   -L/usr/local/lib/python2.7 -L/usr/local/lib -lboost_python -lpython2.7
===>   Returning to build of gnuradio-3.7.2.1
===>   gnuradio-3.7.2.1 depends on shared library: libportaudio.so.2 - not found
===>    Verifying for libportaudio.so.2 in /usr/ports/audio/portaudio2
===>   Installing existing package /packages/All/portaudio2-19.20140130.txz
Installing portaudio2-19.20140130... done
===>   Returning to build of gnuradio-3.7.2.1
===>   gnuradio-3.7.2.1 depends on shared library: libjack.so - not found
===>    Verifying for libjack.so in /usr/ports/audio/jack
===>   Installing existing package /packages/All/jackit-0.121.3_3.txz
Installing jackit-0.121.3_3...Installing celt-0.11.3_1...Installing 
libogg-1.3.1,4... done
 done
Installing libsamplerate-0.1.8_4...Installing libsndfile-1.0.25_3...Installing 
flac-1.3.0_1... done
Installing libvorbis-1.3.4,3... done
 done
 done
Installing portaudio-18.1_3... done
 done
===>   Returning to build of gnuradio-3.7.2.1
===>   gnuradio-3.7.2.1 depends on shared library: libasound.so - not found
===>    Verifying for libasound.so in /usr/ports/audio/alsa-lib
===>   Installing existing package /packages/All/alsa-lib-1.0.27.2_1.txz
Installing alsa-lib-1.0.27.2_1... done
===>   Returning to build of gnuradio-3.7.2.1
===>   gnuradio-3.7.2.1 depends on shared library: libgsl.so - not found
===>    Verifying for libgsl.so in /usr/ports/math/gsl
===>   Installing existing package /packages/All/gsl-1.16.txz
Installing gsl-1.16... done
===>   Returning to build of gnuradio-3.7.2.1
===>   gnuradio-3.7.2.1 depends on shared library: libwx_baseu-2.8.so - found
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for gnuradio-3.7.2.1
===>  Performing out-of-source build
/bin/mkdir -p /wrkdirs/usr/ports/comms/gnuradio/work/.build
env: /usr/local/bin/cmake: No such file or directory
*** Error code 127

Stop.
make: stopped in /usr/ports/comms/gnuradio
===>  Cleaning for gnuradio-3.7.2.1
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to