You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     f...@freebsd.org
Last committer: m...@freebsd.org
Ident:          $FreeBSD: branches/2014Q2/emulators/raine/Makefile 340722 
2014-01-22 17:00:46Z mat $
Log URL:        
http://beefy1.isc.freebsd.org/bulk/10i386-quarterly/2014-05-28_22h19m38s/logs/raine-0.43.3_9.log
Build URL:      
http://beefy1.isc.freebsd.org/bulk/10i386-quarterly/2014-05-28_22h19m38s
Log:

====>> Building emulators/raine
build started at Thu May 29 08:54:15 UTC 2014
port directory: /usr/ports/emulators/raine
building for: FreeBSD 10i386-quarterly-job-20 10.0-RELEASE-p3 FreeBSD 
10.0-RELEASE-p3 i386
maintained by: f...@freebsd.org
Makefile ident:      $FreeBSD: branches/2014Q2/emulators/raine/Makefile 340722 
2014-01-22 17:00:46Z mat $
Poudriere version: 3.1-pre
Host OSVERSION: 1100013
Jail OSVERSION: 1000510

---Begin Environment---
UNAME_m=i386
UNAME_p=i386
OSVERSION=1000510
UNAME_v=FreeBSD 10.0-RELEASE-p3
UNAME_r=10.0-RELEASE-p3
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
SAVED_TERM=
MASTERMNT=/usr/local/poudriere/data/build/10i386-quarterly/ref
PKG_EXT=txz
tpid=83592
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
POUDRIERE_BUILD_TYPE=bulk
PKGNG=1
PKGNAME=raine-0.43.3_9
PKG_DELETE=/usr/local/sbin/pkg-static delete -y -f
PKG_ADD=/usr/local/sbin/pkg-static add
OLDPWD=/usr/local/poudriere/data/build/10i386-quarterly/ref/poudriere/rdeps
PWD=/usr/local/poudriere/data/build/10i386-quarterly/ref/poudriere/pool
MASTERNAME=10i386-quarterly
USER=root
HOME=/root
POUDRIERE_VERSION=3.1-pre
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
PKG_VERSION=/poudriere/pkg-static version
PKG_BIN=/usr/local/sbin/pkg-static
---End Environment---

---Begin OPTIONS List---
---End OPTIONS List---

--CONFIGURE_ARGS--

--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
TMPDIR="/tmp" MAKE=gmake TMPDIR="/tmp" SHELL=/bin/sh CONFIG_SHELL=/bin/sh 
SDL_CONFIG=/usr/local/bin/sdl-config
--End CONFIGURE_ENV--

--MAKE_ENV--
TMPDIR="/tmp" TMPDIR="/tmp" SHELL=/bin/sh NO_LINT=YES 
SDL_CONFIG=/usr/local/bin/sdl-config PREFIX=/usr/local  LOCALBASE=/usr/local  
LIBDIR="/usr/lib"  CC="cc" CFLAGS="-O2 -pipe -fno-strict-aliasing"  CPP="cpp" 
CPPFLAGS=""  LDFLAGS=""  CXX="c++" CXXFLAGS="-O2 -pipe -fno-strict-aliasing"  
MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install  -s -o root -g wheel -m 
555"  BSD_INSTALL_LIB="install  -s -o root -g wheel -m 444"  
BSD_INSTALL_SCRIPT="install  -o root -g wheel -m 555"  
BSD_INSTALL_DATA="install  -o root -g wheel -m 444"  BSD_INSTALL_MAN="install  
-o root -g wheel -m 444"
--End MAKE_ENV--

--PLIST_SUB--
OSREL=10.0
PREFIX=%D
LOCALBASE=/usr/local
PORTDOCS=""
PORTEXAMPLES=""
PORTDATA=""
LIB32DIR=lib
GTK2_VERSION="2.10.0"
GTK3_VERSION="3.0.0"
DOCSDIR="share/doc/raine"
EXAMPLESDIR="share/examples/raine"
DATADIR="share/raine"
WWWDIR="www/raine"
ETCDIR="etc/raine"
--End PLIST_SUB--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/raine
DOCSDIR=/usr/local/share/doc/raine
EXAMPLESDIR=/usr/local/share/examples/raine
WWWDIR=/usr/local/www/raine
ETCDIR=/usr/local/etc/raine
--End SUB_LIST--

---Begin make.conf---
ARCH=i386
MACHINE=i386
MACHINE_ARCH=i386
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
WITH_PKGNG=yes
# clean-restricted via poudriere.conf NO_RESTRICTED
#NO_RESTRICTED=yes
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
===>  Cleaning for raine-0.43.3_9
=======================<phase: check-sanity   >============================
===========================================================================
=======================<phase: pkg-depends    >============================
===>   raine-0.43.3_9 depends on file: /usr/local/sbin/pkg - not found
===>    Verifying install for /usr/local/sbin/pkg in /usr/ports/ports-mgmt/pkg
===>   Installing existing package /packages/All/pkg-1.2.7.txz
Installing pkg-1.2.7... done
If you are upgrading from the old package format, first run:

  # pkg2ng
===>   Returning to build of raine-0.43.3_9
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===> Fetching all distfiles required by raine-0.43.3_9 for building
===========================================================================
=======================<phase: checksum       >============================
===> Fetching all distfiles required by raine-0.43.3_9 for building
=> SHA256 Checksum OK for raines-0.43.3.tar.bz2.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===> Fetching all distfiles required by raine-0.43.3_9 for building
===>  Extracting for raine-0.43.3_9
=> SHA256 Checksum OK for raines-0.43.3.tar.bz2.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for raine-0.43.3_9
===>  Applying FreeBSD patches for raine-0.43.3_9
===========================================================================
=======================<phase: build-depends  >============================
===>   raine-0.43.3_9 depends on file: /usr/local/bin/nasm - not found
===>    Verifying install for /usr/local/bin/nasm in /usr/ports/devel/nasm
===>   Installing existing package /packages/All/nasm-2.10.09,1.txz
Installing nasm-2.10.09,1... done
===>   Returning to build of raine-0.43.3_9
===>   raine-0.43.3_9 depends on executable: gmake - not found
===>    Verifying install for gmake in /usr/ports/devel/gmake
===>   Installing existing package /packages/All/gmake-3.82_1.txz
Installing gmake-3.82_1...Installing gettext-0.18.3.1... done
 done
===>   Returning to build of raine-0.43.3_9
===>   raine-0.43.3_9 depends on file: /usr/local/bin/sdl-config - not found
===>    Verifying install for /usr/local/bin/sdl-config in 
/usr/ports/devel/sdl12
===>   Installing existing package /packages/All/sdl-1.2.15_3,2.txz
Installing sdl-1.2.15_3,2...Installing aalib-1.4.r5_9... done
Installing libGLU-9.0.0...Installing libGL-7.6.1_4...Installing 
dri2proto-2.8... done
Installing expat-2.1.0... done
Installing libX11-1.6.2,1...Installing kbproto-1.0.6... done
Installing libXau-1.0.8...Installing xproto-7.0.25... done
 done
Installing libXdmcp-1.1.1... done
Installing libxcb-1.9.3...Installing libpthread-stubs-0.3_4... done
Installing libxml2-2.9.1_1... done
 done
 done
Installing libXdamage-1.1.4...Installing damageproto-1.2.1... done
Installing libXfixes-5.0.1...Installing fixesproto-5.0... done
 done
 done
Installing libXext-1.3.2,1...Installing xextproto-7.2.1... done
 done
Installing libXxf86vm-1.1.3...Installing xf86vidmodeproto-2.3.1... done
 done
Installing libdrm-2.4.17_1...Installing libpciaccess-0.13.2...Installing 
pciids-20140312... done
 done
 done
 done
 done
Installing libXrandr-1.4.2...Installing libXrender-0.9.8...Installing 
renderproto-0.11.1... done
 done
Installing randrproto-1.4.0... done
 done
 done
------------------------------------------------------------------------------
 Your SDL library has been built with libvgl support, which means that you
 can run almost any SDL application straight on your console (VESA 2.0
 compatible videocard is required).

 To do this you have to load the vesa kernel module or enable it in your
 kernel, and set environment variable "SDL_VIDEODRIVER=vgl".
------------------------------------------------------------------------------
===>   Returning to build of raine-0.43.3_9
===========================================================================
=======================<phase: lib-depends    >============================
===>   raine-0.43.3_9 depends on shared library: alleg - not found
===>    Verifying install for alleg in /usr/ports/devel/allegro
===>   Installing existing package /packages/All/allegro-4.4.2_3.txz
Installing allegro-4.4.2_3...Installing alsa-lib-1.0.27.2_1... done
Installing libXcursor-1.1.14... done
Installing libXpm-3.5.11...Installing libXt-1.1.4,1...Installing 
libSM-1.2.2,1...Installing libICE-1.0.8,1... done
 done
 done
 done
Installing libXxf86dga-1.1.4...Installing xf86dgaproto-2.1... done
 done
Installing libogg-1.3.1,4... done
Installing libvorbis-1.3.4,3... done
Installing png-1.5.18... done
 done
===============================================================================

Allegro has been installed.

Allegro have two Demos (Games)

Shooter and Skater


You can use executable

    /usr/local/bin/shooter

    /usr/local/bin/skater


Or can use desktop files

    /usr/local/share/applications/shooter.desktop

    /usr/local/share/applications/skater.desktop

Have fun!

===============================================================================
===>   Returning to build of raine-0.43.3_9
===>   raine-0.43.3_9 depends on shared library: png15 - found
===>   raine-0.43.3_9 depends on shared library: vga.1 - not found
===>    Verifying install for vga.1 in /usr/ports/graphics/svgalib
===>   Installing existing package /packages/All/svgalib-1.4.3_6.txz
Installing svgalib-1.4.3_6... done
===>   Returning to build of raine-0.43.3_9
===>   raine-0.43.3_9 depends on shared library: SDL-1.2 - found
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for raine-0.43.3_9
===========================================================================
=======================<phase: build          >============================
===>  Building for raine-0.43.3_9
gmake[1]: Entering directory 
`/wrkdirs/usr/ports/emulators/raine/work/raine-0.43.3'
makefile:1055: cpuinfo: No such file or directory
Checking for gcc version ... 
not found
Checking for gcc version ... 
not found
Checking for gcc-3.4 version ... 
not found
Checking for gcc-3.3 version ... 
not found
Checking for gcc-3.2 version ... 
not found
Checking for gcc-3.1 version ... 
not found
Checking for gcc3 version ... 
not found
Checking for gcc-3.0 version ... 
not found
Checking for cc version ... 
4.2.1, ok
pvendor GenuineIntel pfamily 6 model 44
Checking for GCC & CPU optimization abilities ... pentium3
gmake[1]: Leaving directory 
`/wrkdirs/usr/ports/emulators/raine/work/raine-0.43.3'
gmake[1]: Entering directory 
`/wrkdirs/usr/ports/emulators/raine/work/raine-0.43.3'
Building Raine, Fully optimized version with svgalib support with gcc for 
linux-gnu CPU=pentium3
dependencies : if you get an error here, install the required dev package
libpng:1.5.18
sdl:1.2.15
allegro:4.4.2
Compiling StarScream...
gmake[1]: gcc: Command not found
gmake[1]: *** [linux-gnu/object/68000/star.o] Error 127
gmake[1]: Leaving directory 
`/wrkdirs/usr/ports/emulators/raine/work/raine-0.43.3'
*** Error code 1

Stop.
make: stopped in /usr/ports/emulators/raine
===>  Cleaning for raine-0.43.3_9
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to