You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     l...@freebsd.org
Last committer: l...@freebsd.org
Ident:          $FreeBSD: branches/2014Q2/games/scummvm-tools/Makefile 350856 
2014-04-10 21:25:00Z lme $
Log URL:        
http://beefy1.isc.freebsd.org/bulk/10i386-quarterly/2014-05-28_22h19m38s/logs/scummvm-tools-1.6.0_2.log
Build URL:      
http://beefy1.isc.freebsd.org/bulk/10i386-quarterly/2014-05-28_22h19m38s
Log:

====>> Building games/scummvm-tools
build started at Thu May 29 13:19:34 UTC 2014
port directory: /usr/ports/games/scummvm-tools
building for: FreeBSD 10i386-quarterly-job-06 10.0-RELEASE-p3 FreeBSD 
10.0-RELEASE-p3 i386
maintained by: l...@freebsd.org
Makefile ident:      $FreeBSD: branches/2014Q2/games/scummvm-tools/Makefile 
350856 2014-04-10 21:25:00Z lme $
Poudriere version: 3.1-pre
Host OSVERSION: 1100013
Jail OSVERSION: 1000510

---Begin Environment---
UNAME_m=i386
UNAME_p=i386
OSVERSION=1000510
UNAME_v=FreeBSD 10.0-RELEASE-p3
UNAME_r=10.0-RELEASE-p3
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
SAVED_TERM=
MASTERMNT=/usr/local/poudriere/data/build/10i386-quarterly/ref
PKG_EXT=txz
tpid=39506
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
POUDRIERE_BUILD_TYPE=bulk
PKGNG=1
PKGNAME=scummvm-tools-1.6.0_2
PKG_DELETE=/usr/local/sbin/pkg-static delete -y -f
PKG_ADD=/usr/local/sbin/pkg-static add
OLDPWD=/usr/local/poudriere/data/build/10i386-quarterly/ref/poudriere/rdeps
PWD=/usr/local/poudriere/data/build/10i386-quarterly/ref/poudriere/pool
MASTERNAME=10i386-quarterly
USER=root
HOME=/root
POUDRIERE_VERSION=3.1-pre
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
PKG_VERSION=/poudriere/pkg-static version
PKG_BIN=/usr/local/sbin/pkg-static
---End Environment---

---Begin OPTIONS List---
===> The following configuration options are available for 
scummvm-tools-1.6.0_2:
     WXGTK=on: wxGTK GUI toolkit support
===> Use 'make config' to modify these settings
---End OPTIONS List---

--CONFIGURE_ARGS--
--prefix=/usr/local ${_LATE_CONFIGURE_ARGS}
--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
TMPDIR="/tmp" TMPDIR="/tmp" MAKE=gmake TMPDIR="/tmp" SHELL=/bin/sh 
CONFIG_SHELL=/bin/sh WX_CONFIG=/usr/local/bin/wxgtk2u-2.8-config 
CONFIG_SITE=/usr/ports/Templates/config.site lt_cv_sys_max_cmd_len=262144
--End CONFIGURE_ENV--

--MAKE_ENV--
TMPDIR="/tmp" TMPDIR="/tmp" TMPDIR="/tmp" SHELL=/bin/sh NO_LINT=YES 
WX_CONFIG=/usr/local/bin/wxgtk2u-2.8-config PREFIX=/usr/local  
LOCALBASE=/usr/local  LIBDIR="/usr/lib"  CC="cc" CFLAGS="-O2 -pipe 
-fno-strict-aliasing"  CPP="cpp" CPPFLAGS=""  LDFLAGS=""  CXX="c++" 
CXXFLAGS="-O2 -pipe -fno-strict-aliasing"  MANPREFIX="/usr/local" 
BSD_INSTALL_PROGRAM="install  -s -o root -g wheel -m 555"  
BSD_INSTALL_LIB="install  -s -o root -g wheel -m 444"  
BSD_INSTALL_SCRIPT="install  -o root -g wheel -m 555"  
BSD_INSTALL_DATA="install  -o root -g wheel -m 444"  BSD_INSTALL_MAN="install  
-o root -g wheel -m 444"
--End MAKE_ENV--

--PLIST_SUB--
WX=""
OSREL=10.0
PREFIX=%D
LOCALBASE=/usr/local
PORTDOCS=""
PORTEXAMPLES=""
PORTDATA=""
LIB32DIR=lib
DOCSDIR="share/doc/scummvm-tools"
EXAMPLESDIR="share/examples/scummvm-tools"
DATADIR="share/scummvm-tools"
WWWDIR="www/scummvm-tools"
ETCDIR="etc/scummvm-tools"
--End PLIST_SUB--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/scummvm-tools
DOCSDIR=/usr/local/share/doc/scummvm-tools
EXAMPLESDIR=/usr/local/share/examples/scummvm-tools
WWWDIR=/usr/local/www/scummvm-tools
ETCDIR=/usr/local/etc/scummvm-tools
--End SUB_LIST--

---Begin make.conf---
ARCH=i386
MACHINE=i386
MACHINE_ARCH=i386
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
WITH_PKGNG=yes
# clean-restricted via poudriere.conf NO_RESTRICTED
#NO_RESTRICTED=yes
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
===>  Cleaning for scummvm-tools-1.6.0_2
=======================<phase: check-sanity   >============================
===>  License GPLv2 accepted by the user
===========================================================================
=======================<phase: pkg-depends    >============================
===>   scummvm-tools-1.6.0_2 depends on file: /usr/local/sbin/pkg - not found
===>    Verifying install for /usr/local/sbin/pkg in /usr/ports/ports-mgmt/pkg
===>   Installing existing package /packages/All/pkg-1.2.7.txz
Installing pkg-1.2.7... done
If you are upgrading from the old package format, first run:

  # pkg2ng
===>   Returning to build of scummvm-tools-1.6.0_2
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===>  License GPLv2 accepted by the user
===> Fetching all distfiles required by scummvm-tools-1.6.0_2 for building
===========================================================================
=======================<phase: checksum       >============================
===>  License GPLv2 accepted by the user
===> Fetching all distfiles required by scummvm-tools-1.6.0_2 for building
=> SHA256 Checksum OK for scummvm-tools-1.6.0.tar.bz2.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===>  License GPLv2 accepted by the user
===> Fetching all distfiles required by scummvm-tools-1.6.0_2 for building
===>  Extracting for scummvm-tools-1.6.0_2
=> SHA256 Checksum OK for scummvm-tools-1.6.0.tar.bz2.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for scummvm-tools-1.6.0_2
===========================================================================
=======================<phase: build-depends  >============================
===>   scummvm-tools-1.6.0_2 depends on executable: lame - not found
===>    Verifying install for lame in /usr/ports/audio/lame
===>   Installing existing package /packages/All/lame-3.99.5_1.txz
Installing lame-3.99.5_1... done
===>   Returning to build of scummvm-tools-1.6.0_2
===>   scummvm-tools-1.6.0_2 depends on executable: flac - not found
===>    Verifying install for flac in /usr/ports/audio/flac
===>   Installing existing package /packages/All/flac-1.3.0_1.txz
Installing flac-1.3.0_1...Installing libogg-1.3.1,4... done
 done
===>   Returning to build of scummvm-tools-1.6.0_2
===>   scummvm-tools-1.6.0_2 depends on executable: oggenc - not found
===>    Verifying install for oggenc in /usr/ports/audio/vorbis-tools
===>   Installing existing package /packages/All/vorbis-tools-1.4.0_6,3.txz
Installing vorbis-tools-1.4.0_6,3...Installing curl-7.36.0...Installing 
ca_root_nss-3.15.5... done
 done
Installing gettext-0.18.3.1... done
Installing libao-1.1.0_1... done
Installing libkate-0.4.1_2...Installing png-1.5.18... done
 done
Installing libvorbis-1.3.4,3... done
Installing speex-1.2.r1_6,1... done
 done
===>   Returning to build of scummvm-tools-1.6.0_2
===>   scummvm-tools-1.6.0_2 depends on executable: oggdec - found
===>   scummvm-tools-1.6.0_2 depends on executable: gmake - not found
===>    Verifying install for gmake in /usr/ports/devel/gmake
===>   Installing existing package /packages/All/gmake-3.82_1.txz
Installing gmake-3.82_1... done
===>   Returning to build of scummvm-tools-1.6.0_2
===========================================================================
=======================<phase: lib-depends    >============================
===>   scummvm-tools-1.6.0_2 depends on shared library: libpng15.so - found
===>   scummvm-tools-1.6.0_2 depends on shared library: libvorbis.so - found
===>   scummvm-tools-1.6.0_2 depends on shared library: libwx_baseu-2.8.so - 
not found
===>    Verifying for libwx_baseu-2.8.so in 
/usr/ports/x11-toolkits/wxgtk28-unicode
===>   Installing existing package /packages/All/wx28-gtk2-unicode-2.8.12_2.txz
Installing wx28-gtk2-unicode-2.8.12_2...Installing ORBit2-2.14.19...Installing 
glib-2.36.3_2...Installing libffi-3.0.13_1... done
Installing libiconv-1.14_3... done
Installing pcre-8.34... done
Installing perl5-5.16.3_9... done
Installing python27-2.7.6_4... done
No schema files found: doing nothing.
 done
Installing libIDL-0.8.14_1... done
 done
Installing atk-2.8.0...Installing gnomehier-3.0... done
 done
Installing expat-2.1.0... done
Installing gconf2-2.32.0_3...Installing dbus-glib-0.100.2...Installing 
dbus-1.6.18...Installing gnome_subr-1.0... done
Installing libICE-1.0.8,1...Installing xproto-7.0.25... done
 done
Installing libSM-1.2.2,1... done
Installing libX11-1.6.2,1...Installing kbproto-1.0.6... done
Installing libXau-1.0.8... done
Installing libXdmcp-1.1.1... done
Installing libxcb-1.9.3...Installing libpthread-stubs-0.3_4... done
Installing libxml2-2.9.1_1... done
 done
<snip>
Alignment required... no
Checking hosttype... freebsd10.0
Checking if host is POSIX compliant... yes
Checking whether to have a verbose build... no
Checking for Ogg Vorbis... yes
Checking for Tremor... no (Ogg Vorbis/Tremor support is mutually exclusive)
Checking for FLAC >= 1.1.3... yes
Checking for MAD... no
Checking for PNG >= 1.2.8... yes
Checking for zlib... yes
Checking for freetype... 2.5.3
Checking for Boost => 1.32.0... no
Checking whether iconv.h is present... yes
Checking whether iconv needs linking against libiconv... yes
Checking signature of iconv... iconv_t, const char **, size_t *, char **, 
size_t *
Checking for iconv... yes
Looking for wx-config... /usr/local/bin/wxgtk2u-2.8-config
Checking for wxwidgets gui dev component... found

Creating config.h
Creating config.mk
===========================================================================
=======================<phase: build          >============================
===>  Building for scummvm-tools-1.6.0_2
gmake[1]: Entering directory 
`/wrkdirs/usr/ports/games/scummvm-tools/work/scummvm-tools-1.6.0'
    C++      engines/cine/decine.o
    LINK     decine
    C++      engines/gob/degob.o
    C++      engines/gob/degob_script.o
    C++      engines/gob/degob_script_v1.o
    C++      engines/gob/degob_script_v2.o
    C++      engines/gob/degob_script_v3.o
    C++      engines/gob/degob_script_v4.o
    C++      engines/gob/degob_script_v5.o
    C++      engines/gob/degob_script_v6.o
    C++      engines/gob/degob_script_bargon.o
    C++      engines/gob/degob_script_fascin.o
    C++      engines/gob/degob_script_geisha.o
    C++      engines/gob/degob_script_littlered.o
    C++      tool.o
    C++      engines/scumm/descumm.o
engines/scumm/descumm.cpp:1486:68: warning: data argument not used by format 
string [-Wformat-extra-args]
                        sprintf(buf, g_options.alwaysShowOffs ? ") /*%.4X*/ {" 
: ") {", to);
                                                                                
 ~~~~~  ^
engines/scumm/descumm.cpp:1497:67: warning: data argument not used by format 
string [-Wformat-extra-args]
                sprintf(buf, g_options.alwaysShowOffs ? ") /*%.4X*/ {" : ") {", 
to);
                                                                         ~~~~~  
^
2 warnings generated.
    C++      engines/scumm/descumm6.o
engines/scumm/descumm6.cpp:1442:66: warning: data argument not used by format 
string [-Wformat-extra-args]
                        sprintf(e, g_options.alwaysShowOffs ? ") /*%.4X*/ {" : 
") {", to);
                                                                               
~~~~~  ^
engines/scumm/descumm6.cpp:1453:65: warning: data argument not used by format 
string [-Wformat-extra-args]
                sprintf(e, g_options.alwaysShowOffs ? ") /*%.4X*/ {" : ") {", 
to);
                                                                       ~~~~~  ^
2 warnings generated.
    C++      engines/scumm/descumm-common.o
engines/scumm/descumm-common.cpp:239:77: warning: data argument not used by 
format string [-Wformat-extra-args]
                sprintf(buf, g_options.alwaysShowOffs ? "} else /*%.4X*/ {" : 
"} else {", pendingElseTo);
                                                                              
~~~~~~~~~~  ^
1 warning generated.
    C++      engines/scumm/descumm-tool.o
    C++      common/file.o
    C++      common/hashmap.o
    C++      common/md5.o
    C++      common/memorypool.o
    C++      common/str.o
    C++      common/util.o
    C++      sound/adpcm.o
    C++      sound/audiostream.o
    C++      sound/voc.o
    C++      sound/wave.o
    C++      engines/sword2/desword2.o
    C++      main_cli.o
    C++      scummvm-tools-cli.o
    C++      engines/agos/compress_agos.o
    C++      engines/gob/compress_gob.o
    C++      engines/gob/extract_fascination_cd.o
    C++      engines/kyra/compress_kyra.o
    C++      engines/queen/compress_queen.o
    C++      engines/saga/compress_saga.o
    C++      engines/sci/compress_sci.o
    C++      engines/scumm/compress_scumm_bun.o
    C++      engines/scumm/compress_scumm_san.o
    C++      engines/scumm/compress_scumm_sou.o
    C++      engines/sword1/compress_sword1.o
    C++      engines/sword2/compress_sword2.o
    C++      engines/tinsel/compress_tinsel.o
    C++      engines/touche/compress_touche.o
    C++      engines/tucker/compress_tucker.o
    C++      engines/agos/extract_agos.o
    C++      engines/cge/extract_cge.o
    C++      engines/cge/pack_cge.o
    C++      engines/cine/extract_cine.o
    C++      engines/cruise/extract_cruise_pc.o
    C++      engines/gob/extract_gob_stk.o
    C++      engines/kyra/extract_kyra.o
    C++      engines/parallaction/extract_parallaction.o
    C++      engines/scumm/extract_loom_tg16.o
    C++      engines/scumm/extract_mm_apple.o
    C++      engines/scumm/extract_mm_c64.o
    C++      engines/scumm/extract_mm_nes.o
    C++      engines/scumm/extract_scumm_mac.o
    C++      engines/scumm/extract_zak_c64.o
    C++      engines/kyra/kyra_ins.o
    C++      engines/kyra/kyra_pak.o
    C++      compress.o
    C++      tools.o
    C++      encode_dxa.o
    C++      gui/configuration.o
    C++      gui/gui_tools.o
    C++      gui/main.o
    C++      gui/pages.o
    C++      version.o
    LINK     degob
    C++      engines/kyra/dekyra.o
engines/kyra/dekyra.cpp:106:13: warning: variable 'opcodes' is used 
uninitialized whenever 'if' condition is false [-Wsometimes-uninitialized]
        } else if (engine == 2) {
                   ^~~~~~~~~~~
engines/kyra/dekyra.cpp:110:52: note: uninitialized use occurs here
        if (!myScript.loadScript(argv[file], &scriptData, opcodes, 
opcodesSize)) {
                                                          ^~~~~~~
engines/kyra/dekyra.cpp:106:9: note: remove the 'if' if its condition is always 
true
        } else if (engine == 2) {
               ^~~~~~~~~~~~~~~~~
engines/kyra/dekyra.cpp:101:22: note: initialize the variable 'opcodes' to 
silence this warning
        OpcodeEntry *opcodes;
                            ^
                             = NULL
engines/kyra/dekyra.cpp:106:13: warning: variable 'opcodesSize' is used 
uninitialized whenever 'if' condition is false [-Wsometimes-uninitialized]
        } else if (engine == 2) {
                   ^~~~~~~~~~~
engines/kyra/dekyra.cpp:110:61: note: uninitialized use occurs here
        if (!myScript.loadScript(argv[file], &scriptData, opcodes, 
opcodesSize)) {
                                                                   ^~~~~~~~~~~
engines/kyra/dekyra.cpp:106:9: note: remove the 'if' if its condition is always 
true
        } else if (engine == 2) {
               ^~~~~~~~~~~~~~~~~
engines/kyra/dekyra.cpp:102:17: note: initialize the variable 'opcodesSize' to 
silence this warning
        int opcodesSize;
                       ^
                        = 0
2 warnings generated.
    C++      engines/kyra/dekyra_v1.o
    LINK     dekyra
    C++      engines/mohawk/archive.o
In file included from engines/mohawk/archive.cpp:23:
./engines/mohawk/archive.h:210:7: warning: private field '_hasData' is not used 
[-Wunused-private-field]
        bool _hasData;
             ^
./engines/mohawk/archive.h:214:9: warning: private field '_nameTableAmount' is 
not used [-Wunused-private-field]
        uint16 _nameTableAmount;
               ^
./engines/mohawk/archive.h:215:9: warning: private field '_resourceTableAmount' 
is not used [-Wunused-private-field]
        uint16 _resourceTableAmount;
               ^
3 warnings generated.
    C++      engines/mohawk/deriven.o
    C++      engines/mohawk/utils/file.o
    LINK     deriven
    LINK     descumm
    LINK     desword2
    C++      engines/gob/gob_loadcalc.o
    LINK     gob_loadcalc
    C++      engines/mohawk/extract_mohawk.o
    LINK     extract_mohawk
    C++      engines/mohawk/construct_mohawk.o
    LINK     construct_mohawk
    LINK     scummvm-tools-cli
    C++      create_sjisfnt.o
    LINK     create_sjisfnt
    LINK     scummvm-tools
gmake[1]: Leaving directory 
`/wrkdirs/usr/ports/games/scummvm-tools/work/scummvm-tools-1.6.0'
===========================================================================
=======================<phase: run-depends    >============================
===>   scummvm-tools-1.6.0_2 depends on executable: scummvm - not found
===>    Verifying install for scummvm in /usr/ports/games/scummvm
===>   Installing existing package /packages/All/scummvm-1.6.0_1.txz
Installing scummvm-1.6.0_1...Installing libmad-0.15.1b_4... done
Installing sdl-1.2.15_3,2...Installing aalib-1.4.r5_9... done
 done
 done
------------------------------------------------------------------------------
 Your SDL library has been built with libvgl support, which means that you
 can run almost any SDL application straight on your console (VESA 2.0
 compatible videocard is required).

 To do this you have to load the vesa kernel module or enable it in your
 kernel, and set environment variable "SDL_VIDEODRIVER=vgl".
------------------------------------------------------------------------------
===>   Returning to build of scummvm-tools-1.6.0_2
===========================================================================
=======================<phase: stage          >============================
===>  Staging for scummvm-tools-1.6.0_2
/usr/bin/strip: 
'/wrkdirs/usr/ports/games/scummvm-tools/work/scummvm-tools-1.6.0/decompile': No 
such file
*** Error code 1

Stop.
make: stopped in /usr/ports/games/scummvm-tools
===>  Cleaning for scummvm-tools-1.6.0_2
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to