You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     marty...@freebsd.org
Last committer: b...@freebsd.org
Ident:          $FreeBSD: head/editors/yzis/Makefile 355360 2014-05-26 
15:28:28Z bapt $
Log URL:        
http://beefy1.isc.freebsd.org/bulk/91i386-default/2014-05-30_14h17m19s/logs/yzis-1.0.a.1_11.log
Build URL:      
http://beefy1.isc.freebsd.org/bulk/91i386-default/2014-05-30_14h17m19s
Log:

====>> Building editors/yzis
build started at Sat May 31 07:18:27 UTC 2014
port directory: /usr/ports/editors/yzis
building for: FreeBSD 91i386-default-job-01 9.1-RELEASE-p13 FreeBSD 
9.1-RELEASE-p13 i386
maintained by: marty...@freebsd.org
Makefile ident:      $FreeBSD: head/editors/yzis/Makefile 355360 2014-05-26 
15:28:28Z bapt $
Poudriere version: 3.1-pre
Host OSVERSION: 1100013
Jail OSVERSION: 901000

---Begin Environment---
UNAME_m=i386
UNAME_p=i386
OSVERSION=901000
UNAME_v=FreeBSD 9.1-RELEASE-p13
UNAME_r=9.1-RELEASE-p13
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
SAVED_TERM=
MASTERMNT=/usr/local/poudriere/data/build/91i386-default/ref
PKG_EXT=txz
tpid=51687
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
POUDRIERE_BUILD_TYPE=bulk
PKGNG=1
PKGNAME=yzis-1.0.a.1_11
PKG_DELETE=/usr/local/sbin/pkg-static delete -y -f
PKG_ADD=/usr/local/sbin/pkg-static add
OLDPWD=/usr/local/poudriere/data/build/91i386-default/ref/poudriere/rdeps
PWD=/usr/local/poudriere/data/build/91i386-default/ref/poudriere/pool
MASTERNAME=91i386-default
USER=root
HOME=/root
POUDRIERE_VERSION=3.1-pre
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
PKG_VERSION=/poudriere/pkg-static version
PKG_BIN=/usr/local/sbin/pkg-static
---End Environment---

---Begin OPTIONS List---
===> The following configuration options are available for yzis-1.0.a.1_11:
     DOCS=on: Build and/or install documentation
     KYZIS=off: Build kyzis and Yzis kpart
     NYZIS=off: Build nyzis (ncurses frontend)
===> Use 'make config' to modify these settings
---End OPTIONS List---

--CONFIGURE_ARGS--
--with-qt-includes=/usr/local/include/qt4  
--with-qt-libraries=/usr/local/lib/qt4  
--with-extra-includes=/usr/local/include  --with-extra-libs=/usr/local/lib
--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
TMPDIR="/tmp" TMPDIR="/tmp" QTDIR="/usr/local" QMAKE="/usr/local/bin/qmake-qt4" 
 MOC="/usr/local/bin/moc-qt4" RCC="/usr/local/bin/rcc" 
UIC="/usr/local/bin/uic-qt4"  
QMAKESPEC="/usr/local/share/qt4/mkspecs/freebsd-$(ccver="$(g++ --version)"; 
case "$ccver" in *clang*) echo clang ;; *) echo g++ ;; esac)" 
ac_cv_path_PERL=/usr/local/bin/perl ac_cv_path_PERL_PATH=/usr/local/bin/perl 
SHELL=/bin/sh CONFIG_SHELL=/bin/sh
--End CONFIGURE_ENV--

--MAKE_ENV--
TMPDIR="/tmp" TMPDIR="/tmp" LUA_MODLIBDIR=/usr/local/lib/lua/5.1  
LUA_MODSHAREDIR=/usr/local/share/lua/5.1  LUA_VER=5.1  
LUA_INCDIR=/usr/local/include/lua51  LUA_LIBDIR=/usr/local/lib SHELL=/bin/sh 
NO_LINT=YES PREFIX=/usr/local  LOCALBASE=/usr/local  LIBDIR="/usr/lib"  
CC="gcc" CFLAGS="-O2 -pipe -fno-strict-aliasing"  CPP="gcpp" CPPFLAGS=""  
LDFLAGS=""  CXX="g++" CXXFLAGS="-O2 -pipe -fno-strict-aliasing"  
MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install  -s -o root -g wheel -m 
555"  BSD_INSTALL_LIB="install  -s -o root -g wheel -m 444"  
BSD_INSTALL_SCRIPT="install  -o root -g wheel -m 555"  
BSD_INSTALL_DATA="install  -o root -g wheel -m 444"  BSD_INSTALL_MAN="install  
-o root -g wheel -m 444"
--End MAKE_ENV--

--PLIST_SUB--
DOCS=""
NO_DOCS="@comment
"
KYZIS="@comment
"
NO_KYZIS=""
NYZIS="@comment
"
NO_NYZIS=""
QYZIS=""
QT_PREFIX="/usr/local"
QT_BINDIR="bin"
QT_INCDIR="include/qt4"
QT_LIBDIR="lib/qt4"
QT_ARCHDIR="lib/qt4/qt4"
QT_PLUGINDIR="lib/qt4/plugins"
QT_LIBEXECDIR="libexec/qt4"
QT_IMPORTDIR="lib/qt4/imports"
QT_QMLDIR="lib/qt4/qt4/qml"
QT_DATADIR="share/qt4"
QT_DOCDIR="share/doc/qt4"
QT_L10NDIR="share/qt4/translations"
QT_ETCDIR="etc/xdg"
QT_EXAMPLEDIR="share/examples/qt4"
QT_TESTDIR="share/qt4/tests"
QT_MKSPECDIR="share/qt4/mkspecs"
CMAKE_BUILD_TYPE="release"
LUA_MODLIBDIR=lib/lua/5.1
LUA_MODSHAREDIR=share/lua/5.1
LUA_VER=5.1
LUA_INCDIR=/usr/local/include/lua51
LUA_LIBDIR=/usr/local/lib
LUA_VER_STR=51
OSREL=9.1
PREFIX=%D
LOCALBASE=/usr/local
PORTDOCS=""
PORTEXAMPLES=""
PORTDATA=""
LIB32DIR=lib
GTK2_VERSION="2.10.0"
GTK3_VERSION="3.0.0"
PERL_VERSION=5.16.3
PERL_VER=5.16
PERL_ARCH=mach
PERL5_MAN3=lib/perl5/5.16/man/man3
SITE_PERL=lib/perl5/site_perl/5.16
DOCSDIR="share/doc/yzis"
EXAMPLESDIR="share/examples/yzis"
DATADIR="share/yzis"
WWWDIR="www/yzis"
ETCDIR="etc/yzis"
--End PLIST_SUB--

--SUB_LIST--
DOCS=""
NO_DOCS="@comment
"
KYZIS="@comment
"
NO_KYZIS=""
NYZIS="@comment
"
NO_NYZIS=""
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/yzis
DOCSDIR=/usr/local/share/doc/yzis
EXAMPLESDIR=/usr/local/share/examples/yzis
WWWDIR=/usr/local/www/yzis
ETCDIR=/usr/local/etc/yzis
--End SUB_LIST--

---Begin make.conf---
ARCH=i386
MACHINE=i386
MACHINE_ARCH=i386
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
WITH_PKGNG=yes
# clean-restricted via poudriere.conf NO_RESTRICTED
#NO_RESTRICTED=yes
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
===>  Cleaning for yzis-1.0.a.1_11
=======================<phase: check-sanity   >============================
===>  License GPLv2 LGPL21 accepted by the user
===========================================================================
=======================<phase: pkg-depends    >============================
===>   yzis-1.0.a.1_11 depends on file: /usr/local/sbin/pkg - not found
===>    Verifying install for /usr/local/sbin/pkg in /usr/ports/ports-mgmt/pkg
===>   Installing existing package /packages/All/pkg-1.2.7_2.txz
Installing pkg-1.2.7_2... done
If you are upgrading from the old package format, first run:

  # pkg2ng
===>   Returning to build of yzis-1.0.a.1_11
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===>  License GPLv2 LGPL21 accepted by the user
===> Fetching all distfiles required by yzis-1.0.a.1_11 for building
===========================================================================
=======================<phase: checksum       >============================
===>  License GPLv2 LGPL21 accepted by the user
===> Fetching all distfiles required by yzis-1.0.a.1_11 for building
=> SHA256 Checksum OK for yzis-1.0-alpha1.tar.bz2.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===>  License GPLv2 LGPL21 accepted by the user
===> Fetching all distfiles required by yzis-1.0.a.1_11 for building
===>  Extracting for yzis-1.0.a.1_11
=> SHA256 Checksum OK for yzis-1.0-alpha1.tar.bz2.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for yzis-1.0.a.1_11
===>  Applying FreeBSD patches for yzis-1.0.a.1_11
===========================================================================
=======================<phase: build-depends  >============================
===>   yzis-1.0.a.1_11 depends on executable: dot - not found
===>    Verifying install for dot in /usr/ports/graphics/graphviz
===>   Installing existing package /packages/All/graphviz-2.36.0_6.txz
Installing graphviz-2.36.0_6...Installing expat-2.1.0... done
Installing fontconfig-2.11.0_3,1...Installing freetype2-2.5.3_2... done
Running fc-cache to build fontconfig cache...
/usr/local/share/fonts: skipping, no such directory
/usr/local/lib/X11/fonts: caching, new cache contents: 0 fonts, 1 dirs
<snip>
====
Note that some of the standard modules are provided as separate
ports since they require extra dependencies:

bsddb           databases/py-bsddb
gdbm            databases/py-gdbm
sqlite3         databases/py-sqlite3
tkinter         x11-toolkits/py-tkinter

Install them as needed.
====
Since FreeBSD has new USB stack, freeglut normally doesn't build on FreeBSD 8
(yet). To workaround this a small patch adds one include file and comments out
content of one function (only leaves return NULL).

This might cause side effects.  Joysticks do not work, and there might be ports
that do not compile or applications that crash because of this.

Do not hesitate to contact x...@freebsd.org if there are any issues and side
effects because of this.
Make sure that the freetype module is loaded.  If it is not, add the following
line to the "Modules" section of your X Windows configuration file:

        Load "freetype"

Add the following line to the "Files" section of X Windows configuration file:

        FontPath "/usr/local/lib/X11/fonts/dejavu/"

Note: your X Windows configuration file is typically /etc/X11/XF86Config
if you are using XFree86, and /etc/X11/xorg.conf if you are using X.Org.
===>   Returning to build of yzis-1.0.a.1_11
===>   yzis-1.0.a.1_11 depends on executable: doxygen - not found
===>    Verifying install for doxygen in /usr/ports/devel/doxygen
===>   Installing existing package /packages/All/doxygen-1.8.3.1_1.txz
Installing doxygen-1.8.3.1_1... done
===>   Returning to build of yzis-1.0.a.1_11
===>   yzis-1.0.a.1_11 depends on file: /usr/local/bin/cmake - not found
===>    Verifying install for /usr/local/bin/cmake in /usr/ports/devel/cmake
===>   Installing existing package /packages/All/cmake-2.8.12.1_4.txz
Installing cmake-2.8.12.1_4...Installing cmake-modules-2.8.12.1_1... done
 done
===>   Returning to build of yzis-1.0.a.1_11
===>   yzis-1.0.a.1_11 depends on file: /usr/local/libdata/pkgconfig/x11.pc - 
found
===>   yzis-1.0.a.1_11 depends on file: /usr/local/libdata/pkgconfig/xext.pc - 
found
===>   yzis-1.0.a.1_11 depends on file: /usr/local/libdata/pkgconfig/ice.pc - 
found
===>   yzis-1.0.a.1_11 depends on file: /usr/local/lib/qt4/libQtGui.so - not 
found
===>    Verifying install for /usr/local/lib/qt4/libQtGui.so in 
/usr/ports/x11-toolkits/qt4-gui
===>   Installing existing package /packages/All/qt4-gui-4.8.6.txz
Installing qt4-gui-4.8.6...Installing libXcursor-1.1.14_2... done
Installing libXinerama-1.1.3_2,1...Installing xineramaproto-1.2.1... done
 done
Installing qt4-corelib-4.8.6... done
Installing xdg-utils-1.0.2.20130919_1...Installing hicolor-icon-theme-0.12... 
done
Installing xprop-1.2.2... done
Installing xset-1.2.3_1...Installing libXfontcache-1.0.5_2...Installing 
fontcacheproto-0.1.3... done
 done
 done
 done
 done
======================================================================

Qt 4 can be built with optional support for:
 - Common UNIX Printing System (CUPS) (enabled by default)
 - Network Audio System (NAS)
 - Qt style that renders using GTK (QGTKSTYLE)

In order to enable them, you have to add
        QT4_OPTIONS=    CUPS NAS QGTKSTYLE
to your /etc/make.conf and compile devel/qt4-corelib and
x11-toolkits/qt4-gui ports.

Attention! Whenever you change the QT4_OPTIONS both
devel/qt4-corelib and x11-toolkits/qt4-gui ports must be rebuilt!

======================================================================
======================================================================

Qt paint engine makes common use of shared memory. To avoid MIT-SHM
errors (i.e., blank windows), you probably need to raise shared memory
limits in loader.conf(5). The following should be safe values for the
KDE Plasma Desktop:

kern.ipc.shmall=32768
kern.ipc.shmmni=1024
kern.ipc.shmseg=1024

======================================================================
===>   Returning to build of yzis-1.0.a.1_11
===>   yzis-1.0.a.1_11 depends on file: /usr/local/bin/moc-qt4 - not found
===>    Verifying install for /usr/local/bin/moc-qt4 in /usr/ports/devel/qt4-moc
===>   Installing existing package /packages/All/qt4-moc-4.8.6.txz
Installing qt4-moc-4.8.6... done
===>   Returning to build of yzis-1.0.a.1_11
===>   yzis-1.0.a.1_11 depends on file: /usr/local/bin/qmake-qt4 - not found
===>    Verifying install for /usr/local/bin/qmake-qt4 in 
/usr/ports/devel/qmake4
===>   Installing existing package /packages/All/qt4-qmake-4.8.6.txz
Installing qt4-qmake-4.8.6... done
===>   Returning to build of yzis-1.0.a.1_11
===>   yzis-1.0.a.1_11 depends on file: /usr/local/lib/qt4/libQtTest.so - not 
found
===>    Verifying install for /usr/local/lib/qt4/libQtTest.so in 
/usr/ports/devel/qt4-testlib
===>   Installing existing package /packages/All/qt4-testlib-4.8.6.txz
Installing qt4-testlib-4.8.6... done
===>   Returning to build of yzis-1.0.a.1_11
===>   yzis-1.0.a.1_11 depends on file: /usr/local/bin/rcc - not found
===>    Verifying install for /usr/local/bin/rcc in /usr/ports/devel/qt4-rcc
===>   Installing existing package /packages/All/qt4-rcc-4.8.6.txz
Installing qt4-rcc-4.8.6... done
===>   Returning to build of yzis-1.0.a.1_11
===>   yzis-1.0.a.1_11 depends on file: /usr/local/bin/uic-qt4 - not found
===>    Verifying install for /usr/local/bin/uic-qt4 in /usr/ports/devel/qt4-uic
===>   Installing existing package /packages/All/qt4-uic-4.8.6.txz
Installing qt4-uic-4.8.6... done
===>   Returning to build of yzis-1.0.a.1_11
===>   yzis-1.0.a.1_11 depends on file: /usr/local/lib/qt4/libQtXml.so - not 
found
===>    Verifying install for /usr/local/lib/qt4/libQtXml.so in 
/usr/ports/textproc/qt4-xml
===>   Installing existing package /packages/All/qt4-xml-4.8.6.txz
Installing qt4-xml-4.8.6... done
===>   Returning to build of yzis-1.0.a.1_11
===>   yzis-1.0.a.1_11 depends on executable: gtk-update-icon-cache - not found
===>    Verifying install for gtk-update-icon-cache in 
/usr/ports/graphics/gtk-update-icon-cache
===>   Installing existing package 
/packages/All/gtk-update-icon-cache-2.24.22.txz
Installing gtk-update-icon-cache-2.24.22...Installing atk-2.8.0...Installing 
gnomehier-3.0... done
 done
Installing gdk-pixbuf2-2.28.2...Installing jasper-1.900.1_14... done
 done
Installing libXcomposite-0.4.4_2,1...Installing compositeproto-0.4.2... done
 done
Installing shared-mime-info-1.1_1... done
 done
===>   Returning to build of yzis-1.0.a.1_11
===>   yzis-1.0.a.1_11 depends on file: /usr/local/bin/perl5.16.3 - found
===========================================================================
=======================<phase: lib-depends    >============================
===>   yzis-1.0.a.1_11 depends on shared library: libintl.so - found 
(/usr/local/lib/libintl.so.9)
===>   yzis-1.0.a.1_11 depends on shared library: liblua-5.1.so
 - not found
===>    Verifying for liblua-5.1.so in /usr/ports/lang/lua51
===>   Installing existing package /packages/All/lua51-5.1.5_7.txz
Installing lua51-5.1.5_7... done
===>   Returning to build of yzis-1.0.a.1_11
===>   yzis-1.0.a.1_11 depends on shared library: libatk-1.0.so - found 
(/usr/local/lib/libatk-1.0.so.0)
===>   yzis-1.0.a.1_11 depends on shared library: libgdk_pixbuf-2.0.so - found 
(/usr/local/lib/libgdk_pixbuf-2.0.so.0)
===>   yzis-1.0.a.1_11 depends on shared library: libglib-2.0.so - found 
(/usr/local/lib/libglib-2.0.so.0)
===>   yzis-1.0.a.1_11 depends on shared library: libpcre.so - found 
(/usr/local/lib/libpcre.so.3)
===>   yzis-1.0.a.1_11 depends on shared library: libpango-1.0.so - found 
(/usr/local/lib/libpango-1.0.so.0.3400.1)
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for yzis-1.0.a.1_11
===>  Performing in-source build
/bin/mkdir -p /wrkdirs/usr/ports/editors/yzis/work/yzis-1.0-alpha1
-- The C compiler identification is GNU 4.2.1
-- The CXX compiler identification is GNU 4.2.1
-- Check for working C compiler: /usr/bin/gcc
-- Check for working C compiler: /usr/bin/gcc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/g++
-- Check for working CXX compiler: /usr/bin/g++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Found libmagic: /usr/lib/libmagic.so
-- Looking for include file libintl.h
-- Looking for include file libintl.h - found
-- Looking for dgettext
-- Looking for dgettext - not found
-- Looking for dgettext in /usr/local/lib/libintl.so
-- Looking for dgettext in /usr/local/lib/libintl.so - found
-- Found Gettext: in /usr/local/lib/libintl.so
-- Looking for XOpenDisplay in 
/usr/local/lib/libX11.so;/usr/local/lib/libXext.so
-- Looking for XOpenDisplay in 
/usr/local/lib/libX11.so;/usr/local/lib/libXext.so - found
-- Looking for gethostbyname
-- Looking for gethostbyname - found
-- Looking for connect
-- Looking for connect - found
-- Looking for remove
-- Looking for remove - found
-- Looking for shmat
-- Looking for shmat - found
-- Looking for IceConnectionNumber in ICE
-- Looking for IceConnectionNumber in ICE - found
-- Found X11: /usr/local/lib/libX11.so
-- Looking for liblua (version 5.1)
-- WARNING: you are using the obsolete 'PKGCONFIG' macro, use FindPkgConfig
-- WARNING: PKGCONFIG() indicates that the tool pkg-config has not been found 
on your system. You should install it.
-- WARNING: you are using the obsolete 'PKGCONFIG' macro, use FindPkgConfig
-- WARNING: PKGCONFIG() indicates that the tool pkg-config has not been found 
on your system. You should install it.
CMake Error at cmake/modules/FindLibLua51.cmake:80 (message):
  Looking for liblua (version 5.1) - not found
Call Stack (most recent call first):
  CMakeLists.txt:87 (find_package)


-- Configuring incomplete, errors occurred!
See also 
"/wrkdirs/usr/ports/editors/yzis/work/yzis-1.0-alpha1/CMakeFiles/CMakeOutput.log".
See also 
"/wrkdirs/usr/ports/editors/yzis/work/yzis-1.0-alpha1/CMakeFiles/CMakeError.log".
*** [do-configure] Error code 1

Stop in /usr/ports/editors/yzis.
===>  Cleaning for yzis-1.0.a.1_11
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to