You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     guga...@mundounix.com.br
Last committer: b...@freebsd.org
Ident:          $FreeBSD: head/www/luakit/Makefile 355360 2014-05-26 15:28:28Z 
bapt $
Log URL:        
http://beefy2.isc.freebsd.org/bulk/10amd64-default/2014-05-31_16h19m31s/logs/luakit-2012.09.13r1_1.log
Build URL:      
http://beefy2.isc.freebsd.org/bulk/10amd64-default/2014-05-31_16h19m31s
Log:

====>> Building www/luakit
build started at Sun Jun  1 04:16:56 UTC 2014
port directory: /usr/ports/www/luakit
building for: FreeBSD 10amd64-default-job-17 10.0-RELEASE-p3 FreeBSD 
10.0-RELEASE-p3 amd64
maintained by: guga...@mundounix.com.br
Makefile ident:      $FreeBSD: head/www/luakit/Makefile 355360 2014-05-26 
15:28:28Z bapt $
Poudriere version: 3.1-pre
Host OSVERSION: 1100013
Jail OSVERSION: 1000510

---Begin Environment---
OSVERSION=1000510
UNAME_v=FreeBSD 10.0-RELEASE-p3
UNAME_r=10.0-RELEASE-p3
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
SAVED_TERM=
MASTERMNT=/usr/local/poudriere/data/build/10amd64-default/ref
PKG_EXT=txz
tpid=40054
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
POUDRIERE_BUILD_TYPE=bulk
PKGNG=1
PKGNAME=luakit-2012.09.13r1_1
PKG_DELETE=/usr/local/sbin/pkg-static delete -y -f
PKG_ADD=/usr/local/sbin/pkg-static add
OLDPWD=/usr/local/poudriere/data/build/10amd64-default/ref/poudriere/rdeps
PWD=/usr/local/poudriere/data/build/10amd64-default/ref/poudriere/pool
MASTERNAME=10amd64-default
USER=root
HOME=/root
POUDRIERE_VERSION=3.1-pre
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
PKG_VERSION=/poudriere/pkg-static version
PKG_BIN=/usr/local/sbin/pkg-static
---End Environment---

---Begin OPTIONS List---
===> The following configuration options are available for 
luakit-2012.09.13r1_1:
     LUAJIT=off: Use the Just-In-Time compiler for lua
===> Use 'make config' to modify these settings
---End OPTIONS List---

--CONFIGURE_ARGS--

--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
TMPDIR="/tmp" TMPDIR="/tmp" PKG_CONFIG=pkgconf MAKE=gmake SHELL=/bin/sh 
CONFIG_SHELL=/bin/sh
--End CONFIGURE_ENV--

--MAKE_ENV--
TMPDIR="/tmp" TMPDIR="/tmp" LUA_MODLIBDIR=/usr/local/lib/lua/5.1  
LUA_MODSHAREDIR=/usr/local/share/lua/5.1  LUA_VER=5.1  
LUA_INCDIR=/usr/local/include/lua51  LUA_LIBDIR=/usr/local/lib SHELL=/bin/sh 
NO_LINT=YES PREFIX=/usr/local  LOCALBASE=/usr/local  LIBDIR="/usr/lib"  CC="cc" 
CFLAGS="-O2 -pipe -fno-strict-aliasing"  CPP="cpp" CPPFLAGS=""  LDFLAGS=""  
CXX="c++" CXXFLAGS="-O2 -pipe -fno-strict-aliasing"  MANPREFIX="/usr/local" 
BSD_INSTALL_PROGRAM="install  -s -o root -g wheel -m 555"  
BSD_INSTALL_LIB="install  -s -o root -g wheel -m 444"  
BSD_INSTALL_SCRIPT="install  -o root -g wheel -m 555"  
BSD_INSTALL_DATA="install  -o root -g wheel -m 444"  BSD_INSTALL_MAN="install  
-o root -g wheel -m 444"
--End MAKE_ENV--

--PLIST_SUB--
LUA_MODLIBDIR=lib/lua/5.1
LUA_MODSHAREDIR=share/lua/5.1
LUA_VER=5.1
LUA_INCDIR=/usr/local/include/lua51
LUA_LIBDIR=/usr/local/lib
LUA_VER_STR=51
OSREL=10.0
PREFIX=%D
LOCALBASE=/usr/local
PORTDOCS=""
PORTEXAMPLES=""
PORTDATA=""
LIB32DIR=lib
GTK2_VERSION="2.10.0"
GTK3_VERSION="3.0.0"
DOCSDIR="share/doc/luakit"
EXAMPLESDIR="share/examples/luakit"
DATADIR="share/luakit"
WWWDIR="www/luakit"
ETCDIR="etc/luakit"
--End PLIST_SUB--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/luakit
DOCSDIR=/usr/local/share/doc/luakit
EXAMPLESDIR=/usr/local/share/examples/luakit
WWWDIR=/usr/local/www/luakit
ETCDIR=/usr/local/etc/luakit
--End SUB_LIST--

---Begin make.conf---
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
WITH_PKGNG=yes
# clean-restricted ran via poudriere.conf NO_RESTRICTED
#NO_RESTRICTED=yes
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
===>  Cleaning for luakit-2012.09.13r1_1
=======================<phase: check-sanity   >============================
===>  License GPLv3 accepted by the user
===========================================================================
=======================<phase: pkg-depends    >============================
===>   luakit-2012.09.13r1_1 depends on file: /usr/local/sbin/pkg - not found
===>    Verifying install for /usr/local/sbin/pkg in /usr/ports/ports-mgmt/pkg
===>   Installing existing package /packages/All/pkg-1.2.7_2.txz
Installing pkg-1.2.7_2... done
If you are upgrading from the old package format, first run:

  # pkg2ng
===>   Returning to build of luakit-2012.09.13r1_1
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===>  License GPLv3 accepted by the user
===> Fetching all distfiles required by luakit-2012.09.13r1_1 for building
===========================================================================
=======================<phase: checksum       >============================
===>  License GPLv3 accepted by the user
===> Fetching all distfiles required by luakit-2012.09.13r1_1 for building
=> SHA256 Checksum OK for luakit-2012.09.13r1.tar.gz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===>  License GPLv3 accepted by the user
===> Fetching all distfiles required by luakit-2012.09.13r1_1 for building
===>  Extracting for luakit-2012.09.13r1_1
=> SHA256 Checksum OK for luakit-2012.09.13r1.tar.gz.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for luakit-2012.09.13r1_1
===========================================================================
=======================<phase: build-depends  >============================
===>   luakit-2012.09.13r1_1 depends on executable: help2man - not found
===>    Verifying install for help2man in /usr/ports/misc/help2man
===>   Installing existing package /packages/All/help2man-1.43.3_1.txz
Installing help2man-1.43.3_1...Installing gettext-0.18.3.1_1... done
Installing p5-Locale-gettext-1.05_3...Installing perl5-5.16.3_10... done
 done
 done
===>   Returning to build of luakit-2012.09.13r1_1
===>   luakit-2012.09.13r1_1 depends on executable: pkgconf - not found
===>    Verifying install for pkgconf in /usr/ports/devel/pkgconf
===>   Installing existing package /packages/All/pkgconf-0.9.5.txz
Installing pkgconf-0.9.5... done
===>   Returning to build of luakit-2012.09.13r1_1
===>   luakit-2012.09.13r1_1 depends on executable: gmake - not found
===>    Verifying install for gmake in /usr/ports/devel/gmake
===>   Installing existing package /packages/All/gmake-3.82_1.txz
Installing gmake-3.82_1... done
===>   Returning to build of luakit-2012.09.13r1_1
===>   luakit-2012.09.13r1_1 depends on file: /usr/local/bin/intltool-extract - 
not found
===>    Verifying install for /usr/local/bin/intltool-extract in 
/usr/ports/textproc/intltool
===>   Installing existing package /packages/All/intltool-0.50.2.txz
Installing intltool-0.50.2...Installing p5-XML-Parser-2.41_1...Installing 
expat-2.1.0... done
 done
 done
===>   Returning to build of luakit-2012.09.13r1_1
===========================================================================
=======================<phase: lib-depends    >============================
===>   luakit-2012.09.13r1_1 depends on shared library: liblua-5.1.so
 - not found
===>    Verifying for liblua-5.1.so in /usr/ports/lang/lua51
===>   Installing existing package /packages/All/lua51-5.1.5_7.txz
Installing lua51-5.1.5_7... done
===>   Returning to build of luakit-2012.09.13r1_1
===>   luakit-2012.09.13r1_1 depends on shared library: libatk-1.0.so
 - not found
===>    Verifying for libatk-1.0.so in /usr/ports/accessibility/atk
===>   Installing existing package /packages/All/atk-2.8.0.txz
Installing atk-2.8.0...Installing glib-2.36.3_2...Installing libffi-3.0.13_1... 
done
Installing libiconv-1.14_3... done
Installing pcre-8.34_1... done
Installing python27-2.7.6_4... done
No schema files found: doing nothing.
 done
Installing gnomehier-3.0... done
 done
====
Note that some of the standard modules are provided as separate
ports since they require extra dependencies:

bsddb           databases/py-bsddb
gdbm            databases/py-gdbm
sqlite3         databases/py-sqlite3
tkinter         x11-toolkits/py-tkinter

Install them as needed.
====
===>   Returning to build of luakit-2012.09.13r1_1
<snip>
===>   luakit-2012.09.13r1_1 depends on shared library: libgtk-x11-2.0.so
 - not found
===>    Verifying for libgtk-x11-2.0.so in /usr/ports/x11-toolkits/gtk20
===>   Installing existing package /packages/All/gtk2-2.24.22_3.txz
Installing gtk2-2.24.22_3...Installing cups-client-1.7.2...===> Creating users 
and/or groups.
Creating group 'cups' with gid '193'.
Creating user 'cups' with uid '193'.
 done
Installing gdk-pixbuf2-2.28.2...Installing jasper-1.900.1_14...Installing 
jpeg-8_5... done
 done
Installing libX11-1.6.2_2,1...Installing kbproto-1.0.6... done
Installing libXau-1.0.8_2...Installing xproto-7.0.25... done
 done
Installing libXdmcp-1.1.1_2... done
Installing libxcb-1.10_2...Installing libpthread-stubs-0.3_4... done
Installing libxml2-2.9.1_1... done
 done
 done
Installing libXi-1.7.2_2,1...Installing inputproto-2.3... done
Installing libXext-1.3.2_2,1...Installing xextproto-7.3.0... done
 done
Installing libXfixes-5.0.1_2...Installing fixesproto-5.0... done
 done
 done
Installing libXt-1.1.4_2,1...Installing libSM-1.2.2_2,1...Installing 
libICE-1.0.8_2,1... done
 done
 done
Installing png-1.5.18... done
Installing tiff-4.0.3_2...Installing freeglut-2.8.1_2...Installing 
libGLU-9.0.0...Installing libGL-7.6.1_4...Installing dri2proto-2.8... done
Installing libXdamage-1.1.4_2...Installing damageproto-1.2.1... done
 done
Installing libXxf86vm-1.1.3_2...Installing xf86vidmodeproto-2.3.1... done
 done
Installing libdrm-2.4.17_1...Installing libpciaccess-0.13.2_2...Installing 
pciids-20140526... done
 done
 done
 done
 done
Installing libXrandr-1.4.2_2...Installing libXrender-0.9.8_2...Installing 
renderproto-0.11.1... done
 done
Installing randrproto-1.4.0... done
 done
 done
Installing jbigkit-1.6... done
Installing libXmu-1.1.2_2,1... done
 done
 done
Installing gtk-update-icon-cache-2.24.22...Installing 
hicolor-icon-theme-0.12... done
Installing libXcomposite-0.4.4_2,1...Installing compositeproto-0.4.2... done
 done
Installing libXcursor-1.1.14_2... done
Installing libXinerama-1.1.3_2,1...Installing xineramaproto-1.2.1... done
 done
Installing pango-1.34.1_4...Installing cairo-1.10.2_10,2...Installing 
fontconfig-2.11.0_3,1...Installing freetype2-2.5.3_2... done
Running fc-cache to build fontconfig cache...
/usr/local/share/fonts: skipping, no such directory
/usr/local/lib/X11/fonts: caching, new cache contents: 0 fonts, 1 dirs
/usr/local/lib/X11/fonts/local: caching, new cache contents: 0 fonts, 0 dirs
/root/.local/share/fonts: skipping, no such directory
/root/.fonts: skipping, no such directory
/usr/local/share/fonts: skipping, no such directory
/usr/local/lib/X11/fonts: caching, new cache contents: 0 fonts, 1 dirs
/root/.local/share/fonts: skipping, no such directory
/root/.fonts: skipping, no such directory
/var/db/fontconfig: cleaning cache directory
/root/.cache/fontconfig: not cleaning non-existent cache directory
/root/.fontconfig: not cleaning non-existent cache directory
fc-cache: succeeded
 done
Installing pixman-0.32.4_2... done
Installing xcb-util-renderutil-0.3.8_2...Installing xcb-util-0.3.9_3,1... done
 done
 done
Installing encodings-1.0.4_1,1...Installing font-util-1.3.0_1... done
 done
Installing harfbuzz-0.9.28...Installing graphite2-1.2.4... done
Installing icu-52.1... done
 done
Installing libXft-2.3.1_2... done
Installing xorg-fonts-truetype-7.7_1...Installing dejavu-2.34_3... done
Installing font-bh-ttf-1.0.3_1...Installing mkfontdir-1.0.7...Installing 
mkfontscale-1.1.1_1...Installing libfontenc-1.1.2_2... done
 done
 done
 done
Installing font-misc-ethiopic-1.0.3_1... done
Installing font-misc-meltho-1.0.3_1... done
 done
 done
Installing shared-mime-info-1.1_1... done
 done
Installing python-2.7_1,2...Installing python2-2_2... done
 done
 done
Since FreeBSD has new USB stack, freeglut normally doesn't build on FreeBSD 8
(yet). To workaround this a small patch adds one include file and comments out
content of one function (only leaves return NULL).

This might cause side effects.  Joysticks do not work, and there might be ports
that do not compile or applications that crash because of this.

Do not hesitate to contact x...@freebsd.org if there are any issues and side
effects because of this.
Make sure that the freetype module is loaded.  If it is not, add the following
line to the "Modules" section of your X Windows configuration file:

        Load "freetype"

Add the following line to the "Files" section of X Windows configuration file:

        FontPath "/usr/local/lib/X11/fonts/dejavu/"

Note: your X Windows configuration file is typically /etc/X11/XF86Config
if you are using XFree86, and /etc/X11/xorg.conf if you are using X.Org.
===>   Returning to build of luakit-2012.09.13r1_1
===>   luakit-2012.09.13r1_1 depends on shared library: libpango-1.0.so - found 
(/usr/local/lib/libpango-1.0.so.0.3400.1)
===>   luakit-2012.09.13r1_1 depends on shared library: dbus-glib-1 - not found
===>    Verifying install for dbus-glib-1 in /usr/ports/devel/dbus-glib
===>   Installing existing package /packages/All/dbus-glib-0.100.2_1.txz
Installing dbus-glib-0.100.2_1...Installing dbus-1.8.0...Installing 
gnome_subr-1.0... done
===> Creating users and/or groups.
Creating group 'messagebus' with gid '556'.
Creating user 'messagebus' with uid '556'.
 done
 done
===>   Returning to build of luakit-2012.09.13r1_1
===>   luakit-2012.09.13r1_1 depends on shared library: sqlite3 - not found
===>    Verifying install for sqlite3 in /usr/ports/databases/sqlite3
===>   Installing existing package /packages/All/sqlite3-3.8.4.3.txz
Installing sqlite3-3.8.4.3... done
===>   Returning to build of luakit-2012.09.13r1_1
===>   luakit-2012.09.13r1_1 depends on shared library: webkitgtk-1 - not found
===>    Verifying install for webkitgtk-1 in /usr/ports/www/webkit-gtk2
===>   Installing existing package /packages/All/webkit-gtk2-1.8.3_3.txz
Installing webkit-gtk2-1.8.3_3...Installing curl-7.36.0_1...Installing 
ca_root_nss-3.16... done
 done
Installing enchant-1.6.0_3...Installing hunspell-1.3.2_4... done
 done
Installing gstreamer-plugins-0.10.36_4,3...Installing 
gstreamer-0.10.36_2...Installing gobject-introspection-1.36.0_2... done
 done
Installing libXv-1.0.10_2,1...Installing videoproto-2.3.2... done
 done
Installing orc-0.4.19_2... done
 done
Installing libsoup-2.40.3_4...Installing glib-networking-2.36.2_2...Installing 
gnutls-2.12.23_5...Installing libgpg-error-1.13... done
Installing libtasn1-3.3... done
Installing nettle-2.7.1...Installing gmp-5.1.3_2... done
 done
Installing p11-kit-0.20.2_1... done
 done
Installing gsettings-desktop-schemas-3.6.1_1...Installing 
cantarell-fonts-0.0.15.../usr/local/share/fonts/cantarell: caching, new cache 
contents: 2 fonts, 0 dirs
/usr/local/share/fonts/cantarell: caching, new cache contents: 2 fonts, 0 dirs
/var/db/fontconfig: cleaning cache directory
/root/.cache/fontconfig: not cleaning non-existent cache directory
/root/.fontconfig: not cleaning non-existent cache directory
/usr/local/bin/fc-cache: succeeded
 done
 done
Installing libgcrypt-1.5.3_2... done
Installing libproxy-0.4.6... done
 done
 done
Installing libxslt-1.1.28_3... done
 done
===>   Returning to build of luakit-2012.09.13r1_1
===>   luakit-2012.09.13r1_1 depends on shared library: unique-1 - not found
===>    Verifying install for unique-1 in /usr/ports/x11-toolkits/unique
===>   Installing existing package /packages/All/unique-1.1.6_6.txz
Installing unique-1.1.6_6... done
===>   Returning to build of luakit-2012.09.13r1_1
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for luakit-2012.09.13r1_1
===========================================================================
=======================<phase: build          >============================
===>  Building for luakit-2012.09.13r1_1
gmake[1]: Entering directory 
`/wrkdirs/usr/ports/www/luakit/work/mason-larobina-luakit-0d5f4ab'
luakit build options:
CC           = cc
LUA_PKG_NAME = lua-5.1
CFLAGS       = -O2 -pipe -fno-strict-aliasing -std=gnu99 -ggdb -W -Wall -Wextra 
-I/usr/local/include/libsoup-2.4 -I/usr/local/include/libxml2 
-I/usr/local/include/webkitgtk-1.0 -I/usr/local/include/lua51 
-I/usr/local/include/unique-1.0 -I/usr/local/include/gtk-2.0 
-I/usr/local/include/gio-unix-2.0/ -I/usr/local/include/atk-1.0 
-I/usr/local/include/cairo -I/usr/local/include/pixman-1 -D_THREAD_SAFE 
-I/usr/local/include/gdk-pixbuf-2.0 -I/usr/local/include/libpng15 
-I/usr/local/include/pango-1.0 -pthread -I/usr/local/include/glib-2.0 
-I/usr/local/include  -I/usr/local/include/freetype2 
-I/usr/local/include/harfbuzz   -I./
CPPFLAGS     =   -DVERSION="0d5f4ab" -DDEVELOPMENT_PATHS -DWITH_UNIQUE
LDFLAGS      =   -Wl,--export-dynamic -lgthread-2.0 -lwebkitgtk-1.0 -lsoup-2.4 
-ljavascriptcoregtk-1.0 -lsqlite3 -llua-5.1 -lm -lunique-1.0 -lgtk-x11-2.0 
-lgdk-x11-2.0 -lpangocairo-1.0 -lXext -lXrender -lXinerama -lXi -lXrandr 
-lXcursor -lXcomposite -lXdamage -lXfixes -lX11 -latk-1.0 -lcairo -pthread 
-lgdk_pixbuf-2.0 -lgio-2.0 -lpangoft2-1.0 -lpango-1.0 -lgobject-2.0 -lglib-2.0 
-lintl -lfontconfig -L/usr/local/lib -lfreetype  
INSTALLDIR   = /usr/local
MANPREFIX    = /usr/local/man
DOCDIR       = /usr/local/share/doc/luakit

build targets:
SRCS  = luah.c luakit.c common/luaobject.c common/util.c common/property.c 
common/luaclass.c clib/timer.c clib/widget.c clib/download.c clib/luakit.c 
clib/xdg.c clib/unique.c clib/sqlite3.c clib/soup/soup.c clib/soup/auth.c 
clib/soup/cookiejar.c widgets/entry.c widgets/window.c widgets/eventbox.c 
widgets/paned.c widgets/box.c widgets/notebook.c widgets/common.c 
widgets/webview.c widgets/label.c widgets/socket.c common/tokenize.c
HEADS = luah.h common/luaobject.h common/util.h common/signal.h 
common/property.h common/luaclass.h common/lualib.h widgets/common.h 
clib/sqlite3.h clib/timer.h clib/widget.h clib/download.h clib/luakit.h 
clib/xdg.h clib/unique.h clib/soup/soup.h clib/soup/auth.h 
clib/soup/cookiejar.h common/tokenize.h globalconf.h
OBJS  = luah.o luakit.o common/luaobject.o common/util.o common/property.o 
common/luaclass.o clib/timer.o clib/widget.o clib/download.o clib/luakit.o 
clib/xdg.o clib/unique.o clib/sqlite3.o clib/soup/soup.o clib/soup/auth.o 
clib/soup/cookiejar.o widgets/entry.o widgets/window.o widgets/eventbox.o 
widgets/paned.o widgets/box.o widgets/notebook.o widgets/common.o 
widgets/webview.o widgets/label.o widgets/socket.o common/tokenize.o

./build-utils/gentokens.lua common/tokenize.list common/tokenize.h
env: lua-5.1: No such file or directory
gmake[1]: *** [common/tokenize.h] Error 127
gmake[1]: Leaving directory 
`/wrkdirs/usr/ports/www/luakit/work/mason-larobina-luakit-0d5f4ab'
*** Error code 1

Stop.
make: stopped in /usr/ports/www/luakit
===>  Cleaning for luakit-2012.09.13r1_1
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to