You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     zen...@experts-exchange.com
Last committer: anto...@freebsd.org
Ident:          $FreeBSD: head/net-mgmt/zenoss/Makefile 326087 2013-09-02 
20:51:26Z antoine $
Log URL:        
http://beefy2.isc.freebsd.org/bulk/head-amd64-default/2013-09-19_01h04m14s/logs/zenoss-3.1.0_1.log
Build URL:      
http://beefy2.isc.freebsd.org/bulk/head-amd64-default/2013-09-19_01h04m14s
Log:

====>> Building net-mgmt/zenoss
build started at Thu Sep 19 01:31:26 UTC 2013
port directory: /usr/ports/net-mgmt/zenoss
building for: FreeBSD head-amd64-default-job-14 10.0-CURRENT FreeBSD 
10.0-CURRENT amd64
maintained by: zen...@experts-exchange.com
Makefile ident:      $FreeBSD: head/net-mgmt/zenoss/Makefile 326087 2013-09-02 
20:51:26Z antoine $
Poudriere version: 3.1-pre

---Begin Environment---
OSVERSION=1000055
UNAME_v=FreeBSD 10.0-CURRENT
UNAME_r=10.0-CURRENT
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
MASTERMNT=/usr/local/poudriere/data/build/head-amd64-default/ref
PKG_EXT=txz
tpid=7202
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
POUDRIERE_BUILD_TYPE=bulk
NBPARALLEL=24
PKGNG=1
PKGNAME=zenoss-3.1.0_1
PKG_DELETE=/usr/local/sbin/pkg delete -y -f
PKG_ADD=/usr/local/sbin/pkg add
PWD=/root
MASTERNAME=head-amd64-default
USER=root
HOME=/root
POUDRIERE_VERSION=3.1-pre
SKIPSANITY=0
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
---End Environment---

---Begin OPTIONS List---
===> The following configuration options are available for zenoss-3.1.0_1:
====> Options available for the single SHELL: you have to select exactly one of 
them
     BASH=on: Use Bash shell
     BASH_STATIC=off: Use Bash Static shell
===> Use 'make config' to modify these settings
---End OPTIONS List---

--CONFIGURE_ARGS--

--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
TMPDIR="/tmp" MAKE=gmake PKG_CONFIG=pkgconf TMPDIR="/tmp" SHELL=/bin/sh 
CONFIG_SHELL=/bin/sh  AUTOCONF=/usr/local/bin/autoconf-2.69  
AUTOCONF_DIR=/usr/local/share/autoconf-2.69  
AUTOHEADER=/usr/local/bin/autoheader-2.69  
AUTOIFNAMES=/usr/local/bin/ifnames-2.69  AUTOM4TE=/usr/local/bin/autom4te-2.69  
AUTORECONF=/usr/local/bin/autoreconf-2.69  
AUTOSCAN=/usr/local/bin/autoscan-2.69  
AUTOUPDATE=/usr/local/bin/autoupdate-2.69  AUTOCONF_VERSION=2.69 
--End CONFIGURE_ENV--

--MAKE_ENV--
TMPDIR="/tmp" OPENSSLLIB=/usr/lib OPENSSLINC=/usr/include  OPENSSLBASE=/usr 
OPENSSLDIR=/etc/ssl TMPDIR="/tmp" SHELL=/bin/sh NO_LINT=YES  
AUTOCONF=/usr/local/bin/autoconf-2.69  
AUTOCONF_DIR=/usr/local/share/autoconf-2.69  
AUTOHEADER=/usr/local/bin/autoheader-2.69  
AUTOIFNAMES=/usr/local/bin/ifnames-2.69  AUTOM4TE=/usr/local/bin/autom4te-2.69  
AUTORECONF=/usr/local/bin/autoreconf-2.69  
AUTOSCAN=/usr/local/bin/autoscan-2.69  
AUTOUPDATE=/usr/local/bin/autoupdate-2.69  AUTOCONF_VERSION=2.69  
PREFIX=/usr/local  LOCALBASE=/usr/local  LIBDIR="/usr/lib"  CC="cc" CFLAGS="-O2 
-pipe -fno-strict-aliasing"  CPP="cpp" CPPFLAGS=""  LDFLAGS=" 
-Wl,-rpath=/usr/lib:/usr/local/lib"  CXX="c++" CXXFLAGS="-O2 -pipe 
-fno-strict-aliasing"  MANPREFIX="/usr/local/zenoss/share" 
BSD_INSTALL_PROGRAM="install  -s -o root -g wheel -m 555"  
BSD_INSTALL_LIB="install  -s -o root -g wheel -m 444"  
BSD_INSTALL_SCRIPT="install  -o root -g wheel -m 555"  
BSD_INSTALL_DATA="install  -o root -g wheel -m 444"  BSD_INST
 ALL_MAN=
 "install  -o root -g wheel -m 444"
--End MAKE_ENV--

--SUB_LIST--
ZENHOME=/usr/local/zenoss
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/zenoss
DOCSDIR=/usr/local/share/doc/zenoss
EXAMPLESDIR=/usr/local/share/examples/zenoss
WWWDIR=/usr/local/www/zenoss
ETCDIR=/usr/local/etc/zenoss
--End SUB_LIST--

---Begin make.conf---
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
WITH_PKGNG=yes
NO_RESTRICTED=yes
DISABLE_MAKE_JOBS=yes
---End make.conf---
===>  Cleaning for zenoss-3.1.0_1
=======================<phase: check-config   >============================
===========================================================================
=======================<phase: pkg-depends    >============================
===>   zenoss-3.1.0_1 depends on file: /usr/local/sbin/pkg - not found
===>    Verifying install for /usr/local/sbin/pkg in /usr/ports/ports-mgmt/pkg
===>   Installing existing package /packages/All/pkg-1.1.4_2.txz
Installing pkg-1.1.4_2... done
If you are upgrading from the old package format, first run:

  # pkg2ng
===>   Returning to build of zenoss-3.1.0_1
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===>  License GPLv2 accepted by the user
===> Fetching all distfiles required by zenoss-3.1.0_1 for building
===========================================================================
=======================<phase: checksum       >============================
===>  License GPLv2 accepted by the user
===> Fetching all distfiles required by zenoss-3.1.0_1 for building
=> SHA256 Checksum OK for zenoss-3.1.0.tar.gz.
=> SHA256 Checksum OK for JSBuilder2.zip.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===>  License GPLv2 accepted by the user
===> Fetching all distfiles required by zenoss-3.1.0_1 for building
===>  Extracting for zenoss-3.1.0_1
=> SHA256 Checksum OK for zenoss-3.1.0.tar.gz.
=> SHA256 Checksum OK for JSBuilder2.zip.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for zenoss-3.1.0_1
===>  Applying FreeBSD patches for zenoss-3.1.0_1
===========================================================================
=======================<phase: build-depends  >============================
===>   zenoss-3.1.0_1 depends on package: swig>=1.3 - not found
===>    Verifying install for swig>=1.3 in /usr/ports/devel/swig13
===>   Installing existing package /packages/All/swig13-1.3.40.txz
Installing swig13-1.3.40... done
===>   Returning to build of zenoss-3.1.0_1
===>   zenoss-3.1.0_1 depends on file: /usr/local/bin/unzip - not found
===>    Verifying install for /usr/local/bin/unzip in /usr/ports/archivers/unzip
===>   Installing existing package /packages/All/unzip-6.0_1.txz
Installing unzip-6.0_1... done
===>   Returning to build of zenoss-3.1.0_1
===>   zenoss-3.1.0_1 depends on file: /usr/local/openjdk6/bin/java - not found
===>    Verifying install for /usr/local/openjdk6/bin/java in 
/usr/ports/java/openjdk6
===>   Installing existing package /packages/All/openjdk6-b27_7.txz
Installing openjdk6-b27_7...Installing xproto-7.0.24... done
Installing xextproto-7.2.1... done
Installing xbitmaps-1.1.1... done
Installing renderproto-0.11.1... done
Installing recordproto-1.14.2... done
Installing printproto-1.0.5... done
Installing libxcb-1.9.1...Installing libXdmcp-1.1.1... done
Installing libXau-1.0.8... done
Installing libxml2-2.8.0_2... done
Installing libpthread-stubs-0.3_3... done
 done
Installing libXtst-1.2.2...Installing libXi-1.7.2,1...Installing 
libXfixes-5.0.1...Installing libX11-1.6.1,1...Installing kbproto-1.0.6... done
 done
Installing fixesproto-5.0... done
 done
Installing libXext-1.3.2,1... done
Installing inputproto-2.3... done
 done
 done
Installing libXrender-0.9.8... done
Installing libXpm-3.5.10...Installing libSM-1.2.1,1...Installing 
libICE-1.0.8,1... done
 done
Installing libXt-1.1.4,1... done
 done
Installing libXp-1.0.2,1... done
Installing open-motif-2.3.4...Installing libXmu-1.1.1,1... done
Installing libXaw-1.0.11,2... done
Installing libXft-2.3.1...Installing fontconfig-2.10.93,1...Installing 
expat-2.1.0... done
Installing freetype2-2.4.12_1... done
Running fc-cache to build fontconfig cache...
/usr/local/share/fonts: skipping, no such directory
/usr/local/lib/X11/fonts: caching, new cache contents: 0 fonts, 1 dirs
/usr/local/lib/X11/fonts/local: caching, new cache contents: 0 fonts, 0 dirs
/root/.local/share/fonts: skipping, no such directory
/root/.fonts: skipping, no such directory
/var/db/fontconfig: cleaning cache directory
/root/.cache/fontconfig: not cleaning non-existent cache directory
/root/.fontconfig: not cleaning non-existent cache directory
fc-cache: succeeded
 done
 done
Installing png-1.5.17... done
Installing jpeg-8_4... done
 done
Installing dejavu-2.34... done
Installing javavmwrapper-2.4_3... done
Installing java-zoneinfo-2013.d... done
mkdir: /usr/local/openjdk6/jre/lib/applet: File exists
 done
Make sure that the freetype module is loaded.  If it is not, add the following
line to the "Modules" section of your X Windows configuration file:

        Load "freetype"

Add the following line to the "Files" section of X Windows configuration file:

        FontPath "/usr/local/lib/X11/fonts/dejavu/"

Note: your X Windows configuration file is typically /etc/X11/XF86Config
if you are using XFree86, and /etc/X11/xorg.conf if you are using X.Org.
======================================================================

This OpenJDK implementation requires fdescfs(5) mounted on /dev/fd and
procfs(5) mounted on /proc.

If you have not done it yet, please do the following:

        mount -t fdescfs fdesc /dev/fd
        mount -t procfs proc /proc

To make it permanent, you need the following lines in /etc/fstab:

        fdesc   /dev/fd         fdescfs         rw      0       0
        proc    /proc           procfs          rw      0       0

======================================================================
===>   Returning to build of zenoss-3.1.0_1
===>   zenoss-3.1.0_1 depends on executable: gmake - not found
===>    Verifying install for gmake in /usr/ports/devel/gmake
===>   Installing existing package /packages/All/gmake-3.82_1.txz
Installing gmake-3.82_1...Installing gettext-0.18.3... done
 done
===>   Returning to build of zenoss-3.1.0_1
===>   zenoss-3.1.0_1 depends on executable: pkgconf - not found
===>    Verifying install for pkgconf in /usr/ports/devel/pkgconf
===>   Installing existing package /packages/All/pkgconf-0.9.3.txz
Installing pkgconf-0.9.3... done
===>   Returning to build of zenoss-3.1.0_1
===>   zenoss-3.1.0_1 depends on file: /usr/local/bin/autoconf-2.69 - not found
===>    Verifying install for /usr/local/bin/autoconf-2.69 in 
/usr/ports/devel/autoconf
===>   Installing existing package /packages/All/autoconf-2.69.txz
Installing autoconf-2.69...Installing perl-5.14.4...Removing stale symlinks 
from /usr/bin...
    Skipping /usr/bin/perl
    Skipping /usr/bin/perl5
Done.
Creating various symlinks in /usr/bin...
    Symlinking /usr/local/bin/perl5.14.4 to /usr/bin/perl
    Symlinking /usr/local/bin/perl5.14.4 to /usr/bin/perl5
Done.
Cleaning up /etc/make.conf... Done.
Spamming /etc/make.conf... Done.
 done
Installing m4-1.4.16_1,1... done
Installing autoconf-wrapper-20130530... done
 done
===>   Returning to build of zenoss-3.1.0_1
===========================================================================
=======================<phase: lib-depends    >============================
===>   zenoss-3.1.0_1 depends on shared library: mysqlclient.18 - not found
===>    Verifying install for mysqlclient.18 in 
/usr/ports/databases/mysql55-client
===>   Installing existing package /packages/All/mysql-client-5.5.33.txz
Installing mysql-client-5.5.33... done
===>   Returning to build of zenoss-3.1.0_1
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for zenoss-3.1.0_1
===========================================================================
=======================<phase: build          >============================
===>  Building for zenoss-3.1.0_1
===========================================================================
=======================<phase: install-mtree  >============================
===========================================================================
=======================<phase: run-depends    >============================
===>   zenoss-3.1.0_1 depends on package: net-snmp>=5.5 - not found
===>    Verifying install for net-snmp>=5.5 in /usr/ports/net-mgmt/net-snmp
===>   Installing existing package /packages/All/net-snmp-5.7.2_3.txz
Installing net-snmp-5.7.2_3...mkdir: /var/agentx: File exists
 done
**** This port installs snmp daemon, header files and libraries but don't
     invokes snmpd by default.
     If you want to invoke snmpd and/or snmptrapd at startup, put these
     lines into /etc/rc.conf.

        snmpd_enable="YES"
        snmpd_flags="-a"
        snmpd_conffile="/usr/local/share/snmp/snmpd.conf /etc/snmpd.conf"
        snmptrapd_enable="YES"
        snmptrapd_flags="-a -p /var/run/snmptrapd.pid"

**** You may specify the following make variables:

        NET_SNMP_SYS_CONTACT="z...@freebsd.org"
        NET_SNMP_SYS_LOCATION="USA"
        DEFAULT_SNMP_VERSION=3
        NET_SNMP_MIB_MODULES="host smux mibII/mta_sendmail ucd-snmp/diskio"
        NET_SNMP_LOGFILE=/var/log/snmpd.log
        NET_SNMP_PERSISTENTDIR=/var/net-snmp

     to define default values (or overwriting defaults).  At least
     setting first two variables, you will not be prompted during
     configuration process.  You may also set

        BATCH="yes"

     to avoid interactive configuration.
===>   Returning to build of zenoss-3.1.0_1
===>   zenoss-3.1.0_1 depends on package: liberation-fonts-ttf>=1.05 - not found
===>    Verifying install for liberation-fonts-ttf>=1.05 in 
/usr/ports/x11-fonts/liberation-fonts-ttf
===>   Installing existing package 
/packages/All/liberation-fonts-ttf-2.00.1,1.txz
Installing liberation-fonts-ttf-2.00.1,1... done
You can start using the fonts by following these instructions:

Add the following line to the "Files" section of your x.org configuration file:

        FontPath "/usr/local/lib/X11/fonts/Liberation/"
===>   Returning to build of zenoss-3.1.0_1
===>   zenoss-3.1.0_1 depends on package: bash>=4.1 - not found
===>    Verifying install for bash>=4.1 in /usr/ports/shells/bash
===>   Installing existing package /packages/All/bash-4.2.45.txz
Installing bash-4.2.45... done
===>   Returning to build of zenoss-3.1.0_1
===========================================================================
=======================<phase: install        >============================
===>  Installing for zenoss-3.1.0_1
===>   Generating temporary packing list
===>  Checking if net-mgmt/zenoss already installed
===> Creating users and/or groups.
Creating group `zenoss' with gid `949'.
Creating user `zenoss' with uid `949'.
g++ is required to build dependent libraries
*** Error code 1

Stop.
make: stopped in /usr/ports/net-mgmt/zenoss
===>  Cleaning for zenoss-3.1.0_1
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to