You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     step...@freebsd.org
Last committer: ger...@freebsd.org
Ident:          $FreeBSD: 
branches/2014Q2/math/octave-forge-miscellaneous/Makefile 347809 2014-03-10 
20:55:20Z gerald $
Log URL:        
http://beefy2.isc.freebsd.org/bulk/10amd64-quarterly/2014-06-04_02h44m50s/logs/octave-forge-miscellaneous-1.2.0_3.log
Build URL:      
http://beefy2.isc.freebsd.org/bulk/10amd64-quarterly/2014-06-04_02h44m50s
Log:

====>> Building math/octave-forge-miscellaneous
build started at Wed Jun  4 03:01:59 UTC 2014
port directory: /usr/ports/math/octave-forge-miscellaneous
building for: FreeBSD 10amd64-quarterly-job-07 10.0-RELEASE-p3 FreeBSD 
10.0-RELEASE-p3 amd64
maintained by: step...@freebsd.org
Makefile ident:      $FreeBSD: 
branches/2014Q2/math/octave-forge-miscellaneous/Makefile 347809 2014-03-10 
20:55:20Z gerald $
Poudriere version: 3.1-pre
Host OSVERSION: 1100013
Jail OSVERSION: 1000510

---Begin Environment---
OSVERSION=1000510
UNAME_v=FreeBSD 10.0-RELEASE-p3
UNAME_r=10.0-RELEASE-p3
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
SAVED_TERM=
MASTERMNT=/usr/local/poudriere/data/build/10amd64-quarterly/ref
PKG_EXT=txz
tpid=67098
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
POUDRIERE_BUILD_TYPE=bulk
PKGNG=1
PKGNAME=octave-forge-miscellaneous-1.2.0_3
PKG_DELETE=/usr/local/sbin/pkg-static delete -y -f
PKG_ADD=/usr/local/sbin/pkg-static add
OLDPWD=/usr/local/poudriere/data/build/10amd64-quarterly/ref/poudriere/rdeps
PWD=/usr/local/poudriere/data/build/10amd64-quarterly/ref/poudriere/pool
MASTERNAME=10amd64-quarterly
USER=root
HOME=/root
POUDRIERE_VERSION=3.1-pre
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
PKG_VERSION=/poudriere/pkg-static version
PKG_BIN=/usr/local/sbin/pkg-static
---End Environment---

---Begin OPTIONS List---
---End OPTIONS List---

--CONFIGURE_ARGS--

--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
TMPDIR="/tmp" F77="gfortran47" FC="gfortran47" FFLAGS="-O 
-Wl,-rpath=/usr/local/lib/gcc47" FCFLAGS="-Wl,-rpath=/usr/local/lib/gcc47" 
MAKE=gmake SHELL=/bin/sh CONFIG_SHELL=/bin/sh
--End CONFIGURE_ENV--

--MAKE_ENV--
PACKAGE=/wrkdirs/usr/ports/math/octave-forge-miscellaneous/work/miscellaneous-1.2.0.tar.gz
 MKOCTFILE=mkoctfile TMPDIR="/tmp" F77="gfortran47" FC="gfortran47" FFLAGS="-O 
-Wl,-rpath=/usr/local/lib/gcc47" FCFLAGS="-Wl,-rpath=/usr/local/lib/gcc47" 
SHELL=/bin/sh NO_LINT=YES ADDR2LINE="/usr/local/bin/addr2line" 
AR="/usr/local/bin/ar" AS="/usr/local/bin/as" CPPFILT="/usr/local/bin/c++filt" 
GPROF="/usr/local/bin/gprof" LD="/usr/local/bin/ld" NM="/usr/local/bin/nm" 
OBJCOPY="/usr/local/bin/objcopy" OBJDUMP="/usr/local/bin/objdump" 
RANLIB="/usr/local/bin/ranlib" READELF="/usr/local/bin/readelf" 
SIZE="/usr/local/bin/size" STRINGS="/usr/local/bin/strings" PREFIX=/usr/local  
LOCALBASE=/usr/local  LIBDIR="/usr/lib"  CC="cc" CFLAGS="-O2 -pipe 
-fno-strict-aliasing"  CPP="cpp" CPPFLAGS=""  LDFLAGS=" 
-Wl,-rpath=/usr/local/lib/gcc47  -L/usr/local/lib/gcc47 -B/usr/local/bin"  
CXX="c++" CXXFLAGS="-O2 -pipe -fno-strict-aliasing"  MANPREFIX="/usr/local" 
BSD_INSTALL_PROGRAM="install  -s -o root -g wheel -m 5
 55"  BSD_INSTALL_LIB="install  -s -o root -g wheel -m 444"  
BSD_INSTALL_SCRIPT="install  -o root -g wheel -m 555"  
BSD_INSTALL_DATA="install  -o root -g wheel -m 444"  BSD_INSTALL_MAN="install  
-o root -g wheel -m 444"
--End MAKE_ENV--

--PLIST_SUB--
OSREL=10.0
PREFIX=%D
LOCALBASE=/usr/local
PORTDOCS=""
PORTEXAMPLES=""
PORTDATA=""
LIB32DIR=lib
DOCSDIR="share/doc/octave-forge-miscellaneous"
EXAMPLESDIR="share/examples/octave-forge-miscellaneous"
DATADIR="share/octave-forge-miscellaneous"
WWWDIR="www/octave-forge-miscellaneous"
ETCDIR="etc/octave-forge-miscellaneous"
--End PLIST_SUB--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/octave-forge-miscellaneous
DOCSDIR=/usr/local/share/doc/octave-forge-miscellaneous
EXAMPLESDIR=/usr/local/share/examples/octave-forge-miscellaneous
WWWDIR=/usr/local/www/octave-forge-miscellaneous
ETCDIR=/usr/local/etc/octave-forge-miscellaneous
--End SUB_LIST--

---Begin make.conf---
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
WITH_PKGNG=yes
# clean-restricted ran via poudriere.conf NO_RESTRICTED
#NO_RESTRICTED=yes
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
===>  Cleaning for octave-forge-miscellaneous-1.2.0_3
=======================<phase: check-sanity   >============================
===>  License GPLv3 accepted by the user
===========================================================================
=======================<phase: pkg-depends    >============================
===>   octave-forge-miscellaneous-1.2.0_3 depends on file: /usr/local/sbin/pkg 
- not found
===>    Verifying install for /usr/local/sbin/pkg in /usr/ports/ports-mgmt/pkg
===>   Installing existing package /packages/All/pkg-1.2.7.txz
Installing pkg-1.2.7... done
If you are upgrading from the old package format, first run:

  # pkg2ng
===>   Returning to build of octave-forge-miscellaneous-1.2.0_3
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===>  License GPLv3 accepted by the user
===> Fetching all distfiles required by octave-forge-miscellaneous-1.2.0_3 for 
building
===========================================================================
=======================<phase: checksum       >============================
===>  License GPLv3 accepted by the user
===> Fetching all distfiles required by octave-forge-miscellaneous-1.2.0_3 for 
building
=> SHA256 Checksum OK for octave-forge/miscellaneous-1.2.0.tar.gz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===>  License GPLv3 accepted by the user
===> Fetching all distfiles required by octave-forge-miscellaneous-1.2.0_3 for 
building
===>  Extracting for octave-forge-miscellaneous-1.2.0_3
=> SHA256 Checksum OK for octave-forge/miscellaneous-1.2.0.tar.gz.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for octave-forge-miscellaneous-1.2.0_3
===========================================================================
=======================<phase: build-depends  >============================
===>   octave-forge-miscellaneous-1.2.0_3 depends on executable: octave - not 
found
===>    Verifying install for octave in /usr/ports/math/octave
===>   Installing existing package /packages/All/octave-3.8.0_2.txz
Installing octave-3.8.0_2...Installing GraphicsMagick13-1.3.19_3...Installing 
dgs-0.5.9.1_11...Installing ghostscript9-9.06_5...Installing 
cups-image-1.7.1_1...Installing cups-client-1.7.1_1...===> Creating users 
and/or groups.
Creating group 'cups' with gid '193'.
Creating user 'cups' with uid '193'.
 done
Installing jpeg-8_4... done
Installing png-1.5.18... done
Installing tiff-4.0.3...Installing freeglut-2.8.1...Installing 
libGLU-9.0.0...Installing libGL-7.6.1_4...Installing dri2proto-2.8... done
Installing expat-2.1.0... done
Installing libX11-1.6.2,1...Installing kbproto-1.0.6... done
Installing libXau-1.0.8...Installing xproto-7.0.25... done
 done
Installing libXdmcp-1.1.1... done
Installing libxcb-1.9.3...Installing libpthread-stubs-0.3_4... done
Installing libxml2-2.9.1_1... done
 done
 done
Installing libXdamage-1.1.4...Installing damageproto-1.2.1... done
Installing libXfixes-5.0.1...Installing fixesproto-5.0... done
 done
 done
Installing libXext-1.3.2,1...Installing xextproto-7.2.1... done
 done
Installing libXxf86vm-1.1.3...Installing xf86vidmodeproto-2.3.1... done
 done
Installing libdrm-2.4.17_1...Installing libpciaccess-0.13.2...Installing 
pciids-20140312... done
 done
 done
 done
 done
Installing libICE-1.0.8,1... done
Installing libXi-1.7.2,1...Installing inputproto-2.3... done
 done
Installing libXrandr-1.4.2...Installing libXrender-0.9.8...Installing 
renderproto-0.11.1... done
 done
Installing randrproto-1.4.0... done
 done
 done
Installing jbigkit-1.6... done
Installing libSM-1.2.2,1... done
Installing libXmu-1.1.2,1...Installing libXt-1.1.4,1... done
 done
 done
===> Creating users and/or groups.
Using existing group 'cups'.
Using existing user 'cups'.
 done
Installing freetype2-2.5.3... done
Installing gsfonts-8.11_6... done
Installing jbig2dec-0.11_1... done
Installing lcms2-2.5... done
Installing libidn-1.28_1...Installing gettext-0.18.3.1... done
 done
Installing libpaper-1.1.24_1... done
Installing svgalib-1.4.3_6... done
 done
Installing glib12-1.2.10_13... done
 done
Installing gcc-4.7.3...Installing binutils-2.24... done
Installing gcc-ecj-4.5... done
Installing gmp-5.1.3_1... done
Installing mpc-1.0.2...Installing mpfr-3.1.2_1... done
 done
 done
Installing jasper-1.900.1_12... done
Installing libwmf-0.2.8.4_10... done
<snip>
No pages of output.
Transcript written on mptopdf.log.
fmtutil: /usr/local/share/texmf-var/web2c/aleph.fmt installed.
fmtutil: /usr/local/share/texmf-var/web2c/cont-en.fmt installed.
fmtutil: /usr/local/share/texmf-var/web2c/etex.fmt installed.
fmtutil: /usr/local/share/texmf-var/web2c/lambda.fmt installed.
fmtutil: /usr/local/share/texmf-var/web2c/lamed.fmt installed.
fmtutil: /usr/local/share/texmf-var/web2c/latex.fmt installed.
fmtutil: /usr/local/share/texmf-var/web2c/mptopdf.fmt installed.
fmtutil: /usr/local/share/texmf-var/web2c/omega.fmt installed.
fmtutil: /usr/local/share/texmf-var/web2c/pdfetex.fmt installed.
fmtutil: /usr/local/share/texmf-var/web2c/pdflatex.fmt installed.
fmtutil: /usr/local/share/texmf-var/web2c/pdftex.fmt installed.
fmtutil: /usr/local/share/texmf-var/web2c/tex.fmt installed.
fmtutil: /usr/local/share/texmf-var/web2c/metafun.mem installed.
fmtutil: /usr/local/share/texmf-var/web2c/mpost.mem installed.
fmtutil: /usr/local/share/texmf-var/web2c/mf.base installed.
 done
Installing wx28-gtk2-2.8.12_2...Installing ORBit2-2.14.19...Installing 
libIDL-0.8.14_1... done
 done
Installing atk-2.8.0...Installing gnomehier-3.0... done
 done
Installing gconf2-2.32.0_3...Installing dbus-glib-0.100.2...Installing 
dbus-1.6.18...Installing gnome_subr-1.0... done
===> Creating users and/or groups.
Creating group 'messagebus' with gid '556'.
Creating user 'messagebus' with uid '556'.
 done
 done
Installing dconf-0.14.1_1... done
Installing gtk2-2.24.22_1...Installing gdk-pixbuf2-2.28.2... done
Installing gtk-update-icon-cache-2.24.22...Installing 
hicolor-icon-theme-0.12... done
Installing libXcomposite-0.4.4,1...Installing compositeproto-0.4.2... done
 done
Installing libXcursor-1.1.14... done
Installing libXinerama-1.1.3,1...Installing xineramaproto-1.2.1... done
 done
Installing shared-mime-info-1.1... done
 done
Installing python-2.7_1,2...Installing python2-2_2... done
 done
 done
Installing polkit-0.105_2...Installing gobject-introspection-1.36.0_2... done
 done
 done
Installing gstreamer-plugins-0.10.36_3,3...Installing gstreamer-0.10.36... done
Installing libXv-1.0.10,1...Installing videoproto-2.3.2... done
 done
Installing orc-0.4.18... done
 done
Installing libmspack-0.4... done
Installing pangox-compat-0.0.2... done
Installing wx28-gtk2-common-2.8.12_2... done
 done
 done
Installing gsed-4.2.2... done
Installing hdf5-18-1.8.10_1... done
Installing lapack-3.4.2_2... done
Installing openjdk-7.51.13_2,1...Installing libXtst-1.2.2...Installing 
recordproto-1.14.2... done
 done
Installing javavmwrapper-2.4_3... done
Installing java-zoneinfo-2014.b... done
Installing alsa-lib-1.0.27.2_1... done
 done
Installing qhull5-1.0_2... done
Installing qrupdate-1.1.2_2... done
Installing qt4-gui-4.8.5...Installing qt4-corelib-4.8.5_3... done
Installing xdg-utils-1.0.2.20130919_1...Installing xprop-1.2.2... done
Installing xset-1.2.3_1...Installing libXfontcache-1.0.5...Installing 
fontcacheproto-0.1.3... done
 done
 done
 done
 done
Installing qt4-network-4.8.5... done
Installing suitesparse-4.0.2_3... done
Installing texinfo-5.2.20140216... done
 done
Since FreeBSD has new USB stack, freeglut normally doesn't build on FreeBSD 8
(yet). To workaround this a small patch adds one include file and comments out
content of one function (only leaves return NULL).

This might cause side effects.  Joysticks do not work, and there might be ports
that do not compile or applications that crash because of this.

Do not hesitate to contact x...@freebsd.org if there are any issues and side
effects because of this.
Note: in order to use the script "dvipdf", dvips must be installed.
This program may be provided by either print/dvips or print/dvipsk-tetex
(print/dvipsk-tetex may be preferable since it doesn't conflict with
tetex things).

FAPIfontmap and FAPIcidfmap in /usr/local/share/ghostscript/9.06/Resource/Init
have to be configured if you want to use FAPI feature.
====
Note that some of the standard modules are provided as separate
ports since they require extra dependencies:

bsddb           databases/py-bsddb
gdbm            databases/py-gdbm
sqlite3         databases/py-sqlite3
tkinter         x11-toolkits/py-tkinter

Install them as needed.
====
Make sure that the freetype module is loaded.  If it is not, add the following
line to the "Modules" section of your X Windows configuration file:

        Load "freetype"

Add the following line to the "Files" section of X Windows configuration file:

        FontPath "/usr/local/lib/X11/fonts/dejavu/"

Note: your X Windows configuration file is typically /etc/X11/XF86Config
if you are using XFree86, and /etc/X11/xorg.conf if you are using X.Org.
=== IMPORTANT NOTICE ===

- You may want to run texconfig(1) to configure teTeX for your
  local environment. You will find teTeX's local documentation
  in /usr/local/share/texmf-dist/doc/.

- Note that if you have environment variables for teTeX in a wrong
  way (such as TEXINPUTS, TEXMF, TEXMFCNF, and so on),
  they may prevent teTeX from working.
======================================================================

Qt 4 can be built with optional support for:
 - Common UNIX Printing System (CUPS) (enabled by default)
 - Network Audio System (NAS)
 - Qt style that renders using GTK (QGTKSTYLE)

In order to enable them, you have to add
        QT4_OPTIONS=    CUPS NAS QGTKSTYLE
to your /etc/make.conf and compile devel/qt4-corelib and
x11-toolkits/qt4-gui ports.

Attention! Whenever you change the QT4_OPTIONS both
devel/qt4-corelib and x11-toolkits/qt4-gui ports must be rebuilt!

======================================================================
======================================================================

Qt paint engine makes common use of shared memory. To avoid MIT-SHM
errors (i.e., blank windows), you probably need to raise shared memory
limits in loader.conf(5). The following should be safe values for the
KDE Plasma Desktop:

kern.ipc.shmall=32768
kern.ipc.shmmni=1024
kern.ipc.shmseg=1024

======================================================================
===>   Returning to build of octave-forge-miscellaneous-1.2.0_3
===>   octave-forge-miscellaneous-1.2.0_3 depends on executable: gfortran47 - 
found
===>   octave-forge-miscellaneous-1.2.0_3 depends on executable: gmake - not 
found
===>    Verifying install for gmake in /usr/ports/devel/gmake
===>   Installing existing package /packages/All/gmake-3.82_1.txz
Installing gmake-3.82_1... done
===>   Returning to build of octave-forge-miscellaneous-1.2.0_3
===>   octave-forge-miscellaneous-1.2.0_3 depends on file: /usr/local/bin/as - 
found
===========================================================================
=======================<phase: lib-depends    >============================
===>   octave-forge-miscellaneous-1.2.0_3 depends on shared library: pcre - 
found
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for octave-forge-miscellaneous-1.2.0_3
===========================================================================
=======================<phase: build          >============================
===>  Building for octave-forge-miscellaneous-1.2.0_3
gmake[1]: Entering directory 
`/wrkdirs/usr/ports/math/octave-forge-miscellaneous/work/miscellaneous/src'
mkoctfile -Wall text_waitbar.cc
mkoctfile -Wall partarray.cc
partarray.cc:42:31: error: variable length array of non-POD element type 
'Array<octave_idx_type>'
  Array<octave_idx_type> bidc [maxdims], eidc [maxdims];
                              ^
partarray.cc:55:11: error: use of undeclared identifier 'eidc'
          eidc[i] = eidx;
          ^
partarray.cc:70:11: error: use of undeclared identifier 'eidc'
          eidc[i] = octave_value (arg.matrix_value ().column (1)).
          ^
partarray.cc:74:37: error: use of undeclared identifier 'eidc'
              if (bidc[i](j) < 1 || eidc[i](j) > alldims(i))
                                    ^
partarray.cc:77:32: error: use of undeclared identifier 'eidc'
              if (bidc[i](j) > eidc[i](j))
                               ^
partarray.cc:79:17: error: use of undeclared identifier 'eidc'
                eidc[i](j) = bidc[i](j) - 1;
                ^
partarray.cc:106:33: error: use of undeclared identifier 'eidc'
          octave_idx_type end = eidc[j](cidx(j));
                                ^
7 errors generated.
gmake[1]: *** [partarray.oct] Error 1
gmake[1]: Leaving directory 
`/wrkdirs/usr/ports/math/octave-forge-miscellaneous/work/miscellaneous/src'
*** Error code 1

Stop.
make: stopped in /usr/ports/math/octave-forge-miscellaneous
===>  Cleaning for octave-forge-miscellaneous-1.2.0_3
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to