You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     w...@freebsd.org
Last committer: w...@freebsd.org
Ident:          $FreeBSD: head/graphics/mapserver/Makefile 354243 2014-05-16 
15:59:23Z wen $
Log URL:        
http://beefy1.isc.freebsd.org/bulk/91i386-default/2014-06-12_04h07m16s/logs/mapserver-6.4.0_3.log
Build URL:      
http://beefy1.isc.freebsd.org/bulk/91i386-default/2014-06-12_04h07m16s
Log:

====>> Building graphics/mapserver
build started at Thu Jun 12 18:30:30 UTC 2014
port directory: /usr/ports/graphics/mapserver
building for: FreeBSD 91i386-default-job-05 9.1-RELEASE-p13 FreeBSD 
9.1-RELEASE-p13 i386
maintained by: w...@freebsd.org
Makefile ident:      $FreeBSD: head/graphics/mapserver/Makefile 354243 
2014-05-16 15:59:23Z wen $
Poudriere version: 3.1-pre
Host OSVERSION: 1100022
Jail OSVERSION: 901000

---Begin Environment---
UNAME_m=i386
UNAME_p=i386
OSVERSION=901000
UNAME_v=FreeBSD 9.1-RELEASE-p13
UNAME_r=9.1-RELEASE-p13
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
SAVED_TERM=
MASTERMNT=/usr/local/poudriere/data/build/91i386-default/ref
PKG_EXT=txz
tpid=93043
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
POUDRIERE_BUILD_TYPE=bulk
PKGNG=1
PKGNAME=mapserver-6.4.0_3
PKG_DELETE=/usr/local/sbin/pkg-static delete -y -f
PKG_ADD=/usr/local/sbin/pkg-static add
OLDPWD=/usr/local/poudriere/data/build/91i386-default/ref/poudriere/rdeps
PWD=/usr/local/poudriere/data/build/91i386-default/ref/poudriere/pool
MASTERNAME=91i386-default
USER=root
HOME=/root
POUDRIERE_VERSION=3.1-pre
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
PKG_VERSION=/poudriere/pkg-static version
PKG_BIN=/usr/local/sbin/pkg-static
---End Environment---

---Begin OPTIONS List---
===> The following configuration options are available for mapserver-6.4.0_3:
     CAIRO=off: Cairo graphics library support
     CAIRO_SVG=off: Cairo SVG parser support
     CURL=off: Data transfer support via cURL
     DEBUG=off: Build with debugging support
     FASTCGI=off: FastCGI support
     FRIBIDI=on: Fribidi library support
     GDAL=on: GDAL library support
     GEOS=on: GEOS support
     KML=off: KML support
     MAPSERV=on: Mapserv cgi interface support
     PERL=off: Perl scripting language support
     PHP=off: PHP bindings or support
     POSTGIS=off: PostGIS support
     PYTHON=off: Python bindings or support
     WCS=off: WCS Server support
     WFS=off: WFS Server support
     WMS=off: WMS Server support
===> Use 'make config' to modify these settings
---End OPTIONS List---

--CONFIGURE_ARGS--

--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
TMPDIR="/tmp" TMPDIR="/tmp" SHELL=/bin/sh CONFIG_SHELL=/bin/sh
--End CONFIGURE_ENV--

--MAKE_ENV--
TMPDIR="/tmp" TMPDIR="/tmp" NO_PIE=yes SHELL=/bin/sh NO_LINT=YES 
PREFIX=/usr/local  LOCALBASE=/usr/local  LIBDIR="/usr/lib"  CC="cc" CFLAGS="-O2 
-pipe -fno-strict-aliasing"  CPP="cpp" CPPFLAGS=""  LDFLAGS=" -L/usr/local 
-pthread"  CXX="c++" CXXFLAGS="-O2 -pipe -fno-strict-aliasing"  
MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install  -s -o root -g wheel -m 
555"  BSD_INSTALL_LIB="install  -s -o root -g wheel -m 444"  
BSD_INSTALL_SCRIPT="install  -o root -g wheel -m 555"  
BSD_INSTALL_DATA="install  -o root -g wheel -m 444"  BSD_INSTALL_MAN="install  
-o root -g wheel -m 444"
--End MAKE_ENV--

--PLIST_SUB--
MAPSERV=""
APA_VER=22
PYTHON="@comment
"
PHP="@comment
"
PERL="@comment
"
APACHEMODDIR="libexec/apache22"
APACHEINCLUDEDIR="include/apache22"
APACHEETCDIR="etc/apache22"
AP_NAME="mapserver"
AP_MODULE="mapserver.so"
CMAKE_BUILD_TYPE="release"
OSREL=9.1
PREFIX=%D
LOCALBASE=/usr/local
PORTDOCS=""
PORTEXAMPLES=""
PORTDATA=""
LIB32DIR=lib
DOCSDIR="share/doc/mapserver"
EXAMPLESDIR="share/examples/mapserver"
DATADIR="share/mapserver"
WWWDIR="www/mapserver"
ETCDIR="etc/mapserver"
--End PLIST_SUB--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/mapserver
DOCSDIR=/usr/local/share/doc/mapserver
EXAMPLESDIR=/usr/local/share/examples/mapserver
WWWDIR=/usr/local/www/mapserver
ETCDIR=/usr/local/etc/mapserver
--End SUB_LIST--

---Begin make.conf---
ARCH=i386
MACHINE=i386
MACHINE_ARCH=i386
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
WITH_PKGNG=yes
# clean-restricted via poudriere.conf NO_RESTRICTED
#NO_RESTRICTED=yes
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
===>  Cleaning for mapserver-6.4.0_3
=======================<phase: check-sanity   >============================
===========================================================================
=======================<phase: pkg-depends    >============================
===>   mapserver-6.4.0_3 depends on file: /usr/local/sbin/pkg - not found
===>    Verifying install for /usr/local/sbin/pkg in /usr/ports/ports-mgmt/pkg
===>   Installing existing package /packages/All/pkg-1.2.7_2.txz
Installing pkg-1.2.7_2... done
If you are upgrading from the old package format, first run:

  # pkg2ng
===>   Returning to build of mapserver-6.4.0_3
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===> Fetching all distfiles required by mapserver-6.4.0_3 for building
===========================================================================
=======================<phase: checksum       >============================
===> Fetching all distfiles required by mapserver-6.4.0_3 for building
=> SHA256 Checksum OK for mapserver-6.4.0.tar.gz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===> Fetching all distfiles required by mapserver-6.4.0_3 for building
===>  Extracting for mapserver-6.4.0_3
=> SHA256 Checksum OK for mapserver-6.4.0.tar.gz.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for mapserver-6.4.0_3
===>  Applying FreeBSD patches for mapserver-6.4.0_3
===========================================================================
=======================<phase: build-depends  >============================
===>   mapserver-6.4.0_3 depends on file: /usr/local/bin/cmake - not found
===>    Verifying install for /usr/local/bin/cmake in /usr/ports/devel/cmake
===>   Installing existing package /packages/All/cmake-2.8.12.1_4.txz
Installing cmake-2.8.12.1_4...Installing cmake-modules-2.8.12.1_1... done
 done
===>   Returning to build of mapserver-6.4.0_3
===========================================================================
=======================<phase: lib-depends    >============================
===>   mapserver-6.4.0_3 depends on shared library: libgd.so - not found
===>    Verifying for libgd.so in /usr/ports/graphics/gd
===>   Installing existing package /packages/All/libgd-2.1.0_3,1.txz
Installing libgd-2.1.0_3,1...Installing fontconfig-2.11.0_3,1...Installing 
expat-2.1.0... done
Installing freetype2-2.5.3_2... done
Running fc-cache to build fontconfig cache...
/usr/local/share/fonts: skipping, no such directory
/usr/local/lib/X11/fonts: caching, new cache contents: 0 fonts, 1 dirs
/usr/local/lib/X11/fonts/local: caching, new cache contents: 0 fonts, 0 dirs
/root/.local/share/fonts: skipping, no such directory
/root/.fonts: skipping, no such directory
/usr/local/share/fonts: skipping, no such directory
/usr/local/lib/X11/fonts: caching, new cache contents: 0 fonts, 1 dirs
/root/.local/share/fonts: skipping, no such directory
/root/.fonts: skipping, no such directory
/var/db/fontconfig: cleaning cache directory
/root/.cache/fontconfig: not cleaning non-existent cache directory
/root/.fontconfig: not cleaning non-existent cache directory
fc-cache: succeeded
 done
Installing jpeg-8_5... done
Installing png-1.5.18... done
Installing tiff-4.0.3_3...Installing jbigkit-1.6... done
 done
 done
===>   Returning to build of mapserver-6.4.0_3
===>   mapserver-6.4.0_3 depends on shared library: libproj.so - not found
===>    Verifying for libproj.so in /usr/ports/graphics/proj
===>   Installing existing package /packages/All/proj-4.8.0_2.txz
Installing proj-4.8.0_2... done
===>   Returning to build of mapserver-6.4.0_3
===>   mapserver-6.4.0_3 depends on shared library: libpng15.so - found 
(/usr/local/lib/libpng15.so.15)
===>   mapserver-6.4.0_3 depends on shared library: libjpeg.so - found 
(/usr/local/lib/libjpeg.so.11)
===>   mapserver-6.4.0_3 depends on shared library: libgif.so - not found
===>    Verifying for libgif.so in /usr/ports/graphics/giflib
===>   Installing existing package /packages/All/giflib-nox11-4.2.3_2.txz
Installing giflib-nox11-4.2.3_2... done
===>   Returning to build of mapserver-6.4.0_3
===>   mapserver-6.4.0_3 depends on shared library: libfribidi.so - not found
===>    Verifying for libfribidi.so in /usr/ports/converters/fribidi
===>   Installing existing package /packages/All/fribidi-0.19.2_1.txz
Installing fribidi-0.19.2_1... done
===>   Returning to build of mapserver-6.4.0_3
===>   mapserver-6.4.0_3 depends on shared library: libgdal.so - not found
===>    Verifying for libgdal.so in /usr/ports/graphics/gdal
===>   Installing existing package /packages/All/gdal-1.11.0_4.txz
Installing gdal-1.11.0_4...Installing jasper-1.900.1_14... done
Installing libgeotiff-1.4.0_1... done
 done
===>   Returning to build of mapserver-6.4.0_3
===>   mapserver-6.4.0_3 depends on shared library: libgeos.so - not found
===>    Verifying for libgeos.so in /usr/ports/graphics/geos
===>   Installing existing package /packages/All/geos-3.4.2.txz
Installing geos-3.4.2... done
===>   Returning to build of mapserver-6.4.0_3
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for mapserver-6.4.0_3
===>  Performing in-source build
/bin/mkdir -p /wrkdirs/usr/ports/graphics/mapserver/work/mapserver-6.4.0
-- The C compiler identification is GNU 4.2.1
-- The CXX compiler identification is GNU 4.2.1
-- Check for working C compiler: /usr/bin/cc
-- Check for working C compiler: /usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Looking for strrstr
-- Looking for strrstr - not found
-- Looking for strcasecmp
-- Looking for strcasecmp - found
-- Looking for strcasestr
-- Looking for strcasestr - found
-- Looking for strdup
-- Looking for strdup - found
-- Looking for strlcat
-- Looking for strlcat - found
-- Looking for strlcpy
-- Looking for strlcpy - found
-- Looking for strlen
-- Looking for strlen - found
-- Looking for strncasecmp
-- Looking for strncasecmp - found
-- Looking for vsnprintf
-- Looking for vsnprintf - found
-- Looking for lrintf
-- Looking for lrintf - found
-- Looking for lrint
-- Looking for lrint - found
-- Looking for dlfcn.h
-- Looking for dlfcn.h - found
-- Performing Test HAVE_SYNC_FETCH_AND_ADD
-- Performing Test HAVE_SYNC_FETCH_AND_ADD - Success
-- Found ZLIB: /usr/lib/libz.so (found version "1.2.7") 
-- Found PNG: /usr/local/lib/libpng.so (found version "1.5.18") 
-- Found JPEG: /usr/local/lib/libjpeg.so  
-- Found Freetype: /usr/local/lib/libfreetype.so  
-- Found PROJ: /usr/local/lib/libproj.so  
-- Looking for gdImagePng in /usr/local/lib/libgd.so
-- Looking for gdImagePng in /usr/local/lib/libgd.so - found
-- Looking for gdImageJpeg in /usr/local/lib/libgd.so
-- Looking for gdImageJpeg in /usr/local/lib/libgd.so - found
-- Looking for gdImageGif in /usr/local/lib/libgd.so
-- Looking for gdImageGif in /usr/local/lib/libgd.so - found
-- Looking for gdFontCacheSetup in /usr/local/lib/libgd.so
-- Looking for gdFontCacheSetup in /usr/local/lib/libgd.so - found
-- Could NOT find PkgConfig (missing:  PKG_CONFIG_EXECUTABLE) 
-- Found FRIBIDI: /usr/local/lib/libfribidi.so  
-- Looking for iconv
-- Looking for iconv - not found
CMake Error at CMakeLists.txt:43 (message):
  ICONV library/component/dependency could not be found.

    HINTS:
    - disable ICONV support by adding -DWITH_ICONV=0
    - add the ICONV install directory to the CMAKE_PREFIX_PATH variable 
(-DCMAKE_PREFIX_PATH="/path/to/ICONV-install-dir;/path/to/other/dirs"
Call Stack (most recent call first):
  CMakeLists.txt:333 (report_optional_not_found)


-- Found GEOS: /usr/local/lib/libgeos_c.so  
-- Found GDAL: /usr/local/lib/libgdal.so  
-- Could NOT find LibXml2 (missing:  LIBXML2_LIBRARIES LIBXML2_INCLUDE_DIR) 
CMake Error at CMakeLists.txt:43 (message):
  LIBXML2 library/component/dependency could not be found.

    HINTS:
    - disable LIBXML2 support by adding -DWITH_LIBXML2=0
    - add the LIBXML2 install directory to the CMAKE_PREFIX_PATH variable 
(-DCMAKE_PREFIX_PATH="/path/to/LIBXML2-install-dir;/path/to/other/dirs"
Call Stack (most recent call first):
  CMakeLists.txt:632 (report_optional_not_found)


-- Performing Test GIF_GifFileType_UserData
-- Performing Test GIF_GifFileType_UserData - Success
-- Found GIF: /usr/local/lib/libgif.so (found version "4") 
-- * Summary of configured options for this build
--  * Mandatory components
--   * png: /usr/local/lib/libpng.so
--   * jpeg: /usr/local/lib/libjpeg.so
--   * freetype: /usr/local/lib/libfreetype.so
--  * Optional components
--   * GDAL: /usr/local/lib/libgdal.so
--   * OGR: /usr/local/lib/libgdal.so
--   * GD: /usr/local/lib/libgd.so
--   * GIF: /usr/local/lib/libgif.so
--   * MYSQL: disabled
--   * FRIBIDI: /usr/local/lib/libfribidi.so
--   * GIF: /usr/local/lib/libgif.so
--   * CAIRO: disabled
--   * SVGCAIRO: disabled
--   * RSVG: disabled
--   * CURL: disabled
--   * PROJ: /usr/local/lib/libproj.so
--   * LIBXML2: disabled
--   * POSTGIS: disabled
--   * GEOS: /usr/local/lib/libgeos_c.so
--   * FastCGI: disabled
--   * Oracle Spatial: disabled
--   * SDE: disabled
--   * Exempi XMP: disabled
--  * Optional features
--   * WMS SERVER: disabled
--   * WFS SERVER: disabled
--   * WCS SERVER: disabled
--   * SOS SERVER: disabled
--   * WMS CLIENT: disabled
--   * WFS CLIENT: disabled
--   * ICONV: disabled
--   * Thread-safety support: disabled
--   * KML output: disabled
--   * Z+M point coordinate support: disabled
--   * XML Mapfile support: disabled
--  * Mapscripts
--   * Python: disabled
--   * PHP: disabled
--   * PERL: disabled
--   * RUBY: disabled
--   * JAVA: disabled
--   * C#: disabled
--   * Apache Module (Experimental): disabled
-- 
-- Will install files to /usr/local
-- Configuring incomplete, errors occurred!
See also 
"/wrkdirs/usr/ports/graphics/mapserver/work/mapserver-6.4.0/CMakeFiles/CMakeOutput.log".
See also 
"/wrkdirs/usr/ports/graphics/mapserver/work/mapserver-6.4.0/CMakeFiles/CMakeError.log".
*** [do-configure] Error code 1

Stop in /usr/ports/graphics/mapserver.
===>  Cleaning for mapserver-6.4.0_3
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to