You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     multime...@freebsd.org
Last committer: k...@freebsd.org
Ident:          $FreeBSD: head/audio/gstreamer1-plugins-modplug/Makefile 316693 
2013-04-27 20:56:38Z kwm $
Log URL:        
http://beefy2.isc.freebsd.org/bulk/head-amd64-default/2013-09-19_01h04m14s/logs/gstreamer1-plugins-modplug-1.0.10.log
Build URL:      
http://beefy2.isc.freebsd.org/bulk/head-amd64-default/2013-09-19_01h04m14s
Log:

====>> Building audio/gstreamer1-plugins-modplug
build started at Thu Sep 19 04:53:53 UTC 2013
port directory: /usr/ports/audio/gstreamer1-plugins-modplug
building for: FreeBSD head-amd64-default-job-04 10.0-CURRENT FreeBSD 
10.0-CURRENT amd64
maintained by: multime...@freebsd.org
Makefile ident:      $FreeBSD: head/audio/gstreamer1-plugins-modplug/Makefile 
316693 2013-04-27 20:56:38Z kwm $
Poudriere version: 3.1-pre

---Begin Environment---
OSVERSION=1000055
UNAME_v=FreeBSD 10.0-CURRENT
UNAME_r=10.0-CURRENT
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
MASTERMNT=/usr/local/poudriere/data/build/head-amd64-default/ref
PKG_EXT=txz
tpid=11568
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
POUDRIERE_BUILD_TYPE=bulk
NBPARALLEL=24
PKGNG=1
PKGNAME=gstreamer1-plugins-modplug-1.0.10
PKG_DELETE=/usr/local/sbin/pkg delete -y -f
PKG_ADD=/usr/local/sbin/pkg add
PWD=/root
MASTERNAME=head-amd64-default
USER=root
HOME=/root
POUDRIERE_VERSION=3.1-pre
SKIPSANITY=0
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
---End Environment---

---Begin OPTIONS List---
---End OPTIONS List---

--CONFIGURE_ARGS--
--disable-assrender --disable-celt --disable-curl --disable-dts --disable-faac 
--disable-faad --disable-flite --disable-gme --disable-gsm --disable-libmms 
--disable-librfb --enable-modplug --disable-mpeg2enc --disable-mplex 
--disable-neon --disable-ofa --disable-openal --disable-opencv --disable-opus 
--disable-resindvd --disable-rtmp --disable-schro --disable-soundtouch 
--disable-spandsp --disable-zbar --disable-apexsink --disable-cdaudio 
--disable-chromaprint --disable-cog --disable-decklink --disable-directfb 
--disable-dirac --disable-eglgles --disable-jasper --disable-kate 
--disable-ladspa --disable-linsys --disable-lv2 --disable-mimic 
--disable-mpg123 --disable-musepack --disable-musicbrainz --disable-mythtv 
--disable-nas --disable-opensles --disable-pvr --disable-rsvg --disable-sdl 
--disable-sndfile --disable-sndio --disable-spc --disable-teletextdec 
--disable-timidity --disable-vdpau --disable-voaacenc --disable-voamrwbenc 
--disable-wayland --disable-swfdec --disable-xv
 id --ena
 ble-bz2 --enable-dvb --enable-shm --enable-quicktime --disable-gsettings 
--disable-acm --disable-android_media --disable-apple_media --disable-avc 
--disable-dc1394 --disable-dccp --disable-direct3d --disable-directdraw 
--disable-directsound --disable-fbdev --disable-osx_video --disable-uvch264 
--disable-vcd --disable-wildmidi --disable-wininet --enable-modplug  
--x-libraries=/usr/local/lib --x-includes=/usr/local/include 
--prefix=/usr/local ${_LATE_CONFIGURE_ARGS}
--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
TMPDIR="/tmp" MAKE=gmake PKG_CONFIG=pkgconf  TMPDIR="/tmp" SHELL=/bin/sh 
CONFIG_SHELL=/bin/sh   LIBTOOL=/usr/local/bin/libtool  
LIBTOOLIZE=/usr/local/bin/libtoolize  
LIBTOOL_LIBEXECDIR=/usr/local/libexec/libtool  
LIBTOOL_SHAREDIR=/usr/local/share/libtool  
LIBTOOL_M4=/usr/local/share/aclocal/libtool.m4  
LTMAIN=/usr/local/share/libtool/config/ltmain.sh ac_cv_path_DOLT_BASH= 
CONFIG_SITE=/usr/ports/Templates/config.site lt_cv_sys_max_cmd_len=262144
--End CONFIGURE_ENV--

--MAKE_ENV--
TMPDIR="/tmp" TMPDIR="/tmp" SHELL=/bin/sh NO_LINT=YES 
ADDR2LINE="/usr/local/bin/addr2line" AR="/usr/local/bin/ar" 
AS="/usr/local/bin/as" CPPFILT="/usr/local/bin/c++filt" 
GPROF="/usr/local/bin/gprof" LD="/usr/local/bin/ld" NM="/usr/local/bin/nm" 
OBJCOPY="/usr/local/bin/objcopy" OBJDUMP="/usr/local/bin/objdump" 
RANLIB="/usr/local/bin/ranlib" READELF="/usr/local/bin/readelf" 
SIZE="/usr/local/bin/size" STRINGS="/usr/local/bin/strings"   
LIBTOOL=/usr/local/bin/libtool  LIBTOOLIZE=/usr/local/bin/libtoolize  
LIBTOOL_LIBEXECDIR=/usr/local/libexec/libtool  
LIBTOOL_SHAREDIR=/usr/local/share/libtool  
LIBTOOL_M4=/usr/local/share/aclocal/libtool.m4  
LTMAIN=/usr/local/share/libtool/config/ltmain.sh GI_SCANNER_DISABLE_CACHE=1 
PREFIX=/usr/local  LOCALBASE=/usr/local  LIBDIR="/usr/lib"  CC="gcc46" 
CFLAGS="-O2 -pipe -O2 -Wno-format -Wl,-rpath=/usr/local/lib/gcc46 
-fno-strict-aliasing"  CPP="cpp46" CPPFLAGS="-I/usr/local/include "  LDFLAGS=" 
-L/usr/local/lib  -pthread -Wl,-rpath=/usr/local/lib/
 gcc46"  
 CXX="g++46" CXXFLAGS="-O2 -pipe -O2 -Wno-format 
-Wl,-rpath=/usr/local/lib/gcc46 -fno-strict-aliasing 
-Wl,-rpath=/usr/local/lib/gcc46"  MANPREFIX="/usr/local" 
BSD_INSTALL_PROGRAM="install  -s -o root -g wheel -m 555"  
BSD_INSTALL_LIB="install  -s -o root -g wheel -m 444"  
BSD_INSTALL_SCRIPT="install  -o root -g wheel -m 555"  
BSD_INSTALL_DATA="install  -o root -g wheel -m 444"  BSD_INSTALL_MAN="install  
-o root -g wheel -m 444"
--End MAKE_ENV--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/gstreamer
DOCSDIR=/usr/local/share/doc/gstreamer
EXAMPLESDIR=/usr/local/share/examples/gstreamer
WWWDIR=/usr/local/www/gstreamer
ETCDIR=/usr/local/etc/gstreamer
--End SUB_LIST--

---Begin make.conf---
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
WITH_PKGNG=yes
NO_RESTRICTED=yes
DISABLE_MAKE_JOBS=yes
---End make.conf---
===>  Cleaning for gstreamer1-plugins-modplug-1.0.10
=======================<phase: check-config   >============================
===========================================================================
=======================<phase: pkg-depends    >============================
===>   gstreamer1-plugins-modplug-1.0.10 depends on file: /usr/local/sbin/pkg - 
not found
===>    Verifying install for /usr/local/sbin/pkg in /usr/ports/ports-mgmt/pkg
===>   Installing existing package /packages/All/pkg-1.1.4_2.txz
Installing pkg-1.1.4_2... done
If you are upgrading from the old package format, first run:

  # pkg2ng
===>   Returning to build of gstreamer1-plugins-modplug-1.0.10
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===> Fetching all distfiles required by gstreamer1-plugins-modplug-1.0.10 for 
building
===========================================================================
=======================<phase: checksum       >============================
===> Fetching all distfiles required by gstreamer1-plugins-modplug-1.0.10 for 
building
=> SHA256 Checksum OK for gst-plugins-bad-1.0.10.tar.xz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===> Fetching all distfiles required by gstreamer1-plugins-modplug-1.0.10 for 
building
===>  Extracting for gstreamer1-plugins-modplug-1.0.10
=> SHA256 Checksum OK for gst-plugins-bad-1.0.10.tar.xz.
===========================================================================
=======================<phase: patch-depends  >============================
===>   gstreamer1-plugins-modplug-1.0.10 depends on package: libtool>=2.4 - not 
found
===>    Verifying install for libtool>=2.4 in /usr/ports/devel/libtool
===>   Installing existing package /packages/All/libtool-2.4.2_1.txz
Installing libtool-2.4.2_1... done
===>   Returning to build of gstreamer1-plugins-modplug-1.0.10
===>   gstreamer1-plugins-modplug-1.0.10 depends on package: libtool>=2.4 - 
found
===========================================================================
=======================<phase: patch          >============================
===>  Patching for gstreamer1-plugins-modplug-1.0.10
===========================================================================
=======================<phase: build-depends  >============================
===>   gstreamer1-plugins-modplug-1.0.10 depends on package: gstreamer1>=1.0.8 
- not found
===>    Verifying install for gstreamer1>=1.0.8 in 
/usr/ports/multimedia/gstreamer1
===>   Installing existing package /packages/All/gstreamer1-1.0.10.txz
Installing gstreamer1-1.0.10...Installing gnomehier-3.0... done
Installing mpfr-3.1.2...Installing gmp-5.1.2... done
 done
Installing mpc-0.9... done
Installing python27-2.7.5_3...Installing gettext-0.18.3... done
 done
Installing python2-2_1... done
Installing python-2.7_1,2... done
Installing perl-5.14.4...Removing stale symlinks from /usr/bin...
    Skipping /usr/bin/perl
    Skipping /usr/bin/perl5
Done.
Creating various symlinks in /usr/bin...
    Symlinking /usr/local/bin/perl5.14.4 to /usr/bin/perl
    Symlinking /usr/local/bin/perl5.14.4 to /usr/bin/perl5
Done.
Cleaning up /etc/make.conf... Done.
Spamming /etc/make.conf... Done.
 done
Installing gcc-ecj-4.5... done
Installing gcc-4.6.3...Installing binutils-2.23.2... done
 done
Installing pcre-8.33... done
Installing libffi-3.0.13... done
Installing glib-2.36.3...No schema files found: doing nothing.
 done
 done
====
Note that some of the standard modules are provided as separate
ports since they require extra dependencies:

bsddb           databases/py-bsddb
gdbm            databases/py-gdbm
sqlite3         databases/py-sqlite3
tkinter         x11-toolkits/py-tkinter

Install them as needed.
====
===>   Returning to build of gstreamer1-plugins-modplug-1.0.10
===>   gstreamer1-plugins-modplug-1.0.10 depends on package: iso-codes>=0 - not 
found
===>    Verifying install for iso-codes>=0 in /usr/ports/misc/iso-codes
===>   Installing existing package /packages/All/iso-codes-3.43.txz
Installing iso-codes-3.43... done
===>   Returning to build of gstreamer1-plugins-modplug-1.0.10
===>   gstreamer1-plugins-modplug-1.0.10 depends on package: orc>=0.4.16 - not 
found
===>    Verifying install for orc>=0.4.16 in /usr/ports/devel/orc
===>   Installing existing package /packages/All/orc-0.4.18.txz
Installing orc-0.4.18... done
===>   Returning to build of gstreamer1-plugins-modplug-1.0.10
===>   gstreamer1-plugins-modplug-1.0.10 depends on executable: gmake - not 
found
===>    Verifying install for gmake in /usr/ports/devel/gmake
===>   Installing existing package /packages/All/gmake-3.82_1.txz
Installing gmake-3.82_1... done
===>   Returning to build of gstreamer1-plugins-modplug-1.0.10
===>   gstreamer1-plugins-modplug-1.0.10 depends on executable: pkgconf - not 
found
===>    Verifying install for pkgconf in /usr/ports/devel/pkgconf
===>   Installing existing package /packages/All/pkgconf-0.9.3.txz
Installing pkgconf-0.9.3... done
===>   Returning to build of gstreamer1-plugins-modplug-1.0.10
===>   gstreamer1-plugins-modplug-1.0.10 depends on package: 
gstreamer1-plugins>=1.0.8 - not found
===>    Verifying install for gstreamer1-plugins>=1.0.8 in 
/usr/ports/multimedia/gstreamer1-plugins
===>   Installing existing package /packages/All/gstreamer1-plugins-1.0.10.txz
Installing gstreamer1-plugins-1.0.10...Installing libxml2-2.8.0_2... done
Installing freetype2-2.4.12_1... done
 done
===>   Returning to build of gstreamer1-plugins-modplug-1.0.10
===>   gstreamer1-plugins-modplug-1.0.10 depends on executable: gcc46 - found
===>   gstreamer1-plugins-modplug-1.0.10 depends on file: /usr/local/bin/as - 
found
===>   gstreamer1-plugins-modplug-1.0.10 depends on package: 
gstreamer1-plugins-bad>=1.0.8 - not found
===>    Verifying install for gstreamer1-plugins-bad>=1.0.8 in 
/usr/ports/multimedia/gstreamer1-plugins-bad
===>   Installing existing package 
/packages/All/gstreamer1-plugins-bad-1.0.10.txz
Installing gstreamer1-plugins-bad-1.0.10... done
===>   Returning to build of gstreamer1-plugins-modplug-1.0.10
===>   gstreamer1-plugins-modplug-1.0.10 depends on package: libtool>=2.4 - 
found
===>   gstreamer1-plugins-modplug-1.0.10 depends on executable: g-ir-scanner - 
not found
===>    Verifying install for g-ir-scanner in 
/usr/ports/devel/gobject-introspection
===>   Installing existing package 
/packages/All/gobject-introspection-1.36.0_2.txz
Installing gobject-introspection-1.36.0_2... done
===>   Returning to build of gstreamer1-plugins-modplug-1.0.10
===========================================================================
=======================<phase: lib-depends    >============================
===>   gstreamer1-plugins-modplug-1.0.10 depends on shared library: 
libgstreamer-1.0.so - found
===>   gstreamer1-plugins-modplug-1.0.10 depends on shared library: 
libfreetype.so - found
===>   gstreamer1-plugins-modplug-1.0.10 depends on shared library: 
liborc-0.4.so - found
<snip>
        rawparse
        removesilence
        rtpmux
        rtpvp8
        scaletempo
        sdp
        segmentclip
        siren
        smooth
        speed
        subenc
        videoparsers
        y4m

configure: *** Plug-ins without external dependencies that will NOT be built:
        aiff
        cdxaparse
        dccp
        faceoverlay
        freeverb
        hdvparse
        ivfparse
        jp2kdecimator
        librfb
        mve
        mxf
        nsf
        nuvdemux
        patchdetect
        real
        sdi
        stereo
        tta
        videofilters
        videomeasure
        videosignal
        vmnc

configure: *** Plug-ins that have NOT been ported:
        acm
        aiff
        apexsink
        cdaudio
        cdxaparse
        cog
        dc1394
        dccp
        dirac
        directdraw
        directfb
        faceoverlay
        fbdev
        freeverb
        gsettings
        hdvparse
        ivfparse
        jasper
        jp2kdecimator
        kate
        ladspa
        linsys
        lv2
        musepack
        musicbrainz
        mve
        mxf
        mythtv
        nas
        nsf
        nuvdemux
        osx_video
        patchdetect
        quicktime
        real
        rsvg
        sdi
        sdl
        sndfile
        sndio
        stereo
        teletextdec
        timidity
        tta
        uvch264
        vcd
        videofilters
        videomeasure
        videosignal
        vmnc
        wildmidi
        wininet
        xvid

configure: *** Plug-ins with dependencies that will be built:
        bz2
        modplug
        shm

configure: *** Plug-ins with dependencies that will NOT be built:
        acm
        androidmedia
        apexsink
        applemedia
        assrender
        avcsrc
        cdaudio
        celt
        chromaprint
        cog
        curl
        dc1394
        decklink
        dfbvideosink 
        dirac
        direct3dsink
        directdrawsink
        directsoundsrc
        dtsdec
        dvb
        eglgles
        faac
        faad
        fbdevsink
        flite
        fluidsynth
        gme
        gsettings
        gsmenc gsmdec
        jasperdec jasperenc
        kate
        ladspa
        libmms
        linsys
        lv2
        mimic
        mpeg2enc
        mpg123
        mplex
        musepack
        musicbrainz
        mythtvsrc
        nassink
        neonhttpsrc
        ofa
        openal
        opencv
        openjpeg
        opensl
        opus
        osxvideosrc
        pvr
        qtwrapper
        resindvd
        rsvg
        rtmp
        schro
        sdlvideosink sdlaudiosink
        sfsrc sfsink
        sndio
        soundtouch
        spandsp
        spc
        swfdec
        teletextdec
        timidity
        uvch264
        vcdsrc
        vdpau
        vo-aacenc
        vo-amrwbenc
        wayland 
        wildmidi
        wininet
        winks
        winscreencap
        xvid
        zbar

configure: *** Orc acceleration enabled.

===========================================================================
=======================<phase: build          >============================
===>  Building for gstreamer1-plugins-modplug-1.0.10
gmake[1]: Entering directory 
`/wrkdirs/usr/ports/audio/gstreamer1-plugins-modplug/work/gst-plugins-bad-1.0.10/ext/modplug'
  CXX    libgstmodplug_la-gstmodplug.lo
  CXXLD  libgstmodplug.la
c++: warning: argument unused during compilation: '-pthread'
c++: warning: argument unused during compilation: '-pthread'
c++: warning: argument unused during compilation: '-pthread'
c++: warning: argument unused during compilation: '-pthread'
c++: warning: argument unused during compilation: '-pthread'
/usr/bin/ld: cannot find -lstdc++
c++: error: linker command failed with exit code 1 (use -v to see invocation)
gmake[1]: *** [libgstmodplug.la] Error 1
gmake[1]: Leaving directory 
`/wrkdirs/usr/ports/audio/gstreamer1-plugins-modplug/work/gst-plugins-bad-1.0.10/ext/modplug'
*** Error code 2

Stop.
make: stopped in /usr/ports/audio/gstreamer1-plugins-modplug
===>  Cleaning for gstreamer1-plugins-modplug-1.0.10
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to