You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     tcr...@gmail.com
Last committer: m...@freebsd.org
Ident:          $FreeBSD: branches/2014Q2/databases/ocaml-pgocaml/Makefile 
340722 2014-01-22 17:00:46Z mat $
Log URL:        
http://beefy2.isc.freebsd.org/bulk/10amd64-quarterly/2014-06-18_08h49m35s/logs/ocaml-pgocaml-1.5_1.log
Build URL:      
http://beefy2.isc.freebsd.org/bulk/10amd64-quarterly/2014-06-18_08h49m35s
Log:

====>> Building databases/ocaml-pgocaml
build started at Wed Jun 18 12:44:17 UTC 2014
port directory: /usr/ports/databases/ocaml-pgocaml
building for: FreeBSD 10amd64-quarterly-job-23 10.0-RELEASE-p3 FreeBSD 
10.0-RELEASE-p3 amd64
maintained by: tcr...@gmail.com
Makefile ident:      $FreeBSD: branches/2014Q2/databases/ocaml-pgocaml/Makefile 
340722 2014-01-22 17:00:46Z mat $
Poudriere version: 3.1-pre
Host OSVERSION: 1100022
Jail OSVERSION: 1000510

---Begin Environment---
OSVERSION=1000510
UNAME_v=FreeBSD 10.0-RELEASE-p3
UNAME_r=10.0-RELEASE-p3
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
SAVED_TERM=
MASTERMNT=/usr/local/poudriere/data/build/10amd64-quarterly/ref
PKG_EXT=txz
tpid=66010
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
POUDRIERE_BUILD_TYPE=bulk
PKGNG=1
PKGNAME=ocaml-pgocaml-1.5_1
PKG_DELETE=/usr/local/sbin/pkg-static delete -y -f
PKG_ADD=/usr/local/sbin/pkg-static add
OLDPWD=/usr/local/poudriere/data/build/10amd64-quarterly/ref/poudriere/rdeps
PWD=/usr/local/poudriere/data/build/10amd64-quarterly/ref/poudriere/pool
MASTERNAME=10amd64-quarterly
USER=root
HOME=/root
POUDRIERE_VERSION=3.1-pre
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
PKG_VERSION=/poudriere/pkg-static version
PKG_BIN=/usr/local/sbin/pkg-static
---End Environment---

---Begin OPTIONS List---
---End OPTIONS List---

--CONFIGURE_ARGS--

--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
TMPDIR="/tmp" MAKE=gmake TMPDIR="/tmp" SHELL=/bin/sh CONFIG_SHELL=/bin/sh
--End CONFIGURE_ENV--

--MAKE_ENV--
TMPDIR="/tmp" OCAMLFIND_DESTDIR="/usr/local/lib/ocaml/site-lib"  
OCAMLFIND_LDCONF="/usr/local/lib/ocaml/ld.conf" TMPDIR="/tmp" SHELL=/bin/sh 
NO_LINT=YES PREFIX=/usr/local  LOCALBASE=/usr/local  LIBDIR="/usr/lib"  CC="cc" 
CFLAGS="-O2 -pipe -fno-strict-aliasing"  CPP="cpp" CPPFLAGS=""  LDFLAGS=""  
CXX="c++" CXXFLAGS="-O2 -pipe -fno-strict-aliasing"  MANPREFIX="/usr/local" 
BSD_INSTALL_PROGRAM="install  -s -o root -g wheel -m 555"  
BSD_INSTALL_LIB="install  -s -o root -g wheel -m 444"  
BSD_INSTALL_SCRIPT="install  -o root -g wheel -m 555"  
BSD_INSTALL_DATA="install  -o root -g wheel -m 444"  BSD_INSTALL_MAN="install  
-o root -g wheel -m 444"
--End MAKE_ENV--

--PLIST_SUB--
OCAML_SITELIBDIR="lib/ocaml/site-lib"
OSREL=10.0
PREFIX=%D
LOCALBASE=/usr/local
PORTDOCS=""
PORTEXAMPLES=""
PORTDATA=""
LIB32DIR=lib
DOCSDIR="share/doc/pgocaml"
EXAMPLESDIR="share/examples/pgocaml"
DATADIR="share/pgocaml"
WWWDIR="www/pgocaml"
ETCDIR="etc/pgocaml"
--End PLIST_SUB--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/pgocaml
DOCSDIR=/usr/local/share/doc/pgocaml
EXAMPLESDIR=/usr/local/share/examples/pgocaml
WWWDIR=/usr/local/www/pgocaml
ETCDIR=/usr/local/etc/pgocaml
--End SUB_LIST--

---Begin make.conf---
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
WITH_PKGNG=yes
# clean-restricted ran via poudriere.conf NO_RESTRICTED
#NO_RESTRICTED=yes
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
===>  Cleaning for ocaml-pgocaml-1.5_1
=======================<phase: check-sanity   >============================
===========================================================================
=======================<phase: pkg-depends    >============================
===>   ocaml-pgocaml-1.5_1 depends on file: /usr/local/sbin/pkg - not found
===>    Verifying install for /usr/local/sbin/pkg in /usr/ports/ports-mgmt/pkg
===>   Installing existing package /packages/All/pkg-1.2.7.txz
Installing pkg-1.2.7... done
If you are upgrading from the old package format, first run:

  # pkg2ng
===>   Returning to build of ocaml-pgocaml-1.5_1
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===> Fetching all distfiles required by ocaml-pgocaml-1.5_1 for building
===========================================================================
=======================<phase: checksum       >============================
===> Fetching all distfiles required by ocaml-pgocaml-1.5_1 for building
=> SHA256 Checksum OK for pgocaml-1.5.tgz.
===========================================================================
=======================<phase: extract-depends>============================
===>   ocaml-pgocaml-1.5_1 depends on file: /usr/local/bin/ocamlc - not found
===>    Verifying install for /usr/local/bin/ocamlc in /usr/ports/lang/ocaml
===>   Installing existing package /packages/All/ocaml-4.00.1_1.txz
Installing ocaml-4.00.1_1...Installing libX11-1.6.2,1...Installing 
kbproto-1.0.6... done
Installing libXau-1.0.8...Installing xproto-7.0.25... done
 done
Installing libXdmcp-1.1.1... done
Installing libxcb-1.9.3...Installing libpthread-stubs-0.3_4... done
Installing libxml2-2.9.1_1... done
 done
 done
Installing tk85-8.5.15...Installing libXScrnSaver-1.2.2...Installing 
libXext-1.3.2,1...Installing xextproto-7.2.1... done
 done
Installing scrnsaverproto-1.2.2... done
 done
Installing libXft-2.3.1...Installing fontconfig-2.11.0_1,1...Installing 
expat-2.1.0... done
Installing freetype2-2.5.3... done
Running fc-cache to build fontconfig cache...
/usr/local/share/fonts: skipping, no such directory
/usr/local/lib/X11/fonts: caching, new cache contents: 0 fonts, 1 dirs
/usr/local/lib/X11/fonts/local: caching, new cache contents: 0 fonts, 0 dirs
/root/.local/share/fonts: skipping, no such directory
/root/.fonts: skipping, no such directory
/usr/local/share/fonts: skipping, no such directory
/usr/local/lib/X11/fonts: caching, new cache contents: 0 fonts, 1 dirs
/root/.local/share/fonts: skipping, no such directory
/root/.fonts: skipping, no such directory
/var/db/fontconfig: cleaning cache directory
/root/.cache/fontconfig: not cleaning non-existent cache directory
/root/.fontconfig: not cleaning non-existent cache directory
fc-cache: succeeded
 done
Installing libXrender-0.9.8...Installing renderproto-0.11.1... done
 done
 done
Installing tcl85-8.5.15_2... done
 done
 done
===>   Returning to build of ocaml-pgocaml-1.5_1
===========================================================================
=======================<phase: extract        >============================
===> Fetching all distfiles required by ocaml-pgocaml-1.5_1 for building
===>  Extracting for ocaml-pgocaml-1.5_1
=> SHA256 Checksum OK for pgocaml-1.5.tgz.
===========================================================================
=======================<phase: patch-depends  >============================
===>   ocaml-pgocaml-1.5_1 depends on file: /usr/local/bin/ocamlc - found
===========================================================================
=======================<phase: patch          >============================
===>  Patching for ocaml-pgocaml-1.5_1
===========================================================================
=======================<phase: build-depends  >============================
===>   ocaml-pgocaml-1.5_1 depends on file: 
/usr/local/lib/ocaml/site-lib/extlib - not found
===>    Verifying install for /usr/local/lib/ocaml/site-lib/extlib in 
/usr/ports/devel/ocaml-extlib
===>   Installing existing package /packages/All/ocaml-extlib-1.5.4.txz
Installing ocaml-extlib-1.5.4...Installing ocaml-findlib-1.4.1_1... done
 done
===>   Returning to build of ocaml-pgocaml-1.5_1
===>   ocaml-pgocaml-1.5_1 depends on file: /usr/local/lib/ocaml/site-lib/pcre 
- not found
===>    Verifying install for /usr/local/lib/ocaml/site-lib/pcre in 
/usr/ports/devel/ocaml-pcre
===>   Installing existing package /packages/All/ocaml-pcre-7.0.4.txz
Installing ocaml-pcre-7.0.4...Installing pcre-8.34... done
 done
===>   Returning to build of ocaml-pgocaml-1.5_1
===>   ocaml-pgocaml-1.5_1 depends on file: 
/usr/local/lib/ocaml/site-lib/calendar - not found
===>    Verifying install for /usr/local/lib/ocaml/site-lib/calendar in 
/usr/ports/devel/ocaml-calendar
===>   Installing existing package /packages/All/ocaml-calendar-2.03.2.txz
Installing ocaml-calendar-2.03.2... done
===>   Returning to build of ocaml-pgocaml-1.5_1
===>   ocaml-pgocaml-1.5_1 depends on file: /usr/local/lib/ocaml/site-lib/csv - 
not found
===>    Verifying install for /usr/local/lib/ocaml/site-lib/csv in 
/usr/ports/textproc/ocaml-csv
===>   Installing existing package /packages/All/ocaml-csv-1.2.1_2.txz
Installing ocaml-csv-1.2.1_2... done
===>   Returning to build of ocaml-pgocaml-1.5_1
===>   ocaml-pgocaml-1.5_1 depends on file: /usr/local/bin/ocamlc - found
===>   ocaml-pgocaml-1.5_1 depends on file: /usr/local/bin/ocamlfind - found
===>   ocaml-pgocaml-1.5_1 depends on executable: gmake - not found
===>    Verifying install for gmake in /usr/ports/devel/gmake
===>   Installing existing package /packages/All/gmake-3.82_1.txz
Installing gmake-3.82_1...Installing gettext-0.18.3.1... done
 done
===>   Returning to build of ocaml-pgocaml-1.5_1
===========================================================================
=======================<phase: lib-depends    >============================
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for ocaml-pgocaml-1.5_1
===========================================================================
=======================<phase: build          >============================
===>  Building for ocaml-pgocaml-1.5_1
cd /wrkdirs/usr/ports/databases/ocaml-pgocaml/work/pgocaml-1.5; gmake depend
[: The: unexpected operator
gmake[1]: Entering directory 
`/wrkdirs/usr/ports/databases/ocaml-pgocaml/work/pgocaml-1.5'
< pGOCaml_config.ml.in sed -e "s|@DEFAULT_UNIX_DOMAIN_SOCKET_DIR@|"/tmp"|" > 
pGOCaml_config.ml
rm -f .depend
ocamlfind ocamldep -syntax camlp4o -package camlp4.macro pGOCaml*.ml >.depend
ocamldep pGOCaml*.mli >> .depend
ocamldep -pp "camlp4o -I +unix /usr/local/lib/ocaml/unix.cma -I +str 
/usr/local/lib/ocaml/str.cma -I +pcre 
/usr/local/lib/ocaml/site-lib/pcre/pcre.cma -I +extlib 
/usr/local/lib/ocaml/site-lib/extlib/extLib.cma -I +calendar 
/usr/local/lib/ocaml/site-lib/calendar/calendarLib.cma -I +csv 
/usr/local/lib/ocaml/site-lib/csv/csv.cma ./pgocaml.cma ./pa_pgsql.cmo" >> 
.depend
gmake[1]: Leaving directory 
`/wrkdirs/usr/ports/databases/ocaml-pgocaml/work/pgocaml-1.5'
[: The: unexpected operator
gmake[1]: Entering directory 
`/wrkdirs/usr/ports/databases/ocaml-pgocaml/work/pgocaml-1.5'
sed  -e 's/@PACKAGE@/pgocaml/' \
        -e 's/@VERSION@/1.5/' \
        -e 's/@EXTLIB@/extlib/' \
        < META.in > META
ocamlfind ocamlc -g -syntax camlp4o -package camlp4.macro  -package 
unix,extlib,pcre,calendar,csv -c pGOCaml_config.ml
ocamlfind ocamlc -g  -package unix,extlib,pcre,calendar,csv -c 
pGOCaml_generic.mli
ocamlfind ocamlc -g -syntax camlp4o -package camlp4.macro  -package 
unix,extlib,pcre,calendar,csv -c pGOCaml_generic.ml
ocamlfind ocamlc -g  -package unix,extlib,pcre,calendar,csv -c pGOCaml.mli
ocamlfind ocamlc -g -syntax camlp4o -package camlp4.macro  -package 
unix,extlib,pcre,calendar,csv -c pGOCaml.ml
ocamlfind ocamlc -g -package unix,extlib,pcre,calendar,csv -a -o pgocaml.cma 
pGOCaml_config.cmo pGOCaml_generic.cmo pGOCaml.cmo
ocamlfind ocamlopt  -syntax camlp4o -package camlp4.macro  -package 
unix,extlib,pcre,calendar,csv -c pGOCaml_config.ml
ocamlfind ocamlopt  -syntax camlp4o -package camlp4.macro  -package 
unix,extlib,pcre,calendar,csv -c pGOCaml_generic.ml
ocamlfind ocamlopt  -syntax camlp4o -package camlp4.macro  -package 
unix,extlib,pcre,calendar,csv -c pGOCaml.ml
ocamlfind ocamlopt  -package unix,extlib,pcre,calendar,csv -a -o pgocaml.cmxa 
pGOCaml_config.cmx pGOCaml_generic.cmx pGOCaml.cmx
ocamlfind ocamlc -g -package unix,extlib,pcre,calendar,csv \
  -pp "camlp4o pa_extend.cmo q_MLast.cmo  -parser Camlp4MacroParser -impl" \
  -I +camlp4 -c -impl pa_pgsql.ml4
File "pa_pgsql.ml4", line 127, characters 16-16:
Error: Unbound value _loc
gmake[1]: *** [pa_pgsql.cmo] Error 2
gmake[1]: Leaving directory 
`/wrkdirs/usr/ports/databases/ocaml-pgocaml/work/pgocaml-1.5'
*** Error code 1

Stop.
make: stopped in /usr/ports/databases/ocaml-pgocaml
===>  Cleaning for ocaml-pgocaml-1.5_1
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to